reshaped
[planetlab-umts-tools.git] / backend / umtstools-backend.spec
1 %define name planetlab-umts-tools-backend
2 %define version 0.4
3 %define release 2
4
5 Summary: Umts-tools for PlanetLab - backend part
6 Name: %{name}
7 Version: %{version}
8 Release: %{release}
9 Source0: %{name}-%{version}.tar.gz
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
11 BuildArch: noarch
12 Vendor: Universita Federico II di Napoli for Onelab
13 Group: Utilities
14 URL: http://www.unina.it
15 License: GPL
16 Prefix: %{_prefix}
17
18 Requires: vsys
19
20 %description
21 Backend part of a program that allows users of a slice to control a PPP connection over a 3G umts/hsdpa connect card and set the route entries required to use it.
22
23 %prep
24 %setup -q
25
26 %build
27 rm -rf $RPM_BUILD_ROOT
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 mkdir -p $RPM_BUILD_ROOT
32 make clean
33 cp -af root/* $RPM_BUILD_ROOT/
34
35
36 %clean
37
38
39 %post 
40 /sbin/udevadm control reload_rules
41 /sbin/chkconfig umts on
42 /etc/rc.d/init.d/umts start
43 /sbin/service vsys restart
44
45 %preun
46 /sbin/chkconfig umts off
47
48 %files
49 /vsys/umts_backend
50 /usr/lib/umts_functions
51 /etc/udev/rules.d/96-umts-tools.rules
52 /etc/rc.d/init.d/umts
53
54 %defattr(-,root,root)
55 %doc AUTHORS TODO
56
57 %changelog
58 * Tue Sep 30 2008 Giovanni Di Stasi <giovanni.distasi@unina.it> -
59 - initial revision