better parsing of PLC_VSYS_DEFAULTS
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.1
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 Requires: Django
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel PyXML python-simplejson
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %define php_extension_dir %(php-config --extension-dir)
129
130 %files
131 %defattr(-,root,root,-)
132 %dir %{_datadir}/plc_api
133 %dir /var/log/omf/
134 %{_datadir}/plc_api/*
135 %{_bindir}/plcsh
136 %{php_extension_dir}/xmlrpc.so
137 %{_sysconfdir}/php.d/xmlrpc.ini
138 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
139 /etc/plc.d
140 /etc/planetlab/db-config.d
141 /var/www/html/wsdl/plcapi.wsdl
142 /usr/bin/omf_slicemgr.py*
143 /usr/bin/reset_xmpp_pubsub_nodes.py*
144 /var/log/plc_api_ratelimit.log
145
146
147 %changelog
148 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
149 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
150 - AddPerson and UpdatePerson are now tag-aware
151 - as a side-effect AddPerson is more picky and rejects invalid fields
152 - which results in a requirement to use sfa-2.1-22 with this tag
153 - marginal improvement on the xml doc on tags
154
155 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
156 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
157 - reset_xmpp_pubsub_nodes now hos options and usage
158 - new Accessors for vicci
159
160 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
161 - fixed imports for tags management with sites and persons
162 - add predefined 'cpu_freezable' tag
163
164 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
165 - tweaks in interface initialization
166 - has 'vsys_vnet' as a predefined tagtype
167 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
168 - bugfix: GetSlivers & nodegroups
169 - bugfix: in jabber groups management
170
171 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
172 - fix gpg-authentication for Persons (thanks Jordan)
173 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
174 - ip address/network check: v4 or v6
175 - customized DB Message survive upgrade
176 - make sync works in lxc-hosted tests
177 - no svn keywords anymore
178
179 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
180 - fix sorting for methods list in docs
181 - untested but needed tweak for postgres startup in f16
182
183 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
184 - tweaks in postgresql setup - in line with sfa
185
186 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
187 - slight tweaks in Persons.py
188
189 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
190 - GetSession has support for more than one day sessions
191 - reset_xmpp_pubsub_nodes is much more efficient
192 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
193 - bugfix - deleting a person in the middle of the signup process
194
195 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
196 - ratelimit aspects
197 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
198 - requires Django for cache_utils
199 - attempt to expose 'pldistro' to sfa
200 - last_time_spent_online, last_time_spent_offline: new fields in Node
201 - new slice tags 'isolate_loopback' and 'cpu_cores'
202 - refresh-peer federation logs dump exceptions
203 - modpython logs have a timestamp
204 - more verbose/accurate php error reporting
205 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
206 - AddNode, UpdateNode: manage tags directly rather than through another method
207 - BootUpdateNode: only update once
208 - GetPersons: techs can access the list of persons on their site
209 - GetSlices and GetSliceTags: techs can see slices on their nodes
210 - GetSlivers: isrootonsite tag; cacheable
211
212 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
213 - rename initscript_body into initscript_code
214
215 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
216 - new initscript_body tag
217
218 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
219 - working draft for GetSliceSshKeys
220
221 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
222 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
223 - (this is for people who cancel their download)
224
225 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
226 - fix db-config sequence : accessors step now merged in, and occurs at the right time
227 - db-config also more robust
228 - no more explicit 'accessors' step in plc.d
229
230 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
231 - session auth: do *not* delete session when node runs a method that does not have 'node' role
232 - session auth: remove support for bootonce in old boot CDs
233 - give a reason when caller_may_write_slice_tag fails
234 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
235
236 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
237 - SetSliceVref needed the node role
238 - protect GetSliceFamily
239 - Fix bugs in tag authorizations
240
241 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
242 - altered checking of optional fields in Interfaces
243 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
244 - has pyxml and python-simplejson as new deps
245
246 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
247 - tweak doc extraction for fedora14
248
249 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
250 - builtin accessors for the myslice page
251 - Get{Node,Interface}Tags allowed to techs
252 - tweak in ratelimitaspect.py
253
254 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
255 - add admin role to accessor-related tags (arch, {fc,pl}distro)
256
257 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
258 - bugfix in {Update,Delete}PersonTag
259 - updated xml doc for filters, accessors and tagtypes
260 - more explicit msg in case of missing roles
261 - improvements in ratelimitaspects.py
262
263 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
264 - fix the roles for ssh_key and hmac tags
265
266 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
267 - tag permissions system based on roles and not min_role_ids
268 - accessors simplified accordingly (no more min_role_id)
269 - new methods AddRoleToTagType and DeleteRoleFromTagType
270 - accessor-related tagtypes are created sooner, and enforced
271 - cleaned up redundancy between db-config.d and accessors
272
273 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
274 - fix RefreshPeer that was not working in 5.0-17
275
276 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
277 - RefreshPeer is able to cope with 2 peers running different releases of the api
278 - DeletePerson can be used on duplicates
279 - first appearance of ModPythonJson.py
280
281 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
282 - set accessors return the new value
283 - tweaks in the pubsub groups management
284
285 * Wed Jul 28 2010 S.ÇaÄŸlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
286 - convert hostnames to lower case and use ILIKE instead of LIKE
287
288 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
289 - use hrn in pubsub groups
290
291 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
292 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
293 - - OMF fixes
294
295 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
296 - automatically set vsys tag for omf controlled slices
297
298 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
299 - addition of the 'ssh_key' slice tag
300 - first draft of the LDAP interface
301
302 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
303 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
304 - and readable through GetLeaseGranularity
305 - GetSlivers to expose reservation_policy and lease_granularity
306 - GetBootMedium fixed for reservable nodes
307 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
308 - new Apache mod_wsgi python interface
309
310 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
311 - the leases system
312
313 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
314 - previous tag had gone wrong
315
316 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
317 - fix pubsub hostname
318
319 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
320 - tweaks for the omf support (xmpp groups and RC-controlled slices)
321 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
322 - GetNodeFlavour exposes fcdistro
323
324 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
325 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
326
327 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
328 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
329 - pyaspect hooks allow to  maintain the namespace xmpp groups
330 - new omf_slicemgr is a proxy to xmpp, used by these hooks
331 - nodes have their hrn exposed in the 'hrn' tag
332 - node hrn exposed in GetSlivers, as well as the overall xmpp config
333 - system slice 'drl' gets created by db-config
334 - daniel's changes to Filter for supporting wildcards in lists
335 - AddSliceTag consistency check tweaked
336
337 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
338 - major cleanup
339 - get rid of all 4.2-related legacy code
340 - reset the migrations code, planetlab5.sql somes with (5,100)
341 - uses hashlib module when available
342
343 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
344 - first working version of 5.0:
345 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
346 - nodefamily is 3-fold with pldistro-fcdistro-arch
347 - site and person tags
348 - new methods GetSliceFamily and GetNodeFlavour
349 - deprecated the dummynet stuff that were for the external dummyboxes
350 - tags definition : more consistency between db-config scripts and accessors
351 - (get accessor to create the tag type too if absent)
352 - logging an event for AddSliceToNodes
353
354 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
355 - support for fedora 12
356 - fix subtle bug in filtering with ] and quotes
357
358 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
359 - * patch for php-5.3 (the one in f12)
360 - * validate email addresses with regex
361 - * add PersonTags and SiteTags
362 - * add additional accessors for node tags (kvariant, serial, ..)
363
364 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
365 - Redacting password, session, and authstring values from the event log.
366
367 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
368 - let AddSite set ext_consortium_id - required for the poorman registration pages
369 - drop version constraint on Requires: postgresql-python
370 - don't log system calls nor ReportRunLevel
371
372 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
373 - Fix requires for CentOS.
374
375 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
376 - Require postgresql 8.2 (for array operators && and @>)
377
378 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
379 - Filter now supports the | and & features to match in sequence values
380 - bugfix in the postgresql wrapper for sequence filter values
381 - reviewed GetSlivers to export admin keys more efficiently
382 - fix checking roles in UpdateSliceTag
383
384 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
385 - - Some typos in the documentation were fixed.
386 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
387 - to the tag's min_role_id.
388
389 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
390
391 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
392 - Ongoing work to add upcalls, using new SFA class
393 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
394 - reviewed type-checking for the 3 taggable classes node-interface-slice
395 - cleanup ald dummynet stuff
396 - expose the 'extensions' accessors to the API
397 - tweaked checks in AddSliceTag
398 - GetPersons exposes roles by default
399 - bugfix in ReportRunLevel for non-string levels
400 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
401
402 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
403 - new BindObjectToPeer method for sfa
404 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
405
406 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
407 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
408 - reportrunlevel logs its calls only when run_level changes
409 - pycurl more robust wrt to xmlrpclib.Transport
410
411 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
412 - produce a wsdl interface
413 - bugfix in getbootmedium for nodes with interface tags
414
415 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
416 - bugfix for some rare pattern-based filters
417
418 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
419 - improvements in the 4.2 legacy layer
420
421 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
422 - bugfix required for slice tags set on nodegroups
423
424 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
425 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
426
427 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
428 - more powerful legacy layer with 4.2
429
430 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
431 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
432 - migration script has an option for running interactively
433
434 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
435 - skips already added entries
436
437 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
438 - yet another set of fixes for external dummynet boxes
439
440 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
441 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
442 - and tmp file is cleaned up
443
444 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
445 - restore missing ResolveSlices
446
447 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
448 - new method GetDummyBoxMedium
449
450 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
451 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
452
453 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
454 - support for external dummynet boxes back in 4.3 - first draft
455
456 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
457 - fixes for smooth federation between 4.2 and 4.3
458 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
459
460 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
461 - support for BootCD variants (GetBootMedium ['variant:centos5'])
462 - fix corner case with filters like {'~slice_id':[]}
463 - fix transaction leak that caused the db connections pool to exhaust
464 - properly expose all methods, including Legacy/, and not only Methods/
465
466 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
467 - renumbered as 4.3
468 - nodes have new fields run_level (in addition to boot_state) and verified
469 - tweaked migration from 4.2
470 - tuned rpm dependencies
471 - doc generation more explicit about errors like missing python modules
472 - removed obsolete method GetSlicesMD5
473
474 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
475 - unified all tags
476 - renamed interface settings into interface tags and slice attributes into slice tags
477 - nodes have a node_type
478 - various changes on the way to 4.3
479
480 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
481 - Checkpointing : this version still has interface settings and slice attributes
482
483 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
484 - first iteration with taggable nodes/interfaces/slices
485 - embryo for ilinks
486 - cleaned up boot states
487 - migration script moslty complete
488
489 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
490 - fixed doc build by locating locally installed DTDs at build-time
491
492 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
493 - no more doc packaged outside of myplc-docs - doc/ cleaned up
494 - enhancements in doc on filters 
495 - bootcd-aware GetBootMedium merged from onelab
496
497 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
498 - checkpoint while the new myplc-docs package is underway
499 - bugfix: GetSlivers & conf files
500 - doc: removed target files 
501
502 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
503 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
504 - the non-deleted fields were index, resulting in massivly slow queries.
505
506
507 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
508 - plcsh: better handling of options when running as a shell script
509 - getbootmedium exports compute_key
510 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
511
512 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
513 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
514 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
515
516 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
517 - refresh peer script to use a month-dependent logfile
518 - tracking the starting point for UniPi integration of the dummynet boxes
519
520 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
521 - plcsh adds its own path to sys.path
522 - fix so GetNodes can be called from a Node
523
524 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
525 - Initial build.
526
527 %define module_current_branch 4.3