Setting tag plcapi-5.1-3
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.1
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 Requires: Django
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel PyXML python-simplejson
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %define php_extension_dir %(php-config --extension-dir)
129
130 %files
131 %defattr(-,root,root,-)
132 %dir %{_datadir}/plc_api
133 %dir /var/log/omf/
134 %{_datadir}/plc_api/*
135 %{_bindir}/plcsh
136 %{php_extension_dir}/xmlrpc.so
137 %{_sysconfdir}/php.d/xmlrpc.ini
138 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
139 /etc/plc.d
140 /etc/planetlab/db-config.d
141 /var/www/html/wsdl/plcapi.wsdl
142 /usr/bin/omf_slicemgr.py*
143 /usr/bin/reset_xmpp_pubsub_nodes.py*
144 /var/log/plc_api_ratelimit.log
145
146
147 %changelog
148 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
149 - fixed imports for tags management with sites and persons
150 - add predefined 'cpu_freezable' tag
151
152 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
153 - tweaks in interface initialization
154 - has 'vsys_vnet' as a predefined tagtype
155 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
156 - bugfix: GetSlivers & nodegroups
157 - bugfix: in jabber groups management
158
159 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
160 - fix gpg-authentication for Persons (thanks Jordan)
161 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
162 - ip address/network check: v4 or v6
163 - customized DB Message survive upgrade
164 - make sync works in lxc-hosted tests
165 - no svn keywords anymore
166
167 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
168 - fix sorting for methods list in docs
169 - untested but needed tweak for postgres startup in f16
170
171 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
172 - tweaks in postgresql setup - in line with sfa
173
174 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
175 - slight tweaks in Persons.py
176
177 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
178 - GetSession has support for more than one day sessions
179 - reset_xmpp_pubsub_nodes is much more efficient
180 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
181 - bugfix - deleting a person in the middle of the signup process
182
183 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
184 - ratelimit aspects
185 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
186 - requires Django for cache_utils
187 - attempt to expose 'pldistro' to sfa
188 - last_time_spent_online, last_time_spent_offline: new fields in Node
189 - new slice tags 'isolate_loopback' and 'cpu_cores'
190 - refresh-peer federation logs dump exceptions
191 - modpython logs have a timestamp
192 - more verbose/accurate php error reporting
193 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
194 - AddNode, UpdateNode: manage tags directly rather than through another method
195 - BootUpdateNode: only update once
196 - GetPersons: techs can access the list of persons on their site
197 - GetSlices and GetSliceTags: techs can see slices on their nodes
198 - GetSlivers: isrootonsite tag; cacheable
199
200 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
201 - rename initscript_body into initscript_code
202
203 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
204 - new initscript_body tag
205
206 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
207 - working draft for GetSliceSshKeys
208
209 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
210 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
211 - (this is for people who cancel their download)
212
213 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
214 - fix db-config sequence : accessors step now merged in, and occurs at the right time
215 - db-config also more robust
216 - no more explicit 'accessors' step in plc.d
217
218 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
219 - session auth: do *not* delete session when node runs a method that does not have 'node' role
220 - session auth: remove support for bootonce in old boot CDs
221 - give a reason when caller_may_write_slice_tag fails
222 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
223
224 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
225 - SetSliceVref needed the node role
226 - protect GetSliceFamily
227 - Fix bugs in tag authorizations
228
229 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
230 - altered checking of optional fields in Interfaces
231 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
232 - has pyxml and python-simplejson as new deps
233
234 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
235 - tweak doc extraction for fedora14
236
237 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
238 - builtin accessors for the myslice page
239 - Get{Node,Interface}Tags allowed to techs
240 - tweak in ratelimitaspect.py
241
242 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
243 - add admin role to accessor-related tags (arch, {fc,pl}distro)
244
245 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
246 - bugfix in {Update,Delete}PersonTag
247 - updated xml doc for filters, accessors and tagtypes
248 - more explicit msg in case of missing roles
249 - improvements in ratelimitaspects.py
250
251 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
252 - fix the roles for ssh_key and hmac tags
253
254 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
255 - tag permissions system based on roles and not min_role_ids
256 - accessors simplified accordingly (no more min_role_id)
257 - new methods AddRoleToTagType and DeleteRoleFromTagType
258 - accessor-related tagtypes are created sooner, and enforced
259 - cleaned up redundancy between db-config.d and accessors
260
261 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
262 - fix RefreshPeer that was not working in 5.0-17
263
264 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
265 - RefreshPeer is able to cope with 2 peers running different releases of the api
266 - DeletePerson can be used on duplicates
267 - first appearance of ModPythonJson.py
268
269 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
270 - set accessors return the new value
271 - tweaks in the pubsub groups management
272
273 * Wed Jul 28 2010 S.ÇaÄŸlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
274 - convert hostnames to lower case and use ILIKE instead of LIKE
275
276 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
277 - use hrn in pubsub groups
278
279 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
280 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
281 - - OMF fixes
282
283 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
284 - automatically set vsys tag for omf controlled slices
285
286 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
287 - addition of the 'ssh_key' slice tag
288 - first draft of the LDAP interface
289
290 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
291 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
292 - and readable through GetLeaseGranularity
293 - GetSlivers to expose reservation_policy and lease_granularity
294 - GetBootMedium fixed for reservable nodes
295 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
296 - new Apache mod_wsgi python interface
297
298 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
299 - the leases system
300
301 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
302 - previous tag had gone wrong
303
304 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
305 - fix pubsub hostname
306
307 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
308 - tweaks for the omf support (xmpp groups and RC-controlled slices)
309 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
310 - GetNodeFlavour exposes fcdistro
311
312 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
313 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
314
315 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
316 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
317 - pyaspect hooks allow to  maintain the namespace xmpp groups
318 - new omf_slicemgr is a proxy to xmpp, used by these hooks
319 - nodes have their hrn exposed in the 'hrn' tag
320 - node hrn exposed in GetSlivers, as well as the overall xmpp config
321 - system slice 'drl' gets created by db-config
322 - daniel's changes to Filter for supporting wildcards in lists
323 - AddSliceTag consistency check tweaked
324
325 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
326 - major cleanup
327 - get rid of all 4.2-related legacy code
328 - reset the migrations code, planetlab5.sql somes with (5,100)
329 - uses hashlib module when available
330
331 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
332 - first working version of 5.0:
333 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
334 - nodefamily is 3-fold with pldistro-fcdistro-arch
335 - site and person tags
336 - new methods GetSliceFamily and GetNodeFlavour
337 - deprecated the dummynet stuff that were for the external dummyboxes
338 - tags definition : more consistency between db-config scripts and accessors
339 - (get accessor to create the tag type too if absent)
340 - logging an event for AddSliceToNodes
341
342 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
343 - support for fedora 12
344 - fix subtle bug in filtering with ] and quotes
345
346 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
347 - * patch for php-5.3 (the one in f12)
348 - * validate email addresses with regex
349 - * add PersonTags and SiteTags
350 - * add additional accessors for node tags (kvariant, serial, ..)
351
352 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
353 - Redacting password, session, and authstring values from the event log.
354
355 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
356 - let AddSite set ext_consortium_id - required for the poorman registration pages
357 - drop version constraint on Requires: postgresql-python
358 - don't log system calls nor ReportRunLevel
359
360 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
361 - Fix requires for CentOS.
362
363 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
364 - Require postgresql 8.2 (for array operators && and @>)
365
366 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
367 - Filter now supports the | and & features to match in sequence values
368 - bugfix in the postgresql wrapper for sequence filter values
369 - reviewed GetSlivers to export admin keys more efficiently
370 - fix checking roles in UpdateSliceTag
371
372 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
373 - - Some typos in the documentation were fixed.
374 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
375 - to the tag's min_role_id.
376
377 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
378
379 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
380 - Ongoing work to add upcalls, using new SFA class
381 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
382 - reviewed type-checking for the 3 taggable classes node-interface-slice
383 - cleanup ald dummynet stuff
384 - expose the 'extensions' accessors to the API
385 - tweaked checks in AddSliceTag
386 - GetPersons exposes roles by default
387 - bugfix in ReportRunLevel for non-string levels
388 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
389
390 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
391 - new BindObjectToPeer method for sfa
392 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
393
394 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
395 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
396 - reportrunlevel logs its calls only when run_level changes
397 - pycurl more robust wrt to xmlrpclib.Transport
398
399 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
400 - produce a wsdl interface
401 - bugfix in getbootmedium for nodes with interface tags
402
403 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
404 - bugfix for some rare pattern-based filters
405
406 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
407 - improvements in the 4.2 legacy layer
408
409 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
410 - bugfix required for slice tags set on nodegroups
411
412 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
413 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
414
415 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
416 - more powerful legacy layer with 4.2
417
418 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
419 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
420 - migration script has an option for running interactively
421
422 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
423 - skips already added entries
424
425 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
426 - yet another set of fixes for external dummynet boxes
427
428 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
429 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
430 - and tmp file is cleaned up
431
432 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
433 - restore missing ResolveSlices
434
435 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
436 - new method GetDummyBoxMedium
437
438 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
439 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
440
441 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
442 - support for external dummynet boxes back in 4.3 - first draft
443
444 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
445 - fixes for smooth federation between 4.2 and 4.3
446 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
447
448 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
449 - support for BootCD variants (GetBootMedium ['variant:centos5'])
450 - fix corner case with filters like {'~slice_id':[]}
451 - fix transaction leak that caused the db connections pool to exhaust
452 - properly expose all methods, including Legacy/, and not only Methods/
453
454 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
455 - renumbered as 4.3
456 - nodes have new fields run_level (in addition to boot_state) and verified
457 - tweaked migration from 4.2
458 - tuned rpm dependencies
459 - doc generation more explicit about errors like missing python modules
460 - removed obsolete method GetSlicesMD5
461
462 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
463 - unified all tags
464 - renamed interface settings into interface tags and slice attributes into slice tags
465 - nodes have a node_type
466 - various changes on the way to 4.3
467
468 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
469 - Checkpointing : this version still has interface settings and slice attributes
470
471 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
472 - first iteration with taggable nodes/interfaces/slices
473 - embryo for ilinks
474 - cleaned up boot states
475 - migration script moslty complete
476
477 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
478 - fixed doc build by locating locally installed DTDs at build-time
479
480 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
481 - no more doc packaged outside of myplc-docs - doc/ cleaned up
482 - enhancements in doc on filters 
483 - bootcd-aware GetBootMedium merged from onelab
484
485 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
486 - checkpoint while the new myplc-docs package is underway
487 - bugfix: GetSlivers & conf files
488 - doc: removed target files 
489
490 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
491 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
492 - the non-deleted fields were index, resulting in massivly slow queries.
493
494
495 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
496 - plcsh: better handling of options when running as a shell script
497 - getbootmedium exports compute_key
498 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
499
500 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
501 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
502 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
503
504 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
505 - refresh peer script to use a month-dependent logfile
506 - tracking the starting point for UniPi integration of the dummynet boxes
507
508 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
509 - plcsh adds its own path to sys.path
510 - fix so GetNodes can be called from a Node
511
512 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
513 - Initial build.
514
515 %define module_current_branch 4.3