Setting tag plcapi-5.0-32
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.0
3 %define taglevel 32
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 # Install omf_slicemgr.py
116 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
117 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
118 mkdir -p $RPM_BUILD_ROOT/var/log/omf
119
120 # Install ratelimit log
121 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
122 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %define php_extension_dir %(php-config --extension-dir)
128
129 %files
130 %defattr(-,root,root,-)
131 %dir %{_datadir}/plc_api
132 %dir /var/log/omf/
133 %{_datadir}/plc_api/*
134 %{_bindir}/plcsh
135 %{php_extension_dir}/xmlrpc.so
136 %{_sysconfdir}/php.d/xmlrpc.ini
137 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
138 /etc/plc.d
139 /etc/planetlab/db-config.d
140 /var/www/html/wsdl/plcapi.wsdl
141 /usr/bin/omf_slicemgr.py*
142 /usr/bin/reset_xmpp_pubsub_nodes.py*
143 /var/log/plc_api_ratelimit.log
144
145
146 %changelog
147 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
148 - rename initscript_body into initscript_code
149
150 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
151 - new initscript_body tag
152
153 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
154 - working draft for GetSliceSshKeys
155
156 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
157 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
158 - (this is for people who cancel their download)
159
160 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
161 - fix db-config sequence : accessors step now merged in, and occurs at the right time
162 - db-config also more robust
163 - no more explicit 'accessors' step in plc.d
164
165 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
166 - session auth: do *not* delete session when node runs a method that does not have 'node' role
167 - session auth: remove support for bootonce in old boot CDs
168 - give a reason when caller_may_write_slice_tag fails
169 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
170
171 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
172 - SetSliceVref needed the node role
173 - protect GetSliceFamily
174 - Fix bugs in tag authorizations
175
176 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
177 - altered checking of optional fields in Interfaces
178 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
179 - has pyxml and python-simplejson as new deps
180
181 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
182 - tweak doc extraction for fedora14
183
184 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
185 - builtin accessors for the myslice page
186 - Get{Node,Interface}Tags allowed to techs
187 - tweak in ratelimitaspect.py
188
189 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
190 - add admin role to accessor-related tags (arch, {fc,pl}distro)
191
192 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
193 - bugfix in {Update,Delete}PersonTag
194 - updated xml doc for filters, accessors and tagtypes
195 - more explicit msg in case of missing roles
196 - improvements in ratelimitaspects.py
197
198 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
199 - fix the roles for ssh_key and hmac tags
200
201 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
202 - tag permissions system based on roles and not min_role_ids
203 - accessors simplified accordingly (no more min_role_id)
204 - new methods AddRoleToTagType and DeleteRoleFromTagType
205 - accessor-related tagtypes are created sooner, and enforced
206 - cleaned up redundancy between db-config.d and accessors
207
208 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
209 - fix RefreshPeer that was not working in 5.0-17
210
211 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
212 - RefreshPeer is able to cope with 2 peers running different releases of the api
213 - DeletePerson can be used on duplicates
214 - first appearance of ModPythonJson.py
215
216 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
217 - set accessors return the new value
218 - tweaks in the pubsub groups management
219
220 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
221 - convert hostnames to lower case and use ILIKE instead of LIKE
222
223 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
224 - use hrn in pubsub groups
225
226 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
227 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
228 - - OMF fixes
229
230 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
231 - automatically set vsys tag for omf controlled slices
232
233 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
234 - addition of the 'ssh_key' slice tag
235 - first draft of the LDAP interface
236
237 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
238 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
239 - and readable through GetLeaseGranularity
240 - GetSlivers to expose reservation_policy and lease_granularity
241 - GetBootMedium fixed for reservable nodes
242 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
243 - new Apache mod_wsgi python interface
244
245 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
246 - the leases system
247
248 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
249 - previous tag had gone wrong
250
251 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
252 - fix pubsub hostname
253
254 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
255 - tweaks for the omf support (xmpp groups and RC-controlled slices)
256 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
257 - GetNodeFlavour exposes fcdistro
258
259 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
260 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
261
262 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
263 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
264 - pyaspect hooks allow to  maintain the namespace xmpp groups
265 - new omf_slicemgr is a proxy to xmpp, used by these hooks
266 - nodes have their hrn exposed in the 'hrn' tag
267 - node hrn exposed in GetSlivers, as well as the overall xmpp config
268 - system slice 'drl' gets created by db-config
269 - daniel's changes to Filter for supporting wildcards in lists
270 - AddSliceTag consistency check tweaked
271
272 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
273 - major cleanup
274 - get rid of all 4.2-related legacy code
275 - reset the migrations code, planetlab5.sql somes with (5,100)
276 - uses hashlib module when available
277
278 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
279 - first working version of 5.0:
280 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
281 - nodefamily is 3-fold with pldistro-fcdistro-arch
282 - site and person tags
283 - new methods GetSliceFamily and GetNodeFlavour
284 - deprecated the dummynet stuff that were for the external dummyboxes
285 - tags definition : more consistency between db-config scripts and accessors
286 - (get accessor to create the tag type too if absent)
287 - logging an event for AddSliceToNodes
288
289 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
290 - support for fedora 12
291 - fix subtle bug in filtering with ] and quotes
292
293 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
294 - * patch for php-5.3 (the one in f12)
295 - * validate email addresses with regex
296 - * add PersonTags and SiteTags
297 - * add additional accessors for node tags (kvariant, serial, ..)
298
299 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
300 - Redacting password, session, and authstring values from the event log.
301
302 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
303 - let AddSite set ext_consortium_id - required for the poorman registration pages
304 - drop version constraint on Requires: postgresql-python
305 - don't log system calls nor ReportRunLevel
306
307 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
308 - Fix requires for CentOS.
309
310 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
311 - Require postgresql 8.2 (for array operators && and @>)
312
313 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
314 - Filter now supports the | and & features to match in sequence values
315 - bugfix in the postgresql wrapper for sequence filter values
316 - reviewed GetSlivers to export admin keys more efficiently
317 - fix checking roles in UpdateSliceTag
318
319 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
320 - - Some typos in the documentation were fixed.
321 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
322 - to the tag's min_role_id.
323
324 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
325
326 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
327 - Ongoing work to add upcalls, using new SFA class
328 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
329 - reviewed type-checking for the 3 taggable classes node-interface-slice
330 - cleanup ald dummynet stuff
331 - expose the 'extensions' accessors to the API
332 - tweaked checks in AddSliceTag
333 - GetPersons exposes roles by default
334 - bugfix in ReportRunLevel for non-string levels
335 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
336
337 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
338 - new BindObjectToPeer method for sfa
339 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
340
341 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
342 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
343 - reportrunlevel logs its calls only when run_level changes
344 - pycurl more robust wrt to xmlrpclib.Transport
345
346 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
347 - produce a wsdl interface
348 - bugfix in getbootmedium for nodes with interface tags
349
350 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
351 - bugfix for some rare pattern-based filters
352
353 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
354 - improvements in the 4.2 legacy layer
355
356 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
357 - bugfix required for slice tags set on nodegroups
358
359 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
360 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
361
362 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
363 - more powerful legacy layer with 4.2
364
365 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
366 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
367 - migration script has an option for running interactively
368
369 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
370 - skips already added entries
371
372 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
373 - yet another set of fixes for external dummynet boxes
374
375 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
376 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
377 - and tmp file is cleaned up
378
379 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
380 - restore missing ResolveSlices
381
382 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
383 - new method GetDummyBoxMedium
384
385 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
386 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
387
388 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
389 - support for external dummynet boxes back in 4.3 - first draft
390
391 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
392 - fixes for smooth federation between 4.2 and 4.3
393 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
394
395 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
396 - support for BootCD variants (GetBootMedium ['variant:centos5'])
397 - fix corner case with filters like {'~slice_id':[]}
398 - fix transaction leak that caused the db connections pool to exhaust
399 - properly expose all methods, including Legacy/, and not only Methods/
400
401 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
402 - renumbered as 4.3
403 - nodes have new fields run_level (in addition to boot_state) and verified
404 - tweaked migration from 4.2
405 - tuned rpm dependencies
406 - doc generation more explicit about errors like missing python modules
407 - removed obsolete method GetSlicesMD5
408
409 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
410 - unified all tags
411 - renamed interface settings into interface tags and slice attributes into slice tags
412 - nodes have a node_type
413 - various changes on the way to 4.3
414
415 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
416 - Checkpointing : this version still has interface settings and slice attributes
417
418 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
419 - first iteration with taggable nodes/interfaces/slices
420 - embryo for ilinks
421 - cleaned up boot states
422 - migration script moslty complete
423
424 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
425 - fixed doc build by locating locally installed DTDs at build-time
426
427 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
428 - no more doc packaged outside of myplc-docs - doc/ cleaned up
429 - enhancements in doc on filters 
430 - bootcd-aware GetBootMedium merged from onelab
431
432 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
433 - checkpoint while the new myplc-docs package is underway
434 - bugfix: GetSlivers & conf files
435 - doc: removed target files 
436
437 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
438 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
439 - the non-deleted fields were index, resulting in massivly slow queries.
440
441
442 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
443 - plcsh: better handling of options when running as a shell script
444 - getbootmedium exports compute_key
445 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
446
447 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
448 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
449 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
450
451 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
452 - refresh peer script to use a month-dependent logfile
453 - tracking the starting point for UniPi integration of the dummynet boxes
454
455 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
456 - plcsh adds its own path to sys.path
457 - fix so GetNodes can be called from a Node
458
459 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
460 - Initial build.
461
462 %define module_current_branch 4.3