bump release to 5.1
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.1
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 Requires: Django
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel PyXML python-simplejson
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %define php_extension_dir %(php-config --extension-dir)
129
130 %files
131 %defattr(-,root,root,-)
132 %dir %{_datadir}/plc_api
133 %dir /var/log/omf/
134 %{_datadir}/plc_api/*
135 %{_bindir}/plcsh
136 %{php_extension_dir}/xmlrpc.so
137 %{_sysconfdir}/php.d/xmlrpc.ini
138 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
139 /etc/plc.d
140 /etc/planetlab/db-config.d
141 /var/www/html/wsdl/plcapi.wsdl
142 /usr/bin/omf_slicemgr.py*
143 /usr/bin/reset_xmpp_pubsub_nodes.py*
144 /var/log/plc_api_ratelimit.log
145
146
147 %changelog
148 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
149 - fix sorting for methods list in docs
150 - untested but needed tweak for postgres startup in f16
151
152 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
153 - tweaks in postgresql setup - in line with sfa
154
155 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
156 - slight tweaks in Persons.py
157
158 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
159 - GetSession has support for more than one day sessions
160 - reset_xmpp_pubsub_nodes is much more efficient
161 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
162 - bugfix - deleting a person in the middle of the signup process
163
164 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
165 - ratelimit aspects
166 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
167 - requires Django for cache_utils
168 - attempt to expose 'pldistro' to sfa
169 - last_time_spent_online, last_time_spent_offline: new fields in Node
170 - new slice tags 'isolate_loopback' and 'cpu_cores'
171 - refresh-peer federation logs dump exceptions
172 - modpython logs have a timestamp
173 - more verbose/accurate php error reporting
174 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
175 - AddNode, UpdateNode: manage tags directly rather than through another method
176 - BootUpdateNode: only update once
177 - GetPersons: techs can access the list of persons on their site
178 - GetSlices and GetSliceTags: techs can see slices on their nodes
179 - GetSlivers: isrootonsite tag; cacheable
180
181 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
182 - rename initscript_body into initscript_code
183
184 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
185 - new initscript_body tag
186
187 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
188 - working draft for GetSliceSshKeys
189
190 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
191 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
192 - (this is for people who cancel their download)
193
194 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
195 - fix db-config sequence : accessors step now merged in, and occurs at the right time
196 - db-config also more robust
197 - no more explicit 'accessors' step in plc.d
198
199 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
200 - session auth: do *not* delete session when node runs a method that does not have 'node' role
201 - session auth: remove support for bootonce in old boot CDs
202 - give a reason when caller_may_write_slice_tag fails
203 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
204
205 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
206 - SetSliceVref needed the node role
207 - protect GetSliceFamily
208 - Fix bugs in tag authorizations
209
210 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
211 - altered checking of optional fields in Interfaces
212 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
213 - has pyxml and python-simplejson as new deps
214
215 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
216 - tweak doc extraction for fedora14
217
218 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
219 - builtin accessors for the myslice page
220 - Get{Node,Interface}Tags allowed to techs
221 - tweak in ratelimitaspect.py
222
223 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
224 - add admin role to accessor-related tags (arch, {fc,pl}distro)
225
226 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
227 - bugfix in {Update,Delete}PersonTag
228 - updated xml doc for filters, accessors and tagtypes
229 - more explicit msg in case of missing roles
230 - improvements in ratelimitaspects.py
231
232 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
233 - fix the roles for ssh_key and hmac tags
234
235 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
236 - tag permissions system based on roles and not min_role_ids
237 - accessors simplified accordingly (no more min_role_id)
238 - new methods AddRoleToTagType and DeleteRoleFromTagType
239 - accessor-related tagtypes are created sooner, and enforced
240 - cleaned up redundancy between db-config.d and accessors
241
242 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
243 - fix RefreshPeer that was not working in 5.0-17
244
245 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
246 - RefreshPeer is able to cope with 2 peers running different releases of the api
247 - DeletePerson can be used on duplicates
248 - first appearance of ModPythonJson.py
249
250 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
251 - set accessors return the new value
252 - tweaks in the pubsub groups management
253
254 * Wed Jul 28 2010 S.ÇaÄŸlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
255 - convert hostnames to lower case and use ILIKE instead of LIKE
256
257 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
258 - use hrn in pubsub groups
259
260 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
261 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
262 - - OMF fixes
263
264 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
265 - automatically set vsys tag for omf controlled slices
266
267 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
268 - addition of the 'ssh_key' slice tag
269 - first draft of the LDAP interface
270
271 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
272 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
273 - and readable through GetLeaseGranularity
274 - GetSlivers to expose reservation_policy and lease_granularity
275 - GetBootMedium fixed for reservable nodes
276 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
277 - new Apache mod_wsgi python interface
278
279 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
280 - the leases system
281
282 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
283 - previous tag had gone wrong
284
285 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
286 - fix pubsub hostname
287
288 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
289 - tweaks for the omf support (xmpp groups and RC-controlled slices)
290 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
291 - GetNodeFlavour exposes fcdistro
292
293 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
294 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
295
296 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
297 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
298 - pyaspect hooks allow to  maintain the namespace xmpp groups
299 - new omf_slicemgr is a proxy to xmpp, used by these hooks
300 - nodes have their hrn exposed in the 'hrn' tag
301 - node hrn exposed in GetSlivers, as well as the overall xmpp config
302 - system slice 'drl' gets created by db-config
303 - daniel's changes to Filter for supporting wildcards in lists
304 - AddSliceTag consistency check tweaked
305
306 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
307 - major cleanup
308 - get rid of all 4.2-related legacy code
309 - reset the migrations code, planetlab5.sql somes with (5,100)
310 - uses hashlib module when available
311
312 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
313 - first working version of 5.0:
314 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
315 - nodefamily is 3-fold with pldistro-fcdistro-arch
316 - site and person tags
317 - new methods GetSliceFamily and GetNodeFlavour
318 - deprecated the dummynet stuff that were for the external dummyboxes
319 - tags definition : more consistency between db-config scripts and accessors
320 - (get accessor to create the tag type too if absent)
321 - logging an event for AddSliceToNodes
322
323 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
324 - support for fedora 12
325 - fix subtle bug in filtering with ] and quotes
326
327 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
328 - * patch for php-5.3 (the one in f12)
329 - * validate email addresses with regex
330 - * add PersonTags and SiteTags
331 - * add additional accessors for node tags (kvariant, serial, ..)
332
333 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
334 - Redacting password, session, and authstring values from the event log.
335
336 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
337 - let AddSite set ext_consortium_id - required for the poorman registration pages
338 - drop version constraint on Requires: postgresql-python
339 - don't log system calls nor ReportRunLevel
340
341 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
342 - Fix requires for CentOS.
343
344 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
345 - Require postgresql 8.2 (for array operators && and @>)
346
347 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
348 - Filter now supports the | and & features to match in sequence values
349 - bugfix in the postgresql wrapper for sequence filter values
350 - reviewed GetSlivers to export admin keys more efficiently
351 - fix checking roles in UpdateSliceTag
352
353 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
354 - - Some typos in the documentation were fixed.
355 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
356 - to the tag's min_role_id.
357
358 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
359
360 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
361 - Ongoing work to add upcalls, using new SFA class
362 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
363 - reviewed type-checking for the 3 taggable classes node-interface-slice
364 - cleanup ald dummynet stuff
365 - expose the 'extensions' accessors to the API
366 - tweaked checks in AddSliceTag
367 - GetPersons exposes roles by default
368 - bugfix in ReportRunLevel for non-string levels
369 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
370
371 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
372 - new BindObjectToPeer method for sfa
373 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
374
375 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
376 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
377 - reportrunlevel logs its calls only when run_level changes
378 - pycurl more robust wrt to xmlrpclib.Transport
379
380 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
381 - produce a wsdl interface
382 - bugfix in getbootmedium for nodes with interface tags
383
384 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
385 - bugfix for some rare pattern-based filters
386
387 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
388 - improvements in the 4.2 legacy layer
389
390 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
391 - bugfix required for slice tags set on nodegroups
392
393 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
394 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
395
396 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
397 - more powerful legacy layer with 4.2
398
399 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
400 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
401 - migration script has an option for running interactively
402
403 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
404 - skips already added entries
405
406 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
407 - yet another set of fixes for external dummynet boxes
408
409 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
410 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
411 - and tmp file is cleaned up
412
413 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
414 - restore missing ResolveSlices
415
416 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
417 - new method GetDummyBoxMedium
418
419 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
420 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
421
422 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
423 - support for external dummynet boxes back in 4.3 - first draft
424
425 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
426 - fixes for smooth federation between 4.2 and 4.3
427 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
428
429 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
430 - support for BootCD variants (GetBootMedium ['variant:centos5'])
431 - fix corner case with filters like {'~slice_id':[]}
432 - fix transaction leak that caused the db connections pool to exhaust
433 - properly expose all methods, including Legacy/, and not only Methods/
434
435 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
436 - renumbered as 4.3
437 - nodes have new fields run_level (in addition to boot_state) and verified
438 - tweaked migration from 4.2
439 - tuned rpm dependencies
440 - doc generation more explicit about errors like missing python modules
441 - removed obsolete method GetSlicesMD5
442
443 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
444 - unified all tags
445 - renamed interface settings into interface tags and slice attributes into slice tags
446 - nodes have a node_type
447 - various changes on the way to 4.3
448
449 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
450 - Checkpointing : this version still has interface settings and slice attributes
451
452 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
453 - first iteration with taggable nodes/interfaces/slices
454 - embryo for ilinks
455 - cleaned up boot states
456 - migration script moslty complete
457
458 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
459 - fixed doc build by locating locally installed DTDs at build-time
460
461 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
462 - no more doc packaged outside of myplc-docs - doc/ cleaned up
463 - enhancements in doc on filters 
464 - bootcd-aware GetBootMedium merged from onelab
465
466 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
467 - checkpoint while the new myplc-docs package is underway
468 - bugfix: GetSlivers & conf files
469 - doc: removed target files 
470
471 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
472 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
473 - the non-deleted fields were index, resulting in massivly slow queries.
474
475
476 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
477 - plcsh: better handling of options when running as a shell script
478 - getbootmedium exports compute_key
479 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
480
481 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
482 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
483 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
484
485 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
486 - refresh peer script to use a month-dependent logfile
487 - tracking the starting point for UniPi integration of the dummynet boxes
488
489 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
490 - plcsh adds its own path to sys.path
491 - fix so GetNodes can be called from a Node
492
493 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
494 - Initial build.
495
496 %define module_current_branch 4.3