added create_network(), delete_network(), create_subnet(), delete_subnet(), process_t...
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.1
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Nova Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: python-pycurl
26 Requires: httpd
27 Requires: python-gevent
28 Requires: python-lxml
29 # mod_wsgi will replace mod_python when we are ready
30 Requires: mod_wsgi
31 Requires: mod_ssl
32 Requires: SOAPpy
33 Requires: python-simplejson
34 # for the RebootNodeWithPCU method
35 Requires: pcucontrol >= 1.0-6
36 # for OMF integration
37 Requires: pyaspects >= 0.4
38 Requires: python-twisted-words
39 Requires: python-twisted-web
40 # ldap
41 Requires: python-ldap
42 # for memcache
43 Requires: python-memcached
44 Requires: memcached
45 Requires: Django
46 ### avoid having yum complain about updates, as stuff is moving around
47 # plc.d/api
48
49 # Standard xmlrpc.so that ships with PHP does not marshal NULL
50 BuildRequires: php-devel PyXML python-simplejson
51 Obsoletes: php-xmlrpc
52 Provides: php-xmlrpc
53
54 # PostgreSQL and SOAPpy are necessary to run the API server, but not
55 # plcsh. Since the only supported method of running the server is via
56 # MyPLC anyway, don't be so stringent about binary requirements, in
57 # case people want to install this package just for plcsh.
58 # Requires: postgresql-server, SOAPpy
59 AutoReqProv: no
60
61 %description
62 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
63 PlanetLab Central (PLC) database. The API may be accessed directly via
64 the Python shell program plcsh, through a toy standalone server, or
65 through Apache mod_python.
66
67 %prep
68 %setup -q
69
70 %build
71 # python-pycurl and python-psycopg2 avail. from fedora 5
72 # we used to ship our own version of psycopg2 and pycurl, for fedora4
73 # starting with 4.3, support for these two modules is taken out
74
75 # Build __init__.py metafiles and PHP API. 
76 %{__make} %{?_smp_mflags}
77 %{__make} -C wsdl
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
82
83 # Install shell symlink
84 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
85 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
86
87 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
88 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
89 ; Enable xmlrpc extension module
90 extension=xmlrpc.so
91 EOF
92
93 # Install initscripts
94 echo "* Installing initscripts"
95 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
96 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
97
98 # Install db-config.d files
99 echo "* Installing db-config.d files"
100 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
101 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
102 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
103
104 # Install wsdl
105 echo "* Installing wsdl"
106 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
107
108 # Install omf_slicemgr.py
109 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
110 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
111 mkdir -p $RPM_BUILD_ROOT/var/log/omf
112
113 # Install ratelimit log
114 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
115 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %define php_extension_dir %(php-config --extension-dir)
121
122 %files
123 %defattr(-,root,root,-)
124 %dir %{_datadir}/plc_api
125 %dir /var/log/omf/
126 %{_datadir}/plc_api/*
127 %{_bindir}/plcsh
128 %{php_extension_dir}/xmlrpc.so
129 %{_sysconfdir}/php.d/xmlrpc.ini
130 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
131 /etc/plc.d
132 /etc/planetlab/db-config.d
133 /var/www/html/wsdl/plcapi.wsdl
134 /usr/bin/omf_slicemgr.py*
135 /usr/bin/reset_xmpp_pubsub_nodes.py*
136 /var/log/plc_api_ratelimit.log
137
138
139 %changelog
140 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
141 - fixed imports for tags management with sites and persons
142 - add predefined 'cpu_freezable' tag
143
144 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
145 - tweaks in interface initialization
146 - has 'vsys_vnet' as a predefined tagtype
147 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
148 - bugfix: GetSlivers & nodegroups
149 - bugfix: in jabber groups management
150
151 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
152 - fix gpg-authentication for Persons (thanks Jordan)
153 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
154 - ip address/network check: v4 or v6
155 - customized DB Message survive upgrade
156 - make sync works in lxc-hosted tests
157 - no svn keywords anymore
158
159 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
160 - fix sorting for methods list in docs
161 - untested but needed tweak for postgres startup in f16
162
163 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
164 - tweaks in postgresql setup - in line with sfa
165
166 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
167 - slight tweaks in Persons.py
168
169 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
170 - GetSession has support for more than one day sessions
171 - reset_xmpp_pubsub_nodes is much more efficient
172 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
173 - bugfix - deleting a person in the middle of the signup process
174
175 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
176 - ratelimit aspects
177 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
178 - requires Django for cache_utils
179 - attempt to expose 'pldistro' to sfa
180 - last_time_spent_online, last_time_spent_offline: new fields in Node
181 - new slice tags 'isolate_loopback' and 'cpu_cores'
182 - refresh-peer federation logs dump exceptions
183 - modpython logs have a timestamp
184 - more verbose/accurate php error reporting
185 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
186 - AddNode, UpdateNode: manage tags directly rather than through another method
187 - BootUpdateNode: only update once
188 - GetPersons: techs can access the list of persons on their site
189 - GetSlices and GetSliceTags: techs can see slices on their nodes
190 - GetSlivers: isrootonsite tag; cacheable
191
192 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
193 - rename initscript_body into initscript_code
194
195 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
196 - new initscript_body tag
197
198 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
199 - working draft for GetSliceSshKeys
200
201 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
202 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
203 - (this is for people who cancel their download)
204
205 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
206 - fix db-config sequence : accessors step now merged in, and occurs at the right time
207 - db-config also more robust
208 - no more explicit 'accessors' step in plc.d
209
210 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
211 - session auth: do *not* delete session when node runs a method that does not have 'node' role
212 - session auth: remove support for bootonce in old boot CDs
213 - give a reason when caller_may_write_slice_tag fails
214 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
215
216 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
217 - SetSliceVref needed the node role
218 - protect GetSliceFamily
219 - Fix bugs in tag authorizations
220
221 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
222 - altered checking of optional fields in Interfaces
223 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
224 - has pyxml and python-simplejson as new deps
225
226 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
227 - tweak doc extraction for fedora14
228
229 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
230 - builtin accessors for the myslice page
231 - Get{Node,Interface}Tags allowed to techs
232 - tweak in ratelimitaspect.py
233
234 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
235 - add admin role to accessor-related tags (arch, {fc,pl}distro)
236
237 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
238 - bugfix in {Update,Delete}PersonTag
239 - updated xml doc for filters, accessors and tagtypes
240 - more explicit msg in case of missing roles
241 - improvements in ratelimitaspects.py
242
243 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
244 - fix the roles for ssh_key and hmac tags
245
246 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
247 - tag permissions system based on roles and not min_role_ids
248 - accessors simplified accordingly (no more min_role_id)
249 - new methods AddRoleToTagType and DeleteRoleFromTagType
250 - accessor-related tagtypes are created sooner, and enforced
251 - cleaned up redundancy between db-config.d and accessors
252
253 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
254 - fix RefreshPeer that was not working in 5.0-17
255
256 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
257 - RefreshPeer is able to cope with 2 peers running different releases of the api
258 - DeletePerson can be used on duplicates
259 - first appearance of ModPythonJson.py
260
261 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
262 - set accessors return the new value
263 - tweaks in the pubsub groups management
264
265 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
266 - convert hostnames to lower case and use ILIKE instead of LIKE
267
268 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
269 - use hrn in pubsub groups
270
271 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
272 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
273 - - OMF fixes
274
275 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
276 - automatically set vsys tag for omf controlled slices
277
278 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
279 - addition of the 'ssh_key' slice tag
280 - first draft of the LDAP interface
281
282 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
283 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
284 - and readable through GetLeaseGranularity
285 - GetSlivers to expose reservation_policy and lease_granularity
286 - GetBootMedium fixed for reservable nodes
287 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
288 - new Apache mod_wsgi python interface
289
290 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
291 - the leases system
292
293 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
294 - previous tag had gone wrong
295
296 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
297 - fix pubsub hostname
298
299 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
300 - tweaks for the omf support (xmpp groups and RC-controlled slices)
301 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
302 - GetNodeFlavour exposes fcdistro
303
304 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
305 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
306
307 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
308 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
309 - pyaspect hooks allow to  maintain the namespace xmpp groups
310 - new omf_slicemgr is a proxy to xmpp, used by these hooks
311 - nodes have their hrn exposed in the 'hrn' tag
312 - node hrn exposed in GetSlivers, as well as the overall xmpp config
313 - system slice 'drl' gets created by db-config
314 - daniel's changes to Filter for supporting wildcards in lists
315 - AddSliceTag consistency check tweaked
316
317 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
318 - major cleanup
319 - get rid of all 4.2-related legacy code
320 - reset the migrations code, planetlab5.sql somes with (5,100)
321 - uses hashlib module when available
322
323 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
324 - first working version of 5.0:
325 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
326 - nodefamily is 3-fold with pldistro-fcdistro-arch
327 - site and person tags
328 - new methods GetSliceFamily and GetNodeFlavour
329 - deprecated the dummynet stuff that were for the external dummyboxes
330 - tags definition : more consistency between db-config scripts and accessors
331 - (get accessor to create the tag type too if absent)
332 - logging an event for AddSliceToNodes
333
334 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
335 - support for fedora 12
336 - fix subtle bug in filtering with ] and quotes
337
338 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
339 - * patch for php-5.3 (the one in f12)
340 - * validate email addresses with regex
341 - * add PersonTags and SiteTags
342 - * add additional accessors for node tags (kvariant, serial, ..)
343
344 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
345 - Redacting password, session, and authstring values from the event log.
346
347 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
348 - let AddSite set ext_consortium_id - required for the poorman registration pages
349 - drop version constraint on Requires: postgresql-python
350 - don't log system calls nor ReportRunLevel
351
352 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
353 - Fix requires for CentOS.
354
355 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
356 - Require postgresql 8.2 (for array operators && and @>)
357
358 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
359 - Filter now supports the | and & features to match in sequence values
360 - bugfix in the postgresql wrapper for sequence filter values
361 - reviewed GetSlivers to export admin keys more efficiently
362 - fix checking roles in UpdateSliceTag
363
364 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
365 - - Some typos in the documentation were fixed.
366 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
367 - to the tag's min_role_id.
368
369 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
370
371 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
372 - Ongoing work to add upcalls, using new SFA class
373 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
374 - reviewed type-checking for the 3 taggable classes node-interface-slice
375 - cleanup ald dummynet stuff
376 - expose the 'extensions' accessors to the API
377 - tweaked checks in AddSliceTag
378 - GetPersons exposes roles by default
379 - bugfix in ReportRunLevel for non-string levels
380 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
381
382 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
383 - new BindObjectToPeer method for sfa
384 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
385
386 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
387 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
388 - reportrunlevel logs its calls only when run_level changes
389 - pycurl more robust wrt to xmlrpclib.Transport
390
391 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
392 - produce a wsdl interface
393 - bugfix in getbootmedium for nodes with interface tags
394
395 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
396 - bugfix for some rare pattern-based filters
397
398 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
399 - improvements in the 4.2 legacy layer
400
401 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
402 - bugfix required for slice tags set on nodegroups
403
404 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
405 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
406
407 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
408 - more powerful legacy layer with 4.2
409
410 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
411 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
412 - migration script has an option for running interactively
413
414 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
415 - skips already added entries
416
417 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
418 - yet another set of fixes for external dummynet boxes
419
420 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
421 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
422 - and tmp file is cleaned up
423
424 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
425 - restore missing ResolveSlices
426
427 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
428 - new method GetDummyBoxMedium
429
430 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
431 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
432
433 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
434 - support for external dummynet boxes back in 4.3 - first draft
435
436 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
437 - fixes for smooth federation between 4.2 and 4.3
438 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
439
440 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
441 - support for BootCD variants (GetBootMedium ['variant:centos5'])
442 - fix corner case with filters like {'~slice_id':[]}
443 - fix transaction leak that caused the db connections pool to exhaust
444 - properly expose all methods, including Legacy/, and not only Methods/
445
446 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
447 - renumbered as 4.3
448 - nodes have new fields run_level (in addition to boot_state) and verified
449 - tweaked migration from 4.2
450 - tuned rpm dependencies
451 - doc generation more explicit about errors like missing python modules
452 - removed obsolete method GetSlicesMD5
453
454 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
455 - unified all tags
456 - renamed interface settings into interface tags and slice attributes into slice tags
457 - nodes have a node_type
458 - various changes on the way to 4.3
459
460 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
461 - Checkpointing : this version still has interface settings and slice attributes
462
463 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
464 - first iteration with taggable nodes/interfaces/slices
465 - embryo for ilinks
466 - cleaned up boot states
467 - migration script moslty complete
468
469 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
470 - fixed doc build by locating locally installed DTDs at build-time
471
472 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
473 - no more doc packaged outside of myplc-docs - doc/ cleaned up
474 - enhancements in doc on filters 
475 - bootcd-aware GetBootMedium merged from onelab
476
477 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
478 - checkpoint while the new myplc-docs package is underway
479 - bugfix: GetSlivers & conf files
480 - doc: removed target files 
481
482 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
483 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
484 - the non-deleted fields were index, resulting in massivly slow queries.
485
486
487 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
488 - plcsh: better handling of options when running as a shell script
489 - getbootmedium exports compute_key
490 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
491
492 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
493 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
494 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
495
496 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
497 - refresh peer script to use a month-dependent logfile
498 - tracking the starting point for UniPi integration of the dummynet boxes
499
500 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
501 - plcsh adds its own path to sys.path
502 - fix so GetNodes can be called from a Node
503
504 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
505 - Initial build.
506
507 %define module_current_branch 4.3