Merge commit 'origin/master'
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.0
3 %define taglevel 31
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 Requires: Django
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel PyXML python-simplejson
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %define php_extension_dir %(php-config --extension-dir)
129
130 %files
131 %defattr(-,root,root,-)
132 %dir %{_datadir}/plc_api
133 %dir /var/log/omf/
134 %{_datadir}/plc_api/*
135 %{_bindir}/plcsh
136 %{php_extension_dir}/xmlrpc.so
137 %{_sysconfdir}/php.d/xmlrpc.ini
138 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
139 /etc/plc.d
140 /etc/planetlab/db-config.d
141 /var/www/html/wsdl/plcapi.wsdl
142 /usr/bin/omf_slicemgr.py*
143 /usr/bin/reset_xmpp_pubsub_nodes.py*
144 /var/log/plc_api_ratelimit.log
145
146
147 %changelog
148 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
149 - new initscript_body tag
150
151 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
152 - working draft for GetSliceSshKeys
153
154 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
155 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
156 - (this is for people who cancel their download)
157
158 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
159 - fix db-config sequence : accessors step now merged in, and occurs at the right time
160 - db-config also more robust
161 - no more explicit 'accessors' step in plc.d
162
163 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
164 - session auth: do *not* delete session when node runs a method that does not have 'node' role
165 - session auth: remove support for bootonce in old boot CDs
166 - give a reason when caller_may_write_slice_tag fails
167 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
168
169 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
170 - SetSliceVref needed the node role
171 - protect GetSliceFamily
172 - Fix bugs in tag authorizations
173
174 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
175 - altered checking of optional fields in Interfaces
176 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
177 - has pyxml and python-simplejson as new deps
178
179 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
180 - tweak doc extraction for fedora14
181
182 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
183 - builtin accessors for the myslice page
184 - Get{Node,Interface}Tags allowed to techs
185 - tweak in ratelimitaspect.py
186
187 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
188 - add admin role to accessor-related tags (arch, {fc,pl}distro)
189
190 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
191 - bugfix in {Update,Delete}PersonTag
192 - updated xml doc for filters, accessors and tagtypes
193 - more explicit msg in case of missing roles
194 - improvements in ratelimitaspects.py
195
196 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
197 - fix the roles for ssh_key and hmac tags
198
199 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
200 - tag permissions system based on roles and not min_role_ids
201 - accessors simplified accordingly (no more min_role_id)
202 - new methods AddRoleToTagType and DeleteRoleFromTagType
203 - accessor-related tagtypes are created sooner, and enforced
204 - cleaned up redundancy between db-config.d and accessors
205
206 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
207 - fix RefreshPeer that was not working in 5.0-17
208
209 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
210 - RefreshPeer is able to cope with 2 peers running different releases of the api
211 - DeletePerson can be used on duplicates
212 - first appearance of ModPythonJson.py
213
214 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
215 - set accessors return the new value
216 - tweaks in the pubsub groups management
217
218 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
219 - convert hostnames to lower case and use ILIKE instead of LIKE
220
221 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
222 - use hrn in pubsub groups
223
224 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
225 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
226 - - OMF fixes
227
228 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
229 - automatically set vsys tag for omf controlled slices
230
231 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
232 - addition of the 'ssh_key' slice tag
233 - first draft of the LDAP interface
234
235 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
236 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
237 - and readable through GetLeaseGranularity
238 - GetSlivers to expose reservation_policy and lease_granularity
239 - GetBootMedium fixed for reservable nodes
240 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
241 - new Apache mod_wsgi python interface
242
243 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
244 - the leases system
245
246 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
247 - previous tag had gone wrong
248
249 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
250 - fix pubsub hostname
251
252 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
253 - tweaks for the omf support (xmpp groups and RC-controlled slices)
254 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
255 - GetNodeFlavour exposes fcdistro
256
257 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
258 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
259
260 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
261 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
262 - pyaspect hooks allow to  maintain the namespace xmpp groups
263 - new omf_slicemgr is a proxy to xmpp, used by these hooks
264 - nodes have their hrn exposed in the 'hrn' tag
265 - node hrn exposed in GetSlivers, as well as the overall xmpp config
266 - system slice 'drl' gets created by db-config
267 - daniel's changes to Filter for supporting wildcards in lists
268 - AddSliceTag consistency check tweaked
269
270 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
271 - major cleanup
272 - get rid of all 4.2-related legacy code
273 - reset the migrations code, planetlab5.sql somes with (5,100)
274 - uses hashlib module when available
275
276 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
277 - first working version of 5.0:
278 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
279 - nodefamily is 3-fold with pldistro-fcdistro-arch
280 - site and person tags
281 - new methods GetSliceFamily and GetNodeFlavour
282 - deprecated the dummynet stuff that were for the external dummyboxes
283 - tags definition : more consistency between db-config scripts and accessors
284 - (get accessor to create the tag type too if absent)
285 - logging an event for AddSliceToNodes
286
287 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
288 - support for fedora 12
289 - fix subtle bug in filtering with ] and quotes
290
291 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
292 - * patch for php-5.3 (the one in f12)
293 - * validate email addresses with regex
294 - * add PersonTags and SiteTags
295 - * add additional accessors for node tags (kvariant, serial, ..)
296
297 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
298 - Redacting password, session, and authstring values from the event log.
299
300 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
301 - let AddSite set ext_consortium_id - required for the poorman registration pages
302 - drop version constraint on Requires: postgresql-python
303 - don't log system calls nor ReportRunLevel
304
305 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
306 - Fix requires for CentOS.
307
308 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
309 - Require postgresql 8.2 (for array operators && and @>)
310
311 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
312 - Filter now supports the | and & features to match in sequence values
313 - bugfix in the postgresql wrapper for sequence filter values
314 - reviewed GetSlivers to export admin keys more efficiently
315 - fix checking roles in UpdateSliceTag
316
317 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
318 - - Some typos in the documentation were fixed.
319 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
320 - to the tag's min_role_id.
321
322 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
323
324 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
325 - Ongoing work to add upcalls, using new SFA class
326 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
327 - reviewed type-checking for the 3 taggable classes node-interface-slice
328 - cleanup ald dummynet stuff
329 - expose the 'extensions' accessors to the API
330 - tweaked checks in AddSliceTag
331 - GetPersons exposes roles by default
332 - bugfix in ReportRunLevel for non-string levels
333 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
334
335 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
336 - new BindObjectToPeer method for sfa
337 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
338
339 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
340 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
341 - reportrunlevel logs its calls only when run_level changes
342 - pycurl more robust wrt to xmlrpclib.Transport
343
344 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
345 - produce a wsdl interface
346 - bugfix in getbootmedium for nodes with interface tags
347
348 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
349 - bugfix for some rare pattern-based filters
350
351 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
352 - improvements in the 4.2 legacy layer
353
354 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
355 - bugfix required for slice tags set on nodegroups
356
357 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
358 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
359
360 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
361 - more powerful legacy layer with 4.2
362
363 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
364 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
365 - migration script has an option for running interactively
366
367 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
368 - skips already added entries
369
370 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
371 - yet another set of fixes for external dummynet boxes
372
373 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
374 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
375 - and tmp file is cleaned up
376
377 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
378 - restore missing ResolveSlices
379
380 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
381 - new method GetDummyBoxMedium
382
383 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
384 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
385
386 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
387 - support for external dummynet boxes back in 4.3 - first draft
388
389 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
390 - fixes for smooth federation between 4.2 and 4.3
391 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
392
393 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
394 - support for BootCD variants (GetBootMedium ['variant:centos5'])
395 - fix corner case with filters like {'~slice_id':[]}
396 - fix transaction leak that caused the db connections pool to exhaust
397 - properly expose all methods, including Legacy/, and not only Methods/
398
399 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
400 - renumbered as 4.3
401 - nodes have new fields run_level (in addition to boot_state) and verified
402 - tweaked migration from 4.2
403 - tuned rpm dependencies
404 - doc generation more explicit about errors like missing python modules
405 - removed obsolete method GetSlicesMD5
406
407 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
408 - unified all tags
409 - renamed interface settings into interface tags and slice attributes into slice tags
410 - nodes have a node_type
411 - various changes on the way to 4.3
412
413 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
414 - Checkpointing : this version still has interface settings and slice attributes
415
416 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
417 - first iteration with taggable nodes/interfaces/slices
418 - embryo for ilinks
419 - cleaned up boot states
420 - migration script moslty complete
421
422 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
423 - fixed doc build by locating locally installed DTDs at build-time
424
425 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
426 - no more doc packaged outside of myplc-docs - doc/ cleaned up
427 - enhancements in doc on filters 
428 - bootcd-aware GetBootMedium merged from onelab
429
430 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
431 - checkpoint while the new myplc-docs package is underway
432 - bugfix: GetSlivers & conf files
433 - doc: removed target files 
434
435 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
436 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
437 - the non-deleted fields were index, resulting in massivly slow queries.
438
439
440 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
441 - plcsh: better handling of options when running as a shell script
442 - getbootmedium exports compute_key
443 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
444
445 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
446 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
447 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
448
449 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
450 - refresh peer script to use a month-dependent logfile
451 - tracking the starting point for UniPi integration of the dummynet boxes
452
453 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
454 - plcsh adds its own path to sys.path
455 - fix so GetNodes can be called from a Node
456
457 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
458 - Initial build.
459
460 %define module_current_branch 4.3