accessors GetPersonHrn and SetPersonHrn
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.1
3 %define taglevel 4
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 Requires: Django
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel PyXML python-simplejson
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %define php_extension_dir %(php-config --extension-dir)
129
130 %files
131 %defattr(-,root,root,-)
132 %dir %{_datadir}/plc_api
133 %dir /var/log/omf/
134 %{_datadir}/plc_api/*
135 %{_bindir}/plcsh
136 %{php_extension_dir}/xmlrpc.so
137 %{_sysconfdir}/php.d/xmlrpc.ini
138 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
139 /etc/plc.d
140 /etc/planetlab/db-config.d
141 /var/www/html/wsdl/plcapi.wsdl
142 /usr/bin/omf_slicemgr.py*
143 /usr/bin/reset_xmpp_pubsub_nodes.py*
144 /var/log/plc_api_ratelimit.log
145
146
147 %changelog
148 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
149 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
150 - reset_xmpp_pubsub_nodes now hos options and usage
151 - new Accessors for vicci
152
153 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
154 - fixed imports for tags management with sites and persons
155 - add predefined 'cpu_freezable' tag
156
157 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
158 - tweaks in interface initialization
159 - has 'vsys_vnet' as a predefined tagtype
160 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
161 - bugfix: GetSlivers & nodegroups
162 - bugfix: in jabber groups management
163
164 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
165 - fix gpg-authentication for Persons (thanks Jordan)
166 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
167 - ip address/network check: v4 or v6
168 - customized DB Message survive upgrade
169 - make sync works in lxc-hosted tests
170 - no svn keywords anymore
171
172 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
173 - fix sorting for methods list in docs
174 - untested but needed tweak for postgres startup in f16
175
176 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
177 - tweaks in postgresql setup - in line with sfa
178
179 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
180 - slight tweaks in Persons.py
181
182 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
183 - GetSession has support for more than one day sessions
184 - reset_xmpp_pubsub_nodes is much more efficient
185 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
186 - bugfix - deleting a person in the middle of the signup process
187
188 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
189 - ratelimit aspects
190 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
191 - requires Django for cache_utils
192 - attempt to expose 'pldistro' to sfa
193 - last_time_spent_online, last_time_spent_offline: new fields in Node
194 - new slice tags 'isolate_loopback' and 'cpu_cores'
195 - refresh-peer federation logs dump exceptions
196 - modpython logs have a timestamp
197 - more verbose/accurate php error reporting
198 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
199 - AddNode, UpdateNode: manage tags directly rather than through another method
200 - BootUpdateNode: only update once
201 - GetPersons: techs can access the list of persons on their site
202 - GetSlices and GetSliceTags: techs can see slices on their nodes
203 - GetSlivers: isrootonsite tag; cacheable
204
205 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
206 - rename initscript_body into initscript_code
207
208 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
209 - new initscript_body tag
210
211 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
212 - working draft for GetSliceSshKeys
213
214 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
215 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
216 - (this is for people who cancel their download)
217
218 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
219 - fix db-config sequence : accessors step now merged in, and occurs at the right time
220 - db-config also more robust
221 - no more explicit 'accessors' step in plc.d
222
223 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
224 - session auth: do *not* delete session when node runs a method that does not have 'node' role
225 - session auth: remove support for bootonce in old boot CDs
226 - give a reason when caller_may_write_slice_tag fails
227 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
228
229 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
230 - SetSliceVref needed the node role
231 - protect GetSliceFamily
232 - Fix bugs in tag authorizations
233
234 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
235 - altered checking of optional fields in Interfaces
236 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
237 - has pyxml and python-simplejson as new deps
238
239 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
240 - tweak doc extraction for fedora14
241
242 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
243 - builtin accessors for the myslice page
244 - Get{Node,Interface}Tags allowed to techs
245 - tweak in ratelimitaspect.py
246
247 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
248 - add admin role to accessor-related tags (arch, {fc,pl}distro)
249
250 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
251 - bugfix in {Update,Delete}PersonTag
252 - updated xml doc for filters, accessors and tagtypes
253 - more explicit msg in case of missing roles
254 - improvements in ratelimitaspects.py
255
256 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
257 - fix the roles for ssh_key and hmac tags
258
259 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
260 - tag permissions system based on roles and not min_role_ids
261 - accessors simplified accordingly (no more min_role_id)
262 - new methods AddRoleToTagType and DeleteRoleFromTagType
263 - accessor-related tagtypes are created sooner, and enforced
264 - cleaned up redundancy between db-config.d and accessors
265
266 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
267 - fix RefreshPeer that was not working in 5.0-17
268
269 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
270 - RefreshPeer is able to cope with 2 peers running different releases of the api
271 - DeletePerson can be used on duplicates
272 - first appearance of ModPythonJson.py
273
274 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
275 - set accessors return the new value
276 - tweaks in the pubsub groups management
277
278 * Wed Jul 28 2010 S.ÇaÄŸlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
279 - convert hostnames to lower case and use ILIKE instead of LIKE
280
281 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
282 - use hrn in pubsub groups
283
284 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
285 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
286 - - OMF fixes
287
288 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
289 - automatically set vsys tag for omf controlled slices
290
291 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
292 - addition of the 'ssh_key' slice tag
293 - first draft of the LDAP interface
294
295 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
296 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
297 - and readable through GetLeaseGranularity
298 - GetSlivers to expose reservation_policy and lease_granularity
299 - GetBootMedium fixed for reservable nodes
300 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
301 - new Apache mod_wsgi python interface
302
303 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
304 - the leases system
305
306 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
307 - previous tag had gone wrong
308
309 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
310 - fix pubsub hostname
311
312 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
313 - tweaks for the omf support (xmpp groups and RC-controlled slices)
314 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
315 - GetNodeFlavour exposes fcdistro
316
317 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
318 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
319
320 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
321 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
322 - pyaspect hooks allow to  maintain the namespace xmpp groups
323 - new omf_slicemgr is a proxy to xmpp, used by these hooks
324 - nodes have their hrn exposed in the 'hrn' tag
325 - node hrn exposed in GetSlivers, as well as the overall xmpp config
326 - system slice 'drl' gets created by db-config
327 - daniel's changes to Filter for supporting wildcards in lists
328 - AddSliceTag consistency check tweaked
329
330 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
331 - major cleanup
332 - get rid of all 4.2-related legacy code
333 - reset the migrations code, planetlab5.sql somes with (5,100)
334 - uses hashlib module when available
335
336 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
337 - first working version of 5.0:
338 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
339 - nodefamily is 3-fold with pldistro-fcdistro-arch
340 - site and person tags
341 - new methods GetSliceFamily and GetNodeFlavour
342 - deprecated the dummynet stuff that were for the external dummyboxes
343 - tags definition : more consistency between db-config scripts and accessors
344 - (get accessor to create the tag type too if absent)
345 - logging an event for AddSliceToNodes
346
347 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
348 - support for fedora 12
349 - fix subtle bug in filtering with ] and quotes
350
351 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
352 - * patch for php-5.3 (the one in f12)
353 - * validate email addresses with regex
354 - * add PersonTags and SiteTags
355 - * add additional accessors for node tags (kvariant, serial, ..)
356
357 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
358 - Redacting password, session, and authstring values from the event log.
359
360 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
361 - let AddSite set ext_consortium_id - required for the poorman registration pages
362 - drop version constraint on Requires: postgresql-python
363 - don't log system calls nor ReportRunLevel
364
365 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
366 - Fix requires for CentOS.
367
368 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
369 - Require postgresql 8.2 (for array operators && and @>)
370
371 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
372 - Filter now supports the | and & features to match in sequence values
373 - bugfix in the postgresql wrapper for sequence filter values
374 - reviewed GetSlivers to export admin keys more efficiently
375 - fix checking roles in UpdateSliceTag
376
377 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
378 - - Some typos in the documentation were fixed.
379 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
380 - to the tag's min_role_id.
381
382 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
383
384 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
385 - Ongoing work to add upcalls, using new SFA class
386 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
387 - reviewed type-checking for the 3 taggable classes node-interface-slice
388 - cleanup ald dummynet stuff
389 - expose the 'extensions' accessors to the API
390 - tweaked checks in AddSliceTag
391 - GetPersons exposes roles by default
392 - bugfix in ReportRunLevel for non-string levels
393 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
394
395 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
396 - new BindObjectToPeer method for sfa
397 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
398
399 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
400 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
401 - reportrunlevel logs its calls only when run_level changes
402 - pycurl more robust wrt to xmlrpclib.Transport
403
404 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
405 - produce a wsdl interface
406 - bugfix in getbootmedium for nodes with interface tags
407
408 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
409 - bugfix for some rare pattern-based filters
410
411 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
412 - improvements in the 4.2 legacy layer
413
414 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
415 - bugfix required for slice tags set on nodegroups
416
417 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
418 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
419
420 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
421 - more powerful legacy layer with 4.2
422
423 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
424 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
425 - migration script has an option for running interactively
426
427 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
428 - skips already added entries
429
430 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
431 - yet another set of fixes for external dummynet boxes
432
433 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
434 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
435 - and tmp file is cleaned up
436
437 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
438 - restore missing ResolveSlices
439
440 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
441 - new method GetDummyBoxMedium
442
443 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
444 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
445
446 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
447 - support for external dummynet boxes back in 4.3 - first draft
448
449 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
450 - fixes for smooth federation between 4.2 and 4.3
451 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
452
453 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
454 - support for BootCD variants (GetBootMedium ['variant:centos5'])
455 - fix corner case with filters like {'~slice_id':[]}
456 - fix transaction leak that caused the db connections pool to exhaust
457 - properly expose all methods, including Legacy/, and not only Methods/
458
459 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
460 - renumbered as 4.3
461 - nodes have new fields run_level (in addition to boot_state) and verified
462 - tweaked migration from 4.2
463 - tuned rpm dependencies
464 - doc generation more explicit about errors like missing python modules
465 - removed obsolete method GetSlicesMD5
466
467 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
468 - unified all tags
469 - renamed interface settings into interface tags and slice attributes into slice tags
470 - nodes have a node_type
471 - various changes on the way to 4.3
472
473 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
474 - Checkpointing : this version still has interface settings and slice attributes
475
476 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
477 - first iteration with taggable nodes/interfaces/slices
478 - embryo for ilinks
479 - cleaned up boot states
480 - migration script moslty complete
481
482 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
483 - fixed doc build by locating locally installed DTDs at build-time
484
485 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
486 - no more doc packaged outside of myplc-docs - doc/ cleaned up
487 - enhancements in doc on filters 
488 - bootcd-aware GetBootMedium merged from onelab
489
490 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
491 - checkpoint while the new myplc-docs package is underway
492 - bugfix: GetSlivers & conf files
493 - doc: removed target files 
494
495 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
496 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
497 - the non-deleted fields were index, resulting in massivly slow queries.
498
499
500 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
501 - plcsh: better handling of options when running as a shell script
502 - getbootmedium exports compute_key
503 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
504
505 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
506 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
507 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
508
509 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
510 - refresh peer script to use a month-dependent logfile
511 - tracking the starting point for UniPi integration of the dummynet boxes
512
513 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
514 - plcsh adds its own path to sys.path
515 - fix so GetNodes can be called from a Node
516
517 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
518 - Initial build.
519
520 %define module_current_branch 4.3