Merge branch 'master' into memcache
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 18
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 # mod_wsgi will replace mod_python when we are ready
38 Requires: mod_wsgi
39 Requires: mod_ssl
40 Requires: SOAPpy
41 Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50 # for memcache
51 Requires: python-memcached
52 Requires: memcached
53 Requires: php-pecl-memcache
54 ### avoid having yum complain about updates, as stuff is moving around
55 # plc.d/api
56 Conflicts: MyPLC <= 4.3
57
58 # We use psycopg2
59 #
60 # but we don't need to rebuild it as we depend on distro's packages - baris
61 # BuildRequires: postgresql-devel
62
63 # Standard xmlrpc.so that ships with PHP does not marshal NULL
64 BuildRequires: php-devel
65 Obsoletes: php-xmlrpc
66 Provides: php-xmlrpc
67
68 # PostgreSQL and SOAPpy are necessary to run the API server, but not
69 # plcsh. Since the only supported method of running the server is via
70 # MyPLC anyway, don't be so stringent about binary requirements, in
71 # case people want to install this package just for plcsh.
72 # Requires: postgresql-server, SOAPpy
73 AutoReqProv: no
74
75 %description
76 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
77 PlanetLab Central (PLC) database. The API may be accessed directly via
78 the Python shell program plcsh, through a toy standalone server, or
79 through Apache mod_python.
80
81 %prep
82 %setup -q
83
84 %build
85 # python-pycurl and python-psycopg2 avail. from fedora 5
86 # we used to ship our own version of psycopg2 and pycurl, for fedora4
87 # starting with 4.3, support for these two modules is taken out
88
89 # Build __init__.py metafiles and PHP API. 
90 %{__make} %{?_smp_mflags}
91 %{__make} -C wsdl
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
96
97 # Install shell symlink
98 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
99 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
100
101 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
102 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
103 ; Enable xmlrpc extension module
104 extension=xmlrpc.so
105 EOF
106
107 # Install initscripts
108 echo "* Installing initscripts"
109 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
110 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
111
112 # Install db-config.d files
113 echo "* Installing db-config.d files"
114 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
115 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
116 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
117
118 # Install wsdl
119 echo "* Installing wsdl"
120 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
121
122 # Install omf_slicemgr.py
123 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
124 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
125 mkdir -p $RPM_BUILD_ROOT/var/log/omf
126
127 # Install ratelimit log
128 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
129 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %define php_extension_dir %(php-config --extension-dir)
135
136 %files
137 %defattr(-,root,root,-)
138 %dir %{_datadir}/plc_api
139 %dir /var/log/omf/
140 %{_datadir}/plc_api/*
141 %{_bindir}/plcsh
142 %{php_extension_dir}/xmlrpc.so
143 %{_sysconfdir}/php.d/xmlrpc.ini
144 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
145 /etc/plc.d
146 /etc/planetlab/db-config.d
147 /var/www/html/wsdl/plcapi.wsdl
148 /usr/bin/omf_slicemgr.py*
149 /usr/bin/reset_xmpp_pubsub_nodes.py*
150
151
152 %changelog
153 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
154 - fix RefreshPeer that was not working in 5.0-17
155
156 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
157 - RefreshPeer is able to cope with 2 peers running different releases of the api
158 - DeletePerson can be used on duplicates
159 - first appearance of ModPythonJson.py
160
161 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
162 - set accessors return the new value
163 - tweaks in the pubsub groups management
164
165 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
166 - convert hostnames to lower case and use ILIKE instead of LIKE
167
168 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
169 - use hrn in pubsub groups
170
171 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
172 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
173 - - OMF fixes
174
175 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
176 - automatically set vsys tag for omf controlled slices
177
178 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
179 - addition of the 'ssh_key' slice tag
180 - first draft of the LDAP interface
181
182 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
183 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
184 - and readable through GetLeaseGranularity
185 - GetSlivers to expose reservation_policy and lease_granularity
186 - GetBootMedium fixed for reservable nodes
187 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
188 - new Apache mod_wsgi python interface
189
190 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
191 - the leases system
192
193 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
194 - previous tag had gone wrong
195
196 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
197 - fix pubsub hostname
198
199 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
200 - tweaks for the omf support (xmpp groups and RC-controlled slices)
201 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
202 - GetNodeFlavour exposes fcdistro
203
204 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
205 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
206
207 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
208 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
209 - pyaspect hooks allow to  maintain the namespace xmpp groups
210 - new omf_slicemgr is a proxy to xmpp, used by these hooks
211 - nodes have their hrn exposed in the 'hrn' tag
212 - node hrn exposed in GetSlivers, as well as the overall xmpp config
213 - system slice 'drl' gets created by db-config
214 - daniel's changes to Filter for supporting wildcards in lists
215 - AddSliceTag consistency check tweaked
216
217 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
218 - major cleanup
219 - get rid of all 4.2-related legacy code
220 - reset the migrations code, planetlab5.sql somes with (5,100)
221 - uses hashlib module when available
222
223 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
224 - first working version of 5.0:
225 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
226 - nodefamily is 3-fold with pldistro-fcdistro-arch
227 - site and person tags
228 - new methods GetSliceFamily and GetNodeFlavour
229 - deprecated the dummynet stuff that were for the external dummyboxes
230 - tags definition : more consistency between db-config scripts and accessors
231 - (get accessor to create the tag type too if absent)
232 - logging an event for AddSliceToNodes
233
234 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
235 - support for fedora 12
236 - fix subtle bug in filtering with ] and quotes
237
238 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
239 - * patch for php-5.3 (the one in f12)
240 - * validate email addresses with regex
241 - * add PersonTags and SiteTags
242 - * add additional accessors for node tags (kvariant, serial, ..)
243
244 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
245 - Redacting password, session, and authstring values from the event log.
246
247 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
248 - let AddSite set ext_consortium_id - required for the poorman registration pages
249 - drop version constraint on Requires: postgresql-python
250 - don't log system calls nor ReportRunLevel
251
252 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
253 - Fix requires for CentOS.
254
255 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
256 - Require postgresql 8.2 (for array operators && and @>)
257
258 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
259 - Filter now supports the | and & features to match in sequence values
260 - bugfix in the postgresql wrapper for sequence filter values
261 - reviewed GetSlivers to export admin keys more efficiently
262 - fix checking roles in UpdateSliceTag
263
264 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
265 - - Some typos in the documentation were fixed.
266 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
267 - to the tag's min_role_id.
268
269 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
270
271 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
272 - Ongoing work to add upcalls, using new SFA class
273 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
274 - reviewed type-checking for the 3 taggable classes node-interface-slice
275 - cleanup ald dummynet stuff
276 - expose the 'extensions' accessors to the API
277 - tweaked checks in AddSliceTag
278 - GetPersons exposes roles by default
279 - bugfix in ReportRunLevel for non-string levels
280 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
281
282 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
283 - new BindObjectToPeer method for sfa
284 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
285
286 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
287 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
288 - reportrunlevel logs its calls only when run_level changes
289 - pycurl more robust wrt to xmlrpclib.Transport
290
291 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
292 - produce a wsdl interface
293 - bugfix in getbootmedium for nodes with interface tags
294
295 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
296 - bugfix for some rare pattern-based filters
297
298 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
299 - improvements in the 4.2 legacy layer
300
301 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
302 - bugfix required for slice tags set on nodegroups
303
304 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
305 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
306
307 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
308 - more powerful legacy layer with 4.2
309
310 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
311 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
312 - migration script has an option for running interactively
313
314 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
315 - skips already added entries
316
317 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
318 - yet another set of fixes for external dummynet boxes
319
320 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
321 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
322 - and tmp file is cleaned up
323
324 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
325 - restore missing ResolveSlices
326
327 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
328 - new method GetDummyBoxMedium
329
330 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
331 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
332
333 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
334 - support for external dummynet boxes back in 4.3 - first draft
335
336 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
337 - fixes for smooth federation between 4.2 and 4.3
338 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
339
340 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
341 - support for BootCD variants (GetBootMedium ['variant:centos5'])
342 - fix corner case with filters like {'~slice_id':[]}
343 - fix transaction leak that caused the db connections pool to exhaust
344 - properly expose all methods, including Legacy/, and not only Methods/
345
346 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
347 - renumbered as 4.3
348 - nodes have new fields run_level (in addition to boot_state) and verified
349 - tweaked migration from 4.2
350 - tuned rpm dependencies
351 - doc generation more explicit about errors like missing python modules
352 - removed obsolete method GetSlicesMD5
353
354 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
355 - unified all tags
356 - renamed interface settings into interface tags and slice attributes into slice tags
357 - nodes have a node_type
358 - various changes on the way to 4.3
359
360 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
361 - Checkpointing : this version still has interface settings and slice attributes
362
363 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
364 - first iteration with taggable nodes/interfaces/slices
365 - embryo for ilinks
366 - cleaned up boot states
367 - migration script moslty complete
368
369 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
370 - fixed doc build by locating locally installed DTDs at build-time
371
372 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
373 - no more doc packaged outside of myplc-docs - doc/ cleaned up
374 - enhancements in doc on filters 
375 - bootcd-aware GetBootMedium merged from onelab
376
377 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
378 - checkpoint while the new myplc-docs package is underway
379 - bugfix: GetSlivers & conf files
380 - doc: removed target files 
381
382 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
383 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
384 - the non-deleted fields were index, resulting in massivly slow queries.
385
386
387 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
388 - plcsh: better handling of options when running as a shell script
389 - getbootmedium exports compute_key
390 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
391
392 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
393 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
394 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
395
396 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
397 - refresh peer script to use a month-dependent logfile
398 - tracking the starting point for UniPi integration of the dummynet boxes
399
400 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
401 - plcsh adds its own path to sys.path
402 - fix so GetNodes can be called from a Node
403
404 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
405 - Initial build.
406
407 %define module_current_branch 4.3