Added cache_utils to the distribution because it includes a patch and is not packaged...
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.0
3 %define taglevel 30
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 Requires: Django
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel PyXML python-simplejson
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %define php_extension_dir %(php-config --extension-dir)
129
130 %files
131 %defattr(-,root,root,-)
132 %dir %{_datadir}/plc_api
133 %dir /var/log/omf/
134 %{_datadir}/plc_api/*
135 %{_bindir}/plcsh
136 %{php_extension_dir}/xmlrpc.so
137 %{_sysconfdir}/php.d/xmlrpc.ini
138 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
139 /etc/plc.d
140 /etc/planetlab/db-config.d
141 /var/www/html/wsdl/plcapi.wsdl
142 /usr/bin/omf_slicemgr.py*
143 /usr/bin/reset_xmpp_pubsub_nodes.py*
144 /var/log/plc_api_ratelimit.log
145
146
147 %changelog
148 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
149 - working draft for GetSliceSshKeys
150
151 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
152 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
153 - (this is for people who cancel their download)
154
155 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
156 - fix db-config sequence : accessors step now merged in, and occurs at the right time
157 - db-config also more robust
158 - no more explicit 'accessors' step in plc.d
159
160 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
161 - session auth: do *not* delete session when node runs a method that does not have 'node' role
162 - session auth: remove support for bootonce in old boot CDs
163 - give a reason when caller_may_write_slice_tag fails
164 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
165
166 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
167 - SetSliceVref needed the node role
168 - protect GetSliceFamily
169 - Fix bugs in tag authorizations
170
171 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
172 - altered checking of optional fields in Interfaces
173 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
174 - has pyxml and python-simplejson as new deps
175
176 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
177 - tweak doc extraction for fedora14
178
179 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
180 - builtin accessors for the myslice page
181 - Get{Node,Interface}Tags allowed to techs
182 - tweak in ratelimitaspect.py
183
184 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
185 - add admin role to accessor-related tags (arch, {fc,pl}distro)
186
187 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
188 - bugfix in {Update,Delete}PersonTag
189 - updated xml doc for filters, accessors and tagtypes
190 - more explicit msg in case of missing roles
191 - improvements in ratelimitaspects.py
192
193 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
194 - fix the roles for ssh_key and hmac tags
195
196 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
197 - tag permissions system based on roles and not min_role_ids
198 - accessors simplified accordingly (no more min_role_id)
199 - new methods AddRoleToTagType and DeleteRoleFromTagType
200 - accessor-related tagtypes are created sooner, and enforced
201 - cleaned up redundancy between db-config.d and accessors
202
203 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
204 - fix RefreshPeer that was not working in 5.0-17
205
206 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
207 - RefreshPeer is able to cope with 2 peers running different releases of the api
208 - DeletePerson can be used on duplicates
209 - first appearance of ModPythonJson.py
210
211 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
212 - set accessors return the new value
213 - tweaks in the pubsub groups management
214
215 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
216 - convert hostnames to lower case and use ILIKE instead of LIKE
217
218 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
219 - use hrn in pubsub groups
220
221 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
222 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
223 - - OMF fixes
224
225 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
226 - automatically set vsys tag for omf controlled slices
227
228 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
229 - addition of the 'ssh_key' slice tag
230 - first draft of the LDAP interface
231
232 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
233 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
234 - and readable through GetLeaseGranularity
235 - GetSlivers to expose reservation_policy and lease_granularity
236 - GetBootMedium fixed for reservable nodes
237 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
238 - new Apache mod_wsgi python interface
239
240 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
241 - the leases system
242
243 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
244 - previous tag had gone wrong
245
246 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
247 - fix pubsub hostname
248
249 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
250 - tweaks for the omf support (xmpp groups and RC-controlled slices)
251 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
252 - GetNodeFlavour exposes fcdistro
253
254 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
255 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
256
257 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
258 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
259 - pyaspect hooks allow to  maintain the namespace xmpp groups
260 - new omf_slicemgr is a proxy to xmpp, used by these hooks
261 - nodes have their hrn exposed in the 'hrn' tag
262 - node hrn exposed in GetSlivers, as well as the overall xmpp config
263 - system slice 'drl' gets created by db-config
264 - daniel's changes to Filter for supporting wildcards in lists
265 - AddSliceTag consistency check tweaked
266
267 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
268 - major cleanup
269 - get rid of all 4.2-related legacy code
270 - reset the migrations code, planetlab5.sql somes with (5,100)
271 - uses hashlib module when available
272
273 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
274 - first working version of 5.0:
275 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
276 - nodefamily is 3-fold with pldistro-fcdistro-arch
277 - site and person tags
278 - new methods GetSliceFamily and GetNodeFlavour
279 - deprecated the dummynet stuff that were for the external dummyboxes
280 - tags definition : more consistency between db-config scripts and accessors
281 - (get accessor to create the tag type too if absent)
282 - logging an event for AddSliceToNodes
283
284 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
285 - support for fedora 12
286 - fix subtle bug in filtering with ] and quotes
287
288 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
289 - * patch for php-5.3 (the one in f12)
290 - * validate email addresses with regex
291 - * add PersonTags and SiteTags
292 - * add additional accessors for node tags (kvariant, serial, ..)
293
294 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
295 - Redacting password, session, and authstring values from the event log.
296
297 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
298 - let AddSite set ext_consortium_id - required for the poorman registration pages
299 - drop version constraint on Requires: postgresql-python
300 - don't log system calls nor ReportRunLevel
301
302 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
303 - Fix requires for CentOS.
304
305 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
306 - Require postgresql 8.2 (for array operators && and @>)
307
308 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
309 - Filter now supports the | and & features to match in sequence values
310 - bugfix in the postgresql wrapper for sequence filter values
311 - reviewed GetSlivers to export admin keys more efficiently
312 - fix checking roles in UpdateSliceTag
313
314 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
315 - - Some typos in the documentation were fixed.
316 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
317 - to the tag's min_role_id.
318
319 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
320
321 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
322 - Ongoing work to add upcalls, using new SFA class
323 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
324 - reviewed type-checking for the 3 taggable classes node-interface-slice
325 - cleanup ald dummynet stuff
326 - expose the 'extensions' accessors to the API
327 - tweaked checks in AddSliceTag
328 - GetPersons exposes roles by default
329 - bugfix in ReportRunLevel for non-string levels
330 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
331
332 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
333 - new BindObjectToPeer method for sfa
334 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
335
336 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
337 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
338 - reportrunlevel logs its calls only when run_level changes
339 - pycurl more robust wrt to xmlrpclib.Transport
340
341 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
342 - produce a wsdl interface
343 - bugfix in getbootmedium for nodes with interface tags
344
345 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
346 - bugfix for some rare pattern-based filters
347
348 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
349 - improvements in the 4.2 legacy layer
350
351 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
352 - bugfix required for slice tags set on nodegroups
353
354 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
355 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
356
357 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
358 - more powerful legacy layer with 4.2
359
360 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
361 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
362 - migration script has an option for running interactively
363
364 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
365 - skips already added entries
366
367 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
368 - yet another set of fixes for external dummynet boxes
369
370 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
371 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
372 - and tmp file is cleaned up
373
374 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
375 - restore missing ResolveSlices
376
377 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
378 - new method GetDummyBoxMedium
379
380 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
381 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
382
383 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
384 - support for external dummynet boxes back in 4.3 - first draft
385
386 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
387 - fixes for smooth federation between 4.2 and 4.3
388 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
389
390 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
391 - support for BootCD variants (GetBootMedium ['variant:centos5'])
392 - fix corner case with filters like {'~slice_id':[]}
393 - fix transaction leak that caused the db connections pool to exhaust
394 - properly expose all methods, including Legacy/, and not only Methods/
395
396 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
397 - renumbered as 4.3
398 - nodes have new fields run_level (in addition to boot_state) and verified
399 - tweaked migration from 4.2
400 - tuned rpm dependencies
401 - doc generation more explicit about errors like missing python modules
402 - removed obsolete method GetSlicesMD5
403
404 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
405 - unified all tags
406 - renamed interface settings into interface tags and slice attributes into slice tags
407 - nodes have a node_type
408 - various changes on the way to 4.3
409
410 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
411 - Checkpointing : this version still has interface settings and slice attributes
412
413 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
414 - first iteration with taggable nodes/interfaces/slices
415 - embryo for ilinks
416 - cleaned up boot states
417 - migration script moslty complete
418
419 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
420 - fixed doc build by locating locally installed DTDs at build-time
421
422 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
423 - no more doc packaged outside of myplc-docs - doc/ cleaned up
424 - enhancements in doc on filters 
425 - bootcd-aware GetBootMedium merged from onelab
426
427 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
428 - checkpoint while the new myplc-docs package is underway
429 - bugfix: GetSlivers & conf files
430 - doc: removed target files 
431
432 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
433 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
434 - the non-deleted fields were index, resulting in massivly slow queries.
435
436
437 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
438 - plcsh: better handling of options when running as a shell script
439 - getbootmedium exports compute_key
440 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
441
442 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
443 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
444 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
445
446 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
447 - refresh peer script to use a month-dependent logfile
448 - tracking the starting point for UniPi integration of the dummynet boxes
449
450 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
451 - plcsh adds its own path to sys.path
452 - fix so GetNodes can be called from a Node
453
454 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
455 - Initial build.
456
457 %define module_current_branch 4.3