Merge branch 'newinterface' of ssh://bakers@git.planet-lab.org/git/plcapi into newint...
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.1
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 Requires: Django
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel PyXML python-simplejson
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %define php_extension_dir %(php-config --extension-dir)
129
130 %files
131 %defattr(-,root,root,-)
132 %dir %{_datadir}/plc_api
133 %dir /var/log/omf/
134 %{_datadir}/plc_api/*
135 %{_bindir}/plcsh
136 %{php_extension_dir}/xmlrpc.so
137 %{_sysconfdir}/php.d/xmlrpc.ini
138 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
139 /etc/plc.d
140 /etc/planetlab/db-config.d
141 /var/www/html/wsdl/plcapi.wsdl
142 /usr/bin/omf_slicemgr.py*
143 /usr/bin/reset_xmpp_pubsub_nodes.py*
144 /var/log/plc_api_ratelimit.log
145
146
147 %changelog
148 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
149 - fix gpg-authentication for Persons (thanks Jordan)
150 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
151 - ip address/network check: v4 or v6
152 - customized DB Message survive upgrade
153 - make sync works in lxc-hosted tests
154 - no svn keywords anymore
155
156 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
157 - fix sorting for methods list in docs
158 - untested but needed tweak for postgres startup in f16
159
160 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
161 - tweaks in postgresql setup - in line with sfa
162
163 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
164 - slight tweaks in Persons.py
165
166 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
167 - GetSession has support for more than one day sessions
168 - reset_xmpp_pubsub_nodes is much more efficient
169 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
170 - bugfix - deleting a person in the middle of the signup process
171
172 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
173 - ratelimit aspects
174 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
175 - requires Django for cache_utils
176 - attempt to expose 'pldistro' to sfa
177 - last_time_spent_online, last_time_spent_offline: new fields in Node
178 - new slice tags 'isolate_loopback' and 'cpu_cores'
179 - refresh-peer federation logs dump exceptions
180 - modpython logs have a timestamp
181 - more verbose/accurate php error reporting
182 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
183 - AddNode, UpdateNode: manage tags directly rather than through another method
184 - BootUpdateNode: only update once
185 - GetPersons: techs can access the list of persons on their site
186 - GetSlices and GetSliceTags: techs can see slices on their nodes
187 - GetSlivers: isrootonsite tag; cacheable
188
189 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
190 - rename initscript_body into initscript_code
191
192 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
193 - new initscript_body tag
194
195 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
196 - working draft for GetSliceSshKeys
197
198 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
199 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
200 - (this is for people who cancel their download)
201
202 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
203 - fix db-config sequence : accessors step now merged in, and occurs at the right time
204 - db-config also more robust
205 - no more explicit 'accessors' step in plc.d
206
207 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
208 - session auth: do *not* delete session when node runs a method that does not have 'node' role
209 - session auth: remove support for bootonce in old boot CDs
210 - give a reason when caller_may_write_slice_tag fails
211 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
212
213 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
214 - SetSliceVref needed the node role
215 - protect GetSliceFamily
216 - Fix bugs in tag authorizations
217
218 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
219 - altered checking of optional fields in Interfaces
220 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
221 - has pyxml and python-simplejson as new deps
222
223 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
224 - tweak doc extraction for fedora14
225
226 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
227 - builtin accessors for the myslice page
228 - Get{Node,Interface}Tags allowed to techs
229 - tweak in ratelimitaspect.py
230
231 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
232 - add admin role to accessor-related tags (arch, {fc,pl}distro)
233
234 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
235 - bugfix in {Update,Delete}PersonTag
236 - updated xml doc for filters, accessors and tagtypes
237 - more explicit msg in case of missing roles
238 - improvements in ratelimitaspects.py
239
240 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
241 - fix the roles for ssh_key and hmac tags
242
243 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
244 - tag permissions system based on roles and not min_role_ids
245 - accessors simplified accordingly (no more min_role_id)
246 - new methods AddRoleToTagType and DeleteRoleFromTagType
247 - accessor-related tagtypes are created sooner, and enforced
248 - cleaned up redundancy between db-config.d and accessors
249
250 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
251 - fix RefreshPeer that was not working in 5.0-17
252
253 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
254 - RefreshPeer is able to cope with 2 peers running different releases of the api
255 - DeletePerson can be used on duplicates
256 - first appearance of ModPythonJson.py
257
258 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
259 - set accessors return the new value
260 - tweaks in the pubsub groups management
261
262 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
263 - convert hostnames to lower case and use ILIKE instead of LIKE
264
265 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
266 - use hrn in pubsub groups
267
268 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
269 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
270 - - OMF fixes
271
272 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
273 - automatically set vsys tag for omf controlled slices
274
275 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
276 - addition of the 'ssh_key' slice tag
277 - first draft of the LDAP interface
278
279 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
280 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
281 - and readable through GetLeaseGranularity
282 - GetSlivers to expose reservation_policy and lease_granularity
283 - GetBootMedium fixed for reservable nodes
284 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
285 - new Apache mod_wsgi python interface
286
287 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
288 - the leases system
289
290 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
291 - previous tag had gone wrong
292
293 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
294 - fix pubsub hostname
295
296 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
297 - tweaks for the omf support (xmpp groups and RC-controlled slices)
298 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
299 - GetNodeFlavour exposes fcdistro
300
301 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
302 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
303
304 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
305 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
306 - pyaspect hooks allow to  maintain the namespace xmpp groups
307 - new omf_slicemgr is a proxy to xmpp, used by these hooks
308 - nodes have their hrn exposed in the 'hrn' tag
309 - node hrn exposed in GetSlivers, as well as the overall xmpp config
310 - system slice 'drl' gets created by db-config
311 - daniel's changes to Filter for supporting wildcards in lists
312 - AddSliceTag consistency check tweaked
313
314 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
315 - major cleanup
316 - get rid of all 4.2-related legacy code
317 - reset the migrations code, planetlab5.sql somes with (5,100)
318 - uses hashlib module when available
319
320 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
321 - first working version of 5.0:
322 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
323 - nodefamily is 3-fold with pldistro-fcdistro-arch
324 - site and person tags
325 - new methods GetSliceFamily and GetNodeFlavour
326 - deprecated the dummynet stuff that were for the external dummyboxes
327 - tags definition : more consistency between db-config scripts and accessors
328 - (get accessor to create the tag type too if absent)
329 - logging an event for AddSliceToNodes
330
331 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
332 - support for fedora 12
333 - fix subtle bug in filtering with ] and quotes
334
335 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
336 - * patch for php-5.3 (the one in f12)
337 - * validate email addresses with regex
338 - * add PersonTags and SiteTags
339 - * add additional accessors for node tags (kvariant, serial, ..)
340
341 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
342 - Redacting password, session, and authstring values from the event log.
343
344 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
345 - let AddSite set ext_consortium_id - required for the poorman registration pages
346 - drop version constraint on Requires: postgresql-python
347 - don't log system calls nor ReportRunLevel
348
349 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
350 - Fix requires for CentOS.
351
352 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
353 - Require postgresql 8.2 (for array operators && and @>)
354
355 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
356 - Filter now supports the | and & features to match in sequence values
357 - bugfix in the postgresql wrapper for sequence filter values
358 - reviewed GetSlivers to export admin keys more efficiently
359 - fix checking roles in UpdateSliceTag
360
361 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
362 - - Some typos in the documentation were fixed.
363 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
364 - to the tag's min_role_id.
365
366 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
367
368 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
369 - Ongoing work to add upcalls, using new SFA class
370 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
371 - reviewed type-checking for the 3 taggable classes node-interface-slice
372 - cleanup ald dummynet stuff
373 - expose the 'extensions' accessors to the API
374 - tweaked checks in AddSliceTag
375 - GetPersons exposes roles by default
376 - bugfix in ReportRunLevel for non-string levels
377 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
378
379 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
380 - new BindObjectToPeer method for sfa
381 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
382
383 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
384 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
385 - reportrunlevel logs its calls only when run_level changes
386 - pycurl more robust wrt to xmlrpclib.Transport
387
388 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
389 - produce a wsdl interface
390 - bugfix in getbootmedium for nodes with interface tags
391
392 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
393 - bugfix for some rare pattern-based filters
394
395 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
396 - improvements in the 4.2 legacy layer
397
398 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
399 - bugfix required for slice tags set on nodegroups
400
401 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
402 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
403
404 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
405 - more powerful legacy layer with 4.2
406
407 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
408 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
409 - migration script has an option for running interactively
410
411 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
412 - skips already added entries
413
414 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
415 - yet another set of fixes for external dummynet boxes
416
417 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
418 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
419 - and tmp file is cleaned up
420
421 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
422 - restore missing ResolveSlices
423
424 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
425 - new method GetDummyBoxMedium
426
427 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
428 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
429
430 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
431 - support for external dummynet boxes back in 4.3 - first draft
432
433 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
434 - fixes for smooth federation between 4.2 and 4.3
435 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
436
437 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
438 - support for BootCD variants (GetBootMedium ['variant:centos5'])
439 - fix corner case with filters like {'~slice_id':[]}
440 - fix transaction leak that caused the db connections pool to exhaust
441 - properly expose all methods, including Legacy/, and not only Methods/
442
443 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
444 - renumbered as 4.3
445 - nodes have new fields run_level (in addition to boot_state) and verified
446 - tweaked migration from 4.2
447 - tuned rpm dependencies
448 - doc generation more explicit about errors like missing python modules
449 - removed obsolete method GetSlicesMD5
450
451 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
452 - unified all tags
453 - renamed interface settings into interface tags and slice attributes into slice tags
454 - nodes have a node_type
455 - various changes on the way to 4.3
456
457 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
458 - Checkpointing : this version still has interface settings and slice attributes
459
460 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
461 - first iteration with taggable nodes/interfaces/slices
462 - embryo for ilinks
463 - cleaned up boot states
464 - migration script moslty complete
465
466 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
467 - fixed doc build by locating locally installed DTDs at build-time
468
469 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
470 - no more doc packaged outside of myplc-docs - doc/ cleaned up
471 - enhancements in doc on filters 
472 - bootcd-aware GetBootMedium merged from onelab
473
474 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
475 - checkpoint while the new myplc-docs package is underway
476 - bugfix: GetSlivers & conf files
477 - doc: removed target files 
478
479 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
480 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
481 - the non-deleted fields were index, resulting in massivly slow queries.
482
483
484 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
485 - plcsh: better handling of options when running as a shell script
486 - getbootmedium exports compute_key
487 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
488
489 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
490 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
491 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
492
493 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
494 - refresh peer script to use a month-dependent logfile
495 - tracking the starting point for UniPi integration of the dummynet boxes
496
497 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
498 - plcsh adds its own path to sys.path
499 - fix so GetNodes can be called from a Node
500
501 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
502 - Initial build.
503
504 %define module_current_branch 4.3