Setting tag plcapi-4.3-37
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 4.3
9 %define taglevel 37
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 Requires: mod_ssl
38 Requires: SOAPpy
39
40 # We use psycopg2
41 BuildRequires: postgresql-devel
42
43 # Standard xmlrpc.so that ships with PHP does not marshal NULL
44 BuildRequires: php-devel
45 Obsoletes: php-xmlrpc
46 Provides: php-xmlrpc
47
48 # PostgreSQL and SOAPpy are necessary to run the API server, but not
49 # plcsh. Since the only supported method of running the server is via
50 # MyPLC anyway, don't be so stringent about binary requirements, in
51 # case people want to install this package just for plcsh.
52 # Requires: postgresql-server, SOAPpy
53 AutoReqProv: no
54
55 %description
56 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
57 PlanetLab Central (PLC) database. The API may be accessed directly via
58 the Python shell program plcsh, through a toy standalone server, or
59 through Apache mod_python.
60
61 %prep
62 %setup -q
63
64 %build
65 # python-pycurl and python-psycopg2 avail. from fedora 5
66 # we used to ship our own version of psycopg2 and pycurl, for fedora4
67 # starting with 4.3, support for these two modules is taken out
68
69 # Build __init__.py metafiles and PHP API. 
70 %{__make} %{?_smp_mflags}
71 %{__make} -C wsdl
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
76 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
77
78 # Install shell symlink
79 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
80 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
81
82 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
83 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
84 ; Enable xmlrpc extension module
85 extension=xmlrpc.so
86 EOF
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %define php_extension_dir %(php-config --extension-dir)
92
93 %files
94 %defattr(-,root,root,-)
95 %dir %{_datadir}/plc_api
96 %{_datadir}/plc_api/*
97 %{_bindir}/plcsh
98 %{php_extension_dir}/xmlrpc.so
99 %{_sysconfdir}/php.d/xmlrpc.ini
100 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
101 /var/www/html/wsdl/plcapi.wsdl
102
103 %changelog
104 * Tue Mar 01 2011 S.Çağlar Onur <caglar@verivue.com> - plcapi-4.3-37
105 - pass kernel arguments correctly to the build.sh
106
107 * Wed Dec 08 2010 Daniel Hokka Zakrisson <dhokka@cs.princeton.edu> - plcapi-4.3-36
108 - Use correct gateway for secondary interfaces.
109
110 * Mon Feb 22 2010 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-35
111 - - fix AddSlicetag() to not compare slice tags with sliver tags, and vice versa.
112
113 * Fri Feb 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-34
114 - log calls to AddSliceToNodes
115
116 * Thu Jan 21 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-33
117 - rename migration scripts
118
119 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
120 - support for fedora 12
121 - fix subtle bug in filering with ] and quotes
122
123 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
124 - * patch for php-5.3 (the one in f12)
125 - * validate email addresses with regex
126 - * add PersonTags and SiteTags
127 - * add additional accessors for node tags (kvariant, serial, ..)
128
129 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
130 - Redacting password, session, and authstring values from the event log.
131
132 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
133 - let AddSite set ext_consortium_id - required for the poorman registration pages
134 - drop version constraint on Requires: postgresql-python
135 - don't log system calls nor ReportRunLevel
136
137 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
138 - Fix requires for CentOS.
139
140 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
141 - Require postgresql 8.2 (for array operators && and @>)
142
143 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
144 - Filter now supports the | and & features to match in sequence values
145 - bugfix in the postgresql wrapper for sequence filter values
146 - reviewed GetSlivers to export admin keys more efficiently
147 - fix checking roles in UpdateSliceTag
148
149 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
150 - - Some typos in the documentation were fixed.
151 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
152 - to the tag's min_role_id.
153
154 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
155
156 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
157 - Ongoing work to add upcalls, using new SFA class
158 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
159 - reviewed type-checking for the 3 taggable classes node-interface-slice
160 - cleanup ald dummynet stuff
161 - expose the 'extensions' accessors to the API
162 - tweaked checks in AddSliceTag
163 - GetPersons exposes roles by default
164 - bugfix in ReportRunLevel for non-string levels
165 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
166
167 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
168 - new BindObjectToPeer method for sfa
169 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
170
171 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
172 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
173 - reportrunlevel logs its calls only when run_level changes
174 - pycurl more robust wrt to xmlrpclib.Transport
175
176 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
177 - produce a wsdl interface
178 - bugfix in getbootmedium for nodes with interface tags
179
180 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
181 - bugfix for some rare pattern-based filters
182
183 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
184 - improvements in the 4.2 legacy layer
185
186 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
187 - bugfix required for slice tags set on nodegroups
188
189 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
190 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
191
192 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
193 - more powerful legacy layer with 4.2
194
195 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
196 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
197 - migration script has an option for running interactively
198
199 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
200 - skips already added entries
201
202 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
203 - yet another set of fixes for external dummynet boxes
204
205 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
206 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
207 - and tmp file is cleaned up
208
209 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
210 - restore missing ResolveSlices
211
212 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
213 - new method GetDummyBoxMedium
214
215 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
216 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
217
218 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
219 - support for external dummynet boxes back in 4.3 - first draft
220
221 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
222 - fixes for smooth federation between 4.2 and 4.3
223 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
224
225 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
226 - support for BootCD variants (GetBootMedium ['variant:centos5'])
227 - fix corner case with filters like {'~slice_id':[]}
228 - fix transaction leak that caused the db connections pool to exhaust
229 - properly expose all methods, including Legacy/, and not only Methods/
230
231 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
232 - renumbered as 4.3
233 - nodes have new fields run_level (in addition to boot_state) and verified
234 - tweaked migration from 4.2
235 - tuned rpm dependencies
236 - doc generation more explicit about errors like missing python modules
237 - removed obsolete method GetSlicesMD5
238
239 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
240 - unified all tags
241 - renamed interface settings into interface tags and slice attributes into slice tags
242 - nodes have a node_type
243 - various changes on the way to 4.3
244
245 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
246 - Checkpointing : this version still has interface settings and slice attributes
247
248 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
249 - first iteration with taggable nodes/interfaces/slices
250 - embryo for ilinks
251 - cleaned up boot states
252 - migration script moslty complete
253
254 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
255 - fixed doc build by locating locally installed DTDs at build-time
256
257 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
258 - no more doc packaged outside of myplc-docs - doc/ cleaned up
259 - enhancements in doc on filters 
260 - bootcd-aware GetBootMedium merged from onelab
261
262 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
263 - checkpoint while the new myplc-docs package is underway
264 - bugfix: GetSlivers & conf files
265 - doc: removed target files 
266
267 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
268 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
269 - the non-deleted fields were index, resulting in massivly slow queries.
270
271
272 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
273 - plcsh: better handling of options when running as a shell script
274 - getbootmedium exports compute_key
275 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
276
277 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
278 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
279 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
280
281 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
282 - refresh peer script to use a month-dependent logfile
283 - tracking the starting point for UniPi integration of the dummynet boxes
284
285 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
286 - plcsh adds its own path to sys.path
287 - fix so GetNodes can be called from a Node
288
289 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
290 - Initial build.
291
292 %define module_current_branch 4.2