we'll need to import omf_slicemgr
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 2
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 Requires: mod_ssl
38 Requires: SOAPpy
39 # for the RebootNodeWithPCU method
40 Requires: pcucontrol
41 # for OMF integration
42 Requires: pyaspects
43 Requires: python-twisted-words
44 Requires: python-twisted-web
45
46 ### avoid having yum complain about updates, as stuff is moving around
47 # plc.d/api
48 Conflicts: MyPLC <= 4.3
49
50 # We use psycopg2
51 BuildRequires: postgresql-devel
52
53 # Standard xmlrpc.so that ships with PHP does not marshal NULL
54 BuildRequires: php-devel
55 Obsoletes: php-xmlrpc
56 Provides: php-xmlrpc
57
58 # PostgreSQL and SOAPpy are necessary to run the API server, but not
59 # plcsh. Since the only supported method of running the server is via
60 # MyPLC anyway, don't be so stringent about binary requirements, in
61 # case people want to install this package just for plcsh.
62 # Requires: postgresql-server, SOAPpy
63 AutoReqProv: no
64
65 %description
66 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
67 PlanetLab Central (PLC) database. The API may be accessed directly via
68 the Python shell program plcsh, through a toy standalone server, or
69 through Apache mod_python.
70
71 %prep
72 %setup -q
73
74 %build
75 # python-pycurl and python-psycopg2 avail. from fedora 5
76 # we used to ship our own version of psycopg2 and pycurl, for fedora4
77 # starting with 4.3, support for these two modules is taken out
78
79 # Build __init__.py metafiles and PHP API. 
80 %{__make} %{?_smp_mflags}
81 %{__make} -C wsdl
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
86
87 # Install shell symlink
88 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
89 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
90
91 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
92 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
93 ; Enable xmlrpc extension module
94 extension=xmlrpc.so
95 EOF
96
97 # Install initscripts
98 echo "* Installing initscripts"
99 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
100 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
101
102 # Install db-config.d files
103 echo "* Installing db-config.d files"
104 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
105 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
106 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
107
108 # Install wsdl
109 echo "* Installing wsdl"
110 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
111
112 # Install omf_slicemgr.py
113 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %define php_extension_dir %(php-config --extension-dir)
119
120 %files
121 %defattr(-,root,root,-)
122 %dir %{_datadir}/plc_api
123 %{_datadir}/plc_api/*
124 %{_bindir}/plcsh
125 %{php_extension_dir}/xmlrpc.so
126 %{_sysconfdir}/php.d/xmlrpc.ini
127 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
128 /etc/plc.d
129 /etc/planetlab/db-config.d
130 /var/www/html/wsdl/plcapi.wsdl
131 /usr/bin/omf_slicemgr.py*
132
133 %changelog
134 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
135 - major cleanup
136 - get rid of all 4.2-related legacy code
137 - reset the migrations code, planetlab5.sql somes with (5,100)
138 - uses hashlib module when available
139
140 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
141 - first working version of 5.0:
142 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
143 - nodefamily is 3-fold with pldistro-fcdistro-arch
144 - site and person tags
145 - new methods GetSliceFamily and GetNodeFlavour
146 - deprecated the dummynet stuff that were for the external dummyboxes
147 - tags definition : more consistency between db-config scripts and accessors
148 - (get accessor to create the tag type too if absent)
149 - logging an event for AddSliceToNodes
150
151 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
152 - support for fedora 12
153 - fix subtle bug in filtering with ] and quotes
154
155 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
156 - * patch for php-5.3 (the one in f12)
157 - * validate email addresses with regex
158 - * add PersonTags and SiteTags
159 - * add additional accessors for node tags (kvariant, serial, ..)
160
161 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
162 - Redacting password, session, and authstring values from the event log.
163
164 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
165 - let AddSite set ext_consortium_id - required for the poorman registration pages
166 - drop version constraint on Requires: postgresql-python
167 - don't log system calls nor ReportRunLevel
168
169 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
170 - Fix requires for CentOS.
171
172 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
173 - Require postgresql 8.2 (for array operators && and @>)
174
175 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
176 - Filter now supports the | and & features to match in sequence values
177 - bugfix in the postgresql wrapper for sequence filter values
178 - reviewed GetSlivers to export admin keys more efficiently
179 - fix checking roles in UpdateSliceTag
180
181 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
182 - - Some typos in the documentation were fixed.
183 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
184 - to the tag's min_role_id.
185
186 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
187
188 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
189 - Ongoing work to add upcalls, using new SFA class
190 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
191 - reviewed type-checking for the 3 taggable classes node-interface-slice
192 - cleanup ald dummynet stuff
193 - expose the 'extensions' accessors to the API
194 - tweaked checks in AddSliceTag
195 - GetPersons exposes roles by default
196 - bugfix in ReportRunLevel for non-string levels
197 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
198
199 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
200 - new BindObjectToPeer method for sfa
201 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
202
203 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
204 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
205 - reportrunlevel logs its calls only when run_level changes
206 - pycurl more robust wrt to xmlrpclib.Transport
207
208 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
209 - produce a wsdl interface
210 - bugfix in getbootmedium for nodes with interface tags
211
212 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
213 - bugfix for some rare pattern-based filters
214
215 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
216 - improvements in the 4.2 legacy layer
217
218 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
219 - bugfix required for slice tags set on nodegroups
220
221 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
222 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
223
224 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
225 - more powerful legacy layer with 4.2
226
227 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
228 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
229 - migration script has an option for running interactively
230
231 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
232 - skips already added entries
233
234 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
235 - yet another set of fixes for external dummynet boxes
236
237 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
238 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
239 - and tmp file is cleaned up
240
241 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
242 - restore missing ResolveSlices
243
244 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
245 - new method GetDummyBoxMedium
246
247 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
248 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
249
250 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
251 - support for external dummynet boxes back in 4.3 - first draft
252
253 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
254 - fixes for smooth federation between 4.2 and 4.3
255 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
256
257 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
258 - support for BootCD variants (GetBootMedium ['variant:centos5'])
259 - fix corner case with filters like {'~slice_id':[]}
260 - fix transaction leak that caused the db connections pool to exhaust
261 - properly expose all methods, including Legacy/, and not only Methods/
262
263 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
264 - renumbered as 4.3
265 - nodes have new fields run_level (in addition to boot_state) and verified
266 - tweaked migration from 4.2
267 - tuned rpm dependencies
268 - doc generation more explicit about errors like missing python modules
269 - removed obsolete method GetSlicesMD5
270
271 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
272 - unified all tags
273 - renamed interface settings into interface tags and slice attributes into slice tags
274 - nodes have a node_type
275 - various changes on the way to 4.3
276
277 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
278 - Checkpointing : this version still has interface settings and slice attributes
279
280 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
281 - first iteration with taggable nodes/interfaces/slices
282 - embryo for ilinks
283 - cleaned up boot states
284 - migration script moslty complete
285
286 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
287 - fixed doc build by locating locally installed DTDs at build-time
288
289 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
290 - no more doc packaged outside of myplc-docs - doc/ cleaned up
291 - enhancements in doc on filters 
292 - bootcd-aware GetBootMedium merged from onelab
293
294 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
295 - checkpoint while the new myplc-docs package is underway
296 - bugfix: GetSlivers & conf files
297 - doc: removed target files 
298
299 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
300 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
301 - the non-deleted fields were index, resulting in massivly slow queries.
302
303
304 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
305 - plcsh: better handling of options when running as a shell script
306 - getbootmedium exports compute_key
307 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
308
309 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
310 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
311 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
312
313 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
314 - refresh peer script to use a month-dependent logfile
315 - tracking the starting point for UniPi integration of the dummynet boxes
316
317 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
318 - plcsh adds its own path to sys.path
319 - fix so GetNodes can be called from a Node
320
321 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
322 - Initial build.
323
324 %define module_current_branch 4.3