Merge branch 'master' into funcaspect
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.0
3 %define taglevel 30
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 Requires: Django
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel PyXML python-simplejson
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 # Create func directories
126 mkdir -p $RPM_BUILD_ROOT/var/www/html/func
127 mkdir -p $RPM_BUILD_ROOT/var/log/funcaspect/
128 chmod apache:apache $RPM_BUILD_ROOT/var/www/html/func
129 chmod apache:apache $RPM_BUILD_ROOT/var/log/funcaspect/
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %define php_extension_dir %(php-config --extension-dir)
135
136 %files
137 %defattr(-,root,root,-)
138 %dir %{_datadir}/plc_api
139 %dir /var/log/omf/
140 %{_datadir}/plc_api/*
141 %{_bindir}/plcsh
142 %{php_extension_dir}/xmlrpc.so
143 %{_sysconfdir}/php.d/xmlrpc.ini
144 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
145 /etc/plc.d
146 /etc/planetlab/db-config.d
147 /var/www/html/wsdl/plcapi.wsdl
148 /usr/bin/omf_slicemgr.py*
149 /usr/bin/reset_xmpp_pubsub_nodes.py*
150 /var/log/plc_api_ratelimit.log
151
152
153 %changelog
154 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
155 - working draft for GetSliceSshKeys
156
157 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
158 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
159 - (this is for people who cancel their download)
160
161 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
162 - fix db-config sequence : accessors step now merged in, and occurs at the right time
163 - db-config also more robust
164 - no more explicit 'accessors' step in plc.d
165
166 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
167 - session auth: do *not* delete session when node runs a method that does not have 'node' role
168 - session auth: remove support for bootonce in old boot CDs
169 - give a reason when caller_may_write_slice_tag fails
170 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
171
172 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
173 - SetSliceVref needed the node role
174 - protect GetSliceFamily
175 - Fix bugs in tag authorizations
176
177 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
178 - altered checking of optional fields in Interfaces
179 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
180 - has pyxml and python-simplejson as new deps
181
182 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
183 - tweak doc extraction for fedora14
184
185 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
186 - builtin accessors for the myslice page
187 - Get{Node,Interface}Tags allowed to techs
188 - tweak in ratelimitaspect.py
189
190 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
191 - add admin role to accessor-related tags (arch, {fc,pl}distro)
192
193 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
194 - bugfix in {Update,Delete}PersonTag
195 - updated xml doc for filters, accessors and tagtypes
196 - more explicit msg in case of missing roles
197 - improvements in ratelimitaspects.py
198
199 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
200 - fix the roles for ssh_key and hmac tags
201
202 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
203 - tag permissions system based on roles and not min_role_ids
204 - accessors simplified accordingly (no more min_role_id)
205 - new methods AddRoleToTagType and DeleteRoleFromTagType
206 - accessor-related tagtypes are created sooner, and enforced
207 - cleaned up redundancy between db-config.d and accessors
208
209 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
210 - fix RefreshPeer that was not working in 5.0-17
211
212 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
213 - RefreshPeer is able to cope with 2 peers running different releases of the api
214 - DeletePerson can be used on duplicates
215 - first appearance of ModPythonJson.py
216
217 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
218 - set accessors return the new value
219 - tweaks in the pubsub groups management
220
221 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
222 - convert hostnames to lower case and use ILIKE instead of LIKE
223
224 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
225 - use hrn in pubsub groups
226
227 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
228 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
229 - - OMF fixes
230
231 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
232 - automatically set vsys tag for omf controlled slices
233
234 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
235 - addition of the 'ssh_key' slice tag
236 - first draft of the LDAP interface
237
238 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
239 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
240 - and readable through GetLeaseGranularity
241 - GetSlivers to expose reservation_policy and lease_granularity
242 - GetBootMedium fixed for reservable nodes
243 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
244 - new Apache mod_wsgi python interface
245
246 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
247 - the leases system
248
249 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
250 - previous tag had gone wrong
251
252 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
253 - fix pubsub hostname
254
255 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
256 - tweaks for the omf support (xmpp groups and RC-controlled slices)
257 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
258 - GetNodeFlavour exposes fcdistro
259
260 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
261 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
262
263 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
264 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
265 - pyaspect hooks allow to  maintain the namespace xmpp groups
266 - new omf_slicemgr is a proxy to xmpp, used by these hooks
267 - nodes have their hrn exposed in the 'hrn' tag
268 - node hrn exposed in GetSlivers, as well as the overall xmpp config
269 - system slice 'drl' gets created by db-config
270 - daniel's changes to Filter for supporting wildcards in lists
271 - AddSliceTag consistency check tweaked
272
273 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
274 - major cleanup
275 - get rid of all 4.2-related legacy code
276 - reset the migrations code, planetlab5.sql somes with (5,100)
277 - uses hashlib module when available
278
279 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
280 - first working version of 5.0:
281 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
282 - nodefamily is 3-fold with pldistro-fcdistro-arch
283 - site and person tags
284 - new methods GetSliceFamily and GetNodeFlavour
285 - deprecated the dummynet stuff that were for the external dummyboxes
286 - tags definition : more consistency between db-config scripts and accessors
287 - (get accessor to create the tag type too if absent)
288 - logging an event for AddSliceToNodes
289
290 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
291 - support for fedora 12
292 - fix subtle bug in filtering with ] and quotes
293
294 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
295 - * patch for php-5.3 (the one in f12)
296 - * validate email addresses with regex
297 - * add PersonTags and SiteTags
298 - * add additional accessors for node tags (kvariant, serial, ..)
299
300 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
301 - Redacting password, session, and authstring values from the event log.
302
303 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
304 - let AddSite set ext_consortium_id - required for the poorman registration pages
305 - drop version constraint on Requires: postgresql-python
306 - don't log system calls nor ReportRunLevel
307
308 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
309 - Fix requires for CentOS.
310
311 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
312 - Require postgresql 8.2 (for array operators && and @>)
313
314 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
315 - Filter now supports the | and & features to match in sequence values
316 - bugfix in the postgresql wrapper for sequence filter values
317 - reviewed GetSlivers to export admin keys more efficiently
318 - fix checking roles in UpdateSliceTag
319
320 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
321 - - Some typos in the documentation were fixed.
322 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
323 - to the tag's min_role_id.
324
325 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
326
327 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
328 - Ongoing work to add upcalls, using new SFA class
329 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
330 - reviewed type-checking for the 3 taggable classes node-interface-slice
331 - cleanup ald dummynet stuff
332 - expose the 'extensions' accessors to the API
333 - tweaked checks in AddSliceTag
334 - GetPersons exposes roles by default
335 - bugfix in ReportRunLevel for non-string levels
336 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
337
338 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
339 - new BindObjectToPeer method for sfa
340 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
341
342 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
343 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
344 - reportrunlevel logs its calls only when run_level changes
345 - pycurl more robust wrt to xmlrpclib.Transport
346
347 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
348 - produce a wsdl interface
349 - bugfix in getbootmedium for nodes with interface tags
350
351 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
352 - bugfix for some rare pattern-based filters
353
354 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
355 - improvements in the 4.2 legacy layer
356
357 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
358 - bugfix required for slice tags set on nodegroups
359
360 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
361 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
362
363 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
364 - more powerful legacy layer with 4.2
365
366 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
367 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
368 - migration script has an option for running interactively
369
370 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
371 - skips already added entries
372
373 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
374 - yet another set of fixes for external dummynet boxes
375
376 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
377 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
378 - and tmp file is cleaned up
379
380 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
381 - restore missing ResolveSlices
382
383 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
384 - new method GetDummyBoxMedium
385
386 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
387 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
388
389 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
390 - support for external dummynet boxes back in 4.3 - first draft
391
392 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
393 - fixes for smooth federation between 4.2 and 4.3
394 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
395
396 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
397 - support for BootCD variants (GetBootMedium ['variant:centos5'])
398 - fix corner case with filters like {'~slice_id':[]}
399 - fix transaction leak that caused the db connections pool to exhaust
400 - properly expose all methods, including Legacy/, and not only Methods/
401
402 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
403 - renumbered as 4.3
404 - nodes have new fields run_level (in addition to boot_state) and verified
405 - tweaked migration from 4.2
406 - tuned rpm dependencies
407 - doc generation more explicit about errors like missing python modules
408 - removed obsolete method GetSlicesMD5
409
410 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
411 - unified all tags
412 - renamed interface settings into interface tags and slice attributes into slice tags
413 - nodes have a node_type
414 - various changes on the way to 4.3
415
416 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
417 - Checkpointing : this version still has interface settings and slice attributes
418
419 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
420 - first iteration with taggable nodes/interfaces/slices
421 - embryo for ilinks
422 - cleaned up boot states
423 - migration script moslty complete
424
425 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
426 - fixed doc build by locating locally installed DTDs at build-time
427
428 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
429 - no more doc packaged outside of myplc-docs - doc/ cleaned up
430 - enhancements in doc on filters 
431 - bootcd-aware GetBootMedium merged from onelab
432
433 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
434 - checkpoint while the new myplc-docs package is underway
435 - bugfix: GetSlivers & conf files
436 - doc: removed target files 
437
438 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
439 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
440 - the non-deleted fields were index, resulting in massivly slow queries.
441
442
443 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
444 - plcsh: better handling of options when running as a shell script
445 - getbootmedium exports compute_key
446 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
447
448 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
449 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
450 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
451
452 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
453 - refresh peer script to use a month-dependent logfile
454 - tracking the starting point for UniPi integration of the dummynet boxes
455
456 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
457 - plcsh adds its own path to sys.path
458 - fix so GetNodes can be called from a Node
459
460 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
461 - Initial build.
462
463 %define module_current_branch 4.3