Merge branch 'master' of ssh://git.onelab.eu/git/plcapi
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.0
3 %define taglevel 34
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 Requires: Django
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel PyXML python-simplejson
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %define php_extension_dir %(php-config --extension-dir)
129
130 %files
131 %defattr(-,root,root,-)
132 %dir %{_datadir}/plc_api
133 %dir /var/log/omf/
134 %{_datadir}/plc_api/*
135 %{_bindir}/plcsh
136 %{php_extension_dir}/xmlrpc.so
137 %{_sysconfdir}/php.d/xmlrpc.ini
138 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
139 /etc/plc.d
140 /etc/planetlab/db-config.d
141 /var/www/html/wsdl/plcapi.wsdl
142 /usr/bin/omf_slicemgr.py*
143 /usr/bin/reset_xmpp_pubsub_nodes.py*
144 /var/log/plc_api_ratelimit.log
145
146
147 %changelog
148 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
149 - GetSession has support for more than one day sessions
150 - reset_xmpp_pubsub_nodes is much more efficient
151 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
152 - bugfix - deleting a person in the middle of the signup process
153
154 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
155 - ratelimit aspects
156 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
157 - requires Django for cache_utils
158 - attempt to expose 'pldistro' to sfa
159 - last_time_spent_online, last_time_spent_offline: new fields in Node
160 - new slice tags 'isolate_loopback' and 'cpu_cores'
161 - refresh-peer federation logs dump exceptions
162 - modpython logs have a timestamp
163 - more verbose/accurate php error reporting
164 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
165 - AddNode, UpdateNode: manage tags directly rather than through another method
166 - BootUpdateNode: only update once
167 - GetPersons: techs can access the list of persons on their site
168 - GetSlices and GetSliceTags: techs can see slices on their nodes
169 - GetSlivers: isrootonsite tag; cacheable
170
171 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
172 - rename initscript_body into initscript_code
173
174 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
175 - new initscript_body tag
176
177 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
178 - working draft for GetSliceSshKeys
179
180 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
181 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
182 - (this is for people who cancel their download)
183
184 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
185 - fix db-config sequence : accessors step now merged in, and occurs at the right time
186 - db-config also more robust
187 - no more explicit 'accessors' step in plc.d
188
189 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
190 - session auth: do *not* delete session when node runs a method that does not have 'node' role
191 - session auth: remove support for bootonce in old boot CDs
192 - give a reason when caller_may_write_slice_tag fails
193 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
194
195 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
196 - SetSliceVref needed the node role
197 - protect GetSliceFamily
198 - Fix bugs in tag authorizations
199
200 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
201 - altered checking of optional fields in Interfaces
202 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
203 - has pyxml and python-simplejson as new deps
204
205 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
206 - tweak doc extraction for fedora14
207
208 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
209 - builtin accessors for the myslice page
210 - Get{Node,Interface}Tags allowed to techs
211 - tweak in ratelimitaspect.py
212
213 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
214 - add admin role to accessor-related tags (arch, {fc,pl}distro)
215
216 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
217 - bugfix in {Update,Delete}PersonTag
218 - updated xml doc for filters, accessors and tagtypes
219 - more explicit msg in case of missing roles
220 - improvements in ratelimitaspects.py
221
222 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
223 - fix the roles for ssh_key and hmac tags
224
225 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
226 - tag permissions system based on roles and not min_role_ids
227 - accessors simplified accordingly (no more min_role_id)
228 - new methods AddRoleToTagType and DeleteRoleFromTagType
229 - accessor-related tagtypes are created sooner, and enforced
230 - cleaned up redundancy between db-config.d and accessors
231
232 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
233 - fix RefreshPeer that was not working in 5.0-17
234
235 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
236 - RefreshPeer is able to cope with 2 peers running different releases of the api
237 - DeletePerson can be used on duplicates
238 - first appearance of ModPythonJson.py
239
240 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
241 - set accessors return the new value
242 - tweaks in the pubsub groups management
243
244 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
245 - convert hostnames to lower case and use ILIKE instead of LIKE
246
247 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
248 - use hrn in pubsub groups
249
250 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
251 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
252 - - OMF fixes
253
254 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
255 - automatically set vsys tag for omf controlled slices
256
257 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
258 - addition of the 'ssh_key' slice tag
259 - first draft of the LDAP interface
260
261 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
262 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
263 - and readable through GetLeaseGranularity
264 - GetSlivers to expose reservation_policy and lease_granularity
265 - GetBootMedium fixed for reservable nodes
266 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
267 - new Apache mod_wsgi python interface
268
269 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
270 - the leases system
271
272 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
273 - previous tag had gone wrong
274
275 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
276 - fix pubsub hostname
277
278 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
279 - tweaks for the omf support (xmpp groups and RC-controlled slices)
280 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
281 - GetNodeFlavour exposes fcdistro
282
283 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
284 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
285
286 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
287 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
288 - pyaspect hooks allow to  maintain the namespace xmpp groups
289 - new omf_slicemgr is a proxy to xmpp, used by these hooks
290 - nodes have their hrn exposed in the 'hrn' tag
291 - node hrn exposed in GetSlivers, as well as the overall xmpp config
292 - system slice 'drl' gets created by db-config
293 - daniel's changes to Filter for supporting wildcards in lists
294 - AddSliceTag consistency check tweaked
295
296 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
297 - major cleanup
298 - get rid of all 4.2-related legacy code
299 - reset the migrations code, planetlab5.sql somes with (5,100)
300 - uses hashlib module when available
301
302 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
303 - first working version of 5.0:
304 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
305 - nodefamily is 3-fold with pldistro-fcdistro-arch
306 - site and person tags
307 - new methods GetSliceFamily and GetNodeFlavour
308 - deprecated the dummynet stuff that were for the external dummyboxes
309 - tags definition : more consistency between db-config scripts and accessors
310 - (get accessor to create the tag type too if absent)
311 - logging an event for AddSliceToNodes
312
313 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
314 - support for fedora 12
315 - fix subtle bug in filtering with ] and quotes
316
317 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
318 - * patch for php-5.3 (the one in f12)
319 - * validate email addresses with regex
320 - * add PersonTags and SiteTags
321 - * add additional accessors for node tags (kvariant, serial, ..)
322
323 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
324 - Redacting password, session, and authstring values from the event log.
325
326 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
327 - let AddSite set ext_consortium_id - required for the poorman registration pages
328 - drop version constraint on Requires: postgresql-python
329 - don't log system calls nor ReportRunLevel
330
331 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
332 - Fix requires for CentOS.
333
334 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
335 - Require postgresql 8.2 (for array operators && and @>)
336
337 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
338 - Filter now supports the | and & features to match in sequence values
339 - bugfix in the postgresql wrapper for sequence filter values
340 - reviewed GetSlivers to export admin keys more efficiently
341 - fix checking roles in UpdateSliceTag
342
343 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
344 - - Some typos in the documentation were fixed.
345 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
346 - to the tag's min_role_id.
347
348 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
349
350 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
351 - Ongoing work to add upcalls, using new SFA class
352 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
353 - reviewed type-checking for the 3 taggable classes node-interface-slice
354 - cleanup ald dummynet stuff
355 - expose the 'extensions' accessors to the API
356 - tweaked checks in AddSliceTag
357 - GetPersons exposes roles by default
358 - bugfix in ReportRunLevel for non-string levels
359 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
360
361 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
362 - new BindObjectToPeer method for sfa
363 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
364
365 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
366 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
367 - reportrunlevel logs its calls only when run_level changes
368 - pycurl more robust wrt to xmlrpclib.Transport
369
370 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
371 - produce a wsdl interface
372 - bugfix in getbootmedium for nodes with interface tags
373
374 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
375 - bugfix for some rare pattern-based filters
376
377 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
378 - improvements in the 4.2 legacy layer
379
380 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
381 - bugfix required for slice tags set on nodegroups
382
383 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
384 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
385
386 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
387 - more powerful legacy layer with 4.2
388
389 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
390 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
391 - migration script has an option for running interactively
392
393 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
394 - skips already added entries
395
396 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
397 - yet another set of fixes for external dummynet boxes
398
399 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
400 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
401 - and tmp file is cleaned up
402
403 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
404 - restore missing ResolveSlices
405
406 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
407 - new method GetDummyBoxMedium
408
409 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
410 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
411
412 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
413 - support for external dummynet boxes back in 4.3 - first draft
414
415 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
416 - fixes for smooth federation between 4.2 and 4.3
417 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
418
419 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
420 - support for BootCD variants (GetBootMedium ['variant:centos5'])
421 - fix corner case with filters like {'~slice_id':[]}
422 - fix transaction leak that caused the db connections pool to exhaust
423 - properly expose all methods, including Legacy/, and not only Methods/
424
425 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
426 - renumbered as 4.3
427 - nodes have new fields run_level (in addition to boot_state) and verified
428 - tweaked migration from 4.2
429 - tuned rpm dependencies
430 - doc generation more explicit about errors like missing python modules
431 - removed obsolete method GetSlicesMD5
432
433 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
434 - unified all tags
435 - renamed interface settings into interface tags and slice attributes into slice tags
436 - nodes have a node_type
437 - various changes on the way to 4.3
438
439 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
440 - Checkpointing : this version still has interface settings and slice attributes
441
442 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
443 - first iteration with taggable nodes/interfaces/slices
444 - embryo for ilinks
445 - cleaned up boot states
446 - migration script moslty complete
447
448 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
449 - fixed doc build by locating locally installed DTDs at build-time
450
451 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
452 - no more doc packaged outside of myplc-docs - doc/ cleaned up
453 - enhancements in doc on filters 
454 - bootcd-aware GetBootMedium merged from onelab
455
456 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
457 - checkpoint while the new myplc-docs package is underway
458 - bugfix: GetSlivers & conf files
459 - doc: removed target files 
460
461 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
462 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
463 - the non-deleted fields were index, resulting in massivly slow queries.
464
465
466 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
467 - plcsh: better handling of options when running as a shell script
468 - getbootmedium exports compute_key
469 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
470
471 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
472 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
473 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
474
475 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
476 - refresh peer script to use a month-dependent logfile
477 - tracking the starting point for UniPi integration of the dummynet boxes
478
479 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
480 - plcsh adds its own path to sys.path
481 - fix so GetNodes can be called from a Node
482
483 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
484 - Initial build.
485
486 %define module_current_branch 4.3