patch our local xmlrpc lib (for supporting allow_none=True) with php5.4
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.1
3 %define taglevel 6
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 Requires: Django
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel PyXML python-simplejson
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %define php_extension_dir %(php-config --extension-dir)
129
130 %files
131 %defattr(-,root,root,-)
132 %dir %{_datadir}/plc_api
133 %dir /var/log/omf/
134 %{_datadir}/plc_api/*
135 %{_bindir}/plcsh
136 %{php_extension_dir}/xmlrpc.so
137 %{_sysconfdir}/php.d/xmlrpc.ini
138 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
139 /etc/plc.d
140 /etc/planetlab/db-config.d
141 /var/www/html/wsdl/plcapi.wsdl
142 /usr/bin/omf_slicemgr.py*
143 /usr/bin/reset_xmpp_pubsub_nodes.py*
144 /var/log/plc_api_ratelimit.log
145
146
147 %changelog
148 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
149 - implement PLC_VSYS_DEFAULTS in AddSlice
150
151 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
152 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
153 - AddPerson and UpdatePerson are now tag-aware
154 - as a side-effect AddPerson is more picky and rejects invalid fields
155 - which results in a requirement to use sfa-2.1-22 with this tag
156 - marginal improvement on the xml doc on tags
157
158 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
159 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
160 - reset_xmpp_pubsub_nodes now hos options and usage
161 - new Accessors for vicci
162
163 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
164 - fixed imports for tags management with sites and persons
165 - add predefined 'cpu_freezable' tag
166
167 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
168 - tweaks in interface initialization
169 - has 'vsys_vnet' as a predefined tagtype
170 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
171 - bugfix: GetSlivers & nodegroups
172 - bugfix: in jabber groups management
173
174 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
175 - fix gpg-authentication for Persons (thanks Jordan)
176 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
177 - ip address/network check: v4 or v6
178 - customized DB Message survive upgrade
179 - make sync works in lxc-hosted tests
180 - no svn keywords anymore
181
182 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
183 - fix sorting for methods list in docs
184 - untested but needed tweak for postgres startup in f16
185
186 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
187 - tweaks in postgresql setup - in line with sfa
188
189 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
190 - slight tweaks in Persons.py
191
192 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
193 - GetSession has support for more than one day sessions
194 - reset_xmpp_pubsub_nodes is much more efficient
195 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
196 - bugfix - deleting a person in the middle of the signup process
197
198 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
199 - ratelimit aspects
200 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
201 - requires Django for cache_utils
202 - attempt to expose 'pldistro' to sfa
203 - last_time_spent_online, last_time_spent_offline: new fields in Node
204 - new slice tags 'isolate_loopback' and 'cpu_cores'
205 - refresh-peer federation logs dump exceptions
206 - modpython logs have a timestamp
207 - more verbose/accurate php error reporting
208 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
209 - AddNode, UpdateNode: manage tags directly rather than through another method
210 - BootUpdateNode: only update once
211 - GetPersons: techs can access the list of persons on their site
212 - GetSlices and GetSliceTags: techs can see slices on their nodes
213 - GetSlivers: isrootonsite tag; cacheable
214
215 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
216 - rename initscript_body into initscript_code
217
218 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
219 - new initscript_body tag
220
221 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
222 - working draft for GetSliceSshKeys
223
224 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
225 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
226 - (this is for people who cancel their download)
227
228 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
229 - fix db-config sequence : accessors step now merged in, and occurs at the right time
230 - db-config also more robust
231 - no more explicit 'accessors' step in plc.d
232
233 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
234 - session auth: do *not* delete session when node runs a method that does not have 'node' role
235 - session auth: remove support for bootonce in old boot CDs
236 - give a reason when caller_may_write_slice_tag fails
237 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
238
239 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
240 - SetSliceVref needed the node role
241 - protect GetSliceFamily
242 - Fix bugs in tag authorizations
243
244 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
245 - altered checking of optional fields in Interfaces
246 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
247 - has pyxml and python-simplejson as new deps
248
249 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
250 - tweak doc extraction for fedora14
251
252 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
253 - builtin accessors for the myslice page
254 - Get{Node,Interface}Tags allowed to techs
255 - tweak in ratelimitaspect.py
256
257 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
258 - add admin role to accessor-related tags (arch, {fc,pl}distro)
259
260 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
261 - bugfix in {Update,Delete}PersonTag
262 - updated xml doc for filters, accessors and tagtypes
263 - more explicit msg in case of missing roles
264 - improvements in ratelimitaspects.py
265
266 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
267 - fix the roles for ssh_key and hmac tags
268
269 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
270 - tag permissions system based on roles and not min_role_ids
271 - accessors simplified accordingly (no more min_role_id)
272 - new methods AddRoleToTagType and DeleteRoleFromTagType
273 - accessor-related tagtypes are created sooner, and enforced
274 - cleaned up redundancy between db-config.d and accessors
275
276 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
277 - fix RefreshPeer that was not working in 5.0-17
278
279 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
280 - RefreshPeer is able to cope with 2 peers running different releases of the api
281 - DeletePerson can be used on duplicates
282 - first appearance of ModPythonJson.py
283
284 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
285 - set accessors return the new value
286 - tweaks in the pubsub groups management
287
288 * Wed Jul 28 2010 S.ÇaÄŸlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
289 - convert hostnames to lower case and use ILIKE instead of LIKE
290
291 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
292 - use hrn in pubsub groups
293
294 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
295 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
296 - - OMF fixes
297
298 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
299 - automatically set vsys tag for omf controlled slices
300
301 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
302 - addition of the 'ssh_key' slice tag
303 - first draft of the LDAP interface
304
305 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
306 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
307 - and readable through GetLeaseGranularity
308 - GetSlivers to expose reservation_policy and lease_granularity
309 - GetBootMedium fixed for reservable nodes
310 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
311 - new Apache mod_wsgi python interface
312
313 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
314 - the leases system
315
316 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
317 - previous tag had gone wrong
318
319 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
320 - fix pubsub hostname
321
322 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
323 - tweaks for the omf support (xmpp groups and RC-controlled slices)
324 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
325 - GetNodeFlavour exposes fcdistro
326
327 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
328 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
329
330 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
331 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
332 - pyaspect hooks allow to  maintain the namespace xmpp groups
333 - new omf_slicemgr is a proxy to xmpp, used by these hooks
334 - nodes have their hrn exposed in the 'hrn' tag
335 - node hrn exposed in GetSlivers, as well as the overall xmpp config
336 - system slice 'drl' gets created by db-config
337 - daniel's changes to Filter for supporting wildcards in lists
338 - AddSliceTag consistency check tweaked
339
340 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
341 - major cleanup
342 - get rid of all 4.2-related legacy code
343 - reset the migrations code, planetlab5.sql somes with (5,100)
344 - uses hashlib module when available
345
346 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
347 - first working version of 5.0:
348 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
349 - nodefamily is 3-fold with pldistro-fcdistro-arch
350 - site and person tags
351 - new methods GetSliceFamily and GetNodeFlavour
352 - deprecated the dummynet stuff that were for the external dummyboxes
353 - tags definition : more consistency between db-config scripts and accessors
354 - (get accessor to create the tag type too if absent)
355 - logging an event for AddSliceToNodes
356
357 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
358 - support for fedora 12
359 - fix subtle bug in filtering with ] and quotes
360
361 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
362 - * patch for php-5.3 (the one in f12)
363 - * validate email addresses with regex
364 - * add PersonTags and SiteTags
365 - * add additional accessors for node tags (kvariant, serial, ..)
366
367 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
368 - Redacting password, session, and authstring values from the event log.
369
370 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
371 - let AddSite set ext_consortium_id - required for the poorman registration pages
372 - drop version constraint on Requires: postgresql-python
373 - don't log system calls nor ReportRunLevel
374
375 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
376 - Fix requires for CentOS.
377
378 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
379 - Require postgresql 8.2 (for array operators && and @>)
380
381 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
382 - Filter now supports the | and & features to match in sequence values
383 - bugfix in the postgresql wrapper for sequence filter values
384 - reviewed GetSlivers to export admin keys more efficiently
385 - fix checking roles in UpdateSliceTag
386
387 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
388 - - Some typos in the documentation were fixed.
389 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
390 - to the tag's min_role_id.
391
392 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
393
394 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
395 - Ongoing work to add upcalls, using new SFA class
396 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
397 - reviewed type-checking for the 3 taggable classes node-interface-slice
398 - cleanup ald dummynet stuff
399 - expose the 'extensions' accessors to the API
400 - tweaked checks in AddSliceTag
401 - GetPersons exposes roles by default
402 - bugfix in ReportRunLevel for non-string levels
403 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
404
405 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
406 - new BindObjectToPeer method for sfa
407 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
408
409 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
410 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
411 - reportrunlevel logs its calls only when run_level changes
412 - pycurl more robust wrt to xmlrpclib.Transport
413
414 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
415 - produce a wsdl interface
416 - bugfix in getbootmedium for nodes with interface tags
417
418 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
419 - bugfix for some rare pattern-based filters
420
421 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
422 - improvements in the 4.2 legacy layer
423
424 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
425 - bugfix required for slice tags set on nodegroups
426
427 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
428 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
429
430 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
431 - more powerful legacy layer with 4.2
432
433 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
434 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
435 - migration script has an option for running interactively
436
437 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
438 - skips already added entries
439
440 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
441 - yet another set of fixes for external dummynet boxes
442
443 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
444 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
445 - and tmp file is cleaned up
446
447 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
448 - restore missing ResolveSlices
449
450 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
451 - new method GetDummyBoxMedium
452
453 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
454 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
455
456 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
457 - support for external dummynet boxes back in 4.3 - first draft
458
459 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
460 - fixes for smooth federation between 4.2 and 4.3
461 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
462
463 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
464 - support for BootCD variants (GetBootMedium ['variant:centos5'])
465 - fix corner case with filters like {'~slice_id':[]}
466 - fix transaction leak that caused the db connections pool to exhaust
467 - properly expose all methods, including Legacy/, and not only Methods/
468
469 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
470 - renumbered as 4.3
471 - nodes have new fields run_level (in addition to boot_state) and verified
472 - tweaked migration from 4.2
473 - tuned rpm dependencies
474 - doc generation more explicit about errors like missing python modules
475 - removed obsolete method GetSlicesMD5
476
477 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
478 - unified all tags
479 - renamed interface settings into interface tags and slice attributes into slice tags
480 - nodes have a node_type
481 - various changes on the way to 4.3
482
483 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
484 - Checkpointing : this version still has interface settings and slice attributes
485
486 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
487 - first iteration with taggable nodes/interfaces/slices
488 - embryo for ilinks
489 - cleaned up boot states
490 - migration script moslty complete
491
492 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
493 - fixed doc build by locating locally installed DTDs at build-time
494
495 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
496 - no more doc packaged outside of myplc-docs - doc/ cleaned up
497 - enhancements in doc on filters 
498 - bootcd-aware GetBootMedium merged from onelab
499
500 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
501 - checkpoint while the new myplc-docs package is underway
502 - bugfix: GetSlivers & conf files
503 - doc: removed target files 
504
505 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
506 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
507 - the non-deleted fields were index, resulting in massivly slow queries.
508
509
510 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
511 - plcsh: better handling of options when running as a shell script
512 - getbootmedium exports compute_key
513 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
514
515 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
516 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
517 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
518
519 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
520 - refresh peer script to use a month-dependent logfile
521 - tracking the starting point for UniPi integration of the dummynet boxes
522
523 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
524 - plcsh adds its own path to sys.path
525 - fix so GetNodes can be called from a Node
526
527 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
528 - Initial build.
529
530 %define module_current_branch 4.3