install reset_xmpp_pubsub_nodes.py
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 2
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 Requires: mod_ssl
38 Requires: SOAPpy
39 # for the RebootNodeWithPCU method
40 Requires: pcucontrol
41 # for OMF integration
42 Requires: pyaspects
43 Requires: python-twisted-words
44 Requires: python-twisted-web
45
46 ### avoid having yum complain about updates, as stuff is moving around
47 # plc.d/api
48 Conflicts: MyPLC <= 4.3
49
50 # We use psycopg2
51 BuildRequires: postgresql-devel
52
53 # Standard xmlrpc.so that ships with PHP does not marshal NULL
54 BuildRequires: php-devel
55 Obsoletes: php-xmlrpc
56 Provides: php-xmlrpc
57
58 # PostgreSQL and SOAPpy are necessary to run the API server, but not
59 # plcsh. Since the only supported method of running the server is via
60 # MyPLC anyway, don't be so stringent about binary requirements, in
61 # case people want to install this package just for plcsh.
62 # Requires: postgresql-server, SOAPpy
63 AutoReqProv: no
64
65 %description
66 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
67 PlanetLab Central (PLC) database. The API may be accessed directly via
68 the Python shell program plcsh, through a toy standalone server, or
69 through Apache mod_python.
70
71 %prep
72 %setup -q
73
74 %build
75 # python-pycurl and python-psycopg2 avail. from fedora 5
76 # we used to ship our own version of psycopg2 and pycurl, for fedora4
77 # starting with 4.3, support for these two modules is taken out
78
79 # Build __init__.py metafiles and PHP API. 
80 %{__make} %{?_smp_mflags}
81 %{__make} -C wsdl
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
86
87 # Install shell symlink
88 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
89 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
90
91 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
92 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
93 ; Enable xmlrpc extension module
94 extension=xmlrpc.so
95 EOF
96
97 # Install initscripts
98 echo "* Installing initscripts"
99 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
100 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
101
102 # Install db-config.d files
103 echo "* Installing db-config.d files"
104 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
105 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
106 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
107
108 # Install wsdl
109 echo "* Installing wsdl"
110 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
111
112 # Install omf_slicemgr.py
113 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
114 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %define php_extension_dir %(php-config --extension-dir)
120
121 %files
122 %defattr(-,root,root,-)
123 %dir %{_datadir}/plc_api
124 %{_datadir}/plc_api/*
125 %{_bindir}/plcsh
126 %{php_extension_dir}/xmlrpc.so
127 %{_sysconfdir}/php.d/xmlrpc.ini
128 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
129 /etc/plc.d
130 /etc/planetlab/db-config.d
131 /var/www/html/wsdl/plcapi.wsdl
132 /usr/bin/omf_slicemgr.py*
133 /usr/bin/reset_xmpp_pubsub_nodes.py*
134
135 %changelog
136 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
137 - major cleanup
138 - get rid of all 4.2-related legacy code
139 - reset the migrations code, planetlab5.sql somes with (5,100)
140 - uses hashlib module when available
141
142 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
143 - first working version of 5.0:
144 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
145 - nodefamily is 3-fold with pldistro-fcdistro-arch
146 - site and person tags
147 - new methods GetSliceFamily and GetNodeFlavour
148 - deprecated the dummynet stuff that were for the external dummyboxes
149 - tags definition : more consistency between db-config scripts and accessors
150 - (get accessor to create the tag type too if absent)
151 - logging an event for AddSliceToNodes
152
153 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
154 - support for fedora 12
155 - fix subtle bug in filtering with ] and quotes
156
157 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
158 - * patch for php-5.3 (the one in f12)
159 - * validate email addresses with regex
160 - * add PersonTags and SiteTags
161 - * add additional accessors for node tags (kvariant, serial, ..)
162
163 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
164 - Redacting password, session, and authstring values from the event log.
165
166 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
167 - let AddSite set ext_consortium_id - required for the poorman registration pages
168 - drop version constraint on Requires: postgresql-python
169 - don't log system calls nor ReportRunLevel
170
171 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
172 - Fix requires for CentOS.
173
174 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
175 - Require postgresql 8.2 (for array operators && and @>)
176
177 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
178 - Filter now supports the | and & features to match in sequence values
179 - bugfix in the postgresql wrapper for sequence filter values
180 - reviewed GetSlivers to export admin keys more efficiently
181 - fix checking roles in UpdateSliceTag
182
183 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
184 - - Some typos in the documentation were fixed.
185 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
186 - to the tag's min_role_id.
187
188 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
189
190 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
191 - Ongoing work to add upcalls, using new SFA class
192 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
193 - reviewed type-checking for the 3 taggable classes node-interface-slice
194 - cleanup ald dummynet stuff
195 - expose the 'extensions' accessors to the API
196 - tweaked checks in AddSliceTag
197 - GetPersons exposes roles by default
198 - bugfix in ReportRunLevel for non-string levels
199 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
200
201 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
202 - new BindObjectToPeer method for sfa
203 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
204
205 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
206 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
207 - reportrunlevel logs its calls only when run_level changes
208 - pycurl more robust wrt to xmlrpclib.Transport
209
210 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
211 - produce a wsdl interface
212 - bugfix in getbootmedium for nodes with interface tags
213
214 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
215 - bugfix for some rare pattern-based filters
216
217 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
218 - improvements in the 4.2 legacy layer
219
220 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
221 - bugfix required for slice tags set on nodegroups
222
223 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
224 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
225
226 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
227 - more powerful legacy layer with 4.2
228
229 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
230 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
231 - migration script has an option for running interactively
232
233 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
234 - skips already added entries
235
236 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
237 - yet another set of fixes for external dummynet boxes
238
239 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
240 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
241 - and tmp file is cleaned up
242
243 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
244 - restore missing ResolveSlices
245
246 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
247 - new method GetDummyBoxMedium
248
249 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
250 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
251
252 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
253 - support for external dummynet boxes back in 4.3 - first draft
254
255 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
256 - fixes for smooth federation between 4.2 and 4.3
257 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
258
259 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
260 - support for BootCD variants (GetBootMedium ['variant:centos5'])
261 - fix corner case with filters like {'~slice_id':[]}
262 - fix transaction leak that caused the db connections pool to exhaust
263 - properly expose all methods, including Legacy/, and not only Methods/
264
265 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
266 - renumbered as 4.3
267 - nodes have new fields run_level (in addition to boot_state) and verified
268 - tweaked migration from 4.2
269 - tuned rpm dependencies
270 - doc generation more explicit about errors like missing python modules
271 - removed obsolete method GetSlicesMD5
272
273 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
274 - unified all tags
275 - renamed interface settings into interface tags and slice attributes into slice tags
276 - nodes have a node_type
277 - various changes on the way to 4.3
278
279 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
280 - Checkpointing : this version still has interface settings and slice attributes
281
282 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
283 - first iteration with taggable nodes/interfaces/slices
284 - embryo for ilinks
285 - cleaned up boot states
286 - migration script moslty complete
287
288 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
289 - fixed doc build by locating locally installed DTDs at build-time
290
291 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
292 - no more doc packaged outside of myplc-docs - doc/ cleaned up
293 - enhancements in doc on filters 
294 - bootcd-aware GetBootMedium merged from onelab
295
296 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
297 - checkpoint while the new myplc-docs package is underway
298 - bugfix: GetSlivers & conf files
299 - doc: removed target files 
300
301 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
302 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
303 - the non-deleted fields were index, resulting in massivly slow queries.
304
305
306 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
307 - plcsh: better handling of options when running as a shell script
308 - getbootmedium exports compute_key
309 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
310
311 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
312 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
313 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
314
315 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
316 - refresh peer script to use a month-dependent logfile
317 - tracking the starting point for UniPi integration of the dummynet boxes
318
319 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
320 - plcsh adds its own path to sys.path
321 - fix so GetNodes can be called from a Node
322
323 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
324 - Initial build.
325
326 %define module_current_branch 4.3