Setting tag plcapi-5.1-2
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.1
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 Requires: mod_python
31 # mod_wsgi will replace mod_python when we are ready
32 Requires: mod_wsgi
33 Requires: mod_ssl
34 Requires: SOAPpy
35 Requires: python-simplejson
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration
39 Requires: pyaspects >= 0.4
40 Requires: python-twisted-words
41 Requires: python-twisted-web
42 # ldap
43 Requires: python-ldap
44 # for memcache
45 Requires: python-memcached
46 Requires: memcached
47 Requires: Django
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel PyXML python-simplejson
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %define php_extension_dir %(php-config --extension-dir)
129
130 %files
131 %defattr(-,root,root,-)
132 %dir %{_datadir}/plc_api
133 %dir /var/log/omf/
134 %{_datadir}/plc_api/*
135 %{_bindir}/plcsh
136 %{php_extension_dir}/xmlrpc.so
137 %{_sysconfdir}/php.d/xmlrpc.ini
138 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
139 /etc/plc.d
140 /etc/planetlab/db-config.d
141 /var/www/html/wsdl/plcapi.wsdl
142 /usr/bin/omf_slicemgr.py*
143 /usr/bin/reset_xmpp_pubsub_nodes.py*
144 /var/log/plc_api_ratelimit.log
145
146
147 %changelog
148 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
149 - tweaks in interface initialization
150 - has 'vsys_vnet' as a predefined tagtype
151 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
152 - bugfix: GetSlivers & nodegroups
153 - bugfix: in jabber groups management
154
155 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
156 - fix gpg-authentication for Persons (thanks Jordan)
157 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
158 - ip address/network check: v4 or v6
159 - customized DB Message survive upgrade
160 - make sync works in lxc-hosted tests
161 - no svn keywords anymore
162
163 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
164 - fix sorting for methods list in docs
165 - untested but needed tweak for postgres startup in f16
166
167 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
168 - tweaks in postgresql setup - in line with sfa
169
170 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
171 - slight tweaks in Persons.py
172
173 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
174 - GetSession has support for more than one day sessions
175 - reset_xmpp_pubsub_nodes is much more efficient
176 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
177 - bugfix - deleting a person in the middle of the signup process
178
179 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
180 - ratelimit aspects
181 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
182 - requires Django for cache_utils
183 - attempt to expose 'pldistro' to sfa
184 - last_time_spent_online, last_time_spent_offline: new fields in Node
185 - new slice tags 'isolate_loopback' and 'cpu_cores'
186 - refresh-peer federation logs dump exceptions
187 - modpython logs have a timestamp
188 - more verbose/accurate php error reporting
189 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
190 - AddNode, UpdateNode: manage tags directly rather than through another method
191 - BootUpdateNode: only update once
192 - GetPersons: techs can access the list of persons on their site
193 - GetSlices and GetSliceTags: techs can see slices on their nodes
194 - GetSlivers: isrootonsite tag; cacheable
195
196 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
197 - rename initscript_body into initscript_code
198
199 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
200 - new initscript_body tag
201
202 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
203 - working draft for GetSliceSshKeys
204
205 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
206 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
207 - (this is for people who cancel their download)
208
209 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
210 - fix db-config sequence : accessors step now merged in, and occurs at the right time
211 - db-config also more robust
212 - no more explicit 'accessors' step in plc.d
213
214 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
215 - session auth: do *not* delete session when node runs a method that does not have 'node' role
216 - session auth: remove support for bootonce in old boot CDs
217 - give a reason when caller_may_write_slice_tag fails
218 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
219
220 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
221 - SetSliceVref needed the node role
222 - protect GetSliceFamily
223 - Fix bugs in tag authorizations
224
225 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
226 - altered checking of optional fields in Interfaces
227 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
228 - has pyxml and python-simplejson as new deps
229
230 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
231 - tweak doc extraction for fedora14
232
233 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
234 - builtin accessors for the myslice page
235 - Get{Node,Interface}Tags allowed to techs
236 - tweak in ratelimitaspect.py
237
238 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
239 - add admin role to accessor-related tags (arch, {fc,pl}distro)
240
241 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
242 - bugfix in {Update,Delete}PersonTag
243 - updated xml doc for filters, accessors and tagtypes
244 - more explicit msg in case of missing roles
245 - improvements in ratelimitaspects.py
246
247 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
248 - fix the roles for ssh_key and hmac tags
249
250 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
251 - tag permissions system based on roles and not min_role_ids
252 - accessors simplified accordingly (no more min_role_id)
253 - new methods AddRoleToTagType and DeleteRoleFromTagType
254 - accessor-related tagtypes are created sooner, and enforced
255 - cleaned up redundancy between db-config.d and accessors
256
257 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
258 - fix RefreshPeer that was not working in 5.0-17
259
260 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
261 - RefreshPeer is able to cope with 2 peers running different releases of the api
262 - DeletePerson can be used on duplicates
263 - first appearance of ModPythonJson.py
264
265 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
266 - set accessors return the new value
267 - tweaks in the pubsub groups management
268
269 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
270 - convert hostnames to lower case and use ILIKE instead of LIKE
271
272 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
273 - use hrn in pubsub groups
274
275 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
276 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
277 - - OMF fixes
278
279 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
280 - automatically set vsys tag for omf controlled slices
281
282 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
283 - addition of the 'ssh_key' slice tag
284 - first draft of the LDAP interface
285
286 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
287 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
288 - and readable through GetLeaseGranularity
289 - GetSlivers to expose reservation_policy and lease_granularity
290 - GetBootMedium fixed for reservable nodes
291 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
292 - new Apache mod_wsgi python interface
293
294 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
295 - the leases system
296
297 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
298 - previous tag had gone wrong
299
300 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
301 - fix pubsub hostname
302
303 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
304 - tweaks for the omf support (xmpp groups and RC-controlled slices)
305 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
306 - GetNodeFlavour exposes fcdistro
307
308 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
309 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
310
311 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
312 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
313 - pyaspect hooks allow to  maintain the namespace xmpp groups
314 - new omf_slicemgr is a proxy to xmpp, used by these hooks
315 - nodes have their hrn exposed in the 'hrn' tag
316 - node hrn exposed in GetSlivers, as well as the overall xmpp config
317 - system slice 'drl' gets created by db-config
318 - daniel's changes to Filter for supporting wildcards in lists
319 - AddSliceTag consistency check tweaked
320
321 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
322 - major cleanup
323 - get rid of all 4.2-related legacy code
324 - reset the migrations code, planetlab5.sql somes with (5,100)
325 - uses hashlib module when available
326
327 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
328 - first working version of 5.0:
329 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
330 - nodefamily is 3-fold with pldistro-fcdistro-arch
331 - site and person tags
332 - new methods GetSliceFamily and GetNodeFlavour
333 - deprecated the dummynet stuff that were for the external dummyboxes
334 - tags definition : more consistency between db-config scripts and accessors
335 - (get accessor to create the tag type too if absent)
336 - logging an event for AddSliceToNodes
337
338 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
339 - support for fedora 12
340 - fix subtle bug in filtering with ] and quotes
341
342 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
343 - * patch for php-5.3 (the one in f12)
344 - * validate email addresses with regex
345 - * add PersonTags and SiteTags
346 - * add additional accessors for node tags (kvariant, serial, ..)
347
348 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
349 - Redacting password, session, and authstring values from the event log.
350
351 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
352 - let AddSite set ext_consortium_id - required for the poorman registration pages
353 - drop version constraint on Requires: postgresql-python
354 - don't log system calls nor ReportRunLevel
355
356 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
357 - Fix requires for CentOS.
358
359 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
360 - Require postgresql 8.2 (for array operators && and @>)
361
362 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
363 - Filter now supports the | and & features to match in sequence values
364 - bugfix in the postgresql wrapper for sequence filter values
365 - reviewed GetSlivers to export admin keys more efficiently
366 - fix checking roles in UpdateSliceTag
367
368 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
369 - - Some typos in the documentation were fixed.
370 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
371 - to the tag's min_role_id.
372
373 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
374
375 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
376 - Ongoing work to add upcalls, using new SFA class
377 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
378 - reviewed type-checking for the 3 taggable classes node-interface-slice
379 - cleanup ald dummynet stuff
380 - expose the 'extensions' accessors to the API
381 - tweaked checks in AddSliceTag
382 - GetPersons exposes roles by default
383 - bugfix in ReportRunLevel for non-string levels
384 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
385
386 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
387 - new BindObjectToPeer method for sfa
388 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
389
390 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
391 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
392 - reportrunlevel logs its calls only when run_level changes
393 - pycurl more robust wrt to xmlrpclib.Transport
394
395 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
396 - produce a wsdl interface
397 - bugfix in getbootmedium for nodes with interface tags
398
399 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
400 - bugfix for some rare pattern-based filters
401
402 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
403 - improvements in the 4.2 legacy layer
404
405 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
406 - bugfix required for slice tags set on nodegroups
407
408 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
409 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
410
411 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
412 - more powerful legacy layer with 4.2
413
414 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
415 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
416 - migration script has an option for running interactively
417
418 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
419 - skips already added entries
420
421 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
422 - yet another set of fixes for external dummynet boxes
423
424 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
425 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
426 - and tmp file is cleaned up
427
428 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
429 - restore missing ResolveSlices
430
431 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
432 - new method GetDummyBoxMedium
433
434 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
435 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
436
437 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
438 - support for external dummynet boxes back in 4.3 - first draft
439
440 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
441 - fixes for smooth federation between 4.2 and 4.3
442 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
443
444 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
445 - support for BootCD variants (GetBootMedium ['variant:centos5'])
446 - fix corner case with filters like {'~slice_id':[]}
447 - fix transaction leak that caused the db connections pool to exhaust
448 - properly expose all methods, including Legacy/, and not only Methods/
449
450 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
451 - renumbered as 4.3
452 - nodes have new fields run_level (in addition to boot_state) and verified
453 - tweaked migration from 4.2
454 - tuned rpm dependencies
455 - doc generation more explicit about errors like missing python modules
456 - removed obsolete method GetSlicesMD5
457
458 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
459 - unified all tags
460 - renamed interface settings into interface tags and slice attributes into slice tags
461 - nodes have a node_type
462 - various changes on the way to 4.3
463
464 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
465 - Checkpointing : this version still has interface settings and slice attributes
466
467 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
468 - first iteration with taggable nodes/interfaces/slices
469 - embryo for ilinks
470 - cleaned up boot states
471 - migration script moslty complete
472
473 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
474 - fixed doc build by locating locally installed DTDs at build-time
475
476 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
477 - no more doc packaged outside of myplc-docs - doc/ cleaned up
478 - enhancements in doc on filters 
479 - bootcd-aware GetBootMedium merged from onelab
480
481 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
482 - checkpoint while the new myplc-docs package is underway
483 - bugfix: GetSlivers & conf files
484 - doc: removed target files 
485
486 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
487 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
488 - the non-deleted fields were index, resulting in massivly slow queries.
489
490
491 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
492 - plcsh: better handling of options when running as a shell script
493 - getbootmedium exports compute_key
494 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
495
496 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
497 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
498 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
499
500 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
501 - refresh peer script to use a month-dependent logfile
502 - tracking the starting point for UniPi integration of the dummynet boxes
503
504 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
505 - plcsh adds its own path to sys.path
506 - fix so GetNodes can be called from a Node
507
508 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
509 - Initial build.
510
511 %define module_current_branch 4.3