Setting tag PLCAPI-4.3-22
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 4.3
9 %define taglevel 22
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql postgresql-server postgresql-python
32 Requires: python-psycopg2
33 Requires: python-pycurl
34 Requires: httpd
35 Requires: mod_python
36 Requires: mod_ssl
37 Requires: SOAPpy
38
39 # We use psycopg2
40 BuildRequires: postgresql-devel
41
42 # Standard xmlrpc.so that ships with PHP does not marshal NULL
43 BuildRequires: php-devel
44 Obsoletes: php-xmlrpc
45 Provides: php-xmlrpc
46
47 # PostgreSQL and SOAPpy are necessary to run the API server, but not
48 # plcsh. Since the only supported method of running the server is via
49 # MyPLC anyway, don't be so stringent about binary requirements, in
50 # case people want to install this package just for plcsh.
51 # Requires: postgresql-server, SOAPpy
52 AutoReqProv: no
53
54 %description
55 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
56 PlanetLab Central (PLC) database. The API may be accessed directly via
57 the Python shell program plcsh, through a toy standalone server, or
58 through Apache mod_python.
59
60 %prep
61 %setup -q
62
63 %build
64 # python-pycurl and python-psycopg2 avail. from fedora 5
65 # we used to ship our own version of psycopg2 and pycurl, for fedora4
66 # starting with 4.3, support for these two modules is taken out
67
68 # Build __init__.py metafiles and PHP API. 
69 %{__make} %{?_smp_mflags}
70 %{__make} -C wsdl
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
75 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
76
77 # Install shell symlink
78 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
79 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
80
81 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
82 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
83 ; Enable xmlrpc extension module
84 extension=xmlrpc.so
85 EOF
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %define php_extension_dir %(php-config --extension-dir)
91
92 %files
93 %defattr(-,root,root,-)
94 %dir %{_datadir}/plc_api
95 %{_datadir}/plc_api/*
96 %{_bindir}/plcsh
97 %{php_extension_dir}/xmlrpc.so
98 %{_sysconfdir}/php.d/xmlrpc.ini
99 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
100 /var/www/html/wsdl/plcapi.wsdl
101
102 %changelog
103 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
104 - new BindObjectToPeer method for sfa
105 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
106
107 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
108 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
109 - reportrunlevel logs its calls only when run_level changes
110 - pycurl more robust wrt to xmlrpclib.Transport
111
112 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
113 - produce a wsdl interface
114 - bugfix in getbootmedium for nodes with interface tags
115
116 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
117 - bugfix for some rare pattern-based filters
118
119 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
120 - improvements in the 4.2 legacy layer
121
122 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
123 - bugfix required for slice tags set on nodegroups
124
125 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
126 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
127
128 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
129 - more powerful legacy layer with 4.2
130
131 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
132 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
133 - migration script has an option for running interactively
134
135 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
136 - skips already added entries
137
138 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
139 - yet another set of fixes for external dummynet boxes
140
141 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
142 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
143 - and tmp file is cleaned up
144
145 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
146 - restore missing ResolveSlices
147
148 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
149 - new method GetDummyBoxMedium
150
151 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
152 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
153
154 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
155 - support for external dummynet boxes back in 4.3 - first draft
156
157 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
158 - fixes for smooth federation between 4.2 and 4.3
159 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
160
161 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
162 - support for BootCD variants (GetBootMedium ['variant:centos5'])
163 - fix corner case with filters like {'~slice_id':[]}
164 - fix transaction leak that caused the db connections pool to exhaust
165 - properly expose all methods, including Legacy/, and not only Methods/
166
167 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
168 - renumbered as 4.3
169 - nodes have new fields run_level (in addition to boot_state) and verified
170 - tweaked migration from 4.2
171 - tuned rpm dependencies
172 - doc generation more explicit about errors like missing python modules
173 - removed obsolete method GetSlicesMD5
174
175 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
176 - unified all tags
177 - renamed interface settings into interface tags and slice attributes into slice tags
178 - nodes have a node_type
179 - various changes on the way to 4.3
180
181 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
182 - Checkpointing : this version still has interface settings and slice attributes
183
184 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
185 - first iteration with taggable nodes/interfaces/slices
186 - embryo for ilinks
187 - cleaned up boot states
188 - migration script moslty complete
189
190 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
191 - fixed doc build by locating locally installed DTDs at build-time
192
193 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
194 - no more doc packaged outside of myplc-docs - doc/ cleaned up
195 - enhancements in doc on filters 
196 - bootcd-aware GetBootMedium merged from onelab
197
198 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
199 - checkpoint while the new myplc-docs package is underway
200 - bugfix: GetSlivers & conf files
201 - doc: removed target files 
202
203 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
204 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
205 - the non-deleted fields were index, resulting in massivly slow queries.
206
207
208 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
209 - plcsh: better handling of options when running as a shell script
210 - getbootmedium exports compute_key
211 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
212
213 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
214 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
215 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
216
217 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
218 - refresh peer script to use a month-dependent logfile
219 - tracking the starting point for UniPi integration of the dummynet boxes
220
221 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
222 - plcsh adds its own path to sys.path
223 - fix so GetNodes can be called from a Node
224
225 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
226 - Initial build.
227
228 %define module_current_branch 4.2