Setting tag PLCAPI-5.0-3
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 3
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 Requires: mod_ssl
38 Requires: SOAPpy
39 # for the RebootNodeWithPCU method
40 Requires: pcucontrol
41 # for OMF integration
42 Requires: pyaspects
43 Requires: python-twisted-words
44 Requires: python-twisted-web
45
46 ### avoid having yum complain about updates, as stuff is moving around
47 # plc.d/api
48 Conflicts: MyPLC <= 4.3
49
50 # We use psycopg2
51 BuildRequires: postgresql-devel
52
53 # Standard xmlrpc.so that ships with PHP does not marshal NULL
54 BuildRequires: php-devel
55 Obsoletes: php-xmlrpc
56 Provides: php-xmlrpc
57
58 # PostgreSQL and SOAPpy are necessary to run the API server, but not
59 # plcsh. Since the only supported method of running the server is via
60 # MyPLC anyway, don't be so stringent about binary requirements, in
61 # case people want to install this package just for plcsh.
62 # Requires: postgresql-server, SOAPpy
63 AutoReqProv: no
64
65 %description
66 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
67 PlanetLab Central (PLC) database. The API may be accessed directly via
68 the Python shell program plcsh, through a toy standalone server, or
69 through Apache mod_python.
70
71 %prep
72 %setup -q
73
74 %build
75 # python-pycurl and python-psycopg2 avail. from fedora 5
76 # we used to ship our own version of psycopg2 and pycurl, for fedora4
77 # starting with 4.3, support for these two modules is taken out
78
79 # Build __init__.py metafiles and PHP API. 
80 %{__make} %{?_smp_mflags}
81 %{__make} -C wsdl
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
86
87 # Install shell symlink
88 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
89 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
90
91 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
92 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
93 ; Enable xmlrpc extension module
94 extension=xmlrpc.so
95 EOF
96
97 # Install initscripts
98 echo "* Installing initscripts"
99 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
100 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
101
102 # Install db-config.d files
103 echo "* Installing db-config.d files"
104 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
105 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
106 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
107
108 # Install wsdl
109 echo "* Installing wsdl"
110 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
111
112 # Install omf_slicemgr.py
113 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
114 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %define php_extension_dir %(php-config --extension-dir)
120
121 %files
122 %defattr(-,root,root,-)
123 %dir %{_datadir}/plc_api
124 %{_datadir}/plc_api/*
125 %{_bindir}/plcsh
126 %{php_extension_dir}/xmlrpc.so
127 %{_sysconfdir}/php.d/xmlrpc.ini
128 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
129 /etc/plc.d
130 /etc/planetlab/db-config.d
131 /var/www/html/wsdl/plcapi.wsdl
132 /usr/bin/omf_slicemgr.py*
133 /usr/bin/reset_xmpp_pubsub_nodes.py*
134
135 %changelog
136 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
137 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
138 - pyaspect hooks allow to  maintain the namespace xmpp groups
139 - new omf_slicemgr is a proxy to xmpp, used by these hooks
140 - nodes have their hrn exposed in the 'hrn' tag
141 - node hrn exposed in GetSlivers, as well as the overall xmpp config
142 - system slice 'drl' gets created by db-config
143 - daniel's changes to Filter for supporting wildcards in lists
144 - AddSliceTag consistency check tweaked
145
146 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
147 - major cleanup
148 - get rid of all 4.2-related legacy code
149 - reset the migrations code, planetlab5.sql somes with (5,100)
150 - uses hashlib module when available
151
152 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
153 - first working version of 5.0:
154 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
155 - nodefamily is 3-fold with pldistro-fcdistro-arch
156 - site and person tags
157 - new methods GetSliceFamily and GetNodeFlavour
158 - deprecated the dummynet stuff that were for the external dummyboxes
159 - tags definition : more consistency between db-config scripts and accessors
160 - (get accessor to create the tag type too if absent)
161 - logging an event for AddSliceToNodes
162
163 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
164 - support for fedora 12
165 - fix subtle bug in filtering with ] and quotes
166
167 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
168 - * patch for php-5.3 (the one in f12)
169 - * validate email addresses with regex
170 - * add PersonTags and SiteTags
171 - * add additional accessors for node tags (kvariant, serial, ..)
172
173 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
174 - Redacting password, session, and authstring values from the event log.
175
176 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
177 - let AddSite set ext_consortium_id - required for the poorman registration pages
178 - drop version constraint on Requires: postgresql-python
179 - don't log system calls nor ReportRunLevel
180
181 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
182 - Fix requires for CentOS.
183
184 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
185 - Require postgresql 8.2 (for array operators && and @>)
186
187 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
188 - Filter now supports the | and & features to match in sequence values
189 - bugfix in the postgresql wrapper for sequence filter values
190 - reviewed GetSlivers to export admin keys more efficiently
191 - fix checking roles in UpdateSliceTag
192
193 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
194 - - Some typos in the documentation were fixed.
195 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
196 - to the tag's min_role_id.
197
198 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
199
200 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
201 - Ongoing work to add upcalls, using new SFA class
202 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
203 - reviewed type-checking for the 3 taggable classes node-interface-slice
204 - cleanup ald dummynet stuff
205 - expose the 'extensions' accessors to the API
206 - tweaked checks in AddSliceTag
207 - GetPersons exposes roles by default
208 - bugfix in ReportRunLevel for non-string levels
209 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
210
211 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
212 - new BindObjectToPeer method for sfa
213 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
214
215 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
216 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
217 - reportrunlevel logs its calls only when run_level changes
218 - pycurl more robust wrt to xmlrpclib.Transport
219
220 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
221 - produce a wsdl interface
222 - bugfix in getbootmedium for nodes with interface tags
223
224 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
225 - bugfix for some rare pattern-based filters
226
227 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
228 - improvements in the 4.2 legacy layer
229
230 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
231 - bugfix required for slice tags set on nodegroups
232
233 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
234 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
235
236 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
237 - more powerful legacy layer with 4.2
238
239 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
240 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
241 - migration script has an option for running interactively
242
243 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
244 - skips already added entries
245
246 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
247 - yet another set of fixes for external dummynet boxes
248
249 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
250 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
251 - and tmp file is cleaned up
252
253 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
254 - restore missing ResolveSlices
255
256 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
257 - new method GetDummyBoxMedium
258
259 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
260 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
261
262 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
263 - support for external dummynet boxes back in 4.3 - first draft
264
265 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
266 - fixes for smooth federation between 4.2 and 4.3
267 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
268
269 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
270 - support for BootCD variants (GetBootMedium ['variant:centos5'])
271 - fix corner case with filters like {'~slice_id':[]}
272 - fix transaction leak that caused the db connections pool to exhaust
273 - properly expose all methods, including Legacy/, and not only Methods/
274
275 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
276 - renumbered as 4.3
277 - nodes have new fields run_level (in addition to boot_state) and verified
278 - tweaked migration from 4.2
279 - tuned rpm dependencies
280 - doc generation more explicit about errors like missing python modules
281 - removed obsolete method GetSlicesMD5
282
283 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
284 - unified all tags
285 - renamed interface settings into interface tags and slice attributes into slice tags
286 - nodes have a node_type
287 - various changes on the way to 4.3
288
289 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
290 - Checkpointing : this version still has interface settings and slice attributes
291
292 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
293 - first iteration with taggable nodes/interfaces/slices
294 - embryo for ilinks
295 - cleaned up boot states
296 - migration script moslty complete
297
298 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
299 - fixed doc build by locating locally installed DTDs at build-time
300
301 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
302 - no more doc packaged outside of myplc-docs - doc/ cleaned up
303 - enhancements in doc on filters 
304 - bootcd-aware GetBootMedium merged from onelab
305
306 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
307 - checkpoint while the new myplc-docs package is underway
308 - bugfix: GetSlivers & conf files
309 - doc: removed target files 
310
311 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
312 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
313 - the non-deleted fields were index, resulting in massivly slow queries.
314
315
316 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
317 - plcsh: better handling of options when running as a shell script
318 - getbootmedium exports compute_key
319 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
320
321 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
322 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
323 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
324
325 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
326 - refresh peer script to use a month-dependent logfile
327 - tracking the starting point for UniPi integration of the dummynet boxes
328
329 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
330 - plcsh adds its own path to sys.path
331 - fix so GetNodes can be called from a Node
332
333 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
334 - Initial build.
335
336 %define module_current_branch 4.3