Tagging module PLCAPI - PLCAPI-4.3-15
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 4.3
9 %define taglevel 15
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql postgresql-server postgresql-python
32 Requires: python-psycopg2
33 Requires: python-pycurl
34 Requires: httpd
35 Requires: mod_python
36 Requires: mod_ssl
37 Requires: SOAPpy
38
39 # We use psycopg2
40 BuildRequires: postgresql-devel
41
42 # Standard xmlrpc.so that ships with PHP does not marshal NULL
43 BuildRequires: php-devel
44 Obsoletes: php-xmlrpc
45 Provides: php-xmlrpc
46
47 # PostgreSQL and SOAPpy are necessary to run the API server, but not
48 # plcsh. Since the only supported method of running the server is via
49 # MyPLC anyway, don't be so stringent about binary requirements, in
50 # case people want to install this package just for plcsh.
51 # Requires: postgresql-server, SOAPpy
52 AutoReqProv: no
53
54 %description
55 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
56 PlanetLab Central (PLC) database. The API may be accessed directly via
57 the Python shell program plcsh, through a toy standalone server, or
58 through Apache mod_python.
59
60 %prep
61 %setup -q
62
63 %build
64 # python-pycurl and python-psycopg2 avail. from fedora 5
65 # we used to ship our own version of psycopg2 and pycurl, for fedora4
66 # starting with 4.3, support for these two modules is taken out
67
68 # Build __init__.py metafiles and PHP API. 
69 %{__make} %{?_smp_mflags}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
74
75 # Install shell symlink
76 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
77 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
78
79 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
80 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
81 ; Enable xmlrpc extension module
82 extension=xmlrpc.so
83 EOF
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %define php_extension_dir %(php-config --extension-dir)
89
90 %files
91 %defattr(-,root,root,-)
92 %dir %{_datadir}/plc_api
93 %{_datadir}/plc_api/*
94 %{_bindir}/plcsh
95 %{php_extension_dir}/xmlrpc.so
96 %{_sysconfdir}/php.d/xmlrpc.ini
97 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
98
99 %changelog
100 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
101 - more powerful legacy layer with 4.2
102
103 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
104 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
105 - migration script has an option for running interactively
106
107 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
108 - skips already added entries
109
110 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
111 - yet another set of fixes for external dummynet boxes
112
113 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
114 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
115 - and tmp file is cleaned up
116
117 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
118 - restore missing ResolveSlices
119
120 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
121 - new method GetDummyBoxMedium
122
123 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
124 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
125
126 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
127 - support for external dummynet boxes back in 4.3 - first draft
128
129 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
130 - fixes for smooth federation between 4.2 and 4.3
131 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
132
133 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
134 - support for BootCD variants (GetBootMedium ['variant:centos5'])
135 - fix corner case with filters like {'~slice_id':[]}
136 - fix transaction leak that caused the db connections pool to exhaust
137 - properly expose all methods, including Legacy/, and not only Methods/
138
139 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
140 - renumbered as 4.3
141 - nodes have new fields run_level (in addition to boot_state) and verified
142 - tweaked migration from 4.2
143 - tuned rpm dependencies
144 - doc generation more explicit about errors like missing python modules
145 - removed obsolete method GetSlicesMD5
146
147 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
148 - unified all tags
149 - renamed interface settings into interface tags and slice attributes into slice tags
150 - nodes have a node_type
151 - various changes on the way to 4.3
152
153 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
154 - Checkpointing : this version still has interface settings and slice attributes
155
156 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
157 - first iteration with taggable nodes/interfaces/slices
158 - embryo for ilinks
159 - cleaned up boot states
160 - migration script moslty complete
161
162 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
163 - fixed doc build by locating locally installed DTDs at build-time
164
165 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
166 - no more doc packaged outside of myplc-docs - doc/ cleaned up
167 - enhancements in doc on filters 
168 - bootcd-aware GetBootMedium merged from onelab
169
170 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
171 - checkpoint while the new myplc-docs package is underway
172 - bugfix: GetSlivers & conf files
173 - doc: removed target files 
174
175 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
176 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
177 - the non-deleted fields were index, resulting in massivly slow queries.
178
179
180 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
181 - plcsh: better handling of options when running as a shell script
182 - getbootmedium exports compute_key
183 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
184
185 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
186 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
187 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
188
189 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
190 - refresh peer script to use a month-dependent logfile
191 - tracking the starting point for UniPi integration of the dummynet boxes
192
193 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
194 - plcsh adds its own path to sys.path
195 - fix so GetNodes can be called from a Node
196
197 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
198 - Initial build.
199
200 %define module_current_branch 4.2