weaken Requires for postgresql-python, as it would not work on CentOS 5 with a 8...
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 4.3
9 %define taglevel 27
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 Requires: mod_ssl
38 Requires: SOAPpy
39
40 # We use psycopg2
41 BuildRequires: postgresql-devel
42
43 # Standard xmlrpc.so that ships with PHP does not marshal NULL
44 BuildRequires: php-devel
45 Obsoletes: php-xmlrpc
46 Provides: php-xmlrpc
47
48 # PostgreSQL and SOAPpy are necessary to run the API server, but not
49 # plcsh. Since the only supported method of running the server is via
50 # MyPLC anyway, don't be so stringent about binary requirements, in
51 # case people want to install this package just for plcsh.
52 # Requires: postgresql-server, SOAPpy
53 AutoReqProv: no
54
55 %description
56 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
57 PlanetLab Central (PLC) database. The API may be accessed directly via
58 the Python shell program plcsh, through a toy standalone server, or
59 through Apache mod_python.
60
61 %prep
62 %setup -q
63
64 %build
65 # python-pycurl and python-psycopg2 avail. from fedora 5
66 # we used to ship our own version of psycopg2 and pycurl, for fedora4
67 # starting with 4.3, support for these two modules is taken out
68
69 # Build __init__.py metafiles and PHP API. 
70 %{__make} %{?_smp_mflags}
71 %{__make} -C wsdl
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
76 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
77
78 # Install shell symlink
79 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
80 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
81
82 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
83 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
84 ; Enable xmlrpc extension module
85 extension=xmlrpc.so
86 EOF
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %define php_extension_dir %(php-config --extension-dir)
92
93 %files
94 %defattr(-,root,root,-)
95 %dir %{_datadir}/plc_api
96 %{_datadir}/plc_api/*
97 %{_bindir}/plcsh
98 %{php_extension_dir}/xmlrpc.so
99 %{_sysconfdir}/php.d/xmlrpc.ini
100 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
101 /var/www/html/wsdl/plcapi.wsdl
102
103 %changelog
104 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
105 - Require postgresql 8.2 (for array operators && and @>)
106
107 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
108 - Filter now supports the | and & features to match in sequence values
109 - bugfix in the postgresql wrapper for sequence filter values
110 - reviewed GetSlivers to export admin keys more efficiently
111 - fix checking roles in UpdateSliceTag
112
113 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
114 - - Some typos in the documentation were fixed.
115 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
116 - to the tag's min_role_id.
117
118 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
119
120 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
121 - Ongoing work to add upcalls, using new SFA class
122 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
123 - reviewed type-checking for the 3 taggable classes node-interface-slice
124 - cleanup ald dummynet stuff
125 - expose the 'extensions' accessors to the API
126 - tweaked checks in AddSliceTag
127 - GetPersons exposes roles by default
128 - bugfix in ReportRunLevel for non-string levels
129 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
130
131 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
132 - new BindObjectToPeer method for sfa
133 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
134
135 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
136 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
137 - reportrunlevel logs its calls only when run_level changes
138 - pycurl more robust wrt to xmlrpclib.Transport
139
140 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
141 - produce a wsdl interface
142 - bugfix in getbootmedium for nodes with interface tags
143
144 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
145 - bugfix for some rare pattern-based filters
146
147 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
148 - improvements in the 4.2 legacy layer
149
150 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
151 - bugfix required for slice tags set on nodegroups
152
153 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
154 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
155
156 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
157 - more powerful legacy layer with 4.2
158
159 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
160 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
161 - migration script has an option for running interactively
162
163 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
164 - skips already added entries
165
166 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
167 - yet another set of fixes for external dummynet boxes
168
169 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
170 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
171 - and tmp file is cleaned up
172
173 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
174 - restore missing ResolveSlices
175
176 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
177 - new method GetDummyBoxMedium
178
179 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
180 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
181
182 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
183 - support for external dummynet boxes back in 4.3 - first draft
184
185 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
186 - fixes for smooth federation between 4.2 and 4.3
187 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
188
189 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
190 - support for BootCD variants (GetBootMedium ['variant:centos5'])
191 - fix corner case with filters like {'~slice_id':[]}
192 - fix transaction leak that caused the db connections pool to exhaust
193 - properly expose all methods, including Legacy/, and not only Methods/
194
195 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
196 - renumbered as 4.3
197 - nodes have new fields run_level (in addition to boot_state) and verified
198 - tweaked migration from 4.2
199 - tuned rpm dependencies
200 - doc generation more explicit about errors like missing python modules
201 - removed obsolete method GetSlicesMD5
202
203 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
204 - unified all tags
205 - renamed interface settings into interface tags and slice attributes into slice tags
206 - nodes have a node_type
207 - various changes on the way to 4.3
208
209 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
210 - Checkpointing : this version still has interface settings and slice attributes
211
212 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
213 - first iteration with taggable nodes/interfaces/slices
214 - embryo for ilinks
215 - cleaned up boot states
216 - migration script moslty complete
217
218 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
219 - fixed doc build by locating locally installed DTDs at build-time
220
221 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
222 - no more doc packaged outside of myplc-docs - doc/ cleaned up
223 - enhancements in doc on filters 
224 - bootcd-aware GetBootMedium merged from onelab
225
226 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
227 - checkpoint while the new myplc-docs package is underway
228 - bugfix: GetSlivers & conf files
229 - doc: removed target files 
230
231 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
232 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
233 - the non-deleted fields were index, resulting in massivly slow queries.
234
235
236 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
237 - plcsh: better handling of options when running as a shell script
238 - getbootmedium exports compute_key
239 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
240
241 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
242 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
243 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
244
245 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
246 - refresh peer script to use a month-dependent logfile
247 - tracking the starting point for UniPi integration of the dummynet boxes
248
249 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
250 - plcsh adds its own path to sys.path
251 - fix so GetNodes can be called from a Node
252
253 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
254 - Initial build.
255
256 %define module_current_branch 4.2