Only weaken the R for CentOS.
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 4.3
9 %define taglevel 27
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 %if "%{?distro}" == "CentOS"
33 Requires: postgresql-python
34 %else
35 Requires: postgresql-python >= 8.2
36 %endif
37 Requires: python-psycopg2
38 Requires: python-pycurl
39 Requires: httpd
40 Requires: mod_python
41 Requires: mod_ssl
42 Requires: SOAPpy
43
44 # We use psycopg2
45 BuildRequires: postgresql-devel
46
47 # Standard xmlrpc.so that ships with PHP does not marshal NULL
48 BuildRequires: php-devel
49 Obsoletes: php-xmlrpc
50 Provides: php-xmlrpc
51
52 # PostgreSQL and SOAPpy are necessary to run the API server, but not
53 # plcsh. Since the only supported method of running the server is via
54 # MyPLC anyway, don't be so stringent about binary requirements, in
55 # case people want to install this package just for plcsh.
56 # Requires: postgresql-server, SOAPpy
57 AutoReqProv: no
58
59 %description
60 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
61 PlanetLab Central (PLC) database. The API may be accessed directly via
62 the Python shell program plcsh, through a toy standalone server, or
63 through Apache mod_python.
64
65 %prep
66 %setup -q
67
68 %build
69 # python-pycurl and python-psycopg2 avail. from fedora 5
70 # we used to ship our own version of psycopg2 and pycurl, for fedora4
71 # starting with 4.3, support for these two modules is taken out
72
73 # Build __init__.py metafiles and PHP API. 
74 %{__make} %{?_smp_mflags}
75 %{__make} -C wsdl
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
80 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
81
82 # Install shell symlink
83 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
84 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
85
86 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
87 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
88 ; Enable xmlrpc extension module
89 extension=xmlrpc.so
90 EOF
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %define php_extension_dir %(php-config --extension-dir)
96
97 %files
98 %defattr(-,root,root,-)
99 %dir %{_datadir}/plc_api
100 %{_datadir}/plc_api/*
101 %{_bindir}/plcsh
102 %{php_extension_dir}/xmlrpc.so
103 %{_sysconfdir}/php.d/xmlrpc.ini
104 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
105 /var/www/html/wsdl/plcapi.wsdl
106
107 %changelog
108 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
109 - Require postgresql 8.2 (for array operators && and @>)
110
111 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
112 - Filter now supports the | and & features to match in sequence values
113 - bugfix in the postgresql wrapper for sequence filter values
114 - reviewed GetSlivers to export admin keys more efficiently
115 - fix checking roles in UpdateSliceTag
116
117 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
118 - - Some typos in the documentation were fixed.
119 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
120 - to the tag's min_role_id.
121
122 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
123
124 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
125 - Ongoing work to add upcalls, using new SFA class
126 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
127 - reviewed type-checking for the 3 taggable classes node-interface-slice
128 - cleanup ald dummynet stuff
129 - expose the 'extensions' accessors to the API
130 - tweaked checks in AddSliceTag
131 - GetPersons exposes roles by default
132 - bugfix in ReportRunLevel for non-string levels
133 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
134
135 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
136 - new BindObjectToPeer method for sfa
137 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
138
139 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
140 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
141 - reportrunlevel logs its calls only when run_level changes
142 - pycurl more robust wrt to xmlrpclib.Transport
143
144 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
145 - produce a wsdl interface
146 - bugfix in getbootmedium for nodes with interface tags
147
148 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
149 - bugfix for some rare pattern-based filters
150
151 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
152 - improvements in the 4.2 legacy layer
153
154 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
155 - bugfix required for slice tags set on nodegroups
156
157 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
158 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
159
160 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
161 - more powerful legacy layer with 4.2
162
163 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
164 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
165 - migration script has an option for running interactively
166
167 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
168 - skips already added entries
169
170 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
171 - yet another set of fixes for external dummynet boxes
172
173 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
174 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
175 - and tmp file is cleaned up
176
177 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
178 - restore missing ResolveSlices
179
180 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
181 - new method GetDummyBoxMedium
182
183 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
184 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
185
186 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
187 - support for external dummynet boxes back in 4.3 - first draft
188
189 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
190 - fixes for smooth federation between 4.2 and 4.3
191 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
192
193 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
194 - support for BootCD variants (GetBootMedium ['variant:centos5'])
195 - fix corner case with filters like {'~slice_id':[]}
196 - fix transaction leak that caused the db connections pool to exhaust
197 - properly expose all methods, including Legacy/, and not only Methods/
198
199 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
200 - renumbered as 4.3
201 - nodes have new fields run_level (in addition to boot_state) and verified
202 - tweaked migration from 4.2
203 - tuned rpm dependencies
204 - doc generation more explicit about errors like missing python modules
205 - removed obsolete method GetSlicesMD5
206
207 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
208 - unified all tags
209 - renamed interface settings into interface tags and slice attributes into slice tags
210 - nodes have a node_type
211 - various changes on the way to 4.3
212
213 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
214 - Checkpointing : this version still has interface settings and slice attributes
215
216 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
217 - first iteration with taggable nodes/interfaces/slices
218 - embryo for ilinks
219 - cleaned up boot states
220 - migration script moslty complete
221
222 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
223 - fixed doc build by locating locally installed DTDs at build-time
224
225 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
226 - no more doc packaged outside of myplc-docs - doc/ cleaned up
227 - enhancements in doc on filters 
228 - bootcd-aware GetBootMedium merged from onelab
229
230 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
231 - checkpoint while the new myplc-docs package is underway
232 - bugfix: GetSlivers & conf files
233 - doc: removed target files 
234
235 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
236 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
237 - the non-deleted fields were index, resulting in massivly slow queries.
238
239
240 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
241 - plcsh: better handling of options when running as a shell script
242 - getbootmedium exports compute_key
243 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
244
245 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
246 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
247 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
248
249 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
250 - refresh peer script to use a month-dependent logfile
251 - tracking the starting point for UniPi integration of the dummynet boxes
252
253 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
254 - plcsh adds its own path to sys.path
255 - fix so GetNodes can be called from a Node
256
257 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
258 - Initial build.
259
260 %define module_current_branch 4.2