requires mod_wsgi
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 10
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 # mod_wsgi will replace mod_python when we are ready
38 Requires: mod_wsgi
39 Requires: mod_ssl
40 Requires: SOAPpy
41 # for the RebootNodeWithPCU method
42 Requires: pcucontrol >= 1.0-6
43 # for OMF integration
44 Requires: pyaspects
45 Requires: python-twisted-words
46 Requires: python-twisted-web
47
48 ### avoid having yum complain about updates, as stuff is moving around
49 # plc.d/api
50 Conflicts: MyPLC <= 4.3
51
52 # We use psycopg2
53 #
54 # but we don't need to rebuild it as we depend on distro's packages - baris
55 # BuildRequires: postgresql-devel
56
57 # Standard xmlrpc.so that ships with PHP does not marshal NULL
58 BuildRequires: php-devel
59 Obsoletes: php-xmlrpc
60 Provides: php-xmlrpc
61
62 # PostgreSQL and SOAPpy are necessary to run the API server, but not
63 # plcsh. Since the only supported method of running the server is via
64 # MyPLC anyway, don't be so stringent about binary requirements, in
65 # case people want to install this package just for plcsh.
66 # Requires: postgresql-server, SOAPpy
67 AutoReqProv: no
68
69 %description
70 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
71 PlanetLab Central (PLC) database. The API may be accessed directly via
72 the Python shell program plcsh, through a toy standalone server, or
73 through Apache mod_python.
74
75 %prep
76 %setup -q
77
78 %build
79 # python-pycurl and python-psycopg2 avail. from fedora 5
80 # we used to ship our own version of psycopg2 and pycurl, for fedora4
81 # starting with 4.3, support for these two modules is taken out
82
83 # Build __init__.py metafiles and PHP API. 
84 %{__make} %{?_smp_mflags}
85 %{__make} -C wsdl
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
90
91 # Install shell symlink
92 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
93 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
94
95 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
96 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
97 ; Enable xmlrpc extension module
98 extension=xmlrpc.so
99 EOF
100
101 # Install initscripts
102 echo "* Installing initscripts"
103 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
104 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
105
106 # Install db-config.d files
107 echo "* Installing db-config.d files"
108 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
110 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
111
112 # Install wsdl
113 echo "* Installing wsdl"
114 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
115
116 # Install omf_slicemgr.py
117 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %define php_extension_dir %(php-config --extension-dir)
125
126 %files
127 %defattr(-,root,root,-)
128 %dir %{_datadir}/plc_api
129 %dir /var/log/omf/
130 %{_datadir}/plc_api/*
131 %{_bindir}/plcsh
132 %{php_extension_dir}/xmlrpc.so
133 %{_sysconfdir}/php.d/xmlrpc.ini
134 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
135 /etc/plc.d
136 /etc/planetlab/db-config.d
137 /var/www/html/wsdl/plcapi.wsdl
138 /usr/bin/omf_slicemgr.py*
139 /usr/bin/reset_xmpp_pubsub_nodes.py*
140
141
142 %changelog
143 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
144 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
145 - and readable through GetLeaseGranularity
146 - GetSlivers to expose reservation_policy and lease_granularity
147 - GetBootMedium fixed for reservable nodes
148 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
149 - new Apache mod_wsgi python interface
150
151 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
152 - the leases system
153
154 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
155 - previous tag had gone wrong
156
157 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
158 - fix pubsub hostname
159
160 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
161 - tweaks for the omf support (xmpp groups and RC-controlled slices)
162 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
163 - GetNodeFlavour exposes fcdistro
164
165 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
166 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
167
168 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
169 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
170 - pyaspect hooks allow to  maintain the namespace xmpp groups
171 - new omf_slicemgr is a proxy to xmpp, used by these hooks
172 - nodes have their hrn exposed in the 'hrn' tag
173 - node hrn exposed in GetSlivers, as well as the overall xmpp config
174 - system slice 'drl' gets created by db-config
175 - daniel's changes to Filter for supporting wildcards in lists
176 - AddSliceTag consistency check tweaked
177
178 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
179 - major cleanup
180 - get rid of all 4.2-related legacy code
181 - reset the migrations code, planetlab5.sql somes with (5,100)
182 - uses hashlib module when available
183
184 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
185 - first working version of 5.0:
186 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
187 - nodefamily is 3-fold with pldistro-fcdistro-arch
188 - site and person tags
189 - new methods GetSliceFamily and GetNodeFlavour
190 - deprecated the dummynet stuff that were for the external dummyboxes
191 - tags definition : more consistency between db-config scripts and accessors
192 - (get accessor to create the tag type too if absent)
193 - logging an event for AddSliceToNodes
194
195 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
196 - support for fedora 12
197 - fix subtle bug in filtering with ] and quotes
198
199 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
200 - * patch for php-5.3 (the one in f12)
201 - * validate email addresses with regex
202 - * add PersonTags and SiteTags
203 - * add additional accessors for node tags (kvariant, serial, ..)
204
205 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
206 - Redacting password, session, and authstring values from the event log.
207
208 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
209 - let AddSite set ext_consortium_id - required for the poorman registration pages
210 - drop version constraint on Requires: postgresql-python
211 - don't log system calls nor ReportRunLevel
212
213 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
214 - Fix requires for CentOS.
215
216 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
217 - Require postgresql 8.2 (for array operators && and @>)
218
219 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
220 - Filter now supports the | and & features to match in sequence values
221 - bugfix in the postgresql wrapper for sequence filter values
222 - reviewed GetSlivers to export admin keys more efficiently
223 - fix checking roles in UpdateSliceTag
224
225 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
226 - - Some typos in the documentation were fixed.
227 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
228 - to the tag's min_role_id.
229
230 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
231
232 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
233 - Ongoing work to add upcalls, using new SFA class
234 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
235 - reviewed type-checking for the 3 taggable classes node-interface-slice
236 - cleanup ald dummynet stuff
237 - expose the 'extensions' accessors to the API
238 - tweaked checks in AddSliceTag
239 - GetPersons exposes roles by default
240 - bugfix in ReportRunLevel for non-string levels
241 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
242
243 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
244 - new BindObjectToPeer method for sfa
245 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
246
247 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
248 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
249 - reportrunlevel logs its calls only when run_level changes
250 - pycurl more robust wrt to xmlrpclib.Transport
251
252 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
253 - produce a wsdl interface
254 - bugfix in getbootmedium for nodes with interface tags
255
256 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
257 - bugfix for some rare pattern-based filters
258
259 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
260 - improvements in the 4.2 legacy layer
261
262 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
263 - bugfix required for slice tags set on nodegroups
264
265 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
266 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
267
268 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
269 - more powerful legacy layer with 4.2
270
271 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
272 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
273 - migration script has an option for running interactively
274
275 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
276 - skips already added entries
277
278 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
279 - yet another set of fixes for external dummynet boxes
280
281 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
282 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
283 - and tmp file is cleaned up
284
285 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
286 - restore missing ResolveSlices
287
288 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
289 - new method GetDummyBoxMedium
290
291 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
292 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
293
294 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
295 - support for external dummynet boxes back in 4.3 - first draft
296
297 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
298 - fixes for smooth federation between 4.2 and 4.3
299 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
300
301 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
302 - support for BootCD variants (GetBootMedium ['variant:centos5'])
303 - fix corner case with filters like {'~slice_id':[]}
304 - fix transaction leak that caused the db connections pool to exhaust
305 - properly expose all methods, including Legacy/, and not only Methods/
306
307 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
308 - renumbered as 4.3
309 - nodes have new fields run_level (in addition to boot_state) and verified
310 - tweaked migration from 4.2
311 - tuned rpm dependencies
312 - doc generation more explicit about errors like missing python modules
313 - removed obsolete method GetSlicesMD5
314
315 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
316 - unified all tags
317 - renamed interface settings into interface tags and slice attributes into slice tags
318 - nodes have a node_type
319 - various changes on the way to 4.3
320
321 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
322 - Checkpointing : this version still has interface settings and slice attributes
323
324 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
325 - first iteration with taggable nodes/interfaces/slices
326 - embryo for ilinks
327 - cleaned up boot states
328 - migration script moslty complete
329
330 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
331 - fixed doc build by locating locally installed DTDs at build-time
332
333 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
334 - no more doc packaged outside of myplc-docs - doc/ cleaned up
335 - enhancements in doc on filters 
336 - bootcd-aware GetBootMedium merged from onelab
337
338 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
339 - checkpoint while the new myplc-docs package is underway
340 - bugfix: GetSlivers & conf files
341 - doc: removed target files 
342
343 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
344 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
345 - the non-deleted fields were index, resulting in massivly slow queries.
346
347
348 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
349 - plcsh: better handling of options when running as a shell script
350 - getbootmedium exports compute_key
351 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
352
353 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
354 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
355 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
356
357 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
358 - refresh peer script to use a month-dependent logfile
359 - tracking the starting point for UniPi integration of the dummynet boxes
360
361 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
362 - plcsh adds its own path to sys.path
363 - fix so GetNodes can be called from a Node
364
365 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
366 - Initial build.
367
368 %define module_current_branch 4.3