Setting tag plcapi-5.0-17
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 17
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 # mod_wsgi will replace mod_python when we are ready
38 Requires: mod_wsgi
39 Requires: mod_ssl
40 Requires: SOAPpy
41 Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50
51 ### avoid having yum complain about updates, as stuff is moving around
52 # plc.d/api
53 Conflicts: MyPLC <= 4.3
54
55 # We use psycopg2
56 #
57 # but we don't need to rebuild it as we depend on distro's packages - baris
58 # BuildRequires: postgresql-devel
59
60 # Standard xmlrpc.so that ships with PHP does not marshal NULL
61 BuildRequires: php-devel
62 Obsoletes: php-xmlrpc
63 Provides: php-xmlrpc
64
65 # PostgreSQL and SOAPpy are necessary to run the API server, but not
66 # plcsh. Since the only supported method of running the server is via
67 # MyPLC anyway, don't be so stringent about binary requirements, in
68 # case people want to install this package just for plcsh.
69 # Requires: postgresql-server, SOAPpy
70 AutoReqProv: no
71
72 %description
73 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
74 PlanetLab Central (PLC) database. The API may be accessed directly via
75 the Python shell program plcsh, through a toy standalone server, or
76 through Apache mod_python.
77
78 %prep
79 %setup -q
80
81 %build
82 # python-pycurl and python-psycopg2 avail. from fedora 5
83 # we used to ship our own version of psycopg2 and pycurl, for fedora4
84 # starting with 4.3, support for these two modules is taken out
85
86 # Build __init__.py metafiles and PHP API. 
87 %{__make} %{?_smp_mflags}
88 %{__make} -C wsdl
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
93
94 # Install shell symlink
95 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
96 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
97
98 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
99 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
100 ; Enable xmlrpc extension module
101 extension=xmlrpc.so
102 EOF
103
104 # Install initscripts
105 echo "* Installing initscripts"
106 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
107 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
108
109 # Install db-config.d files
110 echo "* Installing db-config.d files"
111 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
112 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
113 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
114
115 # Install wsdl
116 echo "* Installing wsdl"
117 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
118
119 # Install omf_slicemgr.py
120 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
121 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
122 mkdir -p $RPM_BUILD_ROOT/var/log/omf
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %define php_extension_dir %(php-config --extension-dir)
128
129 %files
130 %defattr(-,root,root,-)
131 %dir %{_datadir}/plc_api
132 %dir /var/log/omf/
133 %{_datadir}/plc_api/*
134 %{_bindir}/plcsh
135 %{php_extension_dir}/xmlrpc.so
136 %{_sysconfdir}/php.d/xmlrpc.ini
137 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
138 /etc/plc.d
139 /etc/planetlab/db-config.d
140 /var/www/html/wsdl/plcapi.wsdl
141 /usr/bin/omf_slicemgr.py*
142 /usr/bin/reset_xmpp_pubsub_nodes.py*
143
144
145 %changelog
146 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
147 - RefreshPeer is able to cope with 2 peers running different releases of the api
148 - DeletePerson can be used on duplicates
149 - first appearance of ModPythonJson.py
150
151 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
152 - set accessors return the new value
153 - tweaks in the pubsub groups management
154
155 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
156 - convert hostnames to lower case and use ILIKE instead of LIKE
157
158 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
159 - use hrn in pubsub groups
160
161 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
162 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
163 - - OMF fixes
164
165 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
166 - automatically set vsys tag for omf controlled slices
167
168 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
169 - addition of the 'ssh_key' slice tag
170 - first draft of the LDAP interface
171
172 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
173 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
174 - and readable through GetLeaseGranularity
175 - GetSlivers to expose reservation_policy and lease_granularity
176 - GetBootMedium fixed for reservable nodes
177 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
178 - new Apache mod_wsgi python interface
179
180 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
181 - the leases system
182
183 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
184 - previous tag had gone wrong
185
186 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
187 - fix pubsub hostname
188
189 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
190 - tweaks for the omf support (xmpp groups and RC-controlled slices)
191 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
192 - GetNodeFlavour exposes fcdistro
193
194 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
195 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
196
197 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
198 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
199 - pyaspect hooks allow to  maintain the namespace xmpp groups
200 - new omf_slicemgr is a proxy to xmpp, used by these hooks
201 - nodes have their hrn exposed in the 'hrn' tag
202 - node hrn exposed in GetSlivers, as well as the overall xmpp config
203 - system slice 'drl' gets created by db-config
204 - daniel's changes to Filter for supporting wildcards in lists
205 - AddSliceTag consistency check tweaked
206
207 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
208 - major cleanup
209 - get rid of all 4.2-related legacy code
210 - reset the migrations code, planetlab5.sql somes with (5,100)
211 - uses hashlib module when available
212
213 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
214 - first working version of 5.0:
215 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
216 - nodefamily is 3-fold with pldistro-fcdistro-arch
217 - site and person tags
218 - new methods GetSliceFamily and GetNodeFlavour
219 - deprecated the dummynet stuff that were for the external dummyboxes
220 - tags definition : more consistency between db-config scripts and accessors
221 - (get accessor to create the tag type too if absent)
222 - logging an event for AddSliceToNodes
223
224 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
225 - support for fedora 12
226 - fix subtle bug in filtering with ] and quotes
227
228 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
229 - * patch for php-5.3 (the one in f12)
230 - * validate email addresses with regex
231 - * add PersonTags and SiteTags
232 - * add additional accessors for node tags (kvariant, serial, ..)
233
234 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
235 - Redacting password, session, and authstring values from the event log.
236
237 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
238 - let AddSite set ext_consortium_id - required for the poorman registration pages
239 - drop version constraint on Requires: postgresql-python
240 - don't log system calls nor ReportRunLevel
241
242 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
243 - Fix requires for CentOS.
244
245 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
246 - Require postgresql 8.2 (for array operators && and @>)
247
248 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
249 - Filter now supports the | and & features to match in sequence values
250 - bugfix in the postgresql wrapper for sequence filter values
251 - reviewed GetSlivers to export admin keys more efficiently
252 - fix checking roles in UpdateSliceTag
253
254 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
255 - - Some typos in the documentation were fixed.
256 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
257 - to the tag's min_role_id.
258
259 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
260
261 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
262 - Ongoing work to add upcalls, using new SFA class
263 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
264 - reviewed type-checking for the 3 taggable classes node-interface-slice
265 - cleanup ald dummynet stuff
266 - expose the 'extensions' accessors to the API
267 - tweaked checks in AddSliceTag
268 - GetPersons exposes roles by default
269 - bugfix in ReportRunLevel for non-string levels
270 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
271
272 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
273 - new BindObjectToPeer method for sfa
274 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
275
276 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
277 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
278 - reportrunlevel logs its calls only when run_level changes
279 - pycurl more robust wrt to xmlrpclib.Transport
280
281 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
282 - produce a wsdl interface
283 - bugfix in getbootmedium for nodes with interface tags
284
285 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
286 - bugfix for some rare pattern-based filters
287
288 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
289 - improvements in the 4.2 legacy layer
290
291 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
292 - bugfix required for slice tags set on nodegroups
293
294 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
295 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
296
297 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
298 - more powerful legacy layer with 4.2
299
300 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
301 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
302 - migration script has an option for running interactively
303
304 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
305 - skips already added entries
306
307 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
308 - yet another set of fixes for external dummynet boxes
309
310 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
311 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
312 - and tmp file is cleaned up
313
314 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
315 - restore missing ResolveSlices
316
317 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
318 - new method GetDummyBoxMedium
319
320 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
321 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
322
323 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
324 - support for external dummynet boxes back in 4.3 - first draft
325
326 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
327 - fixes for smooth federation between 4.2 and 4.3
328 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
329
330 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
331 - support for BootCD variants (GetBootMedium ['variant:centos5'])
332 - fix corner case with filters like {'~slice_id':[]}
333 - fix transaction leak that caused the db connections pool to exhaust
334 - properly expose all methods, including Legacy/, and not only Methods/
335
336 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
337 - renumbered as 4.3
338 - nodes have new fields run_level (in addition to boot_state) and verified
339 - tweaked migration from 4.2
340 - tuned rpm dependencies
341 - doc generation more explicit about errors like missing python modules
342 - removed obsolete method GetSlicesMD5
343
344 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
345 - unified all tags
346 - renamed interface settings into interface tags and slice attributes into slice tags
347 - nodes have a node_type
348 - various changes on the way to 4.3
349
350 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
351 - Checkpointing : this version still has interface settings and slice attributes
352
353 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
354 - first iteration with taggable nodes/interfaces/slices
355 - embryo for ilinks
356 - cleaned up boot states
357 - migration script moslty complete
358
359 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
360 - fixed doc build by locating locally installed DTDs at build-time
361
362 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
363 - no more doc packaged outside of myplc-docs - doc/ cleaned up
364 - enhancements in doc on filters 
365 - bootcd-aware GetBootMedium merged from onelab
366
367 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
368 - checkpoint while the new myplc-docs package is underway
369 - bugfix: GetSlivers & conf files
370 - doc: removed target files 
371
372 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
373 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
374 - the non-deleted fields were index, resulting in massivly slow queries.
375
376
377 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
378 - plcsh: better handling of options when running as a shell script
379 - getbootmedium exports compute_key
380 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
381
382 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
383 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
384 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
385
386 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
387 - refresh peer script to use a month-dependent logfile
388 - tracking the starting point for UniPi integration of the dummynet boxes
389
390 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
391 - plcsh adds its own path to sys.path
392 - fix so GetNodes can be called from a Node
393
394 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
395 - Initial build.
396
397 %define module_current_branch 4.3