renaming shortcut into accessor
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 0
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31
32 # We use psycopg2
33 BuildRequires: postgresql-devel
34
35 # Standard xmlrpc.so that ships with PHP does not marshal NULL
36 BuildRequires: php-devel
37 Obsoletes: php-xmlrpc
38 Provides: php-xmlrpc
39
40 # PostgreSQL and SOAPpy are necessary to run the API server, but not
41 # plcsh. Since the only supported method of running the server is via
42 # MyPLC anyway, don't be so stringent about binary requirements, in
43 # case people want to install this package just for plcsh.
44 # Requires: postgresql-server, SOAPpy
45 AutoReqProv: no
46
47 %description
48 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
49 PlanetLab Central (PLC) database. The API may be accessed directly via
50 the Python shell program plcsh, through a toy standalone server, or
51 through Apache mod_python.
52
53 %prep
54 %setup -q
55
56 %build
57 # python-pycurl and python-psycopg2 avail. from fedora 5
58 # we used to ship our own version of psycopg2 and pycurl, for fedora4
59 # starting with 5.0, support for these two modules is taken out
60
61 # Build __init__.py metafiles and PHP API. 
62 %{__make} %{?_smp_mflags}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
67
68 # Install shell symlink
69 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
70 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
71
72 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
73 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
74 ; Enable xmlrpc extension module
75 extension=xmlrpc.so
76 EOF
77
78 %post
79 # create local shortcuts if not present (mentioned in PLC/Shortcuts/__init__.py)
80 [ -f %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py ] || cp %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py.in %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %define php_extension_dir %(php-config --extension-dir)
86
87 %files
88 %defattr(-,root,root,-)
89 %dir %{_datadir}/plc_api
90 %{_datadir}/plc_api/*
91 %{_bindir}/plcsh
92 %{php_extension_dir}/xmlrpc.so
93 %{_sysconfdir}/php.d/xmlrpc.ini
94
95 %changelog
96 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
97 - fixed doc build by locating locally installed DTDs at build-time
98
99 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
100 - no more doc packaged outside of myplc-docs - doc/ cleaned up
101 - enhancements in doc on filters 
102 - bootcd-aware GetBootMedium merged from onelab
103
104 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
105 - checkpoint while the new myplc-docs package is underway
106 - bugfix: GetSlivers & conf files
107 - doc: removed target files 
108
109 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
110 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
111 - the non-deleted fields were index, resulting in massivly slow queries.
112
113
114 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
115 - plcsh: better handling of options when running as a shell script
116 - getbootmedium exports compute_key
117 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
118
119 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
120 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
121 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
122
123 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
124 - refresh peer script to use a month-dependent logfile
125 - tracking the starting point for UniPi integration of the dummynet boxes
126
127 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
128 - plcsh adds its own path to sys.path
129 - fix so GetNodes can be called from a Node
130
131 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
132 - Initial build.
133
134 %define module_current_branch 4.2