Setting tag plcapi-5.0-13
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 13
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 # mod_wsgi will replace mod_python when we are ready
38 Requires: mod_wsgi
39 Requires: mod_ssl
40 Requires: SOAPpy
41 # for the RebootNodeWithPCU method
42 Requires: pcucontrol >= 1.0-6
43 # for OMF integration
44 Requires: pyaspects >= 0.4
45 Requires: python-twisted-words
46 Requires: python-twisted-web
47 # ldap
48 Requires: python-ldap
49
50 ### avoid having yum complain about updates, as stuff is moving around
51 # plc.d/api
52 Conflicts: MyPLC <= 4.3
53
54 # We use psycopg2
55 #
56 # but we don't need to rebuild it as we depend on distro's packages - baris
57 # BuildRequires: postgresql-devel
58
59 # Standard xmlrpc.so that ships with PHP does not marshal NULL
60 BuildRequires: php-devel
61 Obsoletes: php-xmlrpc
62 Provides: php-xmlrpc
63
64 # PostgreSQL and SOAPpy are necessary to run the API server, but not
65 # plcsh. Since the only supported method of running the server is via
66 # MyPLC anyway, don't be so stringent about binary requirements, in
67 # case people want to install this package just for plcsh.
68 # Requires: postgresql-server, SOAPpy
69 AutoReqProv: no
70
71 %description
72 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
73 PlanetLab Central (PLC) database. The API may be accessed directly via
74 the Python shell program plcsh, through a toy standalone server, or
75 through Apache mod_python.
76
77 %prep
78 %setup -q
79
80 %build
81 # python-pycurl and python-psycopg2 avail. from fedora 5
82 # we used to ship our own version of psycopg2 and pycurl, for fedora4
83 # starting with 4.3, support for these two modules is taken out
84
85 # Build __init__.py metafiles and PHP API. 
86 %{__make} %{?_smp_mflags}
87 %{__make} -C wsdl
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
92
93 # Install shell symlink
94 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
95 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
96
97 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
98 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
99 ; Enable xmlrpc extension module
100 extension=xmlrpc.so
101 EOF
102
103 # Install initscripts
104 echo "* Installing initscripts"
105 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
106 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
107
108 # Install db-config.d files
109 echo "* Installing db-config.d files"
110 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
111 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
112 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
113
114 # Install wsdl
115 echo "* Installing wsdl"
116 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
117
118 # Install omf_slicemgr.py
119 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
120 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
121 mkdir -p $RPM_BUILD_ROOT/var/log/omf
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %define php_extension_dir %(php-config --extension-dir)
127
128 %files
129 %defattr(-,root,root,-)
130 %dir %{_datadir}/plc_api
131 %dir /var/log/omf/
132 %{_datadir}/plc_api/*
133 %{_bindir}/plcsh
134 %{php_extension_dir}/xmlrpc.so
135 %{_sysconfdir}/php.d/xmlrpc.ini
136 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
137 /etc/plc.d
138 /etc/planetlab/db-config.d
139 /var/www/html/wsdl/plcapi.wsdl
140 /usr/bin/omf_slicemgr.py*
141 /usr/bin/reset_xmpp_pubsub_nodes.py*
142
143
144 %changelog
145 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
146 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
147 - - OMF fixes
148
149 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
150 - automatically set vsys tag for omf controlled slices
151
152 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
153 - addition of the 'ssh_key' slice tag
154 - first draft of the LDAP interface
155
156 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
157 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
158 - and readable through GetLeaseGranularity
159 - GetSlivers to expose reservation_policy and lease_granularity
160 - GetBootMedium fixed for reservable nodes
161 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
162 - new Apache mod_wsgi python interface
163
164 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
165 - the leases system
166
167 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
168 - previous tag had gone wrong
169
170 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
171 - fix pubsub hostname
172
173 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
174 - tweaks for the omf support (xmpp groups and RC-controlled slices)
175 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
176 - GetNodeFlavour exposes fcdistro
177
178 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
179 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
180
181 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
182 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
183 - pyaspect hooks allow to  maintain the namespace xmpp groups
184 - new omf_slicemgr is a proxy to xmpp, used by these hooks
185 - nodes have their hrn exposed in the 'hrn' tag
186 - node hrn exposed in GetSlivers, as well as the overall xmpp config
187 - system slice 'drl' gets created by db-config
188 - daniel's changes to Filter for supporting wildcards in lists
189 - AddSliceTag consistency check tweaked
190
191 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
192 - major cleanup
193 - get rid of all 4.2-related legacy code
194 - reset the migrations code, planetlab5.sql somes with (5,100)
195 - uses hashlib module when available
196
197 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
198 - first working version of 5.0:
199 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
200 - nodefamily is 3-fold with pldistro-fcdistro-arch
201 - site and person tags
202 - new methods GetSliceFamily and GetNodeFlavour
203 - deprecated the dummynet stuff that were for the external dummyboxes
204 - tags definition : more consistency between db-config scripts and accessors
205 - (get accessor to create the tag type too if absent)
206 - logging an event for AddSliceToNodes
207
208 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
209 - support for fedora 12
210 - fix subtle bug in filtering with ] and quotes
211
212 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
213 - * patch for php-5.3 (the one in f12)
214 - * validate email addresses with regex
215 - * add PersonTags and SiteTags
216 - * add additional accessors for node tags (kvariant, serial, ..)
217
218 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
219 - Redacting password, session, and authstring values from the event log.
220
221 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
222 - let AddSite set ext_consortium_id - required for the poorman registration pages
223 - drop version constraint on Requires: postgresql-python
224 - don't log system calls nor ReportRunLevel
225
226 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
227 - Fix requires for CentOS.
228
229 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
230 - Require postgresql 8.2 (for array operators && and @>)
231
232 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
233 - Filter now supports the | and & features to match in sequence values
234 - bugfix in the postgresql wrapper for sequence filter values
235 - reviewed GetSlivers to export admin keys more efficiently
236 - fix checking roles in UpdateSliceTag
237
238 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
239 - - Some typos in the documentation were fixed.
240 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
241 - to the tag's min_role_id.
242
243 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
244
245 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
246 - Ongoing work to add upcalls, using new SFA class
247 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
248 - reviewed type-checking for the 3 taggable classes node-interface-slice
249 - cleanup ald dummynet stuff
250 - expose the 'extensions' accessors to the API
251 - tweaked checks in AddSliceTag
252 - GetPersons exposes roles by default
253 - bugfix in ReportRunLevel for non-string levels
254 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
255
256 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
257 - new BindObjectToPeer method for sfa
258 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
259
260 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
261 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
262 - reportrunlevel logs its calls only when run_level changes
263 - pycurl more robust wrt to xmlrpclib.Transport
264
265 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
266 - produce a wsdl interface
267 - bugfix in getbootmedium for nodes with interface tags
268
269 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
270 - bugfix for some rare pattern-based filters
271
272 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
273 - improvements in the 4.2 legacy layer
274
275 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
276 - bugfix required for slice tags set on nodegroups
277
278 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
279 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
280
281 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
282 - more powerful legacy layer with 4.2
283
284 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
285 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
286 - migration script has an option for running interactively
287
288 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
289 - skips already added entries
290
291 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
292 - yet another set of fixes for external dummynet boxes
293
294 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
295 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
296 - and tmp file is cleaned up
297
298 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
299 - restore missing ResolveSlices
300
301 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
302 - new method GetDummyBoxMedium
303
304 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
305 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
306
307 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
308 - support for external dummynet boxes back in 4.3 - first draft
309
310 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
311 - fixes for smooth federation between 4.2 and 4.3
312 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
313
314 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
315 - support for BootCD variants (GetBootMedium ['variant:centos5'])
316 - fix corner case with filters like {'~slice_id':[]}
317 - fix transaction leak that caused the db connections pool to exhaust
318 - properly expose all methods, including Legacy/, and not only Methods/
319
320 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
321 - renumbered as 4.3
322 - nodes have new fields run_level (in addition to boot_state) and verified
323 - tweaked migration from 4.2
324 - tuned rpm dependencies
325 - doc generation more explicit about errors like missing python modules
326 - removed obsolete method GetSlicesMD5
327
328 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
329 - unified all tags
330 - renamed interface settings into interface tags and slice attributes into slice tags
331 - nodes have a node_type
332 - various changes on the way to 4.3
333
334 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
335 - Checkpointing : this version still has interface settings and slice attributes
336
337 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
338 - first iteration with taggable nodes/interfaces/slices
339 - embryo for ilinks
340 - cleaned up boot states
341 - migration script moslty complete
342
343 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
344 - fixed doc build by locating locally installed DTDs at build-time
345
346 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
347 - no more doc packaged outside of myplc-docs - doc/ cleaned up
348 - enhancements in doc on filters 
349 - bootcd-aware GetBootMedium merged from onelab
350
351 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
352 - checkpoint while the new myplc-docs package is underway
353 - bugfix: GetSlivers & conf files
354 - doc: removed target files 
355
356 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
357 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
358 - the non-deleted fields were index, resulting in massivly slow queries.
359
360
361 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
362 - plcsh: better handling of options when running as a shell script
363 - getbootmedium exports compute_key
364 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
365
366 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
367 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
368 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
369
370 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
371 - refresh peer script to use a month-dependent logfile
372 - tracking the starting point for UniPi integration of the dummynet boxes
373
374 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
375 - plcsh adds its own path to sys.path
376 - fix so GetNodes can be called from a Node
377
378 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
379 - Initial build.
380
381 %define module_current_branch 4.3