cleanup
[plcapi.git] / PLCAPI.spec
1 %define name PLCAPI
2 %define version 5.1
3 %define taglevel 3
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Nova Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: python-pycurl
26 Requires: httpd
27 Requires: python-gevent
28 # mod_wsgi will replace mod_python when we are ready
29 Requires: mod_wsgi
30 Requires: mod_ssl
31 Requires: SOAPpy
32 Requires: python-simplejson
33 # for the RebootNodeWithPCU method
34 Requires: pcucontrol >= 1.0-6
35 # for OMF integration
36 Requires: pyaspects >= 0.4
37 Requires: python-twisted-words
38 Requires: python-twisted-web
39 # ldap
40 Requires: python-ldap
41 # for memcache
42 Requires: python-memcached
43 Requires: memcached
44 Requires: Django
45 ### avoid having yum complain about updates, as stuff is moving around
46 # plc.d/api
47
48 # Standard xmlrpc.so that ships with PHP does not marshal NULL
49 BuildRequires: php-devel PyXML python-simplejson
50 Obsoletes: php-xmlrpc
51 Provides: php-xmlrpc
52
53 # PostgreSQL and SOAPpy are necessary to run the API server, but not
54 # plcsh. Since the only supported method of running the server is via
55 # MyPLC anyway, don't be so stringent about binary requirements, in
56 # case people want to install this package just for plcsh.
57 # Requires: postgresql-server, SOAPpy
58 AutoReqProv: no
59
60 %description
61 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
62 PlanetLab Central (PLC) database. The API may be accessed directly via
63 the Python shell program plcsh, through a toy standalone server, or
64 through Apache mod_python.
65
66 %prep
67 %setup -q
68
69 %build
70 # python-pycurl and python-psycopg2 avail. from fedora 5
71 # we used to ship our own version of psycopg2 and pycurl, for fedora4
72 # starting with 4.3, support for these two modules is taken out
73
74 # Build __init__.py metafiles and PHP API. 
75 %{__make} %{?_smp_mflags}
76 %{__make} -C wsdl
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
81
82 # Install shell symlink
83 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
84 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
85
86 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
87 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
88 ; Enable xmlrpc extension module
89 extension=xmlrpc.so
90 EOF
91
92 # Install initscripts
93 echo "* Installing initscripts"
94 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
95 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
96
97 # Install db-config.d files
98 echo "* Installing db-config.d files"
99 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
100 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
101 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
102
103 # Install wsdl
104 echo "* Installing wsdl"
105 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
106
107 # Install omf_slicemgr.py
108 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
109 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
110 mkdir -p $RPM_BUILD_ROOT/var/log/omf
111
112 # Install ratelimit log
113 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
114 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %define php_extension_dir %(php-config --extension-dir)
120
121 %files
122 %defattr(-,root,root,-)
123 %dir %{_datadir}/plc_api
124 %dir /var/log/omf/
125 %{_datadir}/plc_api/*
126 %{_bindir}/plcsh
127 %{php_extension_dir}/xmlrpc.so
128 %{_sysconfdir}/php.d/xmlrpc.ini
129 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
130 /etc/plc.d
131 /etc/planetlab/db-config.d
132 /var/www/html/wsdl/plcapi.wsdl
133 /usr/bin/omf_slicemgr.py*
134 /usr/bin/reset_xmpp_pubsub_nodes.py*
135 /var/log/plc_api_ratelimit.log
136
137
138 %changelog
139 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
140 - fixed imports for tags management with sites and persons
141 - add predefined 'cpu_freezable' tag
142
143 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
144 - tweaks in interface initialization
145 - has 'vsys_vnet' as a predefined tagtype
146 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
147 - bugfix: GetSlivers & nodegroups
148 - bugfix: in jabber groups management
149
150 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
151 - fix gpg-authentication for Persons (thanks Jordan)
152 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
153 - ip address/network check: v4 or v6
154 - customized DB Message survive upgrade
155 - make sync works in lxc-hosted tests
156 - no svn keywords anymore
157
158 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
159 - fix sorting for methods list in docs
160 - untested but needed tweak for postgres startup in f16
161
162 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
163 - tweaks in postgresql setup - in line with sfa
164
165 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
166 - slight tweaks in Persons.py
167
168 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
169 - GetSession has support for more than one day sessions
170 - reset_xmpp_pubsub_nodes is much more efficient
171 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
172 - bugfix - deleting a person in the middle of the signup process
173
174 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
175 - ratelimit aspects
176 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
177 - requires Django for cache_utils
178 - attempt to expose 'pldistro' to sfa
179 - last_time_spent_online, last_time_spent_offline: new fields in Node
180 - new slice tags 'isolate_loopback' and 'cpu_cores'
181 - refresh-peer federation logs dump exceptions
182 - modpython logs have a timestamp
183 - more verbose/accurate php error reporting
184 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
185 - AddNode, UpdateNode: manage tags directly rather than through another method
186 - BootUpdateNode: only update once
187 - GetPersons: techs can access the list of persons on their site
188 - GetSlices and GetSliceTags: techs can see slices on their nodes
189 - GetSlivers: isrootonsite tag; cacheable
190
191 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
192 - rename initscript_body into initscript_code
193
194 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
195 - new initscript_body tag
196
197 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
198 - working draft for GetSliceSshKeys
199
200 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
201 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
202 - (this is for people who cancel their download)
203
204 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
205 - fix db-config sequence : accessors step now merged in, and occurs at the right time
206 - db-config also more robust
207 - no more explicit 'accessors' step in plc.d
208
209 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
210 - session auth: do *not* delete session when node runs a method that does not have 'node' role
211 - session auth: remove support for bootonce in old boot CDs
212 - give a reason when caller_may_write_slice_tag fails
213 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
214
215 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
216 - SetSliceVref needed the node role
217 - protect GetSliceFamily
218 - Fix bugs in tag authorizations
219
220 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
221 - altered checking of optional fields in Interfaces
222 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
223 - has pyxml and python-simplejson as new deps
224
225 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
226 - tweak doc extraction for fedora14
227
228 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
229 - builtin accessors for the myslice page
230 - Get{Node,Interface}Tags allowed to techs
231 - tweak in ratelimitaspect.py
232
233 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
234 - add admin role to accessor-related tags (arch, {fc,pl}distro)
235
236 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
237 - bugfix in {Update,Delete}PersonTag
238 - updated xml doc for filters, accessors and tagtypes
239 - more explicit msg in case of missing roles
240 - improvements in ratelimitaspects.py
241
242 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
243 - fix the roles for ssh_key and hmac tags
244
245 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
246 - tag permissions system based on roles and not min_role_ids
247 - accessors simplified accordingly (no more min_role_id)
248 - new methods AddRoleToTagType and DeleteRoleFromTagType
249 - accessor-related tagtypes are created sooner, and enforced
250 - cleaned up redundancy between db-config.d and accessors
251
252 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
253 - fix RefreshPeer that was not working in 5.0-17
254
255 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
256 - RefreshPeer is able to cope with 2 peers running different releases of the api
257 - DeletePerson can be used on duplicates
258 - first appearance of ModPythonJson.py
259
260 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
261 - set accessors return the new value
262 - tweaks in the pubsub groups management
263
264 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
265 - convert hostnames to lower case and use ILIKE instead of LIKE
266
267 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
268 - use hrn in pubsub groups
269
270 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
271 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
272 - - OMF fixes
273
274 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
275 - automatically set vsys tag for omf controlled slices
276
277 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
278 - addition of the 'ssh_key' slice tag
279 - first draft of the LDAP interface
280
281 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
282 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
283 - and readable through GetLeaseGranularity
284 - GetSlivers to expose reservation_policy and lease_granularity
285 - GetBootMedium fixed for reservable nodes
286 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
287 - new Apache mod_wsgi python interface
288
289 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
290 - the leases system
291
292 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
293 - previous tag had gone wrong
294
295 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
296 - fix pubsub hostname
297
298 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
299 - tweaks for the omf support (xmpp groups and RC-controlled slices)
300 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
301 - GetNodeFlavour exposes fcdistro
302
303 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
304 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
305
306 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
307 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
308 - pyaspect hooks allow to  maintain the namespace xmpp groups
309 - new omf_slicemgr is a proxy to xmpp, used by these hooks
310 - nodes have their hrn exposed in the 'hrn' tag
311 - node hrn exposed in GetSlivers, as well as the overall xmpp config
312 - system slice 'drl' gets created by db-config
313 - daniel's changes to Filter for supporting wildcards in lists
314 - AddSliceTag consistency check tweaked
315
316 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
317 - major cleanup
318 - get rid of all 4.2-related legacy code
319 - reset the migrations code, planetlab5.sql somes with (5,100)
320 - uses hashlib module when available
321
322 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
323 - first working version of 5.0:
324 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
325 - nodefamily is 3-fold with pldistro-fcdistro-arch
326 - site and person tags
327 - new methods GetSliceFamily and GetNodeFlavour
328 - deprecated the dummynet stuff that were for the external dummyboxes
329 - tags definition : more consistency between db-config scripts and accessors
330 - (get accessor to create the tag type too if absent)
331 - logging an event for AddSliceToNodes
332
333 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
334 - support for fedora 12
335 - fix subtle bug in filtering with ] and quotes
336
337 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
338 - * patch for php-5.3 (the one in f12)
339 - * validate email addresses with regex
340 - * add PersonTags and SiteTags
341 - * add additional accessors for node tags (kvariant, serial, ..)
342
343 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
344 - Redacting password, session, and authstring values from the event log.
345
346 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
347 - let AddSite set ext_consortium_id - required for the poorman registration pages
348 - drop version constraint on Requires: postgresql-python
349 - don't log system calls nor ReportRunLevel
350
351 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
352 - Fix requires for CentOS.
353
354 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
355 - Require postgresql 8.2 (for array operators && and @>)
356
357 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
358 - Filter now supports the | and & features to match in sequence values
359 - bugfix in the postgresql wrapper for sequence filter values
360 - reviewed GetSlivers to export admin keys more efficiently
361 - fix checking roles in UpdateSliceTag
362
363 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
364 - - Some typos in the documentation were fixed.
365 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
366 - to the tag's min_role_id.
367
368 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
369
370 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
371 - Ongoing work to add upcalls, using new SFA class
372 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
373 - reviewed type-checking for the 3 taggable classes node-interface-slice
374 - cleanup ald dummynet stuff
375 - expose the 'extensions' accessors to the API
376 - tweaked checks in AddSliceTag
377 - GetPersons exposes roles by default
378 - bugfix in ReportRunLevel for non-string levels
379 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
380
381 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
382 - new BindObjectToPeer method for sfa
383 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
384
385 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
386 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
387 - reportrunlevel logs its calls only when run_level changes
388 - pycurl more robust wrt to xmlrpclib.Transport
389
390 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
391 - produce a wsdl interface
392 - bugfix in getbootmedium for nodes with interface tags
393
394 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
395 - bugfix for some rare pattern-based filters
396
397 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
398 - improvements in the 4.2 legacy layer
399
400 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
401 - bugfix required for slice tags set on nodegroups
402
403 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
404 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
405
406 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
407 - more powerful legacy layer with 4.2
408
409 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
410 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
411 - migration script has an option for running interactively
412
413 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
414 - skips already added entries
415
416 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
417 - yet another set of fixes for external dummynet boxes
418
419 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
420 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
421 - and tmp file is cleaned up
422
423 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
424 - restore missing ResolveSlices
425
426 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
427 - new method GetDummyBoxMedium
428
429 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
430 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
431
432 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
433 - support for external dummynet boxes back in 4.3 - first draft
434
435 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
436 - fixes for smooth federation between 4.2 and 4.3
437 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
438
439 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
440 - support for BootCD variants (GetBootMedium ['variant:centos5'])
441 - fix corner case with filters like {'~slice_id':[]}
442 - fix transaction leak that caused the db connections pool to exhaust
443 - properly expose all methods, including Legacy/, and not only Methods/
444
445 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
446 - renumbered as 4.3
447 - nodes have new fields run_level (in addition to boot_state) and verified
448 - tweaked migration from 4.2
449 - tuned rpm dependencies
450 - doc generation more explicit about errors like missing python modules
451 - removed obsolete method GetSlicesMD5
452
453 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
454 - unified all tags
455 - renamed interface settings into interface tags and slice attributes into slice tags
456 - nodes have a node_type
457 - various changes on the way to 4.3
458
459 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
460 - Checkpointing : this version still has interface settings and slice attributes
461
462 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
463 - first iteration with taggable nodes/interfaces/slices
464 - embryo for ilinks
465 - cleaned up boot states
466 - migration script moslty complete
467
468 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
469 - fixed doc build by locating locally installed DTDs at build-time
470
471 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
472 - no more doc packaged outside of myplc-docs - doc/ cleaned up
473 - enhancements in doc on filters 
474 - bootcd-aware GetBootMedium merged from onelab
475
476 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
477 - checkpoint while the new myplc-docs package is underway
478 - bugfix: GetSlivers & conf files
479 - doc: removed target files 
480
481 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
482 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
483 - the non-deleted fields were index, resulting in massivly slow queries.
484
485
486 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
487 - plcsh: better handling of options when running as a shell script
488 - getbootmedium exports compute_key
489 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
490
491 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
492 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
493 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
494
495 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
496 - refresh peer script to use a month-dependent logfile
497 - tracking the starting point for UniPi integration of the dummynet boxes
498
499 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
500 - plcsh adds its own path to sys.path
501 - fix so GetNodes can be called from a Node
502
503 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
504 - Initial build.
505
506 %define module_current_branch 4.3