Tagging module PLCAPI - PLCAPI-4.3-20
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 4.3
9 %define taglevel 20
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql postgresql-server postgresql-python
32 Requires: python-psycopg2
33 Requires: python-pycurl
34 Requires: httpd
35 Requires: mod_python
36 Requires: mod_ssl
37 Requires: SOAPpy
38
39 # We use psycopg2
40 BuildRequires: postgresql-devel
41
42 # Standard xmlrpc.so that ships with PHP does not marshal NULL
43 BuildRequires: php-devel
44 Obsoletes: php-xmlrpc
45 Provides: php-xmlrpc
46
47 # PostgreSQL and SOAPpy are necessary to run the API server, but not
48 # plcsh. Since the only supported method of running the server is via
49 # MyPLC anyway, don't be so stringent about binary requirements, in
50 # case people want to install this package just for plcsh.
51 # Requires: postgresql-server, SOAPpy
52 AutoReqProv: no
53
54 %description
55 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
56 PlanetLab Central (PLC) database. The API may be accessed directly via
57 the Python shell program plcsh, through a toy standalone server, or
58 through Apache mod_python.
59
60 %prep
61 %setup -q
62
63 %build
64 # python-pycurl and python-psycopg2 avail. from fedora 5
65 # we used to ship our own version of psycopg2 and pycurl, for fedora4
66 # starting with 4.3, support for these two modules is taken out
67
68 # Build __init__.py metafiles and PHP API. 
69 %{__make} %{?_smp_mflags}
70 %{__make} -C wsdl
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
75 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
76
77 # Install shell symlink
78 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
79 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
80
81 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
82 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
83 ; Enable xmlrpc extension module
84 extension=xmlrpc.so
85 EOF
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %define php_extension_dir %(php-config --extension-dir)
91
92 %files
93 %defattr(-,root,root,-)
94 %dir %{_datadir}/plc_api
95 %{_datadir}/plc_api/*
96 %{_bindir}/plcsh
97 %{php_extension_dir}/xmlrpc.so
98 %{_sysconfdir}/php.d/xmlrpc.ini
99 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
100 /var/www/html/wsdl/plcapi.wsdl
101
102 %changelog
103 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
104 - produce a wsdl interface
105 - bugfix in getbootmedium for nodes with interface tags
106
107 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
108 - bugfix for some rare pattern-based filters
109
110 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
111 - improvements in the 4.2 legacy layer
112
113 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
114 - bugfix required for slice tags set on nodegroups
115
116 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
117 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
118
119 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
120 - more powerful legacy layer with 4.2
121
122 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
123 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
124 - migration script has an option for running interactively
125
126 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
127 - skips already added entries
128
129 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
130 - yet another set of fixes for external dummynet boxes
131
132 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
133 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
134 - and tmp file is cleaned up
135
136 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
137 - restore missing ResolveSlices
138
139 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
140 - new method GetDummyBoxMedium
141
142 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
143 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
144
145 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
146 - support for external dummynet boxes back in 4.3 - first draft
147
148 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
149 - fixes for smooth federation between 4.2 and 4.3
150 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
151
152 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
153 - support for BootCD variants (GetBootMedium ['variant:centos5'])
154 - fix corner case with filters like {'~slice_id':[]}
155 - fix transaction leak that caused the db connections pool to exhaust
156 - properly expose all methods, including Legacy/, and not only Methods/
157
158 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
159 - renumbered as 4.3
160 - nodes have new fields run_level (in addition to boot_state) and verified
161 - tweaked migration from 4.2
162 - tuned rpm dependencies
163 - doc generation more explicit about errors like missing python modules
164 - removed obsolete method GetSlicesMD5
165
166 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
167 - unified all tags
168 - renamed interface settings into interface tags and slice attributes into slice tags
169 - nodes have a node_type
170 - various changes on the way to 4.3
171
172 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
173 - Checkpointing : this version still has interface settings and slice attributes
174
175 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
176 - first iteration with taggable nodes/interfaces/slices
177 - embryo for ilinks
178 - cleaned up boot states
179 - migration script moslty complete
180
181 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
182 - fixed doc build by locating locally installed DTDs at build-time
183
184 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
185 - no more doc packaged outside of myplc-docs - doc/ cleaned up
186 - enhancements in doc on filters 
187 - bootcd-aware GetBootMedium merged from onelab
188
189 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
190 - checkpoint while the new myplc-docs package is underway
191 - bugfix: GetSlivers & conf files
192 - doc: removed target files 
193
194 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
195 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
196 - the non-deleted fields were index, resulting in massivly slow queries.
197
198
199 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
200 - plcsh: better handling of options when running as a shell script
201 - getbootmedium exports compute_key
202 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
203
204 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
205 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
206 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
207
208 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
209 - refresh peer script to use a month-dependent logfile
210 - tracking the starting point for UniPi integration of the dummynet boxes
211
212 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
213 - plcsh adds its own path to sys.path
214 - fix so GetNodes can be called from a Node
215
216 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
217 - Initial build.
218
219 %define module_current_branch 4.2