Require postgresql 8.2 (for array operators && and @>)
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 4.3
9 %define taglevel 27
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2, postgresql-python >= 8.2
32 Requires: python-psycopg2
33 Requires: python-pycurl
34 Requires: httpd
35 Requires: mod_python
36 Requires: mod_ssl
37 Requires: SOAPpy
38
39 # We use psycopg2
40 BuildRequires: postgresql-devel
41
42 # Standard xmlrpc.so that ships with PHP does not marshal NULL
43 BuildRequires: php-devel
44 Obsoletes: php-xmlrpc
45 Provides: php-xmlrpc
46
47 # PostgreSQL and SOAPpy are necessary to run the API server, but not
48 # plcsh. Since the only supported method of running the server is via
49 # MyPLC anyway, don't be so stringent about binary requirements, in
50 # case people want to install this package just for plcsh.
51 # Requires: postgresql-server, SOAPpy
52 AutoReqProv: no
53
54 %description
55 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
56 PlanetLab Central (PLC) database. The API may be accessed directly via
57 the Python shell program plcsh, through a toy standalone server, or
58 through Apache mod_python.
59
60 %prep
61 %setup -q
62
63 %build
64 # python-pycurl and python-psycopg2 avail. from fedora 5
65 # we used to ship our own version of psycopg2 and pycurl, for fedora4
66 # starting with 4.3, support for these two modules is taken out
67
68 # Build __init__.py metafiles and PHP API. 
69 %{__make} %{?_smp_mflags}
70 %{__make} -C wsdl
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
75 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
76
77 # Install shell symlink
78 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
79 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
80
81 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
82 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
83 ; Enable xmlrpc extension module
84 extension=xmlrpc.so
85 EOF
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %define php_extension_dir %(php-config --extension-dir)
91
92 %files
93 %defattr(-,root,root,-)
94 %dir %{_datadir}/plc_api
95 %{_datadir}/plc_api/*
96 %{_bindir}/plcsh
97 %{php_extension_dir}/xmlrpc.so
98 %{_sysconfdir}/php.d/xmlrpc.ini
99 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
100 /var/www/html/wsdl/plcapi.wsdl
101
102 %changelog
103 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
104 - Require postgresql 8.2 (for array operators && and @>)
105
106 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
107 - Filter now supports the | and & features to match in sequence values
108 - bugfix in the postgresql wrapper for sequence filter values
109 - reviewed GetSlivers to export admin keys more efficiently
110 - fix checking roles in UpdateSliceTag
111
112 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
113 - - Some typos in the documentation were fixed.
114 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
115 - to the tag's min_role_id.
116
117 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
118
119 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
120 - Ongoing work to add upcalls, using new SFA class
121 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
122 - reviewed type-checking for the 3 taggable classes node-interface-slice
123 - cleanup ald dummynet stuff
124 - expose the 'extensions' accessors to the API
125 - tweaked checks in AddSliceTag
126 - GetPersons exposes roles by default
127 - bugfix in ReportRunLevel for non-string levels
128 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
129
130 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
131 - new BindObjectToPeer method for sfa
132 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
133
134 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
135 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
136 - reportrunlevel logs its calls only when run_level changes
137 - pycurl more robust wrt to xmlrpclib.Transport
138
139 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
140 - produce a wsdl interface
141 - bugfix in getbootmedium for nodes with interface tags
142
143 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
144 - bugfix for some rare pattern-based filters
145
146 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
147 - improvements in the 4.2 legacy layer
148
149 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
150 - bugfix required for slice tags set on nodegroups
151
152 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
153 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
154
155 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
156 - more powerful legacy layer with 4.2
157
158 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
159 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
160 - migration script has an option for running interactively
161
162 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
163 - skips already added entries
164
165 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
166 - yet another set of fixes for external dummynet boxes
167
168 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
169 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
170 - and tmp file is cleaned up
171
172 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
173 - restore missing ResolveSlices
174
175 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
176 - new method GetDummyBoxMedium
177
178 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
179 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
180
181 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
182 - support for external dummynet boxes back in 4.3 - first draft
183
184 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
185 - fixes for smooth federation between 4.2 and 4.3
186 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
187
188 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
189 - support for BootCD variants (GetBootMedium ['variant:centos5'])
190 - fix corner case with filters like {'~slice_id':[]}
191 - fix transaction leak that caused the db connections pool to exhaust
192 - properly expose all methods, including Legacy/, and not only Methods/
193
194 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
195 - renumbered as 4.3
196 - nodes have new fields run_level (in addition to boot_state) and verified
197 - tweaked migration from 4.2
198 - tuned rpm dependencies
199 - doc generation more explicit about errors like missing python modules
200 - removed obsolete method GetSlicesMD5
201
202 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
203 - unified all tags
204 - renamed interface settings into interface tags and slice attributes into slice tags
205 - nodes have a node_type
206 - various changes on the way to 4.3
207
208 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
209 - Checkpointing : this version still has interface settings and slice attributes
210
211 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
212 - first iteration with taggable nodes/interfaces/slices
213 - embryo for ilinks
214 - cleaned up boot states
215 - migration script moslty complete
216
217 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
218 - fixed doc build by locating locally installed DTDs at build-time
219
220 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
221 - no more doc packaged outside of myplc-docs - doc/ cleaned up
222 - enhancements in doc on filters 
223 - bootcd-aware GetBootMedium merged from onelab
224
225 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
226 - checkpoint while the new myplc-docs package is underway
227 - bugfix: GetSlivers & conf files
228 - doc: removed target files 
229
230 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
231 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
232 - the non-deleted fields were index, resulting in massivly slow queries.
233
234
235 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
236 - plcsh: better handling of options when running as a shell script
237 - getbootmedium exports compute_key
238 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
239
240 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
241 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
242 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
243
244 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
245 - refresh peer script to use a month-dependent logfile
246 - tracking the starting point for UniPi integration of the dummynet boxes
247
248 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
249 - plcsh adds its own path to sys.path
250 - fix so GetNodes can be called from a Node
251
252 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
253 - Initial build.
254
255 %define module_current_branch 4.2