Tagging module PLCAPI - PLCAPI-4.3-16
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 4.3
9 %define taglevel 16
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql postgresql-server postgresql-python
32 Requires: python-psycopg2
33 Requires: python-pycurl
34 Requires: httpd
35 Requires: mod_python
36 Requires: mod_ssl
37 Requires: SOAPpy
38
39 # We use psycopg2
40 BuildRequires: postgresql-devel
41
42 # Standard xmlrpc.so that ships with PHP does not marshal NULL
43 BuildRequires: php-devel
44 Obsoletes: php-xmlrpc
45 Provides: php-xmlrpc
46
47 # PostgreSQL and SOAPpy are necessary to run the API server, but not
48 # plcsh. Since the only supported method of running the server is via
49 # MyPLC anyway, don't be so stringent about binary requirements, in
50 # case people want to install this package just for plcsh.
51 # Requires: postgresql-server, SOAPpy
52 AutoReqProv: no
53
54 %description
55 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
56 PlanetLab Central (PLC) database. The API may be accessed directly via
57 the Python shell program plcsh, through a toy standalone server, or
58 through Apache mod_python.
59
60 %prep
61 %setup -q
62
63 %build
64 # python-pycurl and python-psycopg2 avail. from fedora 5
65 # we used to ship our own version of psycopg2 and pycurl, for fedora4
66 # starting with 4.3, support for these two modules is taken out
67
68 # Build __init__.py metafiles and PHP API. 
69 %{__make} %{?_smp_mflags}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
74
75 # Install shell symlink
76 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
77 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
78
79 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
80 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
81 ; Enable xmlrpc extension module
82 extension=xmlrpc.so
83 EOF
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %define php_extension_dir %(php-config --extension-dir)
89
90 %files
91 %defattr(-,root,root,-)
92 %dir %{_datadir}/plc_api
93 %{_datadir}/plc_api/*
94 %{_bindir}/plcsh
95 %{php_extension_dir}/xmlrpc.so
96 %{_sysconfdir}/php.d/xmlrpc.ini
97 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
98
99 %changelog
100 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
101 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
102
103 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
104 - more powerful legacy layer with 4.2
105
106 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
107 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
108 - migration script has an option for running interactively
109
110 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
111 - skips already added entries
112
113 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
114 - yet another set of fixes for external dummynet boxes
115
116 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
117 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
118 - and tmp file is cleaned up
119
120 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
121 - restore missing ResolveSlices
122
123 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
124 - new method GetDummyBoxMedium
125
126 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
127 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
128
129 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
130 - support for external dummynet boxes back in 4.3 - first draft
131
132 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
133 - fixes for smooth federation between 4.2 and 4.3
134 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
135
136 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
137 - support for BootCD variants (GetBootMedium ['variant:centos5'])
138 - fix corner case with filters like {'~slice_id':[]}
139 - fix transaction leak that caused the db connections pool to exhaust
140 - properly expose all methods, including Legacy/, and not only Methods/
141
142 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
143 - renumbered as 4.3
144 - nodes have new fields run_level (in addition to boot_state) and verified
145 - tweaked migration from 4.2
146 - tuned rpm dependencies
147 - doc generation more explicit about errors like missing python modules
148 - removed obsolete method GetSlicesMD5
149
150 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
151 - unified all tags
152 - renamed interface settings into interface tags and slice attributes into slice tags
153 - nodes have a node_type
154 - various changes on the way to 4.3
155
156 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
157 - Checkpointing : this version still has interface settings and slice attributes
158
159 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
160 - first iteration with taggable nodes/interfaces/slices
161 - embryo for ilinks
162 - cleaned up boot states
163 - migration script moslty complete
164
165 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
166 - fixed doc build by locating locally installed DTDs at build-time
167
168 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
169 - no more doc packaged outside of myplc-docs - doc/ cleaned up
170 - enhancements in doc on filters 
171 - bootcd-aware GetBootMedium merged from onelab
172
173 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
174 - checkpoint while the new myplc-docs package is underway
175 - bugfix: GetSlivers & conf files
176 - doc: removed target files 
177
178 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
179 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
180 - the non-deleted fields were index, resulting in massivly slow queries.
181
182
183 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
184 - plcsh: better handling of options when running as a shell script
185 - getbootmedium exports compute_key
186 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
187
188 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
189 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
190 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
191
192 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
193 - refresh peer script to use a month-dependent logfile
194 - tracking the starting point for UniPi integration of the dummynet boxes
195
196 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
197 - plcsh adds its own path to sys.path
198 - fix so GetNodes can be called from a Node
199
200 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
201 - Initial build.
202
203 %define module_current_branch 4.2