drop the version requirement for postgresql-python altogether. Having the requirement...
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 4.3
9 %define taglevel 28
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 Requires: mod_ssl
38 Requires: SOAPpy
39
40 # We use psycopg2
41 BuildRequires: postgresql-devel
42
43 # Standard xmlrpc.so that ships with PHP does not marshal NULL
44 BuildRequires: php-devel
45 Obsoletes: php-xmlrpc
46 Provides: php-xmlrpc
47
48 # PostgreSQL and SOAPpy are necessary to run the API server, but not
49 # plcsh. Since the only supported method of running the server is via
50 # MyPLC anyway, don't be so stringent about binary requirements, in
51 # case people want to install this package just for plcsh.
52 # Requires: postgresql-server, SOAPpy
53 AutoReqProv: no
54
55 %description
56 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
57 PlanetLab Central (PLC) database. The API may be accessed directly via
58 the Python shell program plcsh, through a toy standalone server, or
59 through Apache mod_python.
60
61 %prep
62 %setup -q
63
64 %build
65 # python-pycurl and python-psycopg2 avail. from fedora 5
66 # we used to ship our own version of psycopg2 and pycurl, for fedora4
67 # starting with 4.3, support for these two modules is taken out
68
69 # Build __init__.py metafiles and PHP API. 
70 %{__make} %{?_smp_mflags}
71 %{__make} -C wsdl
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
76 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
77
78 # Install shell symlink
79 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
80 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
81
82 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
83 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
84 ; Enable xmlrpc extension module
85 extension=xmlrpc.so
86 EOF
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %define php_extension_dir %(php-config --extension-dir)
92
93 %files
94 %defattr(-,root,root,-)
95 %dir %{_datadir}/plc_api
96 %{_datadir}/plc_api/*
97 %{_bindir}/plcsh
98 %{php_extension_dir}/xmlrpc.so
99 %{_sysconfdir}/php.d/xmlrpc.ini
100 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
101 /var/www/html/wsdl/plcapi.wsdl
102
103 %changelog
104 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
105 - Fix requires for CentOS.
106
107 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
108 - Require postgresql 8.2 (for array operators && and @>)
109
110 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
111 - Filter now supports the | and & features to match in sequence values
112 - bugfix in the postgresql wrapper for sequence filter values
113 - reviewed GetSlivers to export admin keys more efficiently
114 - fix checking roles in UpdateSliceTag
115
116 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
117 - - Some typos in the documentation were fixed.
118 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
119 - to the tag's min_role_id.
120
121 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
122
123 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
124 - Ongoing work to add upcalls, using new SFA class
125 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
126 - reviewed type-checking for the 3 taggable classes node-interface-slice
127 - cleanup ald dummynet stuff
128 - expose the 'extensions' accessors to the API
129 - tweaked checks in AddSliceTag
130 - GetPersons exposes roles by default
131 - bugfix in ReportRunLevel for non-string levels
132 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
133
134 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
135 - new BindObjectToPeer method for sfa
136 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
137
138 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
139 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
140 - reportrunlevel logs its calls only when run_level changes
141 - pycurl more robust wrt to xmlrpclib.Transport
142
143 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
144 - produce a wsdl interface
145 - bugfix in getbootmedium for nodes with interface tags
146
147 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
148 - bugfix for some rare pattern-based filters
149
150 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
151 - improvements in the 4.2 legacy layer
152
153 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
154 - bugfix required for slice tags set on nodegroups
155
156 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
157 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
158
159 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
160 - more powerful legacy layer with 4.2
161
162 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
163 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
164 - migration script has an option for running interactively
165
166 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
167 - skips already added entries
168
169 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
170 - yet another set of fixes for external dummynet boxes
171
172 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
173 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
174 - and tmp file is cleaned up
175
176 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
177 - restore missing ResolveSlices
178
179 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
180 - new method GetDummyBoxMedium
181
182 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
183 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
184
185 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
186 - support for external dummynet boxes back in 4.3 - first draft
187
188 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
189 - fixes for smooth federation between 4.2 and 4.3
190 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
191
192 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
193 - support for BootCD variants (GetBootMedium ['variant:centos5'])
194 - fix corner case with filters like {'~slice_id':[]}
195 - fix transaction leak that caused the db connections pool to exhaust
196 - properly expose all methods, including Legacy/, and not only Methods/
197
198 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
199 - renumbered as 4.3
200 - nodes have new fields run_level (in addition to boot_state) and verified
201 - tweaked migration from 4.2
202 - tuned rpm dependencies
203 - doc generation more explicit about errors like missing python modules
204 - removed obsolete method GetSlicesMD5
205
206 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
207 - unified all tags
208 - renamed interface settings into interface tags and slice attributes into slice tags
209 - nodes have a node_type
210 - various changes on the way to 4.3
211
212 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
213 - Checkpointing : this version still has interface settings and slice attributes
214
215 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
216 - first iteration with taggable nodes/interfaces/slices
217 - embryo for ilinks
218 - cleaned up boot states
219 - migration script moslty complete
220
221 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
222 - fixed doc build by locating locally installed DTDs at build-time
223
224 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
225 - no more doc packaged outside of myplc-docs - doc/ cleaned up
226 - enhancements in doc on filters 
227 - bootcd-aware GetBootMedium merged from onelab
228
229 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
230 - checkpoint while the new myplc-docs package is underway
231 - bugfix: GetSlivers & conf files
232 - doc: removed target files 
233
234 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
235 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
236 - the non-deleted fields were index, resulting in massivly slow queries.
237
238
239 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
240 - plcsh: better handling of options when running as a shell script
241 - getbootmedium exports compute_key
242 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
243
244 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
245 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
246 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
247
248 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
249 - refresh peer script to use a month-dependent logfile
250 - tracking the starting point for UniPi integration of the dummynet boxes
251
252 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
253 - plcsh adds its own path to sys.path
254 - fix so GetNodes can be called from a Node
255
256 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
257 - Initial build.
258
259 %define module_current_branch 4.2