Setting tag PLCAPI-5.0-4
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 4
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 Requires: mod_ssl
38 Requires: SOAPpy
39 # for the RebootNodeWithPCU method
40 Requires: pcucontrol
41 # for OMF integration
42 Requires: pyaspects
43 Requires: python-twisted-words
44 Requires: python-twisted-web
45
46 ### avoid having yum complain about updates, as stuff is moving around
47 # plc.d/api
48 Conflicts: MyPLC <= 4.3
49
50 # We use psycopg2
51 BuildRequires: postgresql-devel
52
53 # Standard xmlrpc.so that ships with PHP does not marshal NULL
54 BuildRequires: php-devel
55 Obsoletes: php-xmlrpc
56 Provides: php-xmlrpc
57
58 # PostgreSQL and SOAPpy are necessary to run the API server, but not
59 # plcsh. Since the only supported method of running the server is via
60 # MyPLC anyway, don't be so stringent about binary requirements, in
61 # case people want to install this package just for plcsh.
62 # Requires: postgresql-server, SOAPpy
63 AutoReqProv: no
64
65 %description
66 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
67 PlanetLab Central (PLC) database. The API may be accessed directly via
68 the Python shell program plcsh, through a toy standalone server, or
69 through Apache mod_python.
70
71 %prep
72 %setup -q
73
74 %build
75 # python-pycurl and python-psycopg2 avail. from fedora 5
76 # we used to ship our own version of psycopg2 and pycurl, for fedora4
77 # starting with 4.3, support for these two modules is taken out
78
79 # Build __init__.py metafiles and PHP API. 
80 %{__make} %{?_smp_mflags}
81 %{__make} -C wsdl
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
86
87 # Install shell symlink
88 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
89 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
90
91 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
92 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
93 ; Enable xmlrpc extension module
94 extension=xmlrpc.so
95 EOF
96
97 # Install initscripts
98 echo "* Installing initscripts"
99 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
100 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
101
102 # Install db-config.d files
103 echo "* Installing db-config.d files"
104 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
105 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
106 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
107
108 # Install wsdl
109 echo "* Installing wsdl"
110 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
111
112 # Install omf_slicemgr.py
113 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
114 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %define php_extension_dir %(php-config --extension-dir)
120
121 %files
122 %defattr(-,root,root,-)
123 %dir %{_datadir}/plc_api
124 %{_datadir}/plc_api/*
125 %{_bindir}/plcsh
126 %{php_extension_dir}/xmlrpc.so
127 %{_sysconfdir}/php.d/xmlrpc.ini
128 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
129 /etc/plc.d
130 /etc/planetlab/db-config.d
131 /var/www/html/wsdl/plcapi.wsdl
132 /usr/bin/omf_slicemgr.py*
133 /usr/bin/reset_xmpp_pubsub_nodes.py*
134
135 %changelog
136 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
137 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
138
139 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
140 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
141 - pyaspect hooks allow to  maintain the namespace xmpp groups
142 - new omf_slicemgr is a proxy to xmpp, used by these hooks
143 - nodes have their hrn exposed in the 'hrn' tag
144 - node hrn exposed in GetSlivers, as well as the overall xmpp config
145 - system slice 'drl' gets created by db-config
146 - daniel's changes to Filter for supporting wildcards in lists
147 - AddSliceTag consistency check tweaked
148
149 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
150 - major cleanup
151 - get rid of all 4.2-related legacy code
152 - reset the migrations code, planetlab5.sql somes with (5,100)
153 - uses hashlib module when available
154
155 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
156 - first working version of 5.0:
157 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
158 - nodefamily is 3-fold with pldistro-fcdistro-arch
159 - site and person tags
160 - new methods GetSliceFamily and GetNodeFlavour
161 - deprecated the dummynet stuff that were for the external dummyboxes
162 - tags definition : more consistency between db-config scripts and accessors
163 - (get accessor to create the tag type too if absent)
164 - logging an event for AddSliceToNodes
165
166 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
167 - support for fedora 12
168 - fix subtle bug in filtering with ] and quotes
169
170 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
171 - * patch for php-5.3 (the one in f12)
172 - * validate email addresses with regex
173 - * add PersonTags and SiteTags
174 - * add additional accessors for node tags (kvariant, serial, ..)
175
176 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
177 - Redacting password, session, and authstring values from the event log.
178
179 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
180 - let AddSite set ext_consortium_id - required for the poorman registration pages
181 - drop version constraint on Requires: postgresql-python
182 - don't log system calls nor ReportRunLevel
183
184 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
185 - Fix requires for CentOS.
186
187 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
188 - Require postgresql 8.2 (for array operators && and @>)
189
190 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
191 - Filter now supports the | and & features to match in sequence values
192 - bugfix in the postgresql wrapper for sequence filter values
193 - reviewed GetSlivers to export admin keys more efficiently
194 - fix checking roles in UpdateSliceTag
195
196 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
197 - - Some typos in the documentation were fixed.
198 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
199 - to the tag's min_role_id.
200
201 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
202
203 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
204 - Ongoing work to add upcalls, using new SFA class
205 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
206 - reviewed type-checking for the 3 taggable classes node-interface-slice
207 - cleanup ald dummynet stuff
208 - expose the 'extensions' accessors to the API
209 - tweaked checks in AddSliceTag
210 - GetPersons exposes roles by default
211 - bugfix in ReportRunLevel for non-string levels
212 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
213
214 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
215 - new BindObjectToPeer method for sfa
216 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
217
218 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
219 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
220 - reportrunlevel logs its calls only when run_level changes
221 - pycurl more robust wrt to xmlrpclib.Transport
222
223 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
224 - produce a wsdl interface
225 - bugfix in getbootmedium for nodes with interface tags
226
227 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
228 - bugfix for some rare pattern-based filters
229
230 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
231 - improvements in the 4.2 legacy layer
232
233 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
234 - bugfix required for slice tags set on nodegroups
235
236 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
237 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
238
239 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
240 - more powerful legacy layer with 4.2
241
242 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
243 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
244 - migration script has an option for running interactively
245
246 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
247 - skips already added entries
248
249 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
250 - yet another set of fixes for external dummynet boxes
251
252 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
253 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
254 - and tmp file is cleaned up
255
256 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
257 - restore missing ResolveSlices
258
259 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
260 - new method GetDummyBoxMedium
261
262 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
263 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
264
265 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
266 - support for external dummynet boxes back in 4.3 - first draft
267
268 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
269 - fixes for smooth federation between 4.2 and 4.3
270 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
271
272 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
273 - support for BootCD variants (GetBootMedium ['variant:centos5'])
274 - fix corner case with filters like {'~slice_id':[]}
275 - fix transaction leak that caused the db connections pool to exhaust
276 - properly expose all methods, including Legacy/, and not only Methods/
277
278 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
279 - renumbered as 4.3
280 - nodes have new fields run_level (in addition to boot_state) and verified
281 - tweaked migration from 4.2
282 - tuned rpm dependencies
283 - doc generation more explicit about errors like missing python modules
284 - removed obsolete method GetSlicesMD5
285
286 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
287 - unified all tags
288 - renamed interface settings into interface tags and slice attributes into slice tags
289 - nodes have a node_type
290 - various changes on the way to 4.3
291
292 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
293 - Checkpointing : this version still has interface settings and slice attributes
294
295 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
296 - first iteration with taggable nodes/interfaces/slices
297 - embryo for ilinks
298 - cleaned up boot states
299 - migration script moslty complete
300
301 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
302 - fixed doc build by locating locally installed DTDs at build-time
303
304 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
305 - no more doc packaged outside of myplc-docs - doc/ cleaned up
306 - enhancements in doc on filters 
307 - bootcd-aware GetBootMedium merged from onelab
308
309 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
310 - checkpoint while the new myplc-docs package is underway
311 - bugfix: GetSlivers & conf files
312 - doc: removed target files 
313
314 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
315 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
316 - the non-deleted fields were index, resulting in massivly slow queries.
317
318
319 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
320 - plcsh: better handling of options when running as a shell script
321 - getbootmedium exports compute_key
322 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
323
324 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
325 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
326 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
327
328 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
329 - refresh peer script to use a month-dependent logfile
330 - tracking the starting point for UniPi integration of the dummynet boxes
331
332 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
333 - plcsh adds its own path to sys.path
334 - fix so GetNodes can be called from a Node
335
336 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
337 - Initial build.
338
339 %define module_current_branch 4.3