remove postgresql-devel dependency
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 4
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 Requires: mod_ssl
38 Requires: SOAPpy
39 # for the RebootNodeWithPCU method
40 Requires: pcucontrol
41 # for OMF integration
42 Requires: pyaspects
43 Requires: python-twisted-words
44 Requires: python-twisted-web
45
46 ### avoid having yum complain about updates, as stuff is moving around
47 # plc.d/api
48 Conflicts: MyPLC <= 4.3
49
50 # We use psycopg2
51 #
52 # but we don't need to rebuild it as we depend on distro's packages - baris
53 # BuildRequires: postgresql-devel
54
55 # Standard xmlrpc.so that ships with PHP does not marshal NULL
56 BuildRequires: php-devel
57 Obsoletes: php-xmlrpc
58 Provides: php-xmlrpc
59
60 # PostgreSQL and SOAPpy are necessary to run the API server, but not
61 # plcsh. Since the only supported method of running the server is via
62 # MyPLC anyway, don't be so stringent about binary requirements, in
63 # case people want to install this package just for plcsh.
64 # Requires: postgresql-server, SOAPpy
65 AutoReqProv: no
66
67 %description
68 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
69 PlanetLab Central (PLC) database. The API may be accessed directly via
70 the Python shell program plcsh, through a toy standalone server, or
71 through Apache mod_python.
72
73 %prep
74 %setup -q
75
76 %build
77 # python-pycurl and python-psycopg2 avail. from fedora 5
78 # we used to ship our own version of psycopg2 and pycurl, for fedora4
79 # starting with 4.3, support for these two modules is taken out
80
81 # Build __init__.py metafiles and PHP API. 
82 %{__make} %{?_smp_mflags}
83 %{__make} -C wsdl
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
88
89 # Install shell symlink
90 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
91 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
92
93 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
94 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
95 ; Enable xmlrpc extension module
96 extension=xmlrpc.so
97 EOF
98
99 # Install initscripts
100 echo "* Installing initscripts"
101 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
102 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
103
104 # Install db-config.d files
105 echo "* Installing db-config.d files"
106 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
107 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
109
110 # Install wsdl
111 echo "* Installing wsdl"
112 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
113
114 # Install omf_slicemgr.py
115 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
116 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %define php_extension_dir %(php-config --extension-dir)
122
123 %files
124 %defattr(-,root,root,-)
125 %dir %{_datadir}/plc_api
126 %dir /var/log/omf/
127 %{_datadir}/plc_api/*
128 %{_bindir}/plcsh
129 %{php_extension_dir}/xmlrpc.so
130 %{_sysconfdir}/php.d/xmlrpc.ini
131 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
132 /etc/plc.d
133 /etc/planetlab/db-config.d
134 /var/www/html/wsdl/plcapi.wsdl
135 /usr/bin/omf_slicemgr.py*
136 /usr/bin/reset_xmpp_pubsub_nodes.py*
137
138
139 %changelog
140 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
141 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
142
143 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
144 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
145 - pyaspect hooks allow to  maintain the namespace xmpp groups
146 - new omf_slicemgr is a proxy to xmpp, used by these hooks
147 - nodes have their hrn exposed in the 'hrn' tag
148 - node hrn exposed in GetSlivers, as well as the overall xmpp config
149 - system slice 'drl' gets created by db-config
150 - daniel's changes to Filter for supporting wildcards in lists
151 - AddSliceTag consistency check tweaked
152
153 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
154 - major cleanup
155 - get rid of all 4.2-related legacy code
156 - reset the migrations code, planetlab5.sql somes with (5,100)
157 - uses hashlib module when available
158
159 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
160 - first working version of 5.0:
161 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
162 - nodefamily is 3-fold with pldistro-fcdistro-arch
163 - site and person tags
164 - new methods GetSliceFamily and GetNodeFlavour
165 - deprecated the dummynet stuff that were for the external dummyboxes
166 - tags definition : more consistency between db-config scripts and accessors
167 - (get accessor to create the tag type too if absent)
168 - logging an event for AddSliceToNodes
169
170 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
171 - support for fedora 12
172 - fix subtle bug in filtering with ] and quotes
173
174 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
175 - * patch for php-5.3 (the one in f12)
176 - * validate email addresses with regex
177 - * add PersonTags and SiteTags
178 - * add additional accessors for node tags (kvariant, serial, ..)
179
180 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
181 - Redacting password, session, and authstring values from the event log.
182
183 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
184 - let AddSite set ext_consortium_id - required for the poorman registration pages
185 - drop version constraint on Requires: postgresql-python
186 - don't log system calls nor ReportRunLevel
187
188 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
189 - Fix requires for CentOS.
190
191 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
192 - Require postgresql 8.2 (for array operators && and @>)
193
194 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
195 - Filter now supports the | and & features to match in sequence values
196 - bugfix in the postgresql wrapper for sequence filter values
197 - reviewed GetSlivers to export admin keys more efficiently
198 - fix checking roles in UpdateSliceTag
199
200 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
201 - - Some typos in the documentation were fixed.
202 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
203 - to the tag's min_role_id.
204
205 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
206
207 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
208 - Ongoing work to add upcalls, using new SFA class
209 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
210 - reviewed type-checking for the 3 taggable classes node-interface-slice
211 - cleanup ald dummynet stuff
212 - expose the 'extensions' accessors to the API
213 - tweaked checks in AddSliceTag
214 - GetPersons exposes roles by default
215 - bugfix in ReportRunLevel for non-string levels
216 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
217
218 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
219 - new BindObjectToPeer method for sfa
220 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
221
222 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
223 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
224 - reportrunlevel logs its calls only when run_level changes
225 - pycurl more robust wrt to xmlrpclib.Transport
226
227 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
228 - produce a wsdl interface
229 - bugfix in getbootmedium for nodes with interface tags
230
231 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
232 - bugfix for some rare pattern-based filters
233
234 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
235 - improvements in the 4.2 legacy layer
236
237 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
238 - bugfix required for slice tags set on nodegroups
239
240 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
241 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
242
243 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
244 - more powerful legacy layer with 4.2
245
246 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
247 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
248 - migration script has an option for running interactively
249
250 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
251 - skips already added entries
252
253 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
254 - yet another set of fixes for external dummynet boxes
255
256 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
257 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
258 - and tmp file is cleaned up
259
260 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
261 - restore missing ResolveSlices
262
263 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
264 - new method GetDummyBoxMedium
265
266 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
267 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
268
269 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
270 - support for external dummynet boxes back in 4.3 - first draft
271
272 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
273 - fixes for smooth federation between 4.2 and 4.3
274 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
275
276 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
277 - support for BootCD variants (GetBootMedium ['variant:centos5'])
278 - fix corner case with filters like {'~slice_id':[]}
279 - fix transaction leak that caused the db connections pool to exhaust
280 - properly expose all methods, including Legacy/, and not only Methods/
281
282 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
283 - renumbered as 4.3
284 - nodes have new fields run_level (in addition to boot_state) and verified
285 - tweaked migration from 4.2
286 - tuned rpm dependencies
287 - doc generation more explicit about errors like missing python modules
288 - removed obsolete method GetSlicesMD5
289
290 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
291 - unified all tags
292 - renamed interface settings into interface tags and slice attributes into slice tags
293 - nodes have a node_type
294 - various changes on the way to 4.3
295
296 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
297 - Checkpointing : this version still has interface settings and slice attributes
298
299 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
300 - first iteration with taggable nodes/interfaces/slices
301 - embryo for ilinks
302 - cleaned up boot states
303 - migration script moslty complete
304
305 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
306 - fixed doc build by locating locally installed DTDs at build-time
307
308 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
309 - no more doc packaged outside of myplc-docs - doc/ cleaned up
310 - enhancements in doc on filters 
311 - bootcd-aware GetBootMedium merged from onelab
312
313 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
314 - checkpoint while the new myplc-docs package is underway
315 - bugfix: GetSlivers & conf files
316 - doc: removed target files 
317
318 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
319 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
320 - the non-deleted fields were index, resulting in massivly slow queries.
321
322
323 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
324 - plcsh: better handling of options when running as a shell script
325 - getbootmedium exports compute_key
326 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
327
328 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
329 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
330 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
331
332 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
333 - refresh peer script to use a month-dependent logfile
334 - tracking the starting point for UniPi integration of the dummynet boxes
335
336 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
337 - plcsh adds its own path to sys.path
338 - fix so GetNodes can be called from a Node
339
340 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
341 - Initial build.
342
343 %define module_current_branch 4.3