- obsolete plcapilib
[plcapi.git] / PLCAPI.spec
1 Summary: PlanetLab Central API
2 Name: PLCAPI
3 Version: 4.0
4 Release: 1
5 License: PlanetLab
6 Group: System Environment/Daemons
7 URL: http://cvs.planet-lab.org/cvs/new_plc_api
8 Source0: %{name}-%{version}.tar.gz
9 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11 Obsoletes: plcapilib
12
13 BuildRequires: docbook-dtds, docbook-utils-pdf
14
15 Requires: postgresql-server, SOAPpy
16
17 %description
18 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
19 PlanetLab Central (PLC) database. The API may be accessed directly via
20 the Python shell program plcsh, through a toy standalone server, or
21 through Apache mod_python.
22
23 %prep
24 %setup -q
25
26 %build
27 # Build __init__.py metafiles, documentation, and PHP API
28 %{__make} %{?_smp_mflags}
29
30 # Byte compile
31 %{__python} setup.py build
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35
36 # Install in /usr/share/plc_api
37 %{__python} setup.py install \
38     --install-purelib=$RPM_BUILD_ROOT/%{_datadir}/plc_api \
39     --install-data=$RPM_BUILD_ROOT/%{_datadir}/plc_api
40
41 # Install shell symlink
42 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
43 ln -s %{_datadir}/plc_api/Shell.py $RPM_BUILD_ROOT/%{_bindir}/plcsh
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(-,root,root,-)
50 %doc doc/PLCAPI.xml doc/PLCAPI.pdf doc/PLCAPI.html
51 %dir %{_datadir}/plc_api
52 %{_datadir}/plc_api
53 %{_bindir}/plcsh
54
55 %changelog
56 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
57 - Initial build.
58