Tagging module PLCAPI - PLCAPI-4.2-7
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 4.2
9 %define taglevel 7
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31
32 # We use psycopg2
33 BuildRequires: postgresql-devel
34
35 # Standard xmlrpc.so that ships with PHP does not marshal NULL
36 BuildRequires: php-devel
37 Obsoletes: php-xmlrpc
38 Provides: php-xmlrpc
39
40 # PostgreSQL and SOAPpy are necessary to run the API server, but not
41 # plcsh. Since the only supported method of running the server is via
42 # MyPLC anyway, don't be so stringent about binary requirements, in
43 # case people want to install this package just for plcsh.
44 # Requires: postgresql-server, SOAPpy
45 AutoReqProv: no
46
47 %description
48 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
49 PlanetLab Central (PLC) database. The API may be accessed directly via
50 the Python shell program plcsh, through a toy standalone server, or
51 through Apache mod_python.
52
53 %prep
54 %setup -q
55
56 %build
57 # python-pycurl and python-psycopg2 avail. from fedora 5
58 # make sure to check build/<pldistro>/plc.pkgs
59 if [ "%{distrorelease}" -le 4 ] ; then
60     modules="psycopg2 pycurl"
61 else
62     modules=""
63 fi
64 # Build __init__.py metafiles and PHP API. 
65 %{__make} %{?_smp_mflags} subdirs="php php/xmlrpc" modules="$modules"
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 if [ "%{distrorelease}" -le 4 ] ; then
70     modules="psycopg2 pycurl"
71 else
72     modules=""
73 fi
74 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" modules="$modules"
75
76 # Install shell symlink
77 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
78 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
79
80 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
81 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
82 ; Enable xmlrpc extension module
83 extension=xmlrpc.so
84 EOF
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %define php_extension_dir %(php-config --extension-dir)
90
91 %files
92 %defattr(-,root,root,-)
93 %dir %{_datadir}/plc_api
94 %{_datadir}/plc_api/*
95 %{_bindir}/plcsh
96 %{php_extension_dir}/xmlrpc.so
97 %{_sysconfdir}/php.d/xmlrpc.ini
98 %{_bindir}/refresh-peer.py*
99
100 %changelog
101 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
102 - no more doc packaged outside of myplc-docs - doc/ cleaned up
103 - enhancements in doc on filters 
104 - bootcd-aware GetBootMedium merged from onelab
105
106 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
107 - checkpoint while the new myplc-docs package is underway
108 - bugfix: GetSlivers & conf files
109 - doc: removed target files 
110
111 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
112 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
113 - the non-deleted fields were index, resulting in massivly slow queries.
114
115
116 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
117 - plcsh: better handling of options when running as a shell script
118 - getbootmedium exports compute_key
119 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
120
121 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
122 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
123 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
124
125 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
126 - refresh peer script to use a month-dependent logfile
127 - tracking the starting point for UniPi integration of the dummynet boxes
128
129 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
130 - plcsh adds its own path to sys.path
131 - fix so GetNodes can be called from a Node
132
133 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
134 - Initial build.