Setting tag PLCAPI-5.0-10
[plcapi.git] / PLCAPI.spec
1 #
2 # $Id$
3 #
4
5 %define url $URL$
6
7 %define name PLCAPI
8 %define version 5.0
9 %define taglevel 10
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Summary: PlanetLab Central API
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 License: PlanetLab
18 Group: System Environment/Daemons
19 Source0: %{name}-%{version}.tar.gz
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %(echo %{url} | cut -d ' ' -f 2)
26
27 Obsoletes: plcapilib
28
29 # We use set everywhere
30 Requires: python >= 2.4
31 Requires: postgresql >= 8.2, postgresql-server >= 8.2
32 Requires: postgresql-python
33 Requires: python-psycopg2
34 Requires: python-pycurl
35 Requires: httpd
36 Requires: mod_python
37 Requires: mod_ssl
38 Requires: SOAPpy
39 # for the RebootNodeWithPCU method
40 Requires: pcucontrol >= 1.0-6
41 # for OMF integration
42 Requires: pyaspects
43 Requires: python-twisted-words
44 Requires: python-twisted-web
45
46 ### avoid having yum complain about updates, as stuff is moving around
47 # plc.d/api
48 Conflicts: MyPLC <= 4.3
49
50 # We use psycopg2
51 #
52 # but we don't need to rebuild it as we depend on distro's packages - baris
53 # BuildRequires: postgresql-devel
54
55 # Standard xmlrpc.so that ships with PHP does not marshal NULL
56 BuildRequires: php-devel
57 Obsoletes: php-xmlrpc
58 Provides: php-xmlrpc
59
60 # PostgreSQL and SOAPpy are necessary to run the API server, but not
61 # plcsh. Since the only supported method of running the server is via
62 # MyPLC anyway, don't be so stringent about binary requirements, in
63 # case people want to install this package just for plcsh.
64 # Requires: postgresql-server, SOAPpy
65 AutoReqProv: no
66
67 %description
68 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
69 PlanetLab Central (PLC) database. The API may be accessed directly via
70 the Python shell program plcsh, through a toy standalone server, or
71 through Apache mod_python.
72
73 %prep
74 %setup -q
75
76 %build
77 # python-pycurl and python-psycopg2 avail. from fedora 5
78 # we used to ship our own version of psycopg2 and pycurl, for fedora4
79 # starting with 4.3, support for these two modules is taken out
80
81 # Build __init__.py metafiles and PHP API. 
82 %{__make} %{?_smp_mflags}
83 %{__make} -C wsdl
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
88
89 # Install shell symlink
90 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
91 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
92
93 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
94 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
95 ; Enable xmlrpc extension module
96 extension=xmlrpc.so
97 EOF
98
99 # Install initscripts
100 echo "* Installing initscripts"
101 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
102 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
103
104 # Install db-config.d files
105 echo "* Installing db-config.d files"
106 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
107 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
109
110 # Install wsdl
111 echo "* Installing wsdl"
112 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
113
114 # Install omf_slicemgr.py
115 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
116 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
117 mkdir -p $RPM_BUILD_ROOT/var/log/omf
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %define php_extension_dir %(php-config --extension-dir)
123
124 %files
125 %defattr(-,root,root,-)
126 %dir %{_datadir}/plc_api
127 %dir /var/log/omf/
128 %{_datadir}/plc_api/*
129 %{_bindir}/plcsh
130 %{php_extension_dir}/xmlrpc.so
131 %{_sysconfdir}/php.d/xmlrpc.ini
132 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
133 /etc/plc.d
134 /etc/planetlab/db-config.d
135 /var/www/html/wsdl/plcapi.wsdl
136 /usr/bin/omf_slicemgr.py*
137 /usr/bin/reset_xmpp_pubsub_nodes.py*
138
139
140 %changelog
141 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
142 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
143 - and readable through GetLeaseGranularity
144 - GetSlivers to expose reservation_policy and lease_granularity
145 - GetBootMedium fixed for reservable nodes
146 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
147 - new Apache mod_wsgi python interface
148
149 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
150 - the leases system
151
152 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
153 - previous tag had gone wrong
154
155 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
156 - fix pubsub hostname
157
158 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
159 - tweaks for the omf support (xmpp groups and RC-controlled slices)
160 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
161 - GetNodeFlavour exposes fcdistro
162
163 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
164 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
165
166 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
167 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
168 - pyaspect hooks allow to  maintain the namespace xmpp groups
169 - new omf_slicemgr is a proxy to xmpp, used by these hooks
170 - nodes have their hrn exposed in the 'hrn' tag
171 - node hrn exposed in GetSlivers, as well as the overall xmpp config
172 - system slice 'drl' gets created by db-config
173 - daniel's changes to Filter for supporting wildcards in lists
174 - AddSliceTag consistency check tweaked
175
176 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
177 - major cleanup
178 - get rid of all 4.2-related legacy code
179 - reset the migrations code, planetlab5.sql somes with (5,100)
180 - uses hashlib module when available
181
182 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
183 - first working version of 5.0:
184 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
185 - nodefamily is 3-fold with pldistro-fcdistro-arch
186 - site and person tags
187 - new methods GetSliceFamily and GetNodeFlavour
188 - deprecated the dummynet stuff that were for the external dummyboxes
189 - tags definition : more consistency between db-config scripts and accessors
190 - (get accessor to create the tag type too if absent)
191 - logging an event for AddSliceToNodes
192
193 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
194 - support for fedora 12
195 - fix subtle bug in filtering with ] and quotes
196
197 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
198 - * patch for php-5.3 (the one in f12)
199 - * validate email addresses with regex
200 - * add PersonTags and SiteTags
201 - * add additional accessors for node tags (kvariant, serial, ..)
202
203 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
204 - Redacting password, session, and authstring values from the event log.
205
206 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
207 - let AddSite set ext_consortium_id - required for the poorman registration pages
208 - drop version constraint on Requires: postgresql-python
209 - don't log system calls nor ReportRunLevel
210
211 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
212 - Fix requires for CentOS.
213
214 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
215 - Require postgresql 8.2 (for array operators && and @>)
216
217 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
218 - Filter now supports the | and & features to match in sequence values
219 - bugfix in the postgresql wrapper for sequence filter values
220 - reviewed GetSlivers to export admin keys more efficiently
221 - fix checking roles in UpdateSliceTag
222
223 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
224 - - Some typos in the documentation were fixed.
225 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
226 - to the tag's min_role_id.
227
228 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
229
230 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
231 - Ongoing work to add upcalls, using new SFA class
232 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
233 - reviewed type-checking for the 3 taggable classes node-interface-slice
234 - cleanup ald dummynet stuff
235 - expose the 'extensions' accessors to the API
236 - tweaked checks in AddSliceTag
237 - GetPersons exposes roles by default
238 - bugfix in ReportRunLevel for non-string levels
239 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
240
241 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
242 - new BindObjectToPeer method for sfa
243 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
244
245 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
246 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
247 - reportrunlevel logs its calls only when run_level changes
248 - pycurl more robust wrt to xmlrpclib.Transport
249
250 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
251 - produce a wsdl interface
252 - bugfix in getbootmedium for nodes with interface tags
253
254 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
255 - bugfix for some rare pattern-based filters
256
257 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
258 - improvements in the 4.2 legacy layer
259
260 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
261 - bugfix required for slice tags set on nodegroups
262
263 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
264 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
265
266 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
267 - more powerful legacy layer with 4.2
268
269 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
270 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
271 - migration script has an option for running interactively
272
273 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
274 - skips already added entries
275
276 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
277 - yet another set of fixes for external dummynet boxes
278
279 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
280 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
281 - and tmp file is cleaned up
282
283 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
284 - restore missing ResolveSlices
285
286 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
287 - new method GetDummyBoxMedium
288
289 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
290 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
291
292 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
293 - support for external dummynet boxes back in 4.3 - first draft
294
295 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
296 - fixes for smooth federation between 4.2 and 4.3
297 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
298
299 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
300 - support for BootCD variants (GetBootMedium ['variant:centos5'])
301 - fix corner case with filters like {'~slice_id':[]}
302 - fix transaction leak that caused the db connections pool to exhaust
303 - properly expose all methods, including Legacy/, and not only Methods/
304
305 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
306 - renumbered as 4.3
307 - nodes have new fields run_level (in addition to boot_state) and verified
308 - tweaked migration from 4.2
309 - tuned rpm dependencies
310 - doc generation more explicit about errors like missing python modules
311 - removed obsolete method GetSlicesMD5
312
313 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
314 - unified all tags
315 - renamed interface settings into interface tags and slice attributes into slice tags
316 - nodes have a node_type
317 - various changes on the way to 4.3
318
319 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
320 - Checkpointing : this version still has interface settings and slice attributes
321
322 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
323 - first iteration with taggable nodes/interfaces/slices
324 - embryo for ilinks
325 - cleaned up boot states
326 - migration script moslty complete
327
328 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
329 - fixed doc build by locating locally installed DTDs at build-time
330
331 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
332 - no more doc packaged outside of myplc-docs - doc/ cleaned up
333 - enhancements in doc on filters 
334 - bootcd-aware GetBootMedium merged from onelab
335
336 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
337 - checkpoint while the new myplc-docs package is underway
338 - bugfix: GetSlivers & conf files
339 - doc: removed target files 
340
341 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
342 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
343 - the non-deleted fields were index, resulting in massivly slow queries.
344
345
346 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
347 - plcsh: better handling of options when running as a shell script
348 - getbootmedium exports compute_key
349 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
350
351 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
352 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
353 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
354
355 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
356 - refresh peer script to use a month-dependent logfile
357 - tracking the starting point for UniPi integration of the dummynet boxes
358
359 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
360 - plcsh adds its own path to sys.path
361 - fix so GetNodes can be called from a Node
362
363 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
364 - Initial build.
365
366 %define module_current_branch 4.3