Setting tag plcapi-5.4-2
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.4
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 # f29 does not come with an rpm for that; use pip instead
27 # Requires: Django
28 Requires: postgresql >= 8.2, postgresql-server >= 8.2
29 # We use set everywhere
30 Requires: python >= 2.7
31 Requires: postgresql-python
32 Requires: python-psycopg2
33 Requires: python-pycurl
34 # used in GPG.py as a replacement to PyXML's Canonicalize
35 Requires: python-lxml
36 # Fedora had support for SOAPpy up to fedora20
37 # https://lists.fedoraproject.org/pipermail/devel/2014-June/199730.html
38 # https://lists.fedoraproject.org/pipermail/devel/2014-June/200379.html
39 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
40 Requires: SOAPpy
41 %endif
42 #Requires: python-simplejson
43 # for the RebootNodeWithPCU method
44 Requires: pcucontrol >= 1.0-6
45 # for memcache
46 Requires: memcached python-memcached
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 ####################
52 # obsolete
53 ####################
54 # standard xmlrpc.so that ships with PHP does not marshal NULL
55 # prior to May 2017 we used to ship our own brew of xmlrpc but
56 # that does not build anymore on f25
57 # So bottom line is:
58 # * don't use fedora's php-xmlrpc (no support for marshalling NULL)
59 # * don't use our own that is way too old
60 # * instead - thank you Ciro - we pull it as a git subtree from
61 # https://github.com/gggeek/phpxmlrpc.git
62 # that stuff requires the following though
63 Requires: php-xml
64 ####################
65
66
67 # PostgreSQL and SOAPpy are necessary to run the API server, but not
68 # plcsh. Since the only supported method of running the server is via
69 # MyPLC anyway, don't be so stringent about binary requirements, in
70 # case people want to install this package just for plcsh.
71 # Requires: postgresql-server, SOAPpy
72 AutoReqProv: no
73
74 %description
75 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
76 PlanetLab Central (PLC) database. The API may be accessed directly via
77 the Python shell program plcsh, through a toy standalone server, or
78 through Apache mod_python.
79
80 %prep
81 %setup -q
82
83 %build
84 # python-pycurl and python-psycopg2 avail. from fedora 5
85 # we used to ship our own version of psycopg2 and pycurl, for fedora4
86 # starting with 4.3, support for these two modules is taken out
87 #
88 # Build __init__.py metafiles and PHP API.
89 %{__make} %{?_smp_mflags}
90 %{__make} -C wsdl
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
95
96 # Install shell symlink
97 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
98 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
116 ## Install omf_slicemgr.py
117 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Create log file for plcapi
122 mkdir -p $RPM_BUILD_ROOT/var/log
123 touch $RPM_BUILD_ROOT/var/log/plcapi.log
124 chown apache:apache $RPM_BUILD_ROOT/var/log/plcapi.log
125
126 # Install ratelimit log
127 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
128 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 ###%define php_extension_dir %(php-config --extension-dir)
134
135 %files
136 %defattr(-,root,root,-)
137 %dir %{_datadir}/plc_api
138 #%dir /var/log/omf/
139 %{_datadir}/plc_api/*
140 %{_bindir}/plcsh
141 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
142 /etc/plc.d
143 /etc/planetlab/db-config.d
144 /var/www/html/wsdl/plcapi.wsdl
145 #/usr/bin/omf_slicemgr.py*
146 #/usr/bin/reset_xmpp_pubsub_nodes.py*
147 /var/log/plcapi.log
148 /var/log/plc_api_ratelimit.log
149
150
151 %changelog
152 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plcapi-5.4-2
153 - last version based on python2, runs on f27 and f29
154 - removed dependency to aspects, and so to rate limits
155 - remove dependency to the Django rpm that is no longer available in f29
156 - remove deps to python-twisted
157 - use systemctl rather than service to manage postgresql
158
159 * Wed May 16 2018 Thierry <Parmentelat> - plcapi-5.4-1
160 - define accessor for site tag disabled_registration (used in plewww-5.2-9)
161 - set disable_existing_loggers = False in logging config, that otherwise voids sfa logs
162
163 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.4-0
164 - embed phpxmlrpc as a git subtree from github (OK with fedora24 and 25, probably sooner too)
165 - logs in /var/log/plcapi.log
166 - context managers for most open files
167
168 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
169 - mostly issued for the R2lab deployment
170 - *** major
171 - * dots allowed in login_base and slice name
172 - * new lease filter 'day'
173 - *** minor
174 - * more explicit message in case of overlapping resas
175 - * bugfix: escaping unicode in xml
176 - * GetLeases allowed to anonymous callers
177 - *** miscell
178 - * use plain json library
179
180 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
181 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
182
183 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
184 - new bootstate 'upgrade' is like reinstall but leaves slices intact
185
186 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
187 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
188
189 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
190 - reviewed logging strategy, no more direct print but use log instead
191
192 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
193 - extensions for the ipv6 feature
194 - DeleteSliceTag can be run with the 'node' auth
195 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
196 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
197
198 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
199 - allow GetSlices to filter on tags as well
200
201 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
202 - enable filtering on tags (like hrn) with GetPersons and GetSites
203
204 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
205 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
206
207 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
208 - don't use PyXML that is deprecated in f20, use lxml instead
209 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
210
211 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
212 - create accessor 'hrn' for site as well
213 - create accessors 'sfa_created' for site/slice/person
214 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
215 - UpdatePerson() updates Person HRN according to updated email.
216 - UpdateSite() updates Site HRN according to updated login_base.
217 - Fix AddPersonToSite().
218 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
219 - RefreshPeer() manages Site*Person and Person*Role relationships.
220
221 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
222 - provide a slicename_to_hrn function
223
224 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
225 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
226
227 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
228 - fix for wsgi-based deployments, each thread has its own api()
229
230 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
231 - also cleanup omf-slicemgr initscript
232
233 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
234 - tear down omf-related aspects as this is no longer needed with omfv6
235
236 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
237 - also expose 'expires' in ResolveSlices
238
239 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
240 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
241
242 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
243 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
244
245 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
246 - use SFA code for computing hrn's when available
247
248 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
249 - new slice tag 'interface' for configuring a virtual interface
250 - new builtin 030-interface_tags
251 - new node accessor and tag 'virt' for mixing lxc & vs nodes
252 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
253 - moved ModPypthon and plc.wsgi in the apache/ subdir
254 - renamed PLCAPI.spec into plcapi.spec
255 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
256 - support for php-5.4
257
258 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
259 - implement PLC_VSYS_DEFAULTS in AddSlice
260
261 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
262 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
263 - AddPerson and UpdatePerson are now tag-aware
264 - as a side-effect AddPerson is more picky and rejects invalid fields
265 - which results in a requirement to use sfa-2.1-22 with this tag
266 - marginal improvement on the xml doc on tags
267
268 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
269 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
270 - reset_xmpp_pubsub_nodes now hos options and usage
271 - new Accessors for vicci
272
273 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
274 - fixed imports for tags management with sites and persons
275 - add predefined 'cpu_freezable' tag
276
277 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
278 - tweaks in interface initialization
279 - has 'vsys_vnet' as a predefined tagtype
280 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
281 - bugfix: GetSlivers & nodegroups
282 - bugfix: in jabber groups management
283
284 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
285 - fix gpg-authentication for Persons (thanks Jordan)
286 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
287 - ip address/network check: v4 or v6
288 - customized DB Message survive upgrade
289 - make sync works in lxc-hosted tests
290 - no svn keywords anymore
291
292 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
293 - fix sorting for methods list in docs
294 - untested but needed tweak for postgres startup in f16
295
296 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
297 - tweaks in postgresql setup - in line with sfa
298
299 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
300 - slight tweaks in Persons.py
301
302 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
303 - GetSession has support for more than one day sessions
304 - reset_xmpp_pubsub_nodes is much more efficient
305 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
306 - bugfix - deleting a person in the middle of the signup process
307
308 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
309 - ratelimit aspects
310 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
311 - requires Django for cache_utils
312 - attempt to expose 'pldistro' to sfa
313 - last_time_spent_online, last_time_spent_offline: new fields in Node
314 - new slice tags 'isolate_loopback' and 'cpu_cores'
315 - refresh-peer federation logs dump exceptions
316 - modpython logs have a timestamp
317 - more verbose/accurate php error reporting
318 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
319 - AddNode, UpdateNode: manage tags directly rather than through another method
320 - BootUpdateNode: only update once
321 - GetPersons: techs can access the list of persons on their site
322 - GetSlices and GetSliceTags: techs can see slices on their nodes
323 - GetSlivers: isrootonsite tag; cacheable
324
325 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
326 - rename initscript_body into initscript_code
327
328 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
329 - new initscript_body tag
330
331 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
332 - working draft for GetSliceSshKeys
333
334 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
335 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
336 - (this is for people who cancel their download)
337
338 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
339 - fix db-config sequence : accessors step now merged in, and occurs at the right time
340 - db-config also more robust
341 - no more explicit 'accessors' step in plc.d
342
343 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
344 - session auth: do *not* delete session when node runs a method that does not have 'node' role
345 - session auth: remove support for bootonce in old boot CDs
346 - give a reason when caller_may_write_slice_tag fails
347 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
348
349 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
350 - SetSliceVref needed the node role
351 - protect GetSliceFamily
352 - Fix bugs in tag authorizations
353
354 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
355 - altered checking of optional fields in Interfaces
356 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
357 - has pyxml and python-simplejson as new deps
358
359 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
360 - tweak doc extraction for fedora14
361
362 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
363 - builtin accessors for the myslice page
364 - Get{Node,Interface}Tags allowed to techs
365 - tweak in ratelimitaspect.py
366
367 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
368 - add admin role to accessor-related tags (arch, {fc,pl}distro)
369
370 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
371 - bugfix in {Update,Delete}PersonTag
372 - updated xml doc for filters, accessors and tagtypes
373 - more explicit msg in case of missing roles
374 - improvements in ratelimitaspects.py
375
376 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
377 - fix the roles for ssh_key and hmac tags
378
379 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
380 - tag permissions system based on roles and not min_role_ids
381 - accessors simplified accordingly (no more min_role_id)
382 - new methods AddRoleToTagType and DeleteRoleFromTagType
383 - accessor-related tagtypes are created sooner, and enforced
384 - cleaned up redundancy between db-config.d and accessors
385
386 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
387 - fix RefreshPeer that was not working in 5.0-17
388
389 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
390 - RefreshPeer is able to cope with 2 peers running different releases of the api
391 - DeletePerson can be used on duplicates
392 - first appearance of ModPythonJson.py
393
394 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
395 - set accessors return the new value
396 - tweaks in the pubsub groups management
397
398 * Wed Jul 28 2010 S.ÇaÄŸlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
399 - convert hostnames to lower case and use ILIKE instead of LIKE
400
401 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
402 - use hrn in pubsub groups
403
404 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
405 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
406 - OMF fixes
407
408 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
409 - automatically set vsys tag for omf controlled slices
410
411 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
412 - addition of the 'ssh_key' slice tag
413 - first draft of the LDAP interface
414
415 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
416 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
417 - and readable through GetLeaseGranularity
418 - GetSlivers to expose reservation_policy and lease_granularity
419 - GetBootMedium fixed for reservable nodes
420 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
421 - new Apache mod_wsgi python interface
422
423 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
424 - the leases system
425
426 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
427 - previous tag had gone wrong
428
429 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
430 - fix pubsub hostname
431
432 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
433 - tweaks for the omf support (xmpp groups and RC-controlled slices)
434 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
435 - GetNodeFlavour exposes fcdistro
436
437 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
438 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
439
440 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
441 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
442 - pyaspect hooks allow to  maintain the namespace xmpp groups
443 - new omf_slicemgr is a proxy to xmpp, used by these hooks
444 - nodes have their hrn exposed in the 'hrn' tag
445 - node hrn exposed in GetSlivers, as well as the overall xmpp config
446 - system slice 'drl' gets created by db-config
447 - daniel's changes to Filter for supporting wildcards in lists
448 - AddSliceTag consistency check tweaked
449
450 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
451 - major cleanup
452 - get rid of all 4.2-related legacy code
453 - reset the migrations code, planetlab5.sql somes with (5,100)
454 - uses hashlib module when available
455
456 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
457 - first working version of 5.0:
458 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
459 - nodefamily is 3-fold with pldistro-fcdistro-arch
460 - site and person tags
461 - new methods GetSliceFamily and GetNodeFlavour
462 - deprecated the dummynet stuff that were for the external dummyboxes
463 - tags definition : more consistency between db-config scripts and accessors
464 - (get accessor to create the tag type too if absent)
465 - logging an event for AddSliceToNodes
466
467 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
468 - support for fedora 12
469 - fix subtle bug in filtering with ] and quotes
470
471 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
472 - * patch for php-5.3 (the one in f12)
473 - * validate email addresses with regex
474 - * add PersonTags and SiteTags
475 - * add additional accessors for node tags (kvariant, serial, ..)
476
477 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
478 - Redacting password, session, and authstring values from the event log.
479
480 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
481 - let AddSite set ext_consortium_id - required for the poorman registration pages
482 - drop version constraint on Requires: postgresql-python
483 - don't log system calls nor ReportRunLevel
484
485 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
486 - Fix requires for CentOS.
487
488 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
489 - Require postgresql 8.2 (for array operators && and @>)
490
491 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
492 - Filter now supports the | and & features to match in sequence values
493 - bugfix in the postgresql wrapper for sequence filter values
494 - reviewed GetSlivers to export admin keys more efficiently
495 - fix checking roles in UpdateSliceTag
496
497 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
498 - - Some typos in the documentation were fixed.
499 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
500 - to the tag's min_role_id.
501
502 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
503
504 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
505 - Ongoing work to add upcalls, using new SFA class
506 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
507 - reviewed type-checking for the 3 taggable classes node-interface-slice
508 - cleanup ald dummynet stuff
509 - expose the 'extensions' accessors to the API
510 - tweaked checks in AddSliceTag
511 - GetPersons exposes roles by default
512 - bugfix in ReportRunLevel for non-string levels
513 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
514
515 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
516 - new BindObjectToPeer method for sfa
517 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
518
519 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
520 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
521 - reportrunlevel logs its calls only when run_level changes
522 - pycurl more robust wrt to xmlrpclib.Transport
523
524 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
525 - produce a wsdl interface
526 - bugfix in getbootmedium for nodes with interface tags
527
528 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
529 - bugfix for some rare pattern-based filters
530
531 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
532 - improvements in the 4.2 legacy layer
533
534 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
535 - bugfix required for slice tags set on nodegroups
536
537 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
538 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
539
540 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
541 - more powerful legacy layer with 4.2
542
543 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
544 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
545 - migration script has an option for running interactively
546
547 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
548 - skips already added entries
549
550 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
551 - yet another set of fixes for external dummynet boxes
552
553 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
554 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
555 - and tmp file is cleaned up
556
557 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
558 - restore missing ResolveSlices
559
560 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
561 - new method GetDummyBoxMedium
562
563 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
564 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
565
566 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
567 - support for external dummynet boxes back in 4.3 - first draft
568
569 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
570 - fixes for smooth federation between 4.2 and 4.3
571 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
572
573 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
574 - support for BootCD variants (GetBootMedium ['variant:centos5'])
575 - fix corner case with filters like {'~slice_id':[]}
576 - fix transaction leak that caused the db connections pool to exhaust
577 - properly expose all methods, including Legacy/, and not only Methods/
578
579 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
580 - renumbered as 4.3
581 - nodes have new fields run_level (in addition to boot_state) and verified
582 - tweaked migration from 4.2
583 - tuned rpm dependencies
584 - doc generation more explicit about errors like missing python modules
585 - removed obsolete method GetSlicesMD5
586
587 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
588 - unified all tags
589 - renamed interface settings into interface tags and slice attributes into slice tags
590 - nodes have a node_type
591 - various changes on the way to 4.3
592
593 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
594 - Checkpointing : this version still has interface settings and slice attributes
595
596 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
597 - first iteration with taggable nodes/interfaces/slices
598 - embryo for ilinks
599 - cleaned up boot states
600 - migration script moslty complete
601
602 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
603 - fixed doc build by locating locally installed DTDs at build-time
604
605 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
606 - no more doc packaged outside of myplc-docs - doc/ cleaned up
607 - enhancements in doc on filters
608 - bootcd-aware GetBootMedium merged from onelab
609
610 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
611 - checkpoint while the new myplc-docs package is underway
612 - bugfix: GetSlivers & conf files
613 - doc: removed target files
614
615 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
616 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
617 - the non-deleted fields were index, resulting in massivly slow queries.
618 -
619
620 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
621 - plcsh: better handling of options when running as a shell script
622 - getbootmedium exports compute_key
623 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
624
625 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
626 - GetBootMedium support for build.sh full options, incl. serial & console_spec
627 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
628
629 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
630 - refresh peer script to use a month-dependent logfile
631 - tracking the starting point for UniPi integration of the dummynet boxes
632
633 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
634 - plcsh adds its own path to sys.path
635 - fix so GetNodes can be called from a Node
636
637 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> -
638 - Initial build.
639
640 %define module_current_branch 4.3