remove simplejson dependency
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 10
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 # Fedora had support for SOAPpy up to fedora20
36 # https://lists.fedoraproject.org/pipermail/devel/2014-June/199730.html
37 # https://lists.fedoraproject.org/pipermail/devel/2014-June/200379.html
38 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
39 Requires: SOAPpy
40 %endif
41 #Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50 # for memcache
51 Requires: memcached python-memcached
52 ### avoid having yum complain about updates, as stuff is moving around
53 # plc.d/api
54 Conflicts: MyPLC <= 4.3
55
56 # We use psycopg2
57 #
58 # but we don't need to rebuild it as we depend on distro's packages - baris
59 # BuildRequires: postgresql-devel
60
61 # Standard xmlrpc.so that ships with PHP does not marshal NULL
62 # for building the wsdl interface we used to require PyXML
63 # but this has gone with f20 so turning this off for now
64 BuildRequires: php-devel
65 #BuildRequires: python-simplejson
66 Obsoletes: php-xmlrpc
67 Provides: php-xmlrpc
68
69 # PostgreSQL and SOAPpy are necessary to run the API server, but not
70 # plcsh. Since the only supported method of running the server is via
71 # MyPLC anyway, don't be so stringent about binary requirements, in
72 # case people want to install this package just for plcsh.
73 # Requires: postgresql-server, SOAPpy
74 AutoReqProv: no
75
76 %description
77 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
78 PlanetLab Central (PLC) database. The API may be accessed directly via
79 the Python shell program plcsh, through a toy standalone server, or
80 through Apache mod_python.
81
82 %prep
83 %setup -q
84
85 %build
86 # python-pycurl and python-psycopg2 avail. from fedora 5
87 # we used to ship our own version of psycopg2 and pycurl, for fedora4
88 # starting with 4.3, support for these two modules is taken out
89
90 # Build __init__.py metafiles and PHP API. 
91 %{__make} %{?_smp_mflags}
92 %{__make} -C wsdl
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
97
98 # Install shell symlink
99 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
100 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
101
102 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
103 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
104 ; Enable xmlrpc extension module
105 extension=xmlrpc.so
106 EOF
107
108 # Install initscripts
109 echo "* Installing initscripts"
110 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
111 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
112
113 # Install db-config.d files
114 echo "* Installing db-config.d files"
115 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
116 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
117 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
118
119 # Install wsdl
120 echo "* Installing wsdl"
121 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
122
123 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
124 ## Install omf_slicemgr.py
125 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
126 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
127 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
128
129 # Install ratelimit log
130 mkdir -p $RPM_BUILD_ROOT/var/log
131 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
132 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %define php_extension_dir %(php-config --extension-dir)
138
139 %files
140 %defattr(-,root,root,-)
141 %dir %{_datadir}/plc_api
142 #%dir /var/log/omf/
143 %{_datadir}/plc_api/*
144 %{_bindir}/plcsh
145 %{php_extension_dir}/xmlrpc.so
146 %{_sysconfdir}/php.d/xmlrpc.ini
147 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
148 /etc/plc.d
149 /etc/planetlab/db-config.d
150 /var/www/html/wsdl/plcapi.wsdl
151 #/usr/bin/omf_slicemgr.py*
152 #/usr/bin/reset_xmpp_pubsub_nodes.py*
153 /var/log/plc_api_ratelimit.log
154
155
156 %changelog
157 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
158 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
159
160 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
161 - new bootstate 'upgrade' is like reinstall but leaves slices intact
162
163 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
164 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
165
166 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
167 - reviewed logging strategy, no more direct print but use log instead
168
169 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
170 - extensions for the ipv6 feature
171 - DeleteSliceTag can be run with the 'node' auth
172 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
173 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
174
175 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
176 - allow GetSlices to filter on tags as well
177
178 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
179 - enable filtering on tags (like hrn) with GetPersons and GetSites
180
181 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
182 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
183
184 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
185 - don't use PyXML that is deprecated in f20, use lxml instead
186 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
187
188 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
189 - create accessor 'hrn' for site as well
190 - create accessors 'sfa_created' for site/slice/person
191 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
192 - UpdatePerson() updates Person HRN according to updated email.
193 - UpdateSite() updates Site HRN according to updated login_base.
194 - Fix AddPersonToSite().
195 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
196 - RefreshPeer() manages Site*Person and Person*Role relationships.
197
198 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
199 - provide a slicename_to_hrn function
200
201 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
202 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
203
204 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
205 - fix for wsgi-based deployments, each thread has its own api()
206
207 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
208 - also cleanup omf-slicemgr initscript
209
210 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
211 - tear down omf-related aspects as this is no longer needed with omfv6
212
213 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
214 - also expose 'expires' in ResolveSlices
215
216 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
217 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
218
219 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
220 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
221
222 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
223 - use SFA code for computing hrn's when available
224
225 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
226 - new slice tag 'interface' for configuring a virtual interface
227 - new builtin 030-interface_tags
228 - new node accessor and tag 'virt' for mixing lxc & vs nodes
229 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
230 - moved ModPypthon and plc.wsgi in the apache/ subdir
231 - renamed PLCAPI.spec into plcapi.spec
232 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
233 - support for php-5.4
234
235 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
236 - implement PLC_VSYS_DEFAULTS in AddSlice
237
238 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
239 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
240 - AddPerson and UpdatePerson are now tag-aware
241 - as a side-effect AddPerson is more picky and rejects invalid fields
242 - which results in a requirement to use sfa-2.1-22 with this tag
243 - marginal improvement on the xml doc on tags
244
245 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
246 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
247 - reset_xmpp_pubsub_nodes now hos options and usage
248 - new Accessors for vicci
249
250 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
251 - fixed imports for tags management with sites and persons
252 - add predefined 'cpu_freezable' tag
253
254 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
255 - tweaks in interface initialization
256 - has 'vsys_vnet' as a predefined tagtype
257 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
258 - bugfix: GetSlivers & nodegroups
259 - bugfix: in jabber groups management
260
261 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
262 - fix gpg-authentication for Persons (thanks Jordan)
263 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
264 - ip address/network check: v4 or v6
265 - customized DB Message survive upgrade
266 - make sync works in lxc-hosted tests
267 - no svn keywords anymore
268
269 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
270 - fix sorting for methods list in docs
271 - untested but needed tweak for postgres startup in f16
272
273 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
274 - tweaks in postgresql setup - in line with sfa
275
276 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
277 - slight tweaks in Persons.py
278
279 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
280 - GetSession has support for more than one day sessions
281 - reset_xmpp_pubsub_nodes is much more efficient
282 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
283 - bugfix - deleting a person in the middle of the signup process
284
285 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
286 - ratelimit aspects
287 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
288 - requires Django for cache_utils
289 - attempt to expose 'pldistro' to sfa
290 - last_time_spent_online, last_time_spent_offline: new fields in Node
291 - new slice tags 'isolate_loopback' and 'cpu_cores'
292 - refresh-peer federation logs dump exceptions
293 - modpython logs have a timestamp
294 - more verbose/accurate php error reporting
295 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
296 - AddNode, UpdateNode: manage tags directly rather than through another method
297 - BootUpdateNode: only update once
298 - GetPersons: techs can access the list of persons on their site
299 - GetSlices and GetSliceTags: techs can see slices on their nodes
300 - GetSlivers: isrootonsite tag; cacheable
301
302 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
303 - rename initscript_body into initscript_code
304
305 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
306 - new initscript_body tag
307
308 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
309 - working draft for GetSliceSshKeys
310
311 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
312 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
313 - (this is for people who cancel their download)
314
315 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
316 - fix db-config sequence : accessors step now merged in, and occurs at the right time
317 - db-config also more robust
318 - no more explicit 'accessors' step in plc.d
319
320 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
321 - session auth: do *not* delete session when node runs a method that does not have 'node' role
322 - session auth: remove support for bootonce in old boot CDs
323 - give a reason when caller_may_write_slice_tag fails
324 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
325
326 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
327 - SetSliceVref needed the node role
328 - protect GetSliceFamily
329 - Fix bugs in tag authorizations
330
331 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
332 - altered checking of optional fields in Interfaces
333 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
334 - has pyxml and python-simplejson as new deps
335
336 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
337 - tweak doc extraction for fedora14
338
339 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
340 - builtin accessors for the myslice page
341 - Get{Node,Interface}Tags allowed to techs
342 - tweak in ratelimitaspect.py
343
344 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
345 - add admin role to accessor-related tags (arch, {fc,pl}distro)
346
347 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
348 - bugfix in {Update,Delete}PersonTag
349 - updated xml doc for filters, accessors and tagtypes
350 - more explicit msg in case of missing roles
351 - improvements in ratelimitaspects.py
352
353 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
354 - fix the roles for ssh_key and hmac tags
355
356 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
357 - tag permissions system based on roles and not min_role_ids
358 - accessors simplified accordingly (no more min_role_id)
359 - new methods AddRoleToTagType and DeleteRoleFromTagType
360 - accessor-related tagtypes are created sooner, and enforced
361 - cleaned up redundancy between db-config.d and accessors
362
363 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
364 - fix RefreshPeer that was not working in 5.0-17
365
366 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
367 - RefreshPeer is able to cope with 2 peers running different releases of the api
368 - DeletePerson can be used on duplicates
369 - first appearance of ModPythonJson.py
370
371 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
372 - set accessors return the new value
373 - tweaks in the pubsub groups management
374
375 * Wed Jul 28 2010 S.ÇaÄŸlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
376 - convert hostnames to lower case and use ILIKE instead of LIKE
377
378 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
379 - use hrn in pubsub groups
380
381 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
382 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
383 - OMF fixes
384
385 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
386 - automatically set vsys tag for omf controlled slices
387
388 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
389 - addition of the 'ssh_key' slice tag
390 - first draft of the LDAP interface
391
392 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
393 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
394 - and readable through GetLeaseGranularity
395 - GetSlivers to expose reservation_policy and lease_granularity
396 - GetBootMedium fixed for reservable nodes
397 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
398 - new Apache mod_wsgi python interface
399
400 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
401 - the leases system
402
403 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
404 - previous tag had gone wrong
405
406 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
407 - fix pubsub hostname
408
409 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
410 - tweaks for the omf support (xmpp groups and RC-controlled slices)
411 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
412 - GetNodeFlavour exposes fcdistro
413
414 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
415 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
416
417 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
418 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
419 - pyaspect hooks allow to  maintain the namespace xmpp groups
420 - new omf_slicemgr is a proxy to xmpp, used by these hooks
421 - nodes have their hrn exposed in the 'hrn' tag
422 - node hrn exposed in GetSlivers, as well as the overall xmpp config
423 - system slice 'drl' gets created by db-config
424 - daniel's changes to Filter for supporting wildcards in lists
425 - AddSliceTag consistency check tweaked
426
427 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
428 - major cleanup
429 - get rid of all 4.2-related legacy code
430 - reset the migrations code, planetlab5.sql somes with (5,100)
431 - uses hashlib module when available
432
433 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
434 - first working version of 5.0:
435 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
436 - nodefamily is 3-fold with pldistro-fcdistro-arch
437 - site and person tags
438 - new methods GetSliceFamily and GetNodeFlavour
439 - deprecated the dummynet stuff that were for the external dummyboxes
440 - tags definition : more consistency between db-config scripts and accessors
441 - (get accessor to create the tag type too if absent)
442 - logging an event for AddSliceToNodes
443
444 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
445 - support for fedora 12
446 - fix subtle bug in filtering with ] and quotes
447
448 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
449 - * patch for php-5.3 (the one in f12)
450 - * validate email addresses with regex
451 - * add PersonTags and SiteTags
452 - * add additional accessors for node tags (kvariant, serial, ..)
453
454 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
455 - Redacting password, session, and authstring values from the event log.
456
457 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
458 - let AddSite set ext_consortium_id - required for the poorman registration pages
459 - drop version constraint on Requires: postgresql-python
460 - don't log system calls nor ReportRunLevel
461
462 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
463 - Fix requires for CentOS.
464
465 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
466 - Require postgresql 8.2 (for array operators && and @>)
467
468 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
469 - Filter now supports the | and & features to match in sequence values
470 - bugfix in the postgresql wrapper for sequence filter values
471 - reviewed GetSlivers to export admin keys more efficiently
472 - fix checking roles in UpdateSliceTag
473
474 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
475 - - Some typos in the documentation were fixed.
476 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
477 - to the tag's min_role_id.
478
479 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
480
481 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
482 - Ongoing work to add upcalls, using new SFA class
483 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
484 - reviewed type-checking for the 3 taggable classes node-interface-slice
485 - cleanup ald dummynet stuff
486 - expose the 'extensions' accessors to the API
487 - tweaked checks in AddSliceTag
488 - GetPersons exposes roles by default
489 - bugfix in ReportRunLevel for non-string levels
490 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
491
492 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
493 - new BindObjectToPeer method for sfa
494 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
495
496 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
497 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
498 - reportrunlevel logs its calls only when run_level changes
499 - pycurl more robust wrt to xmlrpclib.Transport
500
501 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
502 - produce a wsdl interface
503 - bugfix in getbootmedium for nodes with interface tags
504
505 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
506 - bugfix for some rare pattern-based filters
507
508 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
509 - improvements in the 4.2 legacy layer
510
511 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
512 - bugfix required for slice tags set on nodegroups
513
514 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
515 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
516
517 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
518 - more powerful legacy layer with 4.2
519
520 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
521 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
522 - migration script has an option for running interactively
523
524 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
525 - skips already added entries
526
527 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
528 - yet another set of fixes for external dummynet boxes
529
530 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
531 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
532 - and tmp file is cleaned up
533
534 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
535 - restore missing ResolveSlices
536
537 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
538 - new method GetDummyBoxMedium
539
540 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
541 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
542
543 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
544 - support for external dummynet boxes back in 4.3 - first draft
545
546 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
547 - fixes for smooth federation between 4.2 and 4.3
548 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
549
550 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
551 - support for BootCD variants (GetBootMedium ['variant:centos5'])
552 - fix corner case with filters like {'~slice_id':[]}
553 - fix transaction leak that caused the db connections pool to exhaust
554 - properly expose all methods, including Legacy/, and not only Methods/
555
556 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
557 - renumbered as 4.3
558 - nodes have new fields run_level (in addition to boot_state) and verified
559 - tweaked migration from 4.2
560 - tuned rpm dependencies
561 - doc generation more explicit about errors like missing python modules
562 - removed obsolete method GetSlicesMD5
563
564 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
565 - unified all tags
566 - renamed interface settings into interface tags and slice attributes into slice tags
567 - nodes have a node_type
568 - various changes on the way to 4.3
569
570 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
571 - Checkpointing : this version still has interface settings and slice attributes
572
573 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
574 - first iteration with taggable nodes/interfaces/slices
575 - embryo for ilinks
576 - cleaned up boot states
577 - migration script moslty complete
578
579 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
580 - fixed doc build by locating locally installed DTDs at build-time
581
582 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
583 - no more doc packaged outside of myplc-docs - doc/ cleaned up
584 - enhancements in doc on filters 
585 - bootcd-aware GetBootMedium merged from onelab
586
587 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
588 - checkpoint while the new myplc-docs package is underway
589 - bugfix: GetSlivers & conf files
590 - doc: removed target files 
591
592 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
593 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
594 - the non-deleted fields were index, resulting in massivly slow queries.
595
596
597 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
598 - plcsh: better handling of options when running as a shell script
599 - getbootmedium exports compute_key
600 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
601
602 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
603 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
604 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
605
606 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
607 - refresh peer script to use a month-dependent logfile
608 - tracking the starting point for UniPi integration of the dummynet boxes
609
610 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
611 - plcsh adds its own path to sys.path
612 - fix so GetNodes can be called from a Node
613
614 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
615 - Initial build.
616
617 %define module_current_branch 4.3