requires php-xml
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 11
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 # Fedora had support for SOAPpy up to fedora20
36 # https://lists.fedoraproject.org/pipermail/devel/2014-June/199730.html
37 # https://lists.fedoraproject.org/pipermail/devel/2014-June/200379.html
38 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
39 Requires: SOAPpy
40 %endif
41 #Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50 # for memcache
51 Requires: memcached python-memcached
52 ### avoid having yum complain about updates, as stuff is moving around
53 # plc.d/api
54 Conflicts: MyPLC <= 4.3
55
56 ####################
57 # obsolete
58 ####################
59 # standard xmlrpc.so that ships with PHP does not marshal NULL
60 # prior to May 2017 we used to ship our own brew of xmlrpc but
61 # that does not build anymore on f25
62 # So bottom line is:
63 # * don't use fedora's php-xmlrpc (no support for marshalling NULL)
64 # * don't use our own that is way too old
65 # * instead - thank you Ciro - we pull it as a git subtree from
66 # https://github.com/gggeek/phpxmlrpc.git
67 # that stuff requires the following though
68 Requires: php-xml
69 ####################
70
71
72 # PostgreSQL and SOAPpy are necessary to run the API server, but not
73 # plcsh. Since the only supported method of running the server is via
74 # MyPLC anyway, don't be so stringent about binary requirements, in
75 # case people want to install this package just for plcsh.
76 # Requires: postgresql-server, SOAPpy
77 AutoReqProv: no
78
79 %description
80 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
81 PlanetLab Central (PLC) database. The API may be accessed directly via
82 the Python shell program plcsh, through a toy standalone server, or
83 through Apache mod_python.
84
85 %prep
86 %setup -q
87
88 %build
89 # python-pycurl and python-psycopg2 avail. from fedora 5
90 # we used to ship our own version of psycopg2 and pycurl, for fedora4
91 # starting with 4.3, support for these two modules is taken out
92
93 # Build __init__.py metafiles and PHP API. 
94 %{__make} %{?_smp_mflags}
95 %{__make} -C wsdl
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
100
101 # Install shell symlink
102 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
103 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
104
105 # Install initscripts
106 echo "* Installing initscripts"
107 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
108 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
109
110 # Install db-config.d files
111 echo "* Installing db-config.d files"
112 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
113 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
114 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
115
116 # Install wsdl
117 echo "* Installing wsdl"
118 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
119
120 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
121 ## Install omf_slicemgr.py
122 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
123 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
124 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
125
126 # Create log file for plcapi
127 mkdir -p $RPM_BUILD_ROOT/var/log
128 touch $RPM_BUILD_ROOT/var/log/plcapi.log
129 chown apache:apache $RPM_BUILD_ROOT/var/log/plcapi.log
130
131 # Install ratelimit log
132 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
133 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 ###%define php_extension_dir %(php-config --extension-dir)
139
140 %files
141 %defattr(-,root,root,-)
142 %dir %{_datadir}/plc_api
143 #%dir /var/log/omf/
144 %{_datadir}/plc_api/*
145 %{_bindir}/plcsh
146 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
147 /etc/plc.d
148 /etc/planetlab/db-config.d
149 /var/www/html/wsdl/plcapi.wsdl
150 #/usr/bin/omf_slicemgr.py*
151 #/usr/bin/reset_xmpp_pubsub_nodes.py*
152 /var/log/plcapi.log
153 /var/log/plc_api_ratelimit.log
154
155
156 %changelog
157 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
158 - mostly issued for the R2lab deployment
159 - *** major
160 - * dots allowed in login_base and slice name
161 - * new lease filter 'day'
162 - *** minor
163 - * more explicit message in case of overlapping resas
164 - * bugfix: escaping unicode in xml
165 - * GetLeases allowed to anonymous callers
166 - *** miscell
167 - * use plain json library
168
169 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
170 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
171
172 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
173 - new bootstate 'upgrade' is like reinstall but leaves slices intact
174
175 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
176 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
177
178 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
179 - reviewed logging strategy, no more direct print but use log instead
180
181 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
182 - extensions for the ipv6 feature
183 - DeleteSliceTag can be run with the 'node' auth
184 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
185 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
186
187 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
188 - allow GetSlices to filter on tags as well
189
190 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
191 - enable filtering on tags (like hrn) with GetPersons and GetSites
192
193 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
194 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
195
196 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
197 - don't use PyXML that is deprecated in f20, use lxml instead
198 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
199
200 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
201 - create accessor 'hrn' for site as well
202 - create accessors 'sfa_created' for site/slice/person
203 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
204 - UpdatePerson() updates Person HRN according to updated email.
205 - UpdateSite() updates Site HRN according to updated login_base.
206 - Fix AddPersonToSite().
207 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
208 - RefreshPeer() manages Site*Person and Person*Role relationships.
209
210 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
211 - provide a slicename_to_hrn function
212
213 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
214 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
215
216 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
217 - fix for wsgi-based deployments, each thread has its own api()
218
219 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
220 - also cleanup omf-slicemgr initscript
221
222 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
223 - tear down omf-related aspects as this is no longer needed with omfv6
224
225 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
226 - also expose 'expires' in ResolveSlices
227
228 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
229 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
230
231 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
232 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
233
234 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
235 - use SFA code for computing hrn's when available
236
237 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
238 - new slice tag 'interface' for configuring a virtual interface
239 - new builtin 030-interface_tags
240 - new node accessor and tag 'virt' for mixing lxc & vs nodes
241 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
242 - moved ModPypthon and plc.wsgi in the apache/ subdir
243 - renamed PLCAPI.spec into plcapi.spec
244 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
245 - support for php-5.4
246
247 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
248 - implement PLC_VSYS_DEFAULTS in AddSlice
249
250 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
251 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
252 - AddPerson and UpdatePerson are now tag-aware
253 - as a side-effect AddPerson is more picky and rejects invalid fields
254 - which results in a requirement to use sfa-2.1-22 with this tag
255 - marginal improvement on the xml doc on tags
256
257 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
258 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
259 - reset_xmpp_pubsub_nodes now hos options and usage
260 - new Accessors for vicci
261
262 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
263 - fixed imports for tags management with sites and persons
264 - add predefined 'cpu_freezable' tag
265
266 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
267 - tweaks in interface initialization
268 - has 'vsys_vnet' as a predefined tagtype
269 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
270 - bugfix: GetSlivers & nodegroups
271 - bugfix: in jabber groups management
272
273 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
274 - fix gpg-authentication for Persons (thanks Jordan)
275 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
276 - ip address/network check: v4 or v6
277 - customized DB Message survive upgrade
278 - make sync works in lxc-hosted tests
279 - no svn keywords anymore
280
281 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
282 - fix sorting for methods list in docs
283 - untested but needed tweak for postgres startup in f16
284
285 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
286 - tweaks in postgresql setup - in line with sfa
287
288 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
289 - slight tweaks in Persons.py
290
291 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
292 - GetSession has support for more than one day sessions
293 - reset_xmpp_pubsub_nodes is much more efficient
294 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
295 - bugfix - deleting a person in the middle of the signup process
296
297 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
298 - ratelimit aspects
299 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
300 - requires Django for cache_utils
301 - attempt to expose 'pldistro' to sfa
302 - last_time_spent_online, last_time_spent_offline: new fields in Node
303 - new slice tags 'isolate_loopback' and 'cpu_cores'
304 - refresh-peer federation logs dump exceptions
305 - modpython logs have a timestamp
306 - more verbose/accurate php error reporting
307 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
308 - AddNode, UpdateNode: manage tags directly rather than through another method
309 - BootUpdateNode: only update once
310 - GetPersons: techs can access the list of persons on their site
311 - GetSlices and GetSliceTags: techs can see slices on their nodes
312 - GetSlivers: isrootonsite tag; cacheable
313
314 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
315 - rename initscript_body into initscript_code
316
317 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
318 - new initscript_body tag
319
320 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
321 - working draft for GetSliceSshKeys
322
323 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
324 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
325 - (this is for people who cancel their download)
326
327 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
328 - fix db-config sequence : accessors step now merged in, and occurs at the right time
329 - db-config also more robust
330 - no more explicit 'accessors' step in plc.d
331
332 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
333 - session auth: do *not* delete session when node runs a method that does not have 'node' role
334 - session auth: remove support for bootonce in old boot CDs
335 - give a reason when caller_may_write_slice_tag fails
336 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
337
338 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
339 - SetSliceVref needed the node role
340 - protect GetSliceFamily
341 - Fix bugs in tag authorizations
342
343 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
344 - altered checking of optional fields in Interfaces
345 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
346 - has pyxml and python-simplejson as new deps
347
348 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
349 - tweak doc extraction for fedora14
350
351 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
352 - builtin accessors for the myslice page
353 - Get{Node,Interface}Tags allowed to techs
354 - tweak in ratelimitaspect.py
355
356 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
357 - add admin role to accessor-related tags (arch, {fc,pl}distro)
358
359 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
360 - bugfix in {Update,Delete}PersonTag
361 - updated xml doc for filters, accessors and tagtypes
362 - more explicit msg in case of missing roles
363 - improvements in ratelimitaspects.py
364
365 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
366 - fix the roles for ssh_key and hmac tags
367
368 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
369 - tag permissions system based on roles and not min_role_ids
370 - accessors simplified accordingly (no more min_role_id)
371 - new methods AddRoleToTagType and DeleteRoleFromTagType
372 - accessor-related tagtypes are created sooner, and enforced
373 - cleaned up redundancy between db-config.d and accessors
374
375 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
376 - fix RefreshPeer that was not working in 5.0-17
377
378 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
379 - RefreshPeer is able to cope with 2 peers running different releases of the api
380 - DeletePerson can be used on duplicates
381 - first appearance of ModPythonJson.py
382
383 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
384 - set accessors return the new value
385 - tweaks in the pubsub groups management
386
387 * Wed Jul 28 2010 S.ÇaÄŸlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
388 - convert hostnames to lower case and use ILIKE instead of LIKE
389
390 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
391 - use hrn in pubsub groups
392
393 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
394 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
395 - OMF fixes
396
397 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
398 - automatically set vsys tag for omf controlled slices
399
400 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
401 - addition of the 'ssh_key' slice tag
402 - first draft of the LDAP interface
403
404 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
405 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
406 - and readable through GetLeaseGranularity
407 - GetSlivers to expose reservation_policy and lease_granularity
408 - GetBootMedium fixed for reservable nodes
409 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
410 - new Apache mod_wsgi python interface
411
412 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
413 - the leases system
414
415 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
416 - previous tag had gone wrong
417
418 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
419 - fix pubsub hostname
420
421 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
422 - tweaks for the omf support (xmpp groups and RC-controlled slices)
423 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
424 - GetNodeFlavour exposes fcdistro
425
426 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
427 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
428
429 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
430 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
431 - pyaspect hooks allow to  maintain the namespace xmpp groups
432 - new omf_slicemgr is a proxy to xmpp, used by these hooks
433 - nodes have their hrn exposed in the 'hrn' tag
434 - node hrn exposed in GetSlivers, as well as the overall xmpp config
435 - system slice 'drl' gets created by db-config
436 - daniel's changes to Filter for supporting wildcards in lists
437 - AddSliceTag consistency check tweaked
438
439 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
440 - major cleanup
441 - get rid of all 4.2-related legacy code
442 - reset the migrations code, planetlab5.sql somes with (5,100)
443 - uses hashlib module when available
444
445 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
446 - first working version of 5.0:
447 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
448 - nodefamily is 3-fold with pldistro-fcdistro-arch
449 - site and person tags
450 - new methods GetSliceFamily and GetNodeFlavour
451 - deprecated the dummynet stuff that were for the external dummyboxes
452 - tags definition : more consistency between db-config scripts and accessors
453 - (get accessor to create the tag type too if absent)
454 - logging an event for AddSliceToNodes
455
456 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
457 - support for fedora 12
458 - fix subtle bug in filtering with ] and quotes
459
460 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
461 - * patch for php-5.3 (the one in f12)
462 - * validate email addresses with regex
463 - * add PersonTags and SiteTags
464 - * add additional accessors for node tags (kvariant, serial, ..)
465
466 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
467 - Redacting password, session, and authstring values from the event log.
468
469 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
470 - let AddSite set ext_consortium_id - required for the poorman registration pages
471 - drop version constraint on Requires: postgresql-python
472 - don't log system calls nor ReportRunLevel
473
474 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
475 - Fix requires for CentOS.
476
477 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
478 - Require postgresql 8.2 (for array operators && and @>)
479
480 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
481 - Filter now supports the | and & features to match in sequence values
482 - bugfix in the postgresql wrapper for sequence filter values
483 - reviewed GetSlivers to export admin keys more efficiently
484 - fix checking roles in UpdateSliceTag
485
486 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
487 - - Some typos in the documentation were fixed.
488 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
489 - to the tag's min_role_id.
490
491 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
492
493 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
494 - Ongoing work to add upcalls, using new SFA class
495 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
496 - reviewed type-checking for the 3 taggable classes node-interface-slice
497 - cleanup ald dummynet stuff
498 - expose the 'extensions' accessors to the API
499 - tweaked checks in AddSliceTag
500 - GetPersons exposes roles by default
501 - bugfix in ReportRunLevel for non-string levels
502 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
503
504 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
505 - new BindObjectToPeer method for sfa
506 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
507
508 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
509 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
510 - reportrunlevel logs its calls only when run_level changes
511 - pycurl more robust wrt to xmlrpclib.Transport
512
513 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
514 - produce a wsdl interface
515 - bugfix in getbootmedium for nodes with interface tags
516
517 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
518 - bugfix for some rare pattern-based filters
519
520 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
521 - improvements in the 4.2 legacy layer
522
523 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
524 - bugfix required for slice tags set on nodegroups
525
526 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
527 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
528
529 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
530 - more powerful legacy layer with 4.2
531
532 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
533 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
534 - migration script has an option for running interactively
535
536 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
537 - skips already added entries
538
539 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
540 - yet another set of fixes for external dummynet boxes
541
542 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
543 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
544 - and tmp file is cleaned up
545
546 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
547 - restore missing ResolveSlices
548
549 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
550 - new method GetDummyBoxMedium
551
552 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
553 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
554
555 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
556 - support for external dummynet boxes back in 4.3 - first draft
557
558 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
559 - fixes for smooth federation between 4.2 and 4.3
560 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
561
562 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
563 - support for BootCD variants (GetBootMedium ['variant:centos5'])
564 - fix corner case with filters like {'~slice_id':[]}
565 - fix transaction leak that caused the db connections pool to exhaust
566 - properly expose all methods, including Legacy/, and not only Methods/
567
568 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
569 - renumbered as 4.3
570 - nodes have new fields run_level (in addition to boot_state) and verified
571 - tweaked migration from 4.2
572 - tuned rpm dependencies
573 - doc generation more explicit about errors like missing python modules
574 - removed obsolete method GetSlicesMD5
575
576 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
577 - unified all tags
578 - renamed interface settings into interface tags and slice attributes into slice tags
579 - nodes have a node_type
580 - various changes on the way to 4.3
581
582 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
583 - Checkpointing : this version still has interface settings and slice attributes
584
585 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
586 - first iteration with taggable nodes/interfaces/slices
587 - embryo for ilinks
588 - cleaned up boot states
589 - migration script moslty complete
590
591 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
592 - fixed doc build by locating locally installed DTDs at build-time
593
594 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
595 - no more doc packaged outside of myplc-docs - doc/ cleaned up
596 - enhancements in doc on filters 
597 - bootcd-aware GetBootMedium merged from onelab
598
599 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
600 - checkpoint while the new myplc-docs package is underway
601 - bugfix: GetSlivers & conf files
602 - doc: removed target files 
603
604 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
605 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
606 - the non-deleted fields were index, resulting in massivly slow queries.
607
608
609 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
610 - plcsh: better handling of options when running as a shell script
611 - getbootmedium exports compute_key
612 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
613
614 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
615 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
616 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
617
618 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
619 - refresh peer script to use a month-dependent logfile
620 - tracking the starting point for UniPi integration of the dummynet boxes
621
622 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
623 - plcsh adds its own path to sys.path
624 - fix so GetNodes can be called from a Node
625
626 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
627 - Initial build.
628
629 %define module_current_branch 4.3