Setting tag plcapi-7.0-0
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 7.0
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 # f29 does not come with an rpm for that; use pip instead
27 # Requires: Django
28 Requires: postgresql >= 8.2, postgresql-server >= 8.2
29 # We use set everywhere
30 Requires: python3
31 Requires: python3-postgresql
32 Requires: python3-psycopg2
33 Requires: python3-pycurl
34 # used in GPG.py as a replacement to PyXML's Canonicalize
35 Requires: python3-lxml
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for memcache
39 Requires: memcached python3-memcached
40
41 ####################
42 # obsolete
43 ####################
44 # standard xmlrpc.so that ships with PHP does not marshal NULL
45 # prior to May 2017 we used to ship our own brew of xmlrpc but
46 # that does not build anymore on f25
47 # So bottom line is:
48 # * don't use fedora's php-xmlrpc (no support for marshalling NULL)
49 # * don't use our own that is way too old
50 # * instead - thank you Ciro - we pull it as a git subtree from
51 # https://github.com/gggeek/phpxmlrpc.git
52 # that stuff requires the following though
53 Requires: php-xml
54 ####################
55
56
57 # PostgreSQL and SOAPpy are necessary to run the API server, but not
58 # plcsh. Since the only supported method of running the server is via
59 # MyPLC anyway, don't be so stringent about binary requirements, in
60 # case people want to install this package just for plcsh.
61 # Requires: postgresql-server, SOAPpy
62 AutoReqProv: no
63
64 %description
65 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
66 PlanetLab Central (PLC) database. The API may be accessed directly via
67 the Python shell program plcsh, through a toy standalone server, or
68 through Apache mod_python.
69
70 %prep
71 %setup -q
72
73 %build
74 # python-pycurl and python-psycopg2 avail. from fedora 5
75 # we used to ship our own version of psycopg2 and pycurl, for fedora4
76 # starting with 4.3, support for these two modules is taken out
77 #
78 # Build __init__.py metafiles and PHP API.
79 %{__make} %{?_smp_mflags}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
84
85 # Install shell symlink
86 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
87 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
88
89 # Install initscripts
90 echo "* Installing initscripts"
91 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
92 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
93
94 # Install db-config.d files
95 echo "* Installing db-config.d files"
96 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
97 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
98 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
99
100 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
101 ## Install omf_slicemgr.py
102 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
103 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
104 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
105
106 # Create log file for plcapi
107 mkdir -p $RPM_BUILD_ROOT/var/log
108 touch $RPM_BUILD_ROOT/var/log/plcapi.log
109 chown apache:apache $RPM_BUILD_ROOT/var/log/plcapi.log
110
111 # Install ratelimit log
112 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
113 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 ###%define php_extension_dir %(php-config --extension-dir)
119
120 %files
121 %defattr(-,root,root,-)
122 %dir %{_datadir}/plc_api
123 #%dir /var/log/omf/
124 %{_datadir}/plc_api/*
125 %{_bindir}/plcsh
126 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
127 /etc/plc.d
128 /etc/planetlab/db-config.d
129 #/usr/bin/omf_slicemgr.py*
130 #/usr/bin/reset_xmpp_pubsub_nodes.py*
131 /var/log/plcapi.log
132 /var/log/plc_api_ratelimit.log
133
134
135 %changelog
136 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plcapi-7.0-0
137 - based on python3, runs on f27 and f29
138 - removed dependency to aspects, and so to rate limits
139 - remove dependency to the Django rpm that is no longer available in f29
140 - remove deps to python-twisted
141 - use systemctl rather than service to manage postgresql
142
143 * Wed May 16 2018 Thierry <Parmentelat> - plcapi-5.4-1
144 - define accessor for site tag disabled_registration (used in plewww-5.2-9)
145 - set disable_existing_loggers = False in logging config, that otherwise voids sfa logs
146
147 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.4-0
148 - embed phpxmlrpc as a git subtree from github (OK with fedora24 and 25, probably sooner too)
149 - logs in /var/log/plcapi.log
150 - context managers for most open files
151
152 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
153 - mostly issued for the R2lab deployment
154 - *** major
155 - * dots allowed in login_base and slice name
156 - * new lease filter 'day'
157 - *** minor
158 - * more explicit message in case of overlapping resas
159 - * bugfix: escaping unicode in xml
160 - * GetLeases allowed to anonymous callers
161 - *** miscell
162 - * use plain json library
163
164 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
165 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
166
167 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
168 - new bootstate 'upgrade' is like reinstall but leaves slices intact
169
170 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
171 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
172
173 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
174 - reviewed logging strategy, no more direct print but use log instead
175
176 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
177 - extensions for the ipv6 feature
178 - DeleteSliceTag can be run with the 'node' auth
179 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
180 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
181
182 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
183 - allow GetSlices to filter on tags as well
184
185 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
186 - enable filtering on tags (like hrn) with GetPersons and GetSites
187
188 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
189 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
190
191 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
192 - don't use PyXML that is deprecated in f20, use lxml instead
193 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
194
195 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
196 - create accessor 'hrn' for site as well
197 - create accessors 'sfa_created' for site/slice/person
198 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
199 - UpdatePerson() updates Person HRN according to updated email.
200 - UpdateSite() updates Site HRN according to updated login_base.
201 - Fix AddPersonToSite().
202 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
203 - RefreshPeer() manages Site*Person and Person*Role relationships.
204
205 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
206 - provide a slicename_to_hrn function
207
208 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
209 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
210
211 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
212 - fix for wsgi-based deployments, each thread has its own api()
213
214 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
215 - also cleanup omf-slicemgr initscript
216
217 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
218 - tear down omf-related aspects as this is no longer needed with omfv6
219
220 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
221 - also expose 'expires' in ResolveSlices
222
223 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
224 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
225
226 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
227 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
228
229 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
230 - use SFA code for computing hrn's when available
231
232 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
233 - new slice tag 'interface' for configuring a virtual interface
234 - new builtin 030-interface_tags
235 - new node accessor and tag 'virt' for mixing lxc & vs nodes
236 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
237 - moved ModPypthon and plc.wsgi in the apache/ subdir
238 - renamed PLCAPI.spec into plcapi.spec
239 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
240 - support for php-5.4
241
242 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
243 - implement PLC_VSYS_DEFAULTS in AddSlice
244
245 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
246 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
247 - AddPerson and UpdatePerson are now tag-aware
248 - as a side-effect AddPerson is more picky and rejects invalid fields
249 - which results in a requirement to use sfa-2.1-22 with this tag
250 - marginal improvement on the xml doc on tags
251
252 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
253 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
254 - reset_xmpp_pubsub_nodes now hos options and usage
255 - new Accessors for vicci
256
257 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
258 - fixed imports for tags management with sites and persons
259 - add predefined 'cpu_freezable' tag
260
261 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
262 - tweaks in interface initialization
263 - has 'vsys_vnet' as a predefined tagtype
264 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
265 - bugfix: GetSlivers & nodegroups
266 - bugfix: in jabber groups management
267
268 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
269 - fix gpg-authentication for Persons (thanks Jordan)
270 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
271 - ip address/network check: v4 or v6
272 - customized DB Message survive upgrade
273 - make sync works in lxc-hosted tests
274 - no svn keywords anymore
275
276 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
277 - fix sorting for methods list in docs
278 - untested but needed tweak for postgres startup in f16
279
280 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
281 - tweaks in postgresql setup - in line with sfa
282
283 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
284 - slight tweaks in Persons.py
285
286 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
287 - GetSession has support for more than one day sessions
288 - reset_xmpp_pubsub_nodes is much more efficient
289 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
290 - bugfix - deleting a person in the middle of the signup process
291
292 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
293 - ratelimit aspects
294 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
295 - requires Django for cache_utils
296 - attempt to expose 'pldistro' to sfa
297 - last_time_spent_online, last_time_spent_offline: new fields in Node
298 - new slice tags 'isolate_loopback' and 'cpu_cores'
299 - refresh-peer federation logs dump exceptions
300 - modpython logs have a timestamp
301 - more verbose/accurate php error reporting
302 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
303 - AddNode, UpdateNode: manage tags directly rather than through another method
304 - BootUpdateNode: only update once
305 - GetPersons: techs can access the list of persons on their site
306 - GetSlices and GetSliceTags: techs can see slices on their nodes
307 - GetSlivers: isrootonsite tag; cacheable
308
309 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
310 - rename initscript_body into initscript_code
311
312 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
313 - new initscript_body tag
314
315 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
316 - working draft for GetSliceSshKeys
317
318 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
319 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
320 - (this is for people who cancel their download)
321
322 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
323 - fix db-config sequence : accessors step now merged in, and occurs at the right time
324 - db-config also more robust
325 - no more explicit 'accessors' step in plc.d
326
327 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
328 - session auth: do *not* delete session when node runs a method that does not have 'node' role
329 - session auth: remove support for bootonce in old boot CDs
330 - give a reason when caller_may_write_slice_tag fails
331 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
332
333 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
334 - SetSliceVref needed the node role
335 - protect GetSliceFamily
336 - Fix bugs in tag authorizations
337
338 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
339 - altered checking of optional fields in Interfaces
340 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
341 - has pyxml and python-simplejson as new deps
342
343 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
344 - tweak doc extraction for fedora14
345
346 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
347 - builtin accessors for the myslice page
348 - Get{Node,Interface}Tags allowed to techs
349 - tweak in ratelimitaspect.py
350
351 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
352 - add admin role to accessor-related tags (arch, {fc,pl}distro)
353
354 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
355 - bugfix in {Update,Delete}PersonTag
356 - updated xml doc for filters, accessors and tagtypes
357 - more explicit msg in case of missing roles
358 - improvements in ratelimitaspects.py
359
360 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
361 - fix the roles for ssh_key and hmac tags
362
363 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
364 - tag permissions system based on roles and not min_role_ids
365 - accessors simplified accordingly (no more min_role_id)
366 - new methods AddRoleToTagType and DeleteRoleFromTagType
367 - accessor-related tagtypes are created sooner, and enforced
368 - cleaned up redundancy between db-config.d and accessors
369
370 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
371 - fix RefreshPeer that was not working in 5.0-17
372
373 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
374 - RefreshPeer is able to cope with 2 peers running different releases of the api
375 - DeletePerson can be used on duplicates
376 - first appearance of ModPythonJson.py
377
378 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
379 - set accessors return the new value
380 - tweaks in the pubsub groups management
381
382 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
383 - convert hostnames to lower case and use ILIKE instead of LIKE
384
385 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
386 - use hrn in pubsub groups
387
388 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
389 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
390 - OMF fixes
391
392 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
393 - automatically set vsys tag for omf controlled slices
394
395 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
396 - addition of the 'ssh_key' slice tag
397 - first draft of the LDAP interface
398
399 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
400 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
401 - and readable through GetLeaseGranularity
402 - GetSlivers to expose reservation_policy and lease_granularity
403 - GetBootMedium fixed for reservable nodes
404 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
405 - new Apache mod_wsgi python interface
406
407 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
408 - the leases system
409
410 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
411 - previous tag had gone wrong
412
413 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
414 - fix pubsub hostname
415
416 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
417 - tweaks for the omf support (xmpp groups and RC-controlled slices)
418 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
419 - GetNodeFlavour exposes fcdistro
420
421 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
422 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
423
424 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
425 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
426 - pyaspect hooks allow to  maintain the namespace xmpp groups
427 - new omf_slicemgr is a proxy to xmpp, used by these hooks
428 - nodes have their hrn exposed in the 'hrn' tag
429 - node hrn exposed in GetSlivers, as well as the overall xmpp config
430 - system slice 'drl' gets created by db-config
431 - daniel's changes to Filter for supporting wildcards in lists
432 - AddSliceTag consistency check tweaked
433
434 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
435 - major cleanup
436 - get rid of all 4.2-related legacy code
437 - reset the migrations code, planetlab5.sql somes with (5,100)
438 - uses hashlib module when available
439
440 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
441 - first working version of 5.0:
442 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
443 - nodefamily is 3-fold with pldistro-fcdistro-arch
444 - site and person tags
445 - new methods GetSliceFamily and GetNodeFlavour
446 - deprecated the dummynet stuff that were for the external dummyboxes
447 - tags definition : more consistency between db-config scripts and accessors
448 - (get accessor to create the tag type too if absent)
449 - logging an event for AddSliceToNodes
450
451 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
452 - support for fedora 12
453 - fix subtle bug in filtering with ] and quotes
454
455 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
456 - * patch for php-5.3 (the one in f12)
457 - * validate email addresses with regex
458 - * add PersonTags and SiteTags
459 - * add additional accessors for node tags (kvariant, serial, ..)
460
461 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
462 - Redacting password, session, and authstring values from the event log.
463
464 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
465 - let AddSite set ext_consortium_id - required for the poorman registration pages
466 - drop version constraint on Requires: postgresql-python
467 - don't log system calls nor ReportRunLevel
468
469 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
470 - Fix requires for CentOS.
471
472 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
473 - Require postgresql 8.2 (for array operators && and @>)
474
475 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
476 - Filter now supports the | and & features to match in sequence values
477 - bugfix in the postgresql wrapper for sequence filter values
478 - reviewed GetSlivers to export admin keys more efficiently
479 - fix checking roles in UpdateSliceTag
480
481 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
482 - - Some typos in the documentation were fixed.
483 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
484 - to the tag's min_role_id.
485
486 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
487
488 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
489 - Ongoing work to add upcalls, using new SFA class
490 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
491 - reviewed type-checking for the 3 taggable classes node-interface-slice
492 - cleanup ald dummynet stuff
493 - expose the 'extensions' accessors to the API
494 - tweaked checks in AddSliceTag
495 - GetPersons exposes roles by default
496 - bugfix in ReportRunLevel for non-string levels
497 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
498
499 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
500 - new BindObjectToPeer method for sfa
501 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
502
503 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
504 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
505 - reportrunlevel logs its calls only when run_level changes
506 - pycurl more robust wrt to xmlrpclib.Transport
507
508 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
509 - produce a wsdl interface
510 - bugfix in getbootmedium for nodes with interface tags
511
512 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
513 - bugfix for some rare pattern-based filters
514
515 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
516 - improvements in the 4.2 legacy layer
517
518 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
519 - bugfix required for slice tags set on nodegroups
520
521 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
522 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
523
524 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
525 - more powerful legacy layer with 4.2
526
527 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
528 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
529 - migration script has an option for running interactively
530
531 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
532 - skips already added entries
533
534 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
535 - yet another set of fixes for external dummynet boxes
536
537 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
538 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
539 - and tmp file is cleaned up
540
541 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
542 - restore missing ResolveSlices
543
544 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
545 - new method GetDummyBoxMedium
546
547 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
548 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
549
550 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
551 - support for external dummynet boxes back in 4.3 - first draft
552
553 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
554 - fixes for smooth federation between 4.2 and 4.3
555 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
556
557 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
558 - support for BootCD variants (GetBootMedium ['variant:centos5'])
559 - fix corner case with filters like {'~slice_id':[]}
560 - fix transaction leak that caused the db connections pool to exhaust
561 - properly expose all methods, including Legacy/, and not only Methods/
562
563 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
564 - renumbered as 4.3
565 - nodes have new fields run_level (in addition to boot_state) and verified
566 - tweaked migration from 4.2
567 - tuned rpm dependencies
568 - doc generation more explicit about errors like missing python modules
569 - removed obsolete method GetSlicesMD5
570
571 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
572 - unified all tags
573 - renamed interface settings into interface tags and slice attributes into slice tags
574 - nodes have a node_type
575 - various changes on the way to 4.3
576
577 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
578 - Checkpointing : this version still has interface settings and slice attributes
579
580 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
581 - first iteration with taggable nodes/interfaces/slices
582 - embryo for ilinks
583 - cleaned up boot states
584 - migration script moslty complete
585
586 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
587 - fixed doc build by locating locally installed DTDs at build-time
588
589 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
590 - no more doc packaged outside of myplc-docs - doc/ cleaned up
591 - enhancements in doc on filters
592 - bootcd-aware GetBootMedium merged from onelab
593
594 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
595 - checkpoint while the new myplc-docs package is underway
596 - bugfix: GetSlivers & conf files
597 - doc: removed target files
598
599 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
600 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
601 - the non-deleted fields were index, resulting in massivly slow queries.
602 -
603
604 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
605 - plcsh: better handling of options when running as a shell script
606 - getbootmedium exports compute_key
607 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
608
609 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
610 - GetBootMedium support for build.sh full options, incl. serial & console_spec
611 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
612
613 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
614 - refresh peer script to use a month-dependent logfile
615 - tracking the starting point for UniPi integration of the dummynet boxes
616
617 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
618 - plcsh adds its own path to sys.path
619 - fix so GetNodes can be called from a Node
620
621 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> -
622 - Initial build.
623
624 %define module_current_branch 4.3