trying out the hint from github issue
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 11
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 # Fedora had support for SOAPpy up to fedora20
36 # https://lists.fedoraproject.org/pipermail/devel/2014-June/199730.html
37 # https://lists.fedoraproject.org/pipermail/devel/2014-June/200379.html
38 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
39 Requires: SOAPpy
40 %endif
41 #Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50 # for memcache
51 Requires: memcached python-memcached
52 ### avoid having yum complain about updates, as stuff is moving around
53 # plc.d/api
54 Conflicts: MyPLC <= 4.3
55 # xmlrpc
56 Requires: php-xmlrpc
57
58 # We use psycopg2
59 #
60 # but we don't need to rebuild it as we depend on distro's packages - baris
61 # BuildRequires: postgresql-devel
62
63 ### # Standard xmlrpc.so that ships with PHP does not marshal NULL
64 ### # for building the wsdl interface we used to require PyXML
65 ### # but this has gone with f20 so turning this off for now
66 ### BuildRequires: php-devel
67 ### #BuildRequires: python-simplejson
68 ### Obsoletes: php-xmlrpc
69 ### Provides: php-xmlrpc
70
71 # PostgreSQL and SOAPpy are necessary to run the API server, but not
72 # plcsh. Since the only supported method of running the server is via
73 # MyPLC anyway, don't be so stringent about binary requirements, in
74 # case people want to install this package just for plcsh.
75 # Requires: postgresql-server, SOAPpy
76 AutoReqProv: no
77
78 %description
79 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
80 PlanetLab Central (PLC) database. The API may be accessed directly via
81 the Python shell program plcsh, through a toy standalone server, or
82 through Apache mod_python.
83
84 %prep
85 %setup -q
86
87 %build
88 # python-pycurl and python-psycopg2 avail. from fedora 5
89 # we used to ship our own version of psycopg2 and pycurl, for fedora4
90 # starting with 4.3, support for these two modules is taken out
91
92 # Build __init__.py metafiles and PHP API. 
93 %{__make} %{?_smp_mflags}
94 %{__make} -C wsdl
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
99
100 # Install shell symlink
101 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
102 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
103
104 ### mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
105 ### cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
106 ### ; Enable xmlrpc extension module
107 ### extension=xmlrpc.so
108 ### EOF
109
110 # Install initscripts
111 echo "* Installing initscripts"
112 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
113 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
114
115 # Install db-config.d files
116 echo "* Installing db-config.d files"
117 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
118 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
119 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
120
121 # Install wsdl
122 echo "* Installing wsdl"
123 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
124
125 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
126 ## Install omf_slicemgr.py
127 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
128 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
129 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
130
131 # Install ratelimit log
132 mkdir -p $RPM_BUILD_ROOT/var/log
133 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
134 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 ###%define php_extension_dir %(php-config --extension-dir)
140
141 %files
142 %defattr(-,root,root,-)
143 %dir %{_datadir}/plc_api
144 #%dir /var/log/omf/
145 %{_datadir}/plc_api/*
146 %{_bindir}/plcsh
147 ### %{php_extension_dir}/xmlrpc.so
148 ### %{_sysconfdir}/php.d/xmlrpc.ini
149 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
150 /etc/plc.d
151 /etc/planetlab/db-config.d
152 /var/www/html/wsdl/plcapi.wsdl
153 #/usr/bin/omf_slicemgr.py*
154 #/usr/bin/reset_xmpp_pubsub_nodes.py*
155 /var/log/plc_api_ratelimit.log
156
157
158 %changelog
159 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
160 - mostly issued for the R2lab deployment
161 - *** major
162 - * dots allowed in login_base and slice name
163 - * new lease filter 'day'
164 - *** minor
165 - * more explicit message in case of overlapping resas
166 - * bugfix: escaping unicode in xml
167 - * GetLeases allowed to anonymous callers
168 - *** miscell
169 - * use plain json library
170
171 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
172 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
173
174 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
175 - new bootstate 'upgrade' is like reinstall but leaves slices intact
176
177 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
178 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
179
180 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
181 - reviewed logging strategy, no more direct print but use log instead
182
183 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
184 - extensions for the ipv6 feature
185 - DeleteSliceTag can be run with the 'node' auth
186 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
187 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
188
189 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
190 - allow GetSlices to filter on tags as well
191
192 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
193 - enable filtering on tags (like hrn) with GetPersons and GetSites
194
195 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
196 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
197
198 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
199 - don't use PyXML that is deprecated in f20, use lxml instead
200 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
201
202 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
203 - create accessor 'hrn' for site as well
204 - create accessors 'sfa_created' for site/slice/person
205 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
206 - UpdatePerson() updates Person HRN according to updated email.
207 - UpdateSite() updates Site HRN according to updated login_base.
208 - Fix AddPersonToSite().
209 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
210 - RefreshPeer() manages Site*Person and Person*Role relationships.
211
212 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
213 - provide a slicename_to_hrn function
214
215 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
216 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
217
218 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
219 - fix for wsgi-based deployments, each thread has its own api()
220
221 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
222 - also cleanup omf-slicemgr initscript
223
224 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
225 - tear down omf-related aspects as this is no longer needed with omfv6
226
227 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
228 - also expose 'expires' in ResolveSlices
229
230 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
231 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
232
233 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
234 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
235
236 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
237 - use SFA code for computing hrn's when available
238
239 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
240 - new slice tag 'interface' for configuring a virtual interface
241 - new builtin 030-interface_tags
242 - new node accessor and tag 'virt' for mixing lxc & vs nodes
243 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
244 - moved ModPypthon and plc.wsgi in the apache/ subdir
245 - renamed PLCAPI.spec into plcapi.spec
246 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
247 - support for php-5.4
248
249 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
250 - implement PLC_VSYS_DEFAULTS in AddSlice
251
252 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
253 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
254 - AddPerson and UpdatePerson are now tag-aware
255 - as a side-effect AddPerson is more picky and rejects invalid fields
256 - which results in a requirement to use sfa-2.1-22 with this tag
257 - marginal improvement on the xml doc on tags
258
259 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
260 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
261 - reset_xmpp_pubsub_nodes now hos options and usage
262 - new Accessors for vicci
263
264 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
265 - fixed imports for tags management with sites and persons
266 - add predefined 'cpu_freezable' tag
267
268 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
269 - tweaks in interface initialization
270 - has 'vsys_vnet' as a predefined tagtype
271 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
272 - bugfix: GetSlivers & nodegroups
273 - bugfix: in jabber groups management
274
275 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
276 - fix gpg-authentication for Persons (thanks Jordan)
277 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
278 - ip address/network check: v4 or v6
279 - customized DB Message survive upgrade
280 - make sync works in lxc-hosted tests
281 - no svn keywords anymore
282
283 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
284 - fix sorting for methods list in docs
285 - untested but needed tweak for postgres startup in f16
286
287 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
288 - tweaks in postgresql setup - in line with sfa
289
290 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
291 - slight tweaks in Persons.py
292
293 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
294 - GetSession has support for more than one day sessions
295 - reset_xmpp_pubsub_nodes is much more efficient
296 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
297 - bugfix - deleting a person in the middle of the signup process
298
299 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
300 - ratelimit aspects
301 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
302 - requires Django for cache_utils
303 - attempt to expose 'pldistro' to sfa
304 - last_time_spent_online, last_time_spent_offline: new fields in Node
305 - new slice tags 'isolate_loopback' and 'cpu_cores'
306 - refresh-peer federation logs dump exceptions
307 - modpython logs have a timestamp
308 - more verbose/accurate php error reporting
309 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
310 - AddNode, UpdateNode: manage tags directly rather than through another method
311 - BootUpdateNode: only update once
312 - GetPersons: techs can access the list of persons on their site
313 - GetSlices and GetSliceTags: techs can see slices on their nodes
314 - GetSlivers: isrootonsite tag; cacheable
315
316 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
317 - rename initscript_body into initscript_code
318
319 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
320 - new initscript_body tag
321
322 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
323 - working draft for GetSliceSshKeys
324
325 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
326 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
327 - (this is for people who cancel their download)
328
329 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
330 - fix db-config sequence : accessors step now merged in, and occurs at the right time
331 - db-config also more robust
332 - no more explicit 'accessors' step in plc.d
333
334 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
335 - session auth: do *not* delete session when node runs a method that does not have 'node' role
336 - session auth: remove support for bootonce in old boot CDs
337 - give a reason when caller_may_write_slice_tag fails
338 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
339
340 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
341 - SetSliceVref needed the node role
342 - protect GetSliceFamily
343 - Fix bugs in tag authorizations
344
345 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
346 - altered checking of optional fields in Interfaces
347 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
348 - has pyxml and python-simplejson as new deps
349
350 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
351 - tweak doc extraction for fedora14
352
353 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
354 - builtin accessors for the myslice page
355 - Get{Node,Interface}Tags allowed to techs
356 - tweak in ratelimitaspect.py
357
358 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
359 - add admin role to accessor-related tags (arch, {fc,pl}distro)
360
361 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
362 - bugfix in {Update,Delete}PersonTag
363 - updated xml doc for filters, accessors and tagtypes
364 - more explicit msg in case of missing roles
365 - improvements in ratelimitaspects.py
366
367 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
368 - fix the roles for ssh_key and hmac tags
369
370 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
371 - tag permissions system based on roles and not min_role_ids
372 - accessors simplified accordingly (no more min_role_id)
373 - new methods AddRoleToTagType and DeleteRoleFromTagType
374 - accessor-related tagtypes are created sooner, and enforced
375 - cleaned up redundancy between db-config.d and accessors
376
377 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
378 - fix RefreshPeer that was not working in 5.0-17
379
380 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
381 - RefreshPeer is able to cope with 2 peers running different releases of the api
382 - DeletePerson can be used on duplicates
383 - first appearance of ModPythonJson.py
384
385 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
386 - set accessors return the new value
387 - tweaks in the pubsub groups management
388
389 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
390 - convert hostnames to lower case and use ILIKE instead of LIKE
391
392 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
393 - use hrn in pubsub groups
394
395 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
396 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
397 - OMF fixes
398
399 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
400 - automatically set vsys tag for omf controlled slices
401
402 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
403 - addition of the 'ssh_key' slice tag
404 - first draft of the LDAP interface
405
406 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
407 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
408 - and readable through GetLeaseGranularity
409 - GetSlivers to expose reservation_policy and lease_granularity
410 - GetBootMedium fixed for reservable nodes
411 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
412 - new Apache mod_wsgi python interface
413
414 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
415 - the leases system
416
417 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
418 - previous tag had gone wrong
419
420 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
421 - fix pubsub hostname
422
423 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
424 - tweaks for the omf support (xmpp groups and RC-controlled slices)
425 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
426 - GetNodeFlavour exposes fcdistro
427
428 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
429 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
430
431 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
432 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
433 - pyaspect hooks allow to  maintain the namespace xmpp groups
434 - new omf_slicemgr is a proxy to xmpp, used by these hooks
435 - nodes have their hrn exposed in the 'hrn' tag
436 - node hrn exposed in GetSlivers, as well as the overall xmpp config
437 - system slice 'drl' gets created by db-config
438 - daniel's changes to Filter for supporting wildcards in lists
439 - AddSliceTag consistency check tweaked
440
441 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
442 - major cleanup
443 - get rid of all 4.2-related legacy code
444 - reset the migrations code, planetlab5.sql somes with (5,100)
445 - uses hashlib module when available
446
447 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
448 - first working version of 5.0:
449 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
450 - nodefamily is 3-fold with pldistro-fcdistro-arch
451 - site and person tags
452 - new methods GetSliceFamily and GetNodeFlavour
453 - deprecated the dummynet stuff that were for the external dummyboxes
454 - tags definition : more consistency between db-config scripts and accessors
455 - (get accessor to create the tag type too if absent)
456 - logging an event for AddSliceToNodes
457
458 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
459 - support for fedora 12
460 - fix subtle bug in filtering with ] and quotes
461
462 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
463 - * patch for php-5.3 (the one in f12)
464 - * validate email addresses with regex
465 - * add PersonTags and SiteTags
466 - * add additional accessors for node tags (kvariant, serial, ..)
467
468 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
469 - Redacting password, session, and authstring values from the event log.
470
471 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
472 - let AddSite set ext_consortium_id - required for the poorman registration pages
473 - drop version constraint on Requires: postgresql-python
474 - don't log system calls nor ReportRunLevel
475
476 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
477 - Fix requires for CentOS.
478
479 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
480 - Require postgresql 8.2 (for array operators && and @>)
481
482 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
483 - Filter now supports the | and & features to match in sequence values
484 - bugfix in the postgresql wrapper for sequence filter values
485 - reviewed GetSlivers to export admin keys more efficiently
486 - fix checking roles in UpdateSliceTag
487
488 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
489 - - Some typos in the documentation were fixed.
490 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
491 - to the tag's min_role_id.
492
493 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
494
495 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
496 - Ongoing work to add upcalls, using new SFA class
497 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
498 - reviewed type-checking for the 3 taggable classes node-interface-slice
499 - cleanup ald dummynet stuff
500 - expose the 'extensions' accessors to the API
501 - tweaked checks in AddSliceTag
502 - GetPersons exposes roles by default
503 - bugfix in ReportRunLevel for non-string levels
504 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
505
506 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
507 - new BindObjectToPeer method for sfa
508 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
509
510 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
511 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
512 - reportrunlevel logs its calls only when run_level changes
513 - pycurl more robust wrt to xmlrpclib.Transport
514
515 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
516 - produce a wsdl interface
517 - bugfix in getbootmedium for nodes with interface tags
518
519 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
520 - bugfix for some rare pattern-based filters
521
522 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
523 - improvements in the 4.2 legacy layer
524
525 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
526 - bugfix required for slice tags set on nodegroups
527
528 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
529 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
530
531 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
532 - more powerful legacy layer with 4.2
533
534 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
535 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
536 - migration script has an option for running interactively
537
538 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
539 - skips already added entries
540
541 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
542 - yet another set of fixes for external dummynet boxes
543
544 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
545 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
546 - and tmp file is cleaned up
547
548 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
549 - restore missing ResolveSlices
550
551 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
552 - new method GetDummyBoxMedium
553
554 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
555 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
556
557 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
558 - support for external dummynet boxes back in 4.3 - first draft
559
560 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
561 - fixes for smooth federation between 4.2 and 4.3
562 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
563
564 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
565 - support for BootCD variants (GetBootMedium ['variant:centos5'])
566 - fix corner case with filters like {'~slice_id':[]}
567 - fix transaction leak that caused the db connections pool to exhaust
568 - properly expose all methods, including Legacy/, and not only Methods/
569
570 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
571 - renumbered as 4.3
572 - nodes have new fields run_level (in addition to boot_state) and verified
573 - tweaked migration from 4.2
574 - tuned rpm dependencies
575 - doc generation more explicit about errors like missing python modules
576 - removed obsolete method GetSlicesMD5
577
578 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
579 - unified all tags
580 - renamed interface settings into interface tags and slice attributes into slice tags
581 - nodes have a node_type
582 - various changes on the way to 4.3
583
584 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
585 - Checkpointing : this version still has interface settings and slice attributes
586
587 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
588 - first iteration with taggable nodes/interfaces/slices
589 - embryo for ilinks
590 - cleaned up boot states
591 - migration script moslty complete
592
593 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
594 - fixed doc build by locating locally installed DTDs at build-time
595
596 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
597 - no more doc packaged outside of myplc-docs - doc/ cleaned up
598 - enhancements in doc on filters 
599 - bootcd-aware GetBootMedium merged from onelab
600
601 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
602 - checkpoint while the new myplc-docs package is underway
603 - bugfix: GetSlivers & conf files
604 - doc: removed target files 
605
606 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
607 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
608 - the non-deleted fields were index, resulting in massivly slow queries.
609
610
611 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
612 - plcsh: better handling of options when running as a shell script
613 - getbootmedium exports compute_key
614 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
615
616 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
617 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
618 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
619
620 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
621 - refresh peer script to use a month-dependent logfile
622 - tracking the starting point for UniPi integration of the dummynet boxes
623
624 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
625 - plcsh adds its own path to sys.path
626 - fix so GetNodes can be called from a Node
627
628 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
629 - Initial build.
630
631 %define module_current_branch 4.3