Setting tag plcapi-5.3-9
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 9
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 # Fedora had support for SOAPpy up to fedora20
36 # https://lists.fedoraproject.org/pipermail/devel/2014-June/199730.html
37 # https://lists.fedoraproject.org/pipermail/devel/2014-June/200379.html
38 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
39 Requires: SOAPpy
40 %endif
41 Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50 # for memcache
51 Requires: memcached python-memcached
52 ### avoid having yum complain about updates, as stuff is moving around
53 # plc.d/api
54 Conflicts: MyPLC <= 4.3
55
56 # We use psycopg2
57 #
58 # but we don't need to rebuild it as we depend on distro's packages - baris
59 # BuildRequires: postgresql-devel
60
61 # Standard xmlrpc.so that ships with PHP does not marshal NULL
62 # for building the wsdl interface we used to require PyXML
63 # but this has gone with f20 so turning this off for now
64 BuildRequires: php-devel python-simplejson
65 Obsoletes: php-xmlrpc
66 Provides: php-xmlrpc
67
68 # PostgreSQL and SOAPpy are necessary to run the API server, but not
69 # plcsh. Since the only supported method of running the server is via
70 # MyPLC anyway, don't be so stringent about binary requirements, in
71 # case people want to install this package just for plcsh.
72 # Requires: postgresql-server, SOAPpy
73 AutoReqProv: no
74
75 %description
76 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
77 PlanetLab Central (PLC) database. The API may be accessed directly via
78 the Python shell program plcsh, through a toy standalone server, or
79 through Apache mod_python.
80
81 %prep
82 %setup -q
83
84 %build
85 # python-pycurl and python-psycopg2 avail. from fedora 5
86 # we used to ship our own version of psycopg2 and pycurl, for fedora4
87 # starting with 4.3, support for these two modules is taken out
88
89 # Build __init__.py metafiles and PHP API. 
90 %{__make} %{?_smp_mflags}
91 %{__make} -C wsdl
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
96
97 # Install shell symlink
98 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
99 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
100
101 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
102 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
103 ; Enable xmlrpc extension module
104 extension=xmlrpc.so
105 EOF
106
107 # Install initscripts
108 echo "* Installing initscripts"
109 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
110 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
111
112 # Install db-config.d files
113 echo "* Installing db-config.d files"
114 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
115 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
116 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
117
118 # Install wsdl
119 echo "* Installing wsdl"
120 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
121
122 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
123 ## Install omf_slicemgr.py
124 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
125 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
126 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
127
128 # Install ratelimit log
129 mkdir -p $RPM_BUILD_ROOT/var/log
130 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
131 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %define php_extension_dir %(php-config --extension-dir)
137
138 %files
139 %defattr(-,root,root,-)
140 %dir %{_datadir}/plc_api
141 #%dir /var/log/omf/
142 %{_datadir}/plc_api/*
143 %{_bindir}/plcsh
144 %{php_extension_dir}/xmlrpc.so
145 %{_sysconfdir}/php.d/xmlrpc.ini
146 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
147 /etc/plc.d
148 /etc/planetlab/db-config.d
149 /var/www/html/wsdl/plcapi.wsdl
150 #/usr/bin/omf_slicemgr.py*
151 #/usr/bin/reset_xmpp_pubsub_nodes.py*
152 /var/log/plc_api_ratelimit.log
153
154
155 %changelog
156 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
157 - new bootstate 'upgrade' is like reinstall but leaves slices intact
158
159 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
160 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
161
162 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
163 - reviewed logging strategy, no more direct print but use log instead
164
165 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
166 - extensions for the ipv6 feature
167 - DeleteSliceTag can be run with the 'node' auth
168 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
169 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
170
171 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
172 - allow GetSlices to filter on tags as well
173
174 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
175 - enable filtering on tags (like hrn) with GetPersons and GetSites
176
177 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
178 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
179
180 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
181 - don't use PyXML that is deprecated in f20, use lxml instead
182 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
183
184 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
185 - create accessor 'hrn' for site as well
186 - create accessors 'sfa_created' for site/slice/person
187 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
188 - UpdatePerson() updates Person HRN according to updated email.
189 - UpdateSite() updates Site HRN according to updated login_base.
190 - Fix AddPersonToSite().
191 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
192 - RefreshPeer() manages Site*Person and Person*Role relationships.
193
194 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
195 - provide a slicename_to_hrn function
196
197 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
198 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
199
200 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
201 - fix for wsgi-based deployments, each thread has its own api()
202
203 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
204 - also cleanup omf-slicemgr initscript
205
206 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
207 - tear down omf-related aspects as this is no longer needed with omfv6
208
209 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
210 - also expose 'expires' in ResolveSlices
211
212 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
213 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
214
215 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
216 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
217
218 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
219 - use SFA code for computing hrn's when available
220
221 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
222 - new slice tag 'interface' for configuring a virtual interface
223 - new builtin 030-interface_tags
224 - new node accessor and tag 'virt' for mixing lxc & vs nodes
225 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
226 - moved ModPypthon and plc.wsgi in the apache/ subdir
227 - renamed PLCAPI.spec into plcapi.spec
228 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
229 - support for php-5.4
230
231 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
232 - implement PLC_VSYS_DEFAULTS in AddSlice
233
234 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
235 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
236 - AddPerson and UpdatePerson are now tag-aware
237 - as a side-effect AddPerson is more picky and rejects invalid fields
238 - which results in a requirement to use sfa-2.1-22 with this tag
239 - marginal improvement on the xml doc on tags
240
241 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
242 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
243 - reset_xmpp_pubsub_nodes now hos options and usage
244 - new Accessors for vicci
245
246 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
247 - fixed imports for tags management with sites and persons
248 - add predefined 'cpu_freezable' tag
249
250 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
251 - tweaks in interface initialization
252 - has 'vsys_vnet' as a predefined tagtype
253 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
254 - bugfix: GetSlivers & nodegroups
255 - bugfix: in jabber groups management
256
257 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
258 - fix gpg-authentication for Persons (thanks Jordan)
259 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
260 - ip address/network check: v4 or v6
261 - customized DB Message survive upgrade
262 - make sync works in lxc-hosted tests
263 - no svn keywords anymore
264
265 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
266 - fix sorting for methods list in docs
267 - untested but needed tweak for postgres startup in f16
268
269 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
270 - tweaks in postgresql setup - in line with sfa
271
272 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
273 - slight tweaks in Persons.py
274
275 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
276 - GetSession has support for more than one day sessions
277 - reset_xmpp_pubsub_nodes is much more efficient
278 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
279 - bugfix - deleting a person in the middle of the signup process
280
281 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
282 - ratelimit aspects
283 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
284 - requires Django for cache_utils
285 - attempt to expose 'pldistro' to sfa
286 - last_time_spent_online, last_time_spent_offline: new fields in Node
287 - new slice tags 'isolate_loopback' and 'cpu_cores'
288 - refresh-peer federation logs dump exceptions
289 - modpython logs have a timestamp
290 - more verbose/accurate php error reporting
291 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
292 - AddNode, UpdateNode: manage tags directly rather than through another method
293 - BootUpdateNode: only update once
294 - GetPersons: techs can access the list of persons on their site
295 - GetSlices and GetSliceTags: techs can see slices on their nodes
296 - GetSlivers: isrootonsite tag; cacheable
297
298 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
299 - rename initscript_body into initscript_code
300
301 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
302 - new initscript_body tag
303
304 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
305 - working draft for GetSliceSshKeys
306
307 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
308 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
309 - (this is for people who cancel their download)
310
311 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
312 - fix db-config sequence : accessors step now merged in, and occurs at the right time
313 - db-config also more robust
314 - no more explicit 'accessors' step in plc.d
315
316 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
317 - session auth: do *not* delete session when node runs a method that does not have 'node' role
318 - session auth: remove support for bootonce in old boot CDs
319 - give a reason when caller_may_write_slice_tag fails
320 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
321
322 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
323 - SetSliceVref needed the node role
324 - protect GetSliceFamily
325 - Fix bugs in tag authorizations
326
327 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
328 - altered checking of optional fields in Interfaces
329 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
330 - has pyxml and python-simplejson as new deps
331
332 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
333 - tweak doc extraction for fedora14
334
335 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
336 - builtin accessors for the myslice page
337 - Get{Node,Interface}Tags allowed to techs
338 - tweak in ratelimitaspect.py
339
340 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
341 - add admin role to accessor-related tags (arch, {fc,pl}distro)
342
343 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
344 - bugfix in {Update,Delete}PersonTag
345 - updated xml doc for filters, accessors and tagtypes
346 - more explicit msg in case of missing roles
347 - improvements in ratelimitaspects.py
348
349 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
350 - fix the roles for ssh_key and hmac tags
351
352 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
353 - tag permissions system based on roles and not min_role_ids
354 - accessors simplified accordingly (no more min_role_id)
355 - new methods AddRoleToTagType and DeleteRoleFromTagType
356 - accessor-related tagtypes are created sooner, and enforced
357 - cleaned up redundancy between db-config.d and accessors
358
359 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
360 - fix RefreshPeer that was not working in 5.0-17
361
362 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
363 - RefreshPeer is able to cope with 2 peers running different releases of the api
364 - DeletePerson can be used on duplicates
365 - first appearance of ModPythonJson.py
366
367 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
368 - set accessors return the new value
369 - tweaks in the pubsub groups management
370
371 * Wed Jul 28 2010 S.ÇaÄŸlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
372 - convert hostnames to lower case and use ILIKE instead of LIKE
373
374 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
375 - use hrn in pubsub groups
376
377 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
378 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
379 - OMF fixes
380
381 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
382 - automatically set vsys tag for omf controlled slices
383
384 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
385 - addition of the 'ssh_key' slice tag
386 - first draft of the LDAP interface
387
388 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
389 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
390 - and readable through GetLeaseGranularity
391 - GetSlivers to expose reservation_policy and lease_granularity
392 - GetBootMedium fixed for reservable nodes
393 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
394 - new Apache mod_wsgi python interface
395
396 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
397 - the leases system
398
399 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
400 - previous tag had gone wrong
401
402 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
403 - fix pubsub hostname
404
405 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
406 - tweaks for the omf support (xmpp groups and RC-controlled slices)
407 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
408 - GetNodeFlavour exposes fcdistro
409
410 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
411 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
412
413 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
414 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
415 - pyaspect hooks allow to  maintain the namespace xmpp groups
416 - new omf_slicemgr is a proxy to xmpp, used by these hooks
417 - nodes have their hrn exposed in the 'hrn' tag
418 - node hrn exposed in GetSlivers, as well as the overall xmpp config
419 - system slice 'drl' gets created by db-config
420 - daniel's changes to Filter for supporting wildcards in lists
421 - AddSliceTag consistency check tweaked
422
423 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
424 - major cleanup
425 - get rid of all 4.2-related legacy code
426 - reset the migrations code, planetlab5.sql somes with (5,100)
427 - uses hashlib module when available
428
429 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
430 - first working version of 5.0:
431 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
432 - nodefamily is 3-fold with pldistro-fcdistro-arch
433 - site and person tags
434 - new methods GetSliceFamily and GetNodeFlavour
435 - deprecated the dummynet stuff that were for the external dummyboxes
436 - tags definition : more consistency between db-config scripts and accessors
437 - (get accessor to create the tag type too if absent)
438 - logging an event for AddSliceToNodes
439
440 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
441 - support for fedora 12
442 - fix subtle bug in filtering with ] and quotes
443
444 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
445 - * patch for php-5.3 (the one in f12)
446 - * validate email addresses with regex
447 - * add PersonTags and SiteTags
448 - * add additional accessors for node tags (kvariant, serial, ..)
449
450 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
451 - Redacting password, session, and authstring values from the event log.
452
453 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
454 - let AddSite set ext_consortium_id - required for the poorman registration pages
455 - drop version constraint on Requires: postgresql-python
456 - don't log system calls nor ReportRunLevel
457
458 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
459 - Fix requires for CentOS.
460
461 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
462 - Require postgresql 8.2 (for array operators && and @>)
463
464 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
465 - Filter now supports the | and & features to match in sequence values
466 - bugfix in the postgresql wrapper for sequence filter values
467 - reviewed GetSlivers to export admin keys more efficiently
468 - fix checking roles in UpdateSliceTag
469
470 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
471 - - Some typos in the documentation were fixed.
472 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
473 - to the tag's min_role_id.
474
475 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
476
477 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
478 - Ongoing work to add upcalls, using new SFA class
479 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
480 - reviewed type-checking for the 3 taggable classes node-interface-slice
481 - cleanup ald dummynet stuff
482 - expose the 'extensions' accessors to the API
483 - tweaked checks in AddSliceTag
484 - GetPersons exposes roles by default
485 - bugfix in ReportRunLevel for non-string levels
486 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
487
488 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
489 - new BindObjectToPeer method for sfa
490 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
491
492 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
493 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
494 - reportrunlevel logs its calls only when run_level changes
495 - pycurl more robust wrt to xmlrpclib.Transport
496
497 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
498 - produce a wsdl interface
499 - bugfix in getbootmedium for nodes with interface tags
500
501 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
502 - bugfix for some rare pattern-based filters
503
504 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
505 - improvements in the 4.2 legacy layer
506
507 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
508 - bugfix required for slice tags set on nodegroups
509
510 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
511 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
512
513 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
514 - more powerful legacy layer with 4.2
515
516 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
517 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
518 - migration script has an option for running interactively
519
520 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
521 - skips already added entries
522
523 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
524 - yet another set of fixes for external dummynet boxes
525
526 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
527 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
528 - and tmp file is cleaned up
529
530 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
531 - restore missing ResolveSlices
532
533 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
534 - new method GetDummyBoxMedium
535
536 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
537 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
538
539 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
540 - support for external dummynet boxes back in 4.3 - first draft
541
542 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
543 - fixes for smooth federation between 4.2 and 4.3
544 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
545
546 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
547 - support for BootCD variants (GetBootMedium ['variant:centos5'])
548 - fix corner case with filters like {'~slice_id':[]}
549 - fix transaction leak that caused the db connections pool to exhaust
550 - properly expose all methods, including Legacy/, and not only Methods/
551
552 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
553 - renumbered as 4.3
554 - nodes have new fields run_level (in addition to boot_state) and verified
555 - tweaked migration from 4.2
556 - tuned rpm dependencies
557 - doc generation more explicit about errors like missing python modules
558 - removed obsolete method GetSlicesMD5
559
560 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
561 - unified all tags
562 - renamed interface settings into interface tags and slice attributes into slice tags
563 - nodes have a node_type
564 - various changes on the way to 4.3
565
566 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
567 - Checkpointing : this version still has interface settings and slice attributes
568
569 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
570 - first iteration with taggable nodes/interfaces/slices
571 - embryo for ilinks
572 - cleaned up boot states
573 - migration script moslty complete
574
575 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
576 - fixed doc build by locating locally installed DTDs at build-time
577
578 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
579 - no more doc packaged outside of myplc-docs - doc/ cleaned up
580 - enhancements in doc on filters 
581 - bootcd-aware GetBootMedium merged from onelab
582
583 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
584 - checkpoint while the new myplc-docs package is underway
585 - bugfix: GetSlivers & conf files
586 - doc: removed target files 
587
588 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
589 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
590 - the non-deleted fields were index, resulting in massivly slow queries.
591
592
593 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
594 - plcsh: better handling of options when running as a shell script
595 - getbootmedium exports compute_key
596 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
597
598 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
599 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
600 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
601
602 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
603 - refresh peer script to use a month-dependent logfile
604 - tracking the starting point for UniPi integration of the dummynet boxes
605
606 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
607 - plcsh adds its own path to sys.path
608 - fix so GetNodes can be called from a Node
609
610 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
611 - Initial build.
612
613 %define module_current_branch 4.3