get rid of ldap
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.4
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 # f29 does not come with an rpm for that; use pip instead
27 # Requires: Django
28 Requires: postgresql >= 8.2, postgresql-server >= 8.2
29 # We use set everywhere
30 Requires: python3
31 Requires: python3-postgresql
32 Requires: python3-psycopg2
33 Requires: python3-pycurl
34 # used in GPG.py as a replacement to PyXML's Canonicalize
35 Requires: python3-lxml
36 # for the RebootNodeWithPCU method
37 Requires: pcucontrol >= 1.0-6
38 # for OMF integration - xxx aspects needs porting too
39 Requires: pyaspects >= 0.4
40 # for memcache
41 Requires: memcached python3-memcached
42
43 ####################
44 # obsolete
45 ####################
46 # standard xmlrpc.so that ships with PHP does not marshal NULL
47 # prior to May 2017 we used to ship our own brew of xmlrpc but
48 # that does not build anymore on f25
49 # So bottom line is:
50 # * don't use fedora's php-xmlrpc (no support for marshalling NULL)
51 # * don't use our own that is way too old
52 # * instead - thank you Ciro - we pull it as a git subtree from
53 # https://github.com/gggeek/phpxmlrpc.git
54 # that stuff requires the following though
55 Requires: php-xml
56 ####################
57
58
59 # PostgreSQL and SOAPpy are necessary to run the API server, but not
60 # plcsh. Since the only supported method of running the server is via
61 # MyPLC anyway, don't be so stringent about binary requirements, in
62 # case people want to install this package just for plcsh.
63 # Requires: postgresql-server, SOAPpy
64 AutoReqProv: no
65
66 %description
67 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
68 PlanetLab Central (PLC) database. The API may be accessed directly via
69 the Python shell program plcsh, through a toy standalone server, or
70 through Apache mod_python.
71
72 %prep
73 %setup -q
74
75 %build
76 # python-pycurl and python-psycopg2 avail. from fedora 5
77 # we used to ship our own version of psycopg2 and pycurl, for fedora4
78 # starting with 4.3, support for these two modules is taken out
79 #
80 # Build __init__.py metafiles and PHP API.
81 %{__make} %{?_smp_mflags}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
86
87 # Install shell symlink
88 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
89 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
90
91 # Install initscripts
92 echo "* Installing initscripts"
93 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
94 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
95
96 # Install db-config.d files
97 echo "* Installing db-config.d files"
98 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
99 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
100 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
101
102 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
103 ## Install omf_slicemgr.py
104 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
105 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
106 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
107
108 # Create log file for plcapi
109 mkdir -p $RPM_BUILD_ROOT/var/log
110 touch $RPM_BUILD_ROOT/var/log/plcapi.log
111 chown apache:apache $RPM_BUILD_ROOT/var/log/plcapi.log
112
113 # Install ratelimit log
114 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
115 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 ###%define php_extension_dir %(php-config --extension-dir)
121
122 %files
123 %defattr(-,root,root,-)
124 %dir %{_datadir}/plc_api
125 #%dir /var/log/omf/
126 %{_datadir}/plc_api/*
127 %{_bindir}/plcsh
128 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
129 /etc/plc.d
130 /etc/planetlab/db-config.d
131 #/usr/bin/omf_slicemgr.py*
132 #/usr/bin/reset_xmpp_pubsub_nodes.py*
133 /var/log/plcapi.log
134 /var/log/plc_api_ratelimit.log
135
136
137 %changelog
138 * Wed May 16 2018 Thierry <Parmentelat> - plcapi-5.4-1
139 - define accessor for site tag disabled_registration (used in plewww-5.2-9)
140 - set disable_existing_loggers = False in logging config, that otherwise voids sfa logs
141
142 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.4-0
143 - embed phpxmlrpc as a git subtree from github (OK with fedora24 and 25, probably sooner too)
144 - logs in /var/log/plcapi.log
145 - context managers for most open files
146
147 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
148 - mostly issued for the R2lab deployment
149 - *** major
150 - * dots allowed in login_base and slice name
151 - * new lease filter 'day'
152 - *** minor
153 - * more explicit message in case of overlapping resas
154 - * bugfix: escaping unicode in xml
155 - * GetLeases allowed to anonymous callers
156 - *** miscell
157 - * use plain json library
158
159 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
160 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
161
162 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
163 - new bootstate 'upgrade' is like reinstall but leaves slices intact
164
165 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
166 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
167
168 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
169 - reviewed logging strategy, no more direct print but use log instead
170
171 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
172 - extensions for the ipv6 feature
173 - DeleteSliceTag can be run with the 'node' auth
174 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
175 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
176
177 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
178 - allow GetSlices to filter on tags as well
179
180 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
181 - enable filtering on tags (like hrn) with GetPersons and GetSites
182
183 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
184 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
185
186 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
187 - don't use PyXML that is deprecated in f20, use lxml instead
188 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
189
190 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
191 - create accessor 'hrn' for site as well
192 - create accessors 'sfa_created' for site/slice/person
193 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
194 - UpdatePerson() updates Person HRN according to updated email.
195 - UpdateSite() updates Site HRN according to updated login_base.
196 - Fix AddPersonToSite().
197 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
198 - RefreshPeer() manages Site*Person and Person*Role relationships.
199
200 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
201 - provide a slicename_to_hrn function
202
203 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
204 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
205
206 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
207 - fix for wsgi-based deployments, each thread has its own api()
208
209 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
210 - also cleanup omf-slicemgr initscript
211
212 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
213 - tear down omf-related aspects as this is no longer needed with omfv6
214
215 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
216 - also expose 'expires' in ResolveSlices
217
218 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
219 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
220
221 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
222 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
223
224 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
225 - use SFA code for computing hrn's when available
226
227 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
228 - new slice tag 'interface' for configuring a virtual interface
229 - new builtin 030-interface_tags
230 - new node accessor and tag 'virt' for mixing lxc & vs nodes
231 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
232 - moved ModPypthon and plc.wsgi in the apache/ subdir
233 - renamed PLCAPI.spec into plcapi.spec
234 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
235 - support for php-5.4
236
237 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
238 - implement PLC_VSYS_DEFAULTS in AddSlice
239
240 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
241 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
242 - AddPerson and UpdatePerson are now tag-aware
243 - as a side-effect AddPerson is more picky and rejects invalid fields
244 - which results in a requirement to use sfa-2.1-22 with this tag
245 - marginal improvement on the xml doc on tags
246
247 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
248 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
249 - reset_xmpp_pubsub_nodes now hos options and usage
250 - new Accessors for vicci
251
252 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
253 - fixed imports for tags management with sites and persons
254 - add predefined 'cpu_freezable' tag
255
256 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
257 - tweaks in interface initialization
258 - has 'vsys_vnet' as a predefined tagtype
259 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
260 - bugfix: GetSlivers & nodegroups
261 - bugfix: in jabber groups management
262
263 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
264 - fix gpg-authentication for Persons (thanks Jordan)
265 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
266 - ip address/network check: v4 or v6
267 - customized DB Message survive upgrade
268 - make sync works in lxc-hosted tests
269 - no svn keywords anymore
270
271 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
272 - fix sorting for methods list in docs
273 - untested but needed tweak for postgres startup in f16
274
275 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
276 - tweaks in postgresql setup - in line with sfa
277
278 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
279 - slight tweaks in Persons.py
280
281 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
282 - GetSession has support for more than one day sessions
283 - reset_xmpp_pubsub_nodes is much more efficient
284 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
285 - bugfix - deleting a person in the middle of the signup process
286
287 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
288 - ratelimit aspects
289 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
290 - requires Django for cache_utils
291 - attempt to expose 'pldistro' to sfa
292 - last_time_spent_online, last_time_spent_offline: new fields in Node
293 - new slice tags 'isolate_loopback' and 'cpu_cores'
294 - refresh-peer federation logs dump exceptions
295 - modpython logs have a timestamp
296 - more verbose/accurate php error reporting
297 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
298 - AddNode, UpdateNode: manage tags directly rather than through another method
299 - BootUpdateNode: only update once
300 - GetPersons: techs can access the list of persons on their site
301 - GetSlices and GetSliceTags: techs can see slices on their nodes
302 - GetSlivers: isrootonsite tag; cacheable
303
304 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
305 - rename initscript_body into initscript_code
306
307 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
308 - new initscript_body tag
309
310 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
311 - working draft for GetSliceSshKeys
312
313 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
314 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
315 - (this is for people who cancel their download)
316
317 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
318 - fix db-config sequence : accessors step now merged in, and occurs at the right time
319 - db-config also more robust
320 - no more explicit 'accessors' step in plc.d
321
322 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
323 - session auth: do *not* delete session when node runs a method that does not have 'node' role
324 - session auth: remove support for bootonce in old boot CDs
325 - give a reason when caller_may_write_slice_tag fails
326 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
327
328 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
329 - SetSliceVref needed the node role
330 - protect GetSliceFamily
331 - Fix bugs in tag authorizations
332
333 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
334 - altered checking of optional fields in Interfaces
335 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
336 - has pyxml and python-simplejson as new deps
337
338 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
339 - tweak doc extraction for fedora14
340
341 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
342 - builtin accessors for the myslice page
343 - Get{Node,Interface}Tags allowed to techs
344 - tweak in ratelimitaspect.py
345
346 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
347 - add admin role to accessor-related tags (arch, {fc,pl}distro)
348
349 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
350 - bugfix in {Update,Delete}PersonTag
351 - updated xml doc for filters, accessors and tagtypes
352 - more explicit msg in case of missing roles
353 - improvements in ratelimitaspects.py
354
355 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
356 - fix the roles for ssh_key and hmac tags
357
358 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
359 - tag permissions system based on roles and not min_role_ids
360 - accessors simplified accordingly (no more min_role_id)
361 - new methods AddRoleToTagType and DeleteRoleFromTagType
362 - accessor-related tagtypes are created sooner, and enforced
363 - cleaned up redundancy between db-config.d and accessors
364
365 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
366 - fix RefreshPeer that was not working in 5.0-17
367
368 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
369 - RefreshPeer is able to cope with 2 peers running different releases of the api
370 - DeletePerson can be used on duplicates
371 - first appearance of ModPythonJson.py
372
373 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
374 - set accessors return the new value
375 - tweaks in the pubsub groups management
376
377 * Wed Jul 28 2010 S.ÇaÄŸlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
378 - convert hostnames to lower case and use ILIKE instead of LIKE
379
380 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
381 - use hrn in pubsub groups
382
383 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
384 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
385 - OMF fixes
386
387 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
388 - automatically set vsys tag for omf controlled slices
389
390 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
391 - addition of the 'ssh_key' slice tag
392 - first draft of the LDAP interface
393
394 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
395 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
396 - and readable through GetLeaseGranularity
397 - GetSlivers to expose reservation_policy and lease_granularity
398 - GetBootMedium fixed for reservable nodes
399 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
400 - new Apache mod_wsgi python interface
401
402 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
403 - the leases system
404
405 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
406 - previous tag had gone wrong
407
408 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
409 - fix pubsub hostname
410
411 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
412 - tweaks for the omf support (xmpp groups and RC-controlled slices)
413 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
414 - GetNodeFlavour exposes fcdistro
415
416 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
417 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
418
419 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
420 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
421 - pyaspect hooks allow to  maintain the namespace xmpp groups
422 - new omf_slicemgr is a proxy to xmpp, used by these hooks
423 - nodes have their hrn exposed in the 'hrn' tag
424 - node hrn exposed in GetSlivers, as well as the overall xmpp config
425 - system slice 'drl' gets created by db-config
426 - daniel's changes to Filter for supporting wildcards in lists
427 - AddSliceTag consistency check tweaked
428
429 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
430 - major cleanup
431 - get rid of all 4.2-related legacy code
432 - reset the migrations code, planetlab5.sql somes with (5,100)
433 - uses hashlib module when available
434
435 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
436 - first working version of 5.0:
437 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
438 - nodefamily is 3-fold with pldistro-fcdistro-arch
439 - site and person tags
440 - new methods GetSliceFamily and GetNodeFlavour
441 - deprecated the dummynet stuff that were for the external dummyboxes
442 - tags definition : more consistency between db-config scripts and accessors
443 - (get accessor to create the tag type too if absent)
444 - logging an event for AddSliceToNodes
445
446 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
447 - support for fedora 12
448 - fix subtle bug in filtering with ] and quotes
449
450 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
451 - * patch for php-5.3 (the one in f12)
452 - * validate email addresses with regex
453 - * add PersonTags and SiteTags
454 - * add additional accessors for node tags (kvariant, serial, ..)
455
456 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
457 - Redacting password, session, and authstring values from the event log.
458
459 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
460 - let AddSite set ext_consortium_id - required for the poorman registration pages
461 - drop version constraint on Requires: postgresql-python
462 - don't log system calls nor ReportRunLevel
463
464 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
465 - Fix requires for CentOS.
466
467 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
468 - Require postgresql 8.2 (for array operators && and @>)
469
470 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
471 - Filter now supports the | and & features to match in sequence values
472 - bugfix in the postgresql wrapper for sequence filter values
473 - reviewed GetSlivers to export admin keys more efficiently
474 - fix checking roles in UpdateSliceTag
475
476 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
477 - - Some typos in the documentation were fixed.
478 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
479 - to the tag's min_role_id.
480
481 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
482
483 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
484 - Ongoing work to add upcalls, using new SFA class
485 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
486 - reviewed type-checking for the 3 taggable classes node-interface-slice
487 - cleanup ald dummynet stuff
488 - expose the 'extensions' accessors to the API
489 - tweaked checks in AddSliceTag
490 - GetPersons exposes roles by default
491 - bugfix in ReportRunLevel for non-string levels
492 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
493
494 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
495 - new BindObjectToPeer method for sfa
496 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
497
498 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
499 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
500 - reportrunlevel logs its calls only when run_level changes
501 - pycurl more robust wrt to xmlrpclib.Transport
502
503 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
504 - produce a wsdl interface
505 - bugfix in getbootmedium for nodes with interface tags
506
507 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
508 - bugfix for some rare pattern-based filters
509
510 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
511 - improvements in the 4.2 legacy layer
512
513 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
514 - bugfix required for slice tags set on nodegroups
515
516 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
517 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
518
519 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
520 - more powerful legacy layer with 4.2
521
522 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
523 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
524 - migration script has an option for running interactively
525
526 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
527 - skips already added entries
528
529 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
530 - yet another set of fixes for external dummynet boxes
531
532 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
533 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
534 - and tmp file is cleaned up
535
536 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
537 - restore missing ResolveSlices
538
539 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
540 - new method GetDummyBoxMedium
541
542 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
543 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
544
545 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
546 - support for external dummynet boxes back in 4.3 - first draft
547
548 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
549 - fixes for smooth federation between 4.2 and 4.3
550 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
551
552 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
553 - support for BootCD variants (GetBootMedium ['variant:centos5'])
554 - fix corner case with filters like {'~slice_id':[]}
555 - fix transaction leak that caused the db connections pool to exhaust
556 - properly expose all methods, including Legacy/, and not only Methods/
557
558 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
559 - renumbered as 4.3
560 - nodes have new fields run_level (in addition to boot_state) and verified
561 - tweaked migration from 4.2
562 - tuned rpm dependencies
563 - doc generation more explicit about errors like missing python modules
564 - removed obsolete method GetSlicesMD5
565
566 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
567 - unified all tags
568 - renamed interface settings into interface tags and slice attributes into slice tags
569 - nodes have a node_type
570 - various changes on the way to 4.3
571
572 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
573 - Checkpointing : this version still has interface settings and slice attributes
574
575 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
576 - first iteration with taggable nodes/interfaces/slices
577 - embryo for ilinks
578 - cleaned up boot states
579 - migration script moslty complete
580
581 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
582 - fixed doc build by locating locally installed DTDs at build-time
583
584 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
585 - no more doc packaged outside of myplc-docs - doc/ cleaned up
586 - enhancements in doc on filters
587 - bootcd-aware GetBootMedium merged from onelab
588
589 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
590 - checkpoint while the new myplc-docs package is underway
591 - bugfix: GetSlivers & conf files
592 - doc: removed target files
593
594 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
595 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
596 - the non-deleted fields were index, resulting in massivly slow queries.
597 -
598
599 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
600 - plcsh: better handling of options when running as a shell script
601 - getbootmedium exports compute_key
602 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
603
604 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
605 - GetBootMedium support for build.sh full options, incl. serial & console_spec
606 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
607
608 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
609 - refresh peer script to use a month-dependent logfile
610 - tracking the starting point for UniPi integration of the dummynet boxes
611
612 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
613 - plcsh adds its own path to sys.path
614 - fix so GetNodes can be called from a Node
615
616 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> -
617 - Initial build.
618
619 %define module_current_branch 4.3