====
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 11
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 # Fedora had support for SOAPpy up to fedora20
36 # https://lists.fedoraproject.org/pipermail/devel/2014-June/199730.html
37 # https://lists.fedoraproject.org/pipermail/devel/2014-June/200379.html
38 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
39 Requires: SOAPpy
40 %endif
41 #Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50 # for memcache
51 Requires: memcached python-memcached
52 ### avoid having yum complain about updates, as stuff is moving around
53 # plc.d/api
54 Conflicts: MyPLC <= 4.3
55
56 # standard xmlrpc.so that ships with PHP does not marshal NULL
57 # prior to May 2017 we used to ship our own brew of xmlrpc but
58 # that does not build anymore on f25
59 # So bottom line is:
60 # * don't use fedora's php-xmlrpc (no support for marshalling NULL)
61 # * don't use our own that is way too old
62 # * instead, thanks to Ciro we pull it from
63 # https://github.com/gggeek/phpxmlrpc.git
64 # Requires: php-xmlrpc
65
66 # PostgreSQL and SOAPpy are necessary to run the API server, but not
67 # plcsh. Since the only supported method of running the server is via
68 # MyPLC anyway, don't be so stringent about binary requirements, in
69 # case people want to install this package just for plcsh.
70 # Requires: postgresql-server, SOAPpy
71 AutoReqProv: no
72
73 %description
74 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
75 PlanetLab Central (PLC) database. The API may be accessed directly via
76 the Python shell program plcsh, through a toy standalone server, or
77 through Apache mod_python.
78
79 %prep
80 %setup -q
81
82 %build
83 # python-pycurl and python-psycopg2 avail. from fedora 5
84 # we used to ship our own version of psycopg2 and pycurl, for fedora4
85 # starting with 4.3, support for these two modules is taken out
86
87 # Build __init__.py metafiles and PHP API. 
88 %{__make} %{?_smp_mflags}
89 %{__make} -C wsdl
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
94
95 # Install shell symlink
96 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
97 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
98
99 ### mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
100 ### cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
101 ### ; Enable xmlrpc extension module
102 ### extension=xmlrpc.so
103 ### EOF
104
105 # Install initscripts
106 echo "* Installing initscripts"
107 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
108 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
109
110 # Install db-config.d files
111 echo "* Installing db-config.d files"
112 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
113 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
114 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
115
116 # Install wsdl
117 echo "* Installing wsdl"
118 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
119
120 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
121 ## Install omf_slicemgr.py
122 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
123 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
124 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
125
126 # Create log file for plcapi
127 mkdir -p $RPM_BUILD_ROOT/var/log
128 touch $RPM_BUILD_ROOT/var/log/plcapi.log
129 chown apache:apache $RPM_BUILD_ROOT/var/log/plcapi.log
130
131 # Install ratelimit log
132 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
133 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 ###%define php_extension_dir %(php-config --extension-dir)
139
140 %files
141 %defattr(-,root,root,-)
142 %dir %{_datadir}/plc_api
143 #%dir /var/log/omf/
144 %{_datadir}/plc_api/*
145 %{_bindir}/plcsh
146 ### %{php_extension_dir}/xmlrpc.so
147 ### %{_sysconfdir}/php.d/xmlrpc.ini
148 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
149 /etc/plc.d
150 /etc/planetlab/db-config.d
151 /var/www/html/wsdl/plcapi.wsdl
152 #/usr/bin/omf_slicemgr.py*
153 #/usr/bin/reset_xmpp_pubsub_nodes.py*
154 /var/log/plc_api_ratelimit.log
155
156
157 %changelog
158 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
159 - mostly issued for the R2lab deployment
160 - *** major
161 - * dots allowed in login_base and slice name
162 - * new lease filter 'day'
163 - *** minor
164 - * more explicit message in case of overlapping resas
165 - * bugfix: escaping unicode in xml
166 - * GetLeases allowed to anonymous callers
167 - *** miscell
168 - * use plain json library
169
170 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
171 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
172
173 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
174 - new bootstate 'upgrade' is like reinstall but leaves slices intact
175
176 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
177 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
178
179 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
180 - reviewed logging strategy, no more direct print but use log instead
181
182 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
183 - extensions for the ipv6 feature
184 - DeleteSliceTag can be run with the 'node' auth
185 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
186 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
187
188 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
189 - allow GetSlices to filter on tags as well
190
191 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
192 - enable filtering on tags (like hrn) with GetPersons and GetSites
193
194 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
195 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
196
197 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
198 - don't use PyXML that is deprecated in f20, use lxml instead
199 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
200
201 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
202 - create accessor 'hrn' for site as well
203 - create accessors 'sfa_created' for site/slice/person
204 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
205 - UpdatePerson() updates Person HRN according to updated email.
206 - UpdateSite() updates Site HRN according to updated login_base.
207 - Fix AddPersonToSite().
208 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
209 - RefreshPeer() manages Site*Person and Person*Role relationships.
210
211 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
212 - provide a slicename_to_hrn function
213
214 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
215 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
216
217 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
218 - fix for wsgi-based deployments, each thread has its own api()
219
220 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
221 - also cleanup omf-slicemgr initscript
222
223 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
224 - tear down omf-related aspects as this is no longer needed with omfv6
225
226 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
227 - also expose 'expires' in ResolveSlices
228
229 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
230 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
231
232 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
233 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
234
235 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
236 - use SFA code for computing hrn's when available
237
238 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
239 - new slice tag 'interface' for configuring a virtual interface
240 - new builtin 030-interface_tags
241 - new node accessor and tag 'virt' for mixing lxc & vs nodes
242 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
243 - moved ModPypthon and plc.wsgi in the apache/ subdir
244 - renamed PLCAPI.spec into plcapi.spec
245 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
246 - support for php-5.4
247
248 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
249 - implement PLC_VSYS_DEFAULTS in AddSlice
250
251 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
252 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
253 - AddPerson and UpdatePerson are now tag-aware
254 - as a side-effect AddPerson is more picky and rejects invalid fields
255 - which results in a requirement to use sfa-2.1-22 with this tag
256 - marginal improvement on the xml doc on tags
257
258 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
259 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
260 - reset_xmpp_pubsub_nodes now hos options and usage
261 - new Accessors for vicci
262
263 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
264 - fixed imports for tags management with sites and persons
265 - add predefined 'cpu_freezable' tag
266
267 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
268 - tweaks in interface initialization
269 - has 'vsys_vnet' as a predefined tagtype
270 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
271 - bugfix: GetSlivers & nodegroups
272 - bugfix: in jabber groups management
273
274 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
275 - fix gpg-authentication for Persons (thanks Jordan)
276 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
277 - ip address/network check: v4 or v6
278 - customized DB Message survive upgrade
279 - make sync works in lxc-hosted tests
280 - no svn keywords anymore
281
282 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
283 - fix sorting for methods list in docs
284 - untested but needed tweak for postgres startup in f16
285
286 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
287 - tweaks in postgresql setup - in line with sfa
288
289 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
290 - slight tweaks in Persons.py
291
292 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
293 - GetSession has support for more than one day sessions
294 - reset_xmpp_pubsub_nodes is much more efficient
295 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
296 - bugfix - deleting a person in the middle of the signup process
297
298 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
299 - ratelimit aspects
300 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
301 - requires Django for cache_utils
302 - attempt to expose 'pldistro' to sfa
303 - last_time_spent_online, last_time_spent_offline: new fields in Node
304 - new slice tags 'isolate_loopback' and 'cpu_cores'
305 - refresh-peer federation logs dump exceptions
306 - modpython logs have a timestamp
307 - more verbose/accurate php error reporting
308 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
309 - AddNode, UpdateNode: manage tags directly rather than through another method
310 - BootUpdateNode: only update once
311 - GetPersons: techs can access the list of persons on their site
312 - GetSlices and GetSliceTags: techs can see slices on their nodes
313 - GetSlivers: isrootonsite tag; cacheable
314
315 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
316 - rename initscript_body into initscript_code
317
318 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
319 - new initscript_body tag
320
321 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
322 - working draft for GetSliceSshKeys
323
324 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
325 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
326 - (this is for people who cancel their download)
327
328 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
329 - fix db-config sequence : accessors step now merged in, and occurs at the right time
330 - db-config also more robust
331 - no more explicit 'accessors' step in plc.d
332
333 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
334 - session auth: do *not* delete session when node runs a method that does not have 'node' role
335 - session auth: remove support for bootonce in old boot CDs
336 - give a reason when caller_may_write_slice_tag fails
337 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
338
339 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
340 - SetSliceVref needed the node role
341 - protect GetSliceFamily
342 - Fix bugs in tag authorizations
343
344 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
345 - altered checking of optional fields in Interfaces
346 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
347 - has pyxml and python-simplejson as new deps
348
349 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
350 - tweak doc extraction for fedora14
351
352 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
353 - builtin accessors for the myslice page
354 - Get{Node,Interface}Tags allowed to techs
355 - tweak in ratelimitaspect.py
356
357 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
358 - add admin role to accessor-related tags (arch, {fc,pl}distro)
359
360 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
361 - bugfix in {Update,Delete}PersonTag
362 - updated xml doc for filters, accessors and tagtypes
363 - more explicit msg in case of missing roles
364 - improvements in ratelimitaspects.py
365
366 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
367 - fix the roles for ssh_key and hmac tags
368
369 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
370 - tag permissions system based on roles and not min_role_ids
371 - accessors simplified accordingly (no more min_role_id)
372 - new methods AddRoleToTagType and DeleteRoleFromTagType
373 - accessor-related tagtypes are created sooner, and enforced
374 - cleaned up redundancy between db-config.d and accessors
375
376 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
377 - fix RefreshPeer that was not working in 5.0-17
378
379 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
380 - RefreshPeer is able to cope with 2 peers running different releases of the api
381 - DeletePerson can be used on duplicates
382 - first appearance of ModPythonJson.py
383
384 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
385 - set accessors return the new value
386 - tweaks in the pubsub groups management
387
388 * Wed Jul 28 2010 S.ÇaÄŸlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
389 - convert hostnames to lower case and use ILIKE instead of LIKE
390
391 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
392 - use hrn in pubsub groups
393
394 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
395 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
396 - OMF fixes
397
398 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
399 - automatically set vsys tag for omf controlled slices
400
401 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
402 - addition of the 'ssh_key' slice tag
403 - first draft of the LDAP interface
404
405 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
406 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
407 - and readable through GetLeaseGranularity
408 - GetSlivers to expose reservation_policy and lease_granularity
409 - GetBootMedium fixed for reservable nodes
410 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
411 - new Apache mod_wsgi python interface
412
413 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
414 - the leases system
415
416 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
417 - previous tag had gone wrong
418
419 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
420 - fix pubsub hostname
421
422 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
423 - tweaks for the omf support (xmpp groups and RC-controlled slices)
424 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
425 - GetNodeFlavour exposes fcdistro
426
427 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
428 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
429
430 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
431 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
432 - pyaspect hooks allow to  maintain the namespace xmpp groups
433 - new omf_slicemgr is a proxy to xmpp, used by these hooks
434 - nodes have their hrn exposed in the 'hrn' tag
435 - node hrn exposed in GetSlivers, as well as the overall xmpp config
436 - system slice 'drl' gets created by db-config
437 - daniel's changes to Filter for supporting wildcards in lists
438 - AddSliceTag consistency check tweaked
439
440 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
441 - major cleanup
442 - get rid of all 4.2-related legacy code
443 - reset the migrations code, planetlab5.sql somes with (5,100)
444 - uses hashlib module when available
445
446 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
447 - first working version of 5.0:
448 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
449 - nodefamily is 3-fold with pldistro-fcdistro-arch
450 - site and person tags
451 - new methods GetSliceFamily and GetNodeFlavour
452 - deprecated the dummynet stuff that were for the external dummyboxes
453 - tags definition : more consistency between db-config scripts and accessors
454 - (get accessor to create the tag type too if absent)
455 - logging an event for AddSliceToNodes
456
457 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
458 - support for fedora 12
459 - fix subtle bug in filtering with ] and quotes
460
461 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
462 - * patch for php-5.3 (the one in f12)
463 - * validate email addresses with regex
464 - * add PersonTags and SiteTags
465 - * add additional accessors for node tags (kvariant, serial, ..)
466
467 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
468 - Redacting password, session, and authstring values from the event log.
469
470 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
471 - let AddSite set ext_consortium_id - required for the poorman registration pages
472 - drop version constraint on Requires: postgresql-python
473 - don't log system calls nor ReportRunLevel
474
475 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
476 - Fix requires for CentOS.
477
478 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
479 - Require postgresql 8.2 (for array operators && and @>)
480
481 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
482 - Filter now supports the | and & features to match in sequence values
483 - bugfix in the postgresql wrapper for sequence filter values
484 - reviewed GetSlivers to export admin keys more efficiently
485 - fix checking roles in UpdateSliceTag
486
487 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
488 - - Some typos in the documentation were fixed.
489 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
490 - to the tag's min_role_id.
491
492 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
493
494 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
495 - Ongoing work to add upcalls, using new SFA class
496 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
497 - reviewed type-checking for the 3 taggable classes node-interface-slice
498 - cleanup ald dummynet stuff
499 - expose the 'extensions' accessors to the API
500 - tweaked checks in AddSliceTag
501 - GetPersons exposes roles by default
502 - bugfix in ReportRunLevel for non-string levels
503 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
504
505 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
506 - new BindObjectToPeer method for sfa
507 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
508
509 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
510 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
511 - reportrunlevel logs its calls only when run_level changes
512 - pycurl more robust wrt to xmlrpclib.Transport
513
514 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
515 - produce a wsdl interface
516 - bugfix in getbootmedium for nodes with interface tags
517
518 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
519 - bugfix for some rare pattern-based filters
520
521 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
522 - improvements in the 4.2 legacy layer
523
524 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
525 - bugfix required for slice tags set on nodegroups
526
527 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
528 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
529
530 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
531 - more powerful legacy layer with 4.2
532
533 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
534 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
535 - migration script has an option for running interactively
536
537 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
538 - skips already added entries
539
540 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
541 - yet another set of fixes for external dummynet boxes
542
543 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
544 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
545 - and tmp file is cleaned up
546
547 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
548 - restore missing ResolveSlices
549
550 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
551 - new method GetDummyBoxMedium
552
553 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
554 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
555
556 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
557 - support for external dummynet boxes back in 4.3 - first draft
558
559 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
560 - fixes for smooth federation between 4.2 and 4.3
561 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
562
563 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
564 - support for BootCD variants (GetBootMedium ['variant:centos5'])
565 - fix corner case with filters like {'~slice_id':[]}
566 - fix transaction leak that caused the db connections pool to exhaust
567 - properly expose all methods, including Legacy/, and not only Methods/
568
569 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
570 - renumbered as 4.3
571 - nodes have new fields run_level (in addition to boot_state) and verified
572 - tweaked migration from 4.2
573 - tuned rpm dependencies
574 - doc generation more explicit about errors like missing python modules
575 - removed obsolete method GetSlicesMD5
576
577 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
578 - unified all tags
579 - renamed interface settings into interface tags and slice attributes into slice tags
580 - nodes have a node_type
581 - various changes on the way to 4.3
582
583 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
584 - Checkpointing : this version still has interface settings and slice attributes
585
586 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
587 - first iteration with taggable nodes/interfaces/slices
588 - embryo for ilinks
589 - cleaned up boot states
590 - migration script moslty complete
591
592 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
593 - fixed doc build by locating locally installed DTDs at build-time
594
595 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
596 - no more doc packaged outside of myplc-docs - doc/ cleaned up
597 - enhancements in doc on filters 
598 - bootcd-aware GetBootMedium merged from onelab
599
600 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
601 - checkpoint while the new myplc-docs package is underway
602 - bugfix: GetSlivers & conf files
603 - doc: removed target files 
604
605 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
606 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
607 - the non-deleted fields were index, resulting in massivly slow queries.
608
609
610 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
611 - plcsh: better handling of options when running as a shell script
612 - getbootmedium exports compute_key
613 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
614
615 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
616 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
617 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
618
619 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
620 - refresh peer script to use a month-dependent logfile
621 - tracking the starting point for UniPi integration of the dummynet boxes
622
623 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
624 - plcsh adds its own path to sys.path
625 - fix so GetNodes can be called from a Node
626
627 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
628 - Initial build.
629
630 %define module_current_branch 4.3