7.1-2
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 7.1
3 %define taglevel 2
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 # Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 # f29 does not come with an rpm for that; use pip instead
27 # Requires: Django
28 Requires: postgresql, postgresql-server
29 # We use set everywhere
30 Requires: python3
31 Requires: python3-postgresql
32 Requires: python3-psycopg2
33 Requires: python3-pycurl
34 # used in GPG.py as a replacement to PyXML's Canonicalize
35 Requires: python3-lxml
36 # for the RebootNodeWithPCU method
37 #Requires: pcucontrol >= 1.0-6
38 # for memcache
39 Requires: memcached python3-memcached
40
41 ####################
42 # phpxmlrpc
43 ####################
44 # standard xmlrpc.so that ships with PHP does not marshal NULL
45 # prior to May 2017 we used to ship our own brew of xmlrpc but
46 # that does not build anymore on f25
47 # So bottom line is:
48 # * don't use fedora's php-xmlrpc (no support for marshalling NULL)
49 # * don't use our own that is way too old
50 # * instead - thank you Ciro - we pull it as a git subtree from
51 # https://github.com/gggeek/phpxmlrpc.git
52 # that stuff requires the following though
53 Requires: php-xml
54 ####################
55
56
57 # PostgreSQL and SOAPpy are necessary to run the API server, but not
58 # plcsh. Since the only supported method of running the server is via
59 # MyPLC anyway, don't be so stringent about binary requirements, in
60 # case people want to install this package just for plcsh.
61 # Requires: postgresql-server, SOAPpy
62 AutoReqProv: no
63
64 %description
65 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
66 PlanetLab Central (PLC) database. The API may be accessed directly via
67 the Python shell program plcsh, through a toy standalone server, or
68 through Apache mod_python.
69
70 %prep
71 %setup -q
72
73 %build
74 # python-pycurl and python-psycopg2 avail. from fedora 5
75 # we used to ship our own version of psycopg2 and pycurl, for fedora4
76 # starting with 4.3, support for these two modules is taken out
77 #
78 # Build __init__.py metafiles and PHP API.
79 %{__make} %{?_smp_mflags}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
84
85 # Install shell symlink
86 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
87 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
88
89 # Install initscripts
90 echo "* Installing initscripts"
91 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
92 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
93
94 # Install db-config.d files
95 echo "* Installing db-config.d files"
96 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
97 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
98 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
99
100 # Create log file for plcapi
101 mkdir -p $RPM_BUILD_ROOT/var/log
102 touch $RPM_BUILD_ROOT/var/log/plcapi.log
103 chown apache:apache $RPM_BUILD_ROOT/var/log/plcapi.log
104
105 # Install ratelimit log
106 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
107 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 ###%define php_extension_dir %(php-config --extension-dir)
113
114 %files
115 %defattr(-,root,root,-)
116 %dir %{_datadir}/plc_api
117 #%dir /var/log/omf/
118 %{_datadir}/plc_api/*
119 %{_bindir}/plcsh
120 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
121 /etc/plc.d
122 /etc/planetlab/db-config.d
123 #/usr/bin/omf_slicemgr.py*
124 #/usr/bin/reset_xmpp_pubsub_nodes.py*
125 /var/log/plcapi.log
126 /var/log/plc_api_ratelimit.log
127
128
129 %changelog
130 * Wed Feb 07 2024 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plcapi-7.1-2
131 - fix clipping of GetLeases, that was having corner cases
132   with adjacent timeslots
133 * Tue Feb 06 2024 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plcapi-7.1-1
134 - allow GetLeases 'clip' and 'alive' parameters to use lists
135   as tuples cannot be marshalled by the xmlrpc layer
136 - packaging modified for f37
137 - support for pgsql14/f37
138 - use a configurable email as the From: when sending emails
139
140 * Sat Apr 30 2022 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plcapi-7.1-0
141 - for php8 in f35:
142 - * the phpxmlrpc layer has been upgraded to recent 4.6.1 that is php8-ready
143 - * classes to use __construct() to define a constructor
144 - * curl_setopt with verifyhost being 1 is no longer allowed
145 - also other older changes related to pgsql 12
146
147 * Mon Jan 07 2019 Thierry Parmentelat <thierry.parmentelat@inria.fr> - plcapi-7.0-0
148 - based on python3, runs on f27 and f29
149 - removed dependency to aspects, and so to rate limits
150 - remove dependency to the Django rpm that is no longer available in f29
151 - remove deps to python-twisted
152 - use systemctl rather than service to manage postgresql
153
154 * Wed May 16 2018 Thierry <Parmentelat> - plcapi-5.4-1
155 - define accessor for site tag disabled_registration (used in plewww-5.2-9)
156 - set disable_existing_loggers = False in logging config, that otherwise voids sfa logs
157
158 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.4-0
159 - embed phpxmlrpc as a git subtree from github (OK with fedora24 and 25, probably sooner too)
160 - logs in /var/log/plcapi.log
161 - context managers for most open files
162
163 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
164 - mostly issued for the R2lab deployment
165 - *** major
166 - * dots allowed in login_base and slice name
167 - * new lease filter 'day'
168 - *** minor
169 - * more explicit message in case of overlapping resas
170 - * bugfix: escaping unicode in xml
171 - * GetLeases allowed to anonymous callers
172 - *** miscell
173 - * use plain json library
174
175 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
176 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
177
178 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
179 - new bootstate 'upgrade' is like reinstall but leaves slices intact
180
181 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
182 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
183
184 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
185 - reviewed logging strategy, no more direct print but use log instead
186
187 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
188 - extensions for the ipv6 feature
189 - DeleteSliceTag can be run with the 'node' auth
190 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
191 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
192
193 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
194 - allow GetSlices to filter on tags as well
195
196 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
197 - enable filtering on tags (like hrn) with GetPersons and GetSites
198
199 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
200 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
201
202 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
203 - don't use PyXML that is deprecated in f20, use lxml instead
204 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
205
206 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
207 - create accessor 'hrn' for site as well
208 - create accessors 'sfa_created' for site/slice/person
209 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
210 - UpdatePerson() updates Person HRN according to updated email.
211 - UpdateSite() updates Site HRN according to updated login_base.
212 - Fix AddPersonToSite().
213 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
214 - RefreshPeer() manages Site*Person and Person*Role relationships.
215
216 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
217 - provide a slicename_to_hrn function
218
219 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
220 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
221
222 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
223 - fix for wsgi-based deployments, each thread has its own api()
224
225 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
226 - also cleanup omf-slicemgr initscript
227
228 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
229 - tear down omf-related aspects as this is no longer needed with omfv6
230
231 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
232 - also expose 'expires' in ResolveSlices
233
234 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
235 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
236
237 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
238 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
239
240 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
241 - use SFA code for computing hrn's when available
242
243 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
244 - new slice tag 'interface' for configuring a virtual interface
245 - new builtin 030-interface_tags
246 - new node accessor and tag 'virt' for mixing lxc & vs nodes
247 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
248 - moved ModPypthon and plc.wsgi in the apache/ subdir
249 - renamed PLCAPI.spec into plcapi.spec
250 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
251 - support for php-5.4
252
253 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
254 - implement PLC_VSYS_DEFAULTS in AddSlice
255
256 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
257 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
258 - AddPerson and UpdatePerson are now tag-aware
259 - as a side-effect AddPerson is more picky and rejects invalid fields
260 - which results in a requirement to use sfa-2.1-22 with this tag
261 - marginal improvement on the xml doc on tags
262
263 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
264 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
265 - reset_xmpp_pubsub_nodes now hos options and usage
266 - new Accessors for vicci
267
268 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
269 - fixed imports for tags management with sites and persons
270 - add predefined 'cpu_freezable' tag
271
272 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
273 - tweaks in interface initialization
274 - has 'vsys_vnet' as a predefined tagtype
275 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
276 - bugfix: GetSlivers & nodegroups
277 - bugfix: in jabber groups management
278
279 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
280 - fix gpg-authentication for Persons (thanks Jordan)
281 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
282 - ip address/network check: v4 or v6
283 - customized DB Message survive upgrade
284 - make sync works in lxc-hosted tests
285 - no svn keywords anymore
286
287 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
288 - fix sorting for methods list in docs
289 - untested but needed tweak for postgres startup in f16
290
291 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
292 - tweaks in postgresql setup - in line with sfa
293
294 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
295 - slight tweaks in Persons.py
296
297 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
298 - GetSession has support for more than one day sessions
299 - reset_xmpp_pubsub_nodes is much more efficient
300 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
301 - bugfix - deleting a person in the middle of the signup process
302
303 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
304 - ratelimit aspects
305 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
306 - requires Django for cache_utils
307 - attempt to expose 'pldistro' to sfa
308 - last_time_spent_online, last_time_spent_offline: new fields in Node
309 - new slice tags 'isolate_loopback' and 'cpu_cores'
310 - refresh-peer federation logs dump exceptions
311 - modpython logs have a timestamp
312 - more verbose/accurate php error reporting
313 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
314 - AddNode, UpdateNode: manage tags directly rather than through another method
315 - BootUpdateNode: only update once
316 - GetPersons: techs can access the list of persons on their site
317 - GetSlices and GetSliceTags: techs can see slices on their nodes
318 - GetSlivers: isrootonsite tag; cacheable
319
320 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
321 - rename initscript_body into initscript_code
322
323 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
324 - new initscript_body tag
325
326 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
327 - working draft for GetSliceSshKeys
328
329 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
330 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
331 - (this is for people who cancel their download)
332
333 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
334 - fix db-config sequence : accessors step now merged in, and occurs at the right time
335 - db-config also more robust
336 - no more explicit 'accessors' step in plc.d
337
338 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
339 - session auth: do *not* delete session when node runs a method that does not have 'node' role
340 - session auth: remove support for bootonce in old boot CDs
341 - give a reason when caller_may_write_slice_tag fails
342 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
343
344 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
345 - SetSliceVref needed the node role
346 - protect GetSliceFamily
347 - Fix bugs in tag authorizations
348
349 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
350 - altered checking of optional fields in Interfaces
351 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
352 - has pyxml and python-simplejson as new deps
353
354 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
355 - tweak doc extraction for fedora14
356
357 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
358 - builtin accessors for the myslice page
359 - Get{Node,Interface}Tags allowed to techs
360 - tweak in ratelimitaspect.py
361
362 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
363 - add admin role to accessor-related tags (arch, {fc,pl}distro)
364
365 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
366 - bugfix in {Update,Delete}PersonTag
367 - updated xml doc for filters, accessors and tagtypes
368 - more explicit msg in case of missing roles
369 - improvements in ratelimitaspects.py
370
371 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
372 - fix the roles for ssh_key and hmac tags
373
374 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
375 - tag permissions system based on roles and not min_role_ids
376 - accessors simplified accordingly (no more min_role_id)
377 - new methods AddRoleToTagType and DeleteRoleFromTagType
378 - accessor-related tagtypes are created sooner, and enforced
379 - cleaned up redundancy between db-config.d and accessors
380
381 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
382 - fix RefreshPeer that was not working in 5.0-17
383
384 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
385 - RefreshPeer is able to cope with 2 peers running different releases of the api
386 - DeletePerson can be used on duplicates
387 - first appearance of ModPythonJson.py
388
389 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
390 - set accessors return the new value
391 - tweaks in the pubsub groups management
392
393 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
394 - convert hostnames to lower case and use ILIKE instead of LIKE
395
396 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
397 - use hrn in pubsub groups
398
399 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
400 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
401 - OMF fixes
402
403 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
404 - automatically set vsys tag for omf controlled slices
405
406 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
407 - addition of the 'ssh_key' slice tag
408 - first draft of the LDAP interface
409
410 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
411 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
412 - and readable through GetLeaseGranularity
413 - GetSlivers to expose reservation_policy and lease_granularity
414 - GetBootMedium fixed for reservable nodes
415 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
416 - new Apache mod_wsgi python interface
417
418 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
419 - the leases system
420
421 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
422 - previous tag had gone wrong
423
424 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
425 - fix pubsub hostname
426
427 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
428 - tweaks for the omf support (xmpp groups and RC-controlled slices)
429 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
430 - GetNodeFlavour exposes fcdistro
431
432 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
433 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
434
435 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
436 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
437 - pyaspect hooks allow to  maintain the namespace xmpp groups
438 - new omf_slicemgr is a proxy to xmpp, used by these hooks
439 - nodes have their hrn exposed in the 'hrn' tag
440 - node hrn exposed in GetSlivers, as well as the overall xmpp config
441 - system slice 'drl' gets created by db-config
442 - daniel's changes to Filter for supporting wildcards in lists
443 - AddSliceTag consistency check tweaked
444
445 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
446 - major cleanup
447 - get rid of all 4.2-related legacy code
448 - reset the migrations code, planetlab5.sql somes with (5,100)
449 - uses hashlib module when available
450
451 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
452 - first working version of 5.0:
453 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
454 - nodefamily is 3-fold with pldistro-fcdistro-arch
455 - site and person tags
456 - new methods GetSliceFamily and GetNodeFlavour
457 - deprecated the dummynet stuff that were for the external dummyboxes
458 - tags definition : more consistency between db-config scripts and accessors
459 - (get accessor to create the tag type too if absent)
460 - logging an event for AddSliceToNodes
461
462 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
463 - support for fedora 12
464 - fix subtle bug in filtering with ] and quotes
465
466 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
467 - * patch for php-5.3 (the one in f12)
468 - * validate email addresses with regex
469 - * add PersonTags and SiteTags
470 - * add additional accessors for node tags (kvariant, serial, ..)
471
472 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
473 - Redacting password, session, and authstring values from the event log.
474
475 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
476 - let AddSite set ext_consortium_id - required for the poorman registration pages
477 - drop version constraint on Requires: postgresql-python
478 - don't log system calls nor ReportRunLevel
479
480 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
481 - Fix requires for CentOS.
482
483 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
484 - Require postgresql 8.2 (for array operators && and @>)
485
486 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
487 - Filter now supports the | and & features to match in sequence values
488 - bugfix in the postgresql wrapper for sequence filter values
489 - reviewed GetSlivers to export admin keys more efficiently
490 - fix checking roles in UpdateSliceTag
491
492 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
493 - - Some typos in the documentation were fixed.
494 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
495 - to the tag's min_role_id.
496
497 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
498
499 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
500 - Ongoing work to add upcalls, using new SFA class
501 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
502 - reviewed type-checking for the 3 taggable classes node-interface-slice
503 - cleanup ald dummynet stuff
504 - expose the 'extensions' accessors to the API
505 - tweaked checks in AddSliceTag
506 - GetPersons exposes roles by default
507 - bugfix in ReportRunLevel for non-string levels
508 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
509
510 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
511 - new BindObjectToPeer method for sfa
512 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
513
514 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
515 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
516 - reportrunlevel logs its calls only when run_level changes
517 - pycurl more robust wrt to xmlrpclib.Transport
518
519 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
520 - produce a wsdl interface
521 - bugfix in getbootmedium for nodes with interface tags
522
523 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
524 - bugfix for some rare pattern-based filters
525
526 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
527 - improvements in the 4.2 legacy layer
528
529 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
530 - bugfix required for slice tags set on nodegroups
531
532 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
533 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
534
535 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
536 - more powerful legacy layer with 4.2
537
538 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
539 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
540 - migration script has an option for running interactively
541
542 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
543 - skips already added entries
544
545 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
546 - yet another set of fixes for external dummynet boxes
547
548 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
549 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
550 - and tmp file is cleaned up
551
552 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
553 - restore missing ResolveSlices
554
555 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
556 - new method GetDummyBoxMedium
557
558 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
559 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
560
561 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
562 - support for external dummynet boxes back in 4.3 - first draft
563
564 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
565 - fixes for smooth federation between 4.2 and 4.3
566 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
567
568 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
569 - support for BootCD variants (GetBootMedium ['variant:centos5'])
570 - fix corner case with filters like {'~slice_id':[]}
571 - fix transaction leak that caused the db connections pool to exhaust
572 - properly expose all methods, including Legacy/, and not only Methods/
573
574 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
575 - renumbered as 4.3
576 - nodes have new fields run_level (in addition to boot_state) and verified
577 - tweaked migration from 4.2
578 - tuned rpm dependencies
579 - doc generation more explicit about errors like missing python modules
580 - removed obsolete method GetSlicesMD5
581
582 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
583 - unified all tags
584 - renamed interface settings into interface tags and slice attributes into slice tags
585 - nodes have a node_type
586 - various changes on the way to 4.3
587
588 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
589 - Checkpointing : this version still has interface settings and slice attributes
590
591 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
592 - first iteration with taggable nodes/interfaces/slices
593 - embryo for ilinks
594 - cleaned up boot states
595 - migration script moslty complete
596
597 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
598 - fixed doc build by locating locally installed DTDs at build-time
599
600 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
601 - no more doc packaged outside of myplc-docs - doc/ cleaned up
602 - enhancements in doc on filters
603 - bootcd-aware GetBootMedium merged from onelab
604
605 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
606 - checkpoint while the new myplc-docs package is underway
607 - bugfix: GetSlivers & conf files
608 - doc: removed target files
609
610 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
611 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
612 - the non-deleted fields were index, resulting in massivly slow queries.
613 -
614
615 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
616 - plcsh: better handling of options when running as a shell script
617 - getbootmedium exports compute_key
618 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
619
620 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
621 - GetBootMedium support for build.sh full options, incl. serial & console_spec
622 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
623
624 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
625 - refresh peer script to use a month-dependent logfile
626 - tracking the starting point for UniPi integration of the dummynet boxes
627
628 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
629 - plcsh adds its own path to sys.path
630 - fix so GetNodes can be called from a Node
631
632 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> -
633 - Initial build.
634
635 %define module_current_branch 4.3