changelogs had gone awash
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.4
3 %define taglevel 0
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 # Fedora had support for SOAPpy up to fedora20
36 # https://lists.fedoraproject.org/pipermail/devel/2014-June/199730.html
37 # https://lists.fedoraproject.org/pipermail/devel/2014-June/200379.html
38 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
39 Requires: SOAPpy
40 %endif
41 #Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50 # for memcache
51 Requires: memcached python-memcached
52 ### avoid having yum complain about updates, as stuff is moving around
53 # plc.d/api
54 Conflicts: MyPLC <= 4.3
55
56 ####################
57 # obsolete
58 ####################
59 # standard xmlrpc.so that ships with PHP does not marshal NULL
60 # prior to May 2017 we used to ship our own brew of xmlrpc but
61 # that does not build anymore on f25
62 # So bottom line is:
63 # * don't use fedora's php-xmlrpc (no support for marshalling NULL)
64 # * don't use our own that is way too old
65 # * instead - thank you Ciro - we pull it as a git subtree from
66 # https://github.com/gggeek/phpxmlrpc.git
67 # that stuff requires the following though
68 Requires: php-xml
69 ####################
70
71
72 # PostgreSQL and SOAPpy are necessary to run the API server, but not
73 # plcsh. Since the only supported method of running the server is via
74 # MyPLC anyway, don't be so stringent about binary requirements, in
75 # case people want to install this package just for plcsh.
76 # Requires: postgresql-server, SOAPpy
77 AutoReqProv: no
78
79 %description
80 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
81 PlanetLab Central (PLC) database. The API may be accessed directly via
82 the Python shell program plcsh, through a toy standalone server, or
83 through Apache mod_python.
84
85 %prep
86 %setup -q
87
88 %build
89 # python-pycurl and python-psycopg2 avail. from fedora 5
90 # we used to ship our own version of psycopg2 and pycurl, for fedora4
91 # starting with 4.3, support for these two modules is taken out
92
93 # Build __init__.py metafiles and PHP API. 
94 %{__make} %{?_smp_mflags}
95 %{__make} -C wsdl
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
100
101 # Install shell symlink
102 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
103 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
104
105 # Install initscripts
106 echo "* Installing initscripts"
107 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
108 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
109
110 # Install db-config.d files
111 echo "* Installing db-config.d files"
112 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
113 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
114 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
115
116 # Install wsdl
117 echo "* Installing wsdl"
118 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
119
120 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
121 ## Install omf_slicemgr.py
122 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
123 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
124 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
125
126 # Create log file for plcapi
127 mkdir -p $RPM_BUILD_ROOT/var/log
128 touch $RPM_BUILD_ROOT/var/log/plcapi.log
129 chown apache:apache $RPM_BUILD_ROOT/var/log/plcapi.log
130
131 # Install ratelimit log
132 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
133 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 ###%define php_extension_dir %(php-config --extension-dir)
139
140 %files
141 %defattr(-,root,root,-)
142 %dir %{_datadir}/plc_api
143 #%dir /var/log/omf/
144 %{_datadir}/plc_api/*
145 %{_bindir}/plcsh
146 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
147 /etc/plc.d
148 /etc/planetlab/db-config.d
149 /var/www/html/wsdl/plcapi.wsdl
150 #/usr/bin/omf_slicemgr.py*
151 #/usr/bin/reset_xmpp_pubsub_nodes.py*
152 /var/log/plcapi.log
153 /var/log/plc_api_ratelimit.log
154
155
156 %changelog
157 * Sun Jul 16 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.4-0
158 - embed phpxmlrpc as a git subtree from github (OK with fedora24 and 25, probably sooner too)
159 - logs in /var/log/plcapi.log
160 - context managers for most open files
161
162 * Wed Feb 08 2017 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-11
163 - mostly issued for the R2lab deployment
164 - *** major
165 - * dots allowed in login_base and slice name
166 - * new lease filter 'day'
167 - *** minor
168 - * more explicit message in case of overlapping resas
169 - * bugfix: escaping unicode in xml
170 - * GetLeases allowed to anonymous callers
171 - *** miscell
172 - * use plain json library
173
174 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
175 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
176
177 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
178 - new bootstate 'upgrade' is like reinstall but leaves slices intact
179
180 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
181 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
182
183 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
184 - reviewed logging strategy, no more direct print but use log instead
185
186 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
187 - extensions for the ipv6 feature
188 - DeleteSliceTag can be run with the 'node' auth
189 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
190 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
191
192 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
193 - allow GetSlices to filter on tags as well
194
195 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
196 - enable filtering on tags (like hrn) with GetPersons and GetSites
197
198 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
199 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
200
201 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
202 - don't use PyXML that is deprecated in f20, use lxml instead
203 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
204
205 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
206 - create accessor 'hrn' for site as well
207 - create accessors 'sfa_created' for site/slice/person
208 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
209 - UpdatePerson() updates Person HRN according to updated email.
210 - UpdateSite() updates Site HRN according to updated login_base.
211 - Fix AddPersonToSite().
212 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
213 - RefreshPeer() manages Site*Person and Person*Role relationships.
214
215 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
216 - provide a slicename_to_hrn function
217
218 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
219 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
220
221 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
222 - fix for wsgi-based deployments, each thread has its own api()
223
224 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
225 - also cleanup omf-slicemgr initscript
226
227 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
228 - tear down omf-related aspects as this is no longer needed with omfv6
229
230 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
231 - also expose 'expires' in ResolveSlices
232
233 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
234 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
235
236 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
237 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
238
239 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
240 - use SFA code for computing hrn's when available
241
242 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
243 - new slice tag 'interface' for configuring a virtual interface
244 - new builtin 030-interface_tags
245 - new node accessor and tag 'virt' for mixing lxc & vs nodes
246 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
247 - moved ModPypthon and plc.wsgi in the apache/ subdir
248 - renamed PLCAPI.spec into plcapi.spec
249 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
250 - support for php-5.4
251
252 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
253 - implement PLC_VSYS_DEFAULTS in AddSlice
254
255 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
256 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
257 - AddPerson and UpdatePerson are now tag-aware
258 - as a side-effect AddPerson is more picky and rejects invalid fields
259 - which results in a requirement to use sfa-2.1-22 with this tag
260 - marginal improvement on the xml doc on tags
261
262 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
263 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
264 - reset_xmpp_pubsub_nodes now hos options and usage
265 - new Accessors for vicci
266
267 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
268 - fixed imports for tags management with sites and persons
269 - add predefined 'cpu_freezable' tag
270
271 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
272 - tweaks in interface initialization
273 - has 'vsys_vnet' as a predefined tagtype
274 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
275 - bugfix: GetSlivers & nodegroups
276 - bugfix: in jabber groups management
277
278 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
279 - fix gpg-authentication for Persons (thanks Jordan)
280 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
281 - ip address/network check: v4 or v6
282 - customized DB Message survive upgrade
283 - make sync works in lxc-hosted tests
284 - no svn keywords anymore
285
286 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
287 - fix sorting for methods list in docs
288 - untested but needed tweak for postgres startup in f16
289
290 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
291 - tweaks in postgresql setup - in line with sfa
292
293 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
294 - slight tweaks in Persons.py
295
296 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
297 - GetSession has support for more than one day sessions
298 - reset_xmpp_pubsub_nodes is much more efficient
299 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
300 - bugfix - deleting a person in the middle of the signup process
301
302 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
303 - ratelimit aspects
304 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
305 - requires Django for cache_utils
306 - attempt to expose 'pldistro' to sfa
307 - last_time_spent_online, last_time_spent_offline: new fields in Node
308 - new slice tags 'isolate_loopback' and 'cpu_cores'
309 - refresh-peer federation logs dump exceptions
310 - modpython logs have a timestamp
311 - more verbose/accurate php error reporting
312 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
313 - AddNode, UpdateNode: manage tags directly rather than through another method
314 - BootUpdateNode: only update once
315 - GetPersons: techs can access the list of persons on their site
316 - GetSlices and GetSliceTags: techs can see slices on their nodes
317 - GetSlivers: isrootonsite tag; cacheable
318
319 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
320 - rename initscript_body into initscript_code
321
322 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
323 - new initscript_body tag
324
325 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
326 - working draft for GetSliceSshKeys
327
328 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
329 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
330 - (this is for people who cancel their download)
331
332 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
333 - fix db-config sequence : accessors step now merged in, and occurs at the right time
334 - db-config also more robust
335 - no more explicit 'accessors' step in plc.d
336
337 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
338 - session auth: do *not* delete session when node runs a method that does not have 'node' role
339 - session auth: remove support for bootonce in old boot CDs
340 - give a reason when caller_may_write_slice_tag fails
341 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
342
343 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
344 - SetSliceVref needed the node role
345 - protect GetSliceFamily
346 - Fix bugs in tag authorizations
347
348 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
349 - altered checking of optional fields in Interfaces
350 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
351 - has pyxml and python-simplejson as new deps
352
353 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
354 - tweak doc extraction for fedora14
355
356 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
357 - builtin accessors for the myslice page
358 - Get{Node,Interface}Tags allowed to techs
359 - tweak in ratelimitaspect.py
360
361 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
362 - add admin role to accessor-related tags (arch, {fc,pl}distro)
363
364 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
365 - bugfix in {Update,Delete}PersonTag
366 - updated xml doc for filters, accessors and tagtypes
367 - more explicit msg in case of missing roles
368 - improvements in ratelimitaspects.py
369
370 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
371 - fix the roles for ssh_key and hmac tags
372
373 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
374 - tag permissions system based on roles and not min_role_ids
375 - accessors simplified accordingly (no more min_role_id)
376 - new methods AddRoleToTagType and DeleteRoleFromTagType
377 - accessor-related tagtypes are created sooner, and enforced
378 - cleaned up redundancy between db-config.d and accessors
379
380 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
381 - fix RefreshPeer that was not working in 5.0-17
382
383 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
384 - RefreshPeer is able to cope with 2 peers running different releases of the api
385 - DeletePerson can be used on duplicates
386 - first appearance of ModPythonJson.py
387
388 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
389 - set accessors return the new value
390 - tweaks in the pubsub groups management
391
392 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
393 - convert hostnames to lower case and use ILIKE instead of LIKE
394
395 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
396 - use hrn in pubsub groups
397
398 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
399 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
400 - OMF fixes
401
402 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
403 - automatically set vsys tag for omf controlled slices
404
405 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
406 - addition of the 'ssh_key' slice tag
407 - first draft of the LDAP interface
408
409 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
410 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
411 - and readable through GetLeaseGranularity
412 - GetSlivers to expose reservation_policy and lease_granularity
413 - GetBootMedium fixed for reservable nodes
414 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
415 - new Apache mod_wsgi python interface
416
417 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
418 - the leases system
419
420 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
421 - previous tag had gone wrong
422
423 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
424 - fix pubsub hostname
425
426 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
427 - tweaks for the omf support (xmpp groups and RC-controlled slices)
428 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
429 - GetNodeFlavour exposes fcdistro
430
431 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
432 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
433
434 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
435 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
436 - pyaspect hooks allow to  maintain the namespace xmpp groups
437 - new omf_slicemgr is a proxy to xmpp, used by these hooks
438 - nodes have their hrn exposed in the 'hrn' tag
439 - node hrn exposed in GetSlivers, as well as the overall xmpp config
440 - system slice 'drl' gets created by db-config
441 - daniel's changes to Filter for supporting wildcards in lists
442 - AddSliceTag consistency check tweaked
443
444 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
445 - major cleanup
446 - get rid of all 4.2-related legacy code
447 - reset the migrations code, planetlab5.sql somes with (5,100)
448 - uses hashlib module when available
449
450 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
451 - first working version of 5.0:
452 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
453 - nodefamily is 3-fold with pldistro-fcdistro-arch
454 - site and person tags
455 - new methods GetSliceFamily and GetNodeFlavour
456 - deprecated the dummynet stuff that were for the external dummyboxes
457 - tags definition : more consistency between db-config scripts and accessors
458 - (get accessor to create the tag type too if absent)
459 - logging an event for AddSliceToNodes
460
461 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
462 - support for fedora 12
463 - fix subtle bug in filtering with ] and quotes
464
465 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
466 - * patch for php-5.3 (the one in f12)
467 - * validate email addresses with regex
468 - * add PersonTags and SiteTags
469 - * add additional accessors for node tags (kvariant, serial, ..)
470
471 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
472 - Redacting password, session, and authstring values from the event log.
473
474 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
475 - let AddSite set ext_consortium_id - required for the poorman registration pages
476 - drop version constraint on Requires: postgresql-python
477 - don't log system calls nor ReportRunLevel
478
479 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
480 - Fix requires for CentOS.
481
482 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
483 - Require postgresql 8.2 (for array operators && and @>)
484
485 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
486 - Filter now supports the | and & features to match in sequence values
487 - bugfix in the postgresql wrapper for sequence filter values
488 - reviewed GetSlivers to export admin keys more efficiently
489 - fix checking roles in UpdateSliceTag
490
491 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
492 - - Some typos in the documentation were fixed.
493 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
494 - to the tag's min_role_id.
495
496 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
497
498 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
499 - Ongoing work to add upcalls, using new SFA class
500 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
501 - reviewed type-checking for the 3 taggable classes node-interface-slice
502 - cleanup ald dummynet stuff
503 - expose the 'extensions' accessors to the API
504 - tweaked checks in AddSliceTag
505 - GetPersons exposes roles by default
506 - bugfix in ReportRunLevel for non-string levels
507 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
508
509 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
510 - new BindObjectToPeer method for sfa
511 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
512
513 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
514 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
515 - reportrunlevel logs its calls only when run_level changes
516 - pycurl more robust wrt to xmlrpclib.Transport
517
518 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
519 - produce a wsdl interface
520 - bugfix in getbootmedium for nodes with interface tags
521
522 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
523 - bugfix for some rare pattern-based filters
524
525 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
526 - improvements in the 4.2 legacy layer
527
528 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
529 - bugfix required for slice tags set on nodegroups
530
531 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
532 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
533
534 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
535 - more powerful legacy layer with 4.2
536
537 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
538 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
539 - migration script has an option for running interactively
540
541 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
542 - skips already added entries
543
544 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
545 - yet another set of fixes for external dummynet boxes
546
547 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
548 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
549 - and tmp file is cleaned up
550
551 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
552 - restore missing ResolveSlices
553
554 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
555 - new method GetDummyBoxMedium
556
557 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
558 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
559
560 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
561 - support for external dummynet boxes back in 4.3 - first draft
562
563 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
564 - fixes for smooth federation between 4.2 and 4.3
565 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
566
567 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
568 - support for BootCD variants (GetBootMedium ['variant:centos5'])
569 - fix corner case with filters like {'~slice_id':[]}
570 - fix transaction leak that caused the db connections pool to exhaust
571 - properly expose all methods, including Legacy/, and not only Methods/
572
573 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
574 - renumbered as 4.3
575 - nodes have new fields run_level (in addition to boot_state) and verified
576 - tweaked migration from 4.2
577 - tuned rpm dependencies
578 - doc generation more explicit about errors like missing python modules
579 - removed obsolete method GetSlicesMD5
580
581 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
582 - unified all tags
583 - renamed interface settings into interface tags and slice attributes into slice tags
584 - nodes have a node_type
585 - various changes on the way to 4.3
586
587 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
588 - Checkpointing : this version still has interface settings and slice attributes
589
590 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
591 - first iteration with taggable nodes/interfaces/slices
592 - embryo for ilinks
593 - cleaned up boot states
594 - migration script moslty complete
595
596 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
597 - fixed doc build by locating locally installed DTDs at build-time
598
599 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
600 - no more doc packaged outside of myplc-docs - doc/ cleaned up
601 - enhancements in doc on filters 
602 - bootcd-aware GetBootMedium merged from onelab
603
604 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
605 - checkpoint while the new myplc-docs package is underway
606 - bugfix: GetSlivers & conf files
607 - doc: removed target files 
608
609 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
610 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
611 - the non-deleted fields were index, resulting in massivly slow queries.
612
613
614 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
615 - plcsh: better handling of options when running as a shell script
616 - getbootmedium exports compute_key
617 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
618
619 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
620 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
621 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
622
623 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
624 - refresh peer script to use a month-dependent logfile
625 - tracking the starting point for UniPi integration of the dummynet boxes
626
627 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
628 - plcsh adds its own path to sys.path
629 - fix so GetNodes can be called from a Node
630
631 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
632 - Initial build.
633
634 %define module_current_branch 4.3