tear down omf aspects as this is not needed any more with OMFv6
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.2
3 %define taglevel 5
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # We use set everywhere
25 Requires: python >= 2.4
26 Requires: postgresql >= 8.2, postgresql-server >= 8.2
27 Requires: postgresql-python
28 Requires: python-psycopg2
29 Requires: python-pycurl
30 Requires: httpd
31 # requirement to mod_python or mod_wsgi: deferred to myplc
32 Requires: mod_ssl
33 Requires: SOAPpy
34 Requires: python-simplejson
35 # for the RebootNodeWithPCU method
36 Requires: pcucontrol >= 1.0-6
37 # for OMF integration
38 Requires: pyaspects >= 0.4
39 Requires: python-twisted-words
40 Requires: python-twisted-web
41 # ldap
42 Requires: python-ldap
43 # for memcache
44 Requires: python-memcached
45 Requires: memcached
46 Requires: Django
47 ### avoid having yum complain about updates, as stuff is moving around
48 # plc.d/api
49 Conflicts: MyPLC <= 4.3
50
51 # We use psycopg2
52 #
53 # but we don't need to rebuild it as we depend on distro's packages - baris
54 # BuildRequires: postgresql-devel
55
56 # Standard xmlrpc.so that ships with PHP does not marshal NULL
57 BuildRequires: php-devel PyXML python-simplejson
58 Obsoletes: php-xmlrpc
59 Provides: php-xmlrpc
60
61 # PostgreSQL and SOAPpy are necessary to run the API server, but not
62 # plcsh. Since the only supported method of running the server is via
63 # MyPLC anyway, don't be so stringent about binary requirements, in
64 # case people want to install this package just for plcsh.
65 # Requires: postgresql-server, SOAPpy
66 AutoReqProv: no
67
68 %description
69 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
70 PlanetLab Central (PLC) database. The API may be accessed directly via
71 the Python shell program plcsh, through a toy standalone server, or
72 through Apache mod_python.
73
74 %prep
75 %setup -q
76
77 %build
78 # python-pycurl and python-psycopg2 avail. from fedora 5
79 # we used to ship our own version of psycopg2 and pycurl, for fedora4
80 # starting with 4.3, support for these two modules is taken out
81
82 # Build __init__.py metafiles and PHP API. 
83 %{__make} %{?_smp_mflags}
84 %{__make} -C wsdl
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
89
90 # Install shell symlink
91 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
92 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
93
94 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
95 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
96 ; Enable xmlrpc extension module
97 extension=xmlrpc.so
98 EOF
99
100 # Install initscripts
101 echo "* Installing initscripts"
102 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
103 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
104
105 # Install db-config.d files
106 echo "* Installing db-config.d files"
107 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
109 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
110
111 # Install wsdl
112 echo "* Installing wsdl"
113 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
114
115 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
116 ## Install omf_slicemgr.py
117 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
118 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
119 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
120
121 # Install ratelimit log
122 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
123 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %define php_extension_dir %(php-config --extension-dir)
129
130 %files
131 %defattr(-,root,root,-)
132 %dir %{_datadir}/plc_api
133 #%dir /var/log/omf/
134 %{_datadir}/plc_api/*
135 %{_bindir}/plcsh
136 %{php_extension_dir}/xmlrpc.so
137 %{_sysconfdir}/php.d/xmlrpc.ini
138 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
139 /etc/plc.d
140 /etc/planetlab/db-config.d
141 /var/www/html/wsdl/plcapi.wsdl
142 #/usr/bin/omf_slicemgr.py*
143 #/usr/bin/reset_xmpp_pubsub_nodes.py*
144 /var/log/plc_api_ratelimit.log
145
146
147 %changelog
148 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
149 - also expose 'expires' in ResolveSlices
150
151 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
152 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
153
154 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
155 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
156
157 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
158 - use SFA code for computing hrn's when available
159
160 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
161 - new slice tag 'interface' for configuring a virtual interface
162 - new builtin 030-interface_tags
163 - new node accessor and tag 'virt' for mixing lxc & vs nodes
164 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
165 - moved ModPypthon and plc.wsgi in the apache/ subdir
166 - renamed PLCAPI.spec into plcapi.spec
167 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
168 - support for php-5.4
169
170 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
171 - implement PLC_VSYS_DEFAULTS in AddSlice
172
173 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
174 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
175 - AddPerson and UpdatePerson are now tag-aware
176 - as a side-effect AddPerson is more picky and rejects invalid fields
177 - which results in a requirement to use sfa-2.1-22 with this tag
178 - marginal improvement on the xml doc on tags
179
180 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
181 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
182 - reset_xmpp_pubsub_nodes now hos options and usage
183 - new Accessors for vicci
184
185 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
186 - fixed imports for tags management with sites and persons
187 - add predefined 'cpu_freezable' tag
188
189 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
190 - tweaks in interface initialization
191 - has 'vsys_vnet' as a predefined tagtype
192 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
193 - bugfix: GetSlivers & nodegroups
194 - bugfix: in jabber groups management
195
196 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
197 - fix gpg-authentication for Persons (thanks Jordan)
198 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
199 - ip address/network check: v4 or v6
200 - customized DB Message survive upgrade
201 - make sync works in lxc-hosted tests
202 - no svn keywords anymore
203
204 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
205 - fix sorting for methods list in docs
206 - untested but needed tweak for postgres startup in f16
207
208 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
209 - tweaks in postgresql setup - in line with sfa
210
211 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
212 - slight tweaks in Persons.py
213
214 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
215 - GetSession has support for more than one day sessions
216 - reset_xmpp_pubsub_nodes is much more efficient
217 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
218 - bugfix - deleting a person in the middle of the signup process
219
220 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
221 - ratelimit aspects
222 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
223 - requires Django for cache_utils
224 - attempt to expose 'pldistro' to sfa
225 - last_time_spent_online, last_time_spent_offline: new fields in Node
226 - new slice tags 'isolate_loopback' and 'cpu_cores'
227 - refresh-peer federation logs dump exceptions
228 - modpython logs have a timestamp
229 - more verbose/accurate php error reporting
230 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
231 - AddNode, UpdateNode: manage tags directly rather than through another method
232 - BootUpdateNode: only update once
233 - GetPersons: techs can access the list of persons on their site
234 - GetSlices and GetSliceTags: techs can see slices on their nodes
235 - GetSlivers: isrootonsite tag; cacheable
236
237 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
238 - rename initscript_body into initscript_code
239
240 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
241 - new initscript_body tag
242
243 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
244 - working draft for GetSliceSshKeys
245
246 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
247 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
248 - (this is for people who cancel their download)
249
250 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
251 - fix db-config sequence : accessors step now merged in, and occurs at the right time
252 - db-config also more robust
253 - no more explicit 'accessors' step in plc.d
254
255 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
256 - session auth: do *not* delete session when node runs a method that does not have 'node' role
257 - session auth: remove support for bootonce in old boot CDs
258 - give a reason when caller_may_write_slice_tag fails
259 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
260
261 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
262 - SetSliceVref needed the node role
263 - protect GetSliceFamily
264 - Fix bugs in tag authorizations
265
266 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
267 - altered checking of optional fields in Interfaces
268 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
269 - has pyxml and python-simplejson as new deps
270
271 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
272 - tweak doc extraction for fedora14
273
274 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
275 - builtin accessors for the myslice page
276 - Get{Node,Interface}Tags allowed to techs
277 - tweak in ratelimitaspect.py
278
279 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
280 - add admin role to accessor-related tags (arch, {fc,pl}distro)
281
282 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
283 - bugfix in {Update,Delete}PersonTag
284 - updated xml doc for filters, accessors and tagtypes
285 - more explicit msg in case of missing roles
286 - improvements in ratelimitaspects.py
287
288 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
289 - fix the roles for ssh_key and hmac tags
290
291 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
292 - tag permissions system based on roles and not min_role_ids
293 - accessors simplified accordingly (no more min_role_id)
294 - new methods AddRoleToTagType and DeleteRoleFromTagType
295 - accessor-related tagtypes are created sooner, and enforced
296 - cleaned up redundancy between db-config.d and accessors
297
298 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
299 - fix RefreshPeer that was not working in 5.0-17
300
301 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
302 - RefreshPeer is able to cope with 2 peers running different releases of the api
303 - DeletePerson can be used on duplicates
304 - first appearance of ModPythonJson.py
305
306 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
307 - set accessors return the new value
308 - tweaks in the pubsub groups management
309
310 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
311 - convert hostnames to lower case and use ILIKE instead of LIKE
312
313 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
314 - use hrn in pubsub groups
315
316 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
317 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
318 - OMF fixes
319
320 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
321 - automatically set vsys tag for omf controlled slices
322
323 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
324 - addition of the 'ssh_key' slice tag
325 - first draft of the LDAP interface
326
327 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
328 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
329 - and readable through GetLeaseGranularity
330 - GetSlivers to expose reservation_policy and lease_granularity
331 - GetBootMedium fixed for reservable nodes
332 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
333 - new Apache mod_wsgi python interface
334
335 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
336 - the leases system
337
338 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
339 - previous tag had gone wrong
340
341 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
342 - fix pubsub hostname
343
344 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
345 - tweaks for the omf support (xmpp groups and RC-controlled slices)
346 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
347 - GetNodeFlavour exposes fcdistro
348
349 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
350 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
351
352 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
353 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
354 - pyaspect hooks allow to  maintain the namespace xmpp groups
355 - new omf_slicemgr is a proxy to xmpp, used by these hooks
356 - nodes have their hrn exposed in the 'hrn' tag
357 - node hrn exposed in GetSlivers, as well as the overall xmpp config
358 - system slice 'drl' gets created by db-config
359 - daniel's changes to Filter for supporting wildcards in lists
360 - AddSliceTag consistency check tweaked
361
362 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
363 - major cleanup
364 - get rid of all 4.2-related legacy code
365 - reset the migrations code, planetlab5.sql somes with (5,100)
366 - uses hashlib module when available
367
368 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
369 - first working version of 5.0:
370 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
371 - nodefamily is 3-fold with pldistro-fcdistro-arch
372 - site and person tags
373 - new methods GetSliceFamily and GetNodeFlavour
374 - deprecated the dummynet stuff that were for the external dummyboxes
375 - tags definition : more consistency between db-config scripts and accessors
376 - (get accessor to create the tag type too if absent)
377 - logging an event for AddSliceToNodes
378
379 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
380 - support for fedora 12
381 - fix subtle bug in filtering with ] and quotes
382
383 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
384 - * patch for php-5.3 (the one in f12)
385 - * validate email addresses with regex
386 - * add PersonTags and SiteTags
387 - * add additional accessors for node tags (kvariant, serial, ..)
388
389 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
390 - Redacting password, session, and authstring values from the event log.
391
392 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
393 - let AddSite set ext_consortium_id - required for the poorman registration pages
394 - drop version constraint on Requires: postgresql-python
395 - don't log system calls nor ReportRunLevel
396
397 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
398 - Fix requires for CentOS.
399
400 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
401 - Require postgresql 8.2 (for array operators && and @>)
402
403 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
404 - Filter now supports the | and & features to match in sequence values
405 - bugfix in the postgresql wrapper for sequence filter values
406 - reviewed GetSlivers to export admin keys more efficiently
407 - fix checking roles in UpdateSliceTag
408
409 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
410 - - Some typos in the documentation were fixed.
411 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
412 - to the tag's min_role_id.
413
414 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
415
416 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
417 - Ongoing work to add upcalls, using new SFA class
418 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
419 - reviewed type-checking for the 3 taggable classes node-interface-slice
420 - cleanup ald dummynet stuff
421 - expose the 'extensions' accessors to the API
422 - tweaked checks in AddSliceTag
423 - GetPersons exposes roles by default
424 - bugfix in ReportRunLevel for non-string levels
425 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
426
427 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
428 - new BindObjectToPeer method for sfa
429 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
430
431 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
432 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
433 - reportrunlevel logs its calls only when run_level changes
434 - pycurl more robust wrt to xmlrpclib.Transport
435
436 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
437 - produce a wsdl interface
438 - bugfix in getbootmedium for nodes with interface tags
439
440 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
441 - bugfix for some rare pattern-based filters
442
443 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
444 - improvements in the 4.2 legacy layer
445
446 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
447 - bugfix required for slice tags set on nodegroups
448
449 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
450 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
451
452 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
453 - more powerful legacy layer with 4.2
454
455 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
456 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
457 - migration script has an option for running interactively
458
459 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
460 - skips already added entries
461
462 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
463 - yet another set of fixes for external dummynet boxes
464
465 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
466 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
467 - and tmp file is cleaned up
468
469 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
470 - restore missing ResolveSlices
471
472 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
473 - new method GetDummyBoxMedium
474
475 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
476 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
477
478 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
479 - support for external dummynet boxes back in 4.3 - first draft
480
481 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
482 - fixes for smooth federation between 4.2 and 4.3
483 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
484
485 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
486 - support for BootCD variants (GetBootMedium ['variant:centos5'])
487 - fix corner case with filters like {'~slice_id':[]}
488 - fix transaction leak that caused the db connections pool to exhaust
489 - properly expose all methods, including Legacy/, and not only Methods/
490
491 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
492 - renumbered as 4.3
493 - nodes have new fields run_level (in addition to boot_state) and verified
494 - tweaked migration from 4.2
495 - tuned rpm dependencies
496 - doc generation more explicit about errors like missing python modules
497 - removed obsolete method GetSlicesMD5
498
499 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
500 - unified all tags
501 - renamed interface settings into interface tags and slice attributes into slice tags
502 - nodes have a node_type
503 - various changes on the way to 4.3
504
505 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
506 - Checkpointing : this version still has interface settings and slice attributes
507
508 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
509 - first iteration with taggable nodes/interfaces/slices
510 - embryo for ilinks
511 - cleaned up boot states
512 - migration script moslty complete
513
514 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
515 - fixed doc build by locating locally installed DTDs at build-time
516
517 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
518 - no more doc packaged outside of myplc-docs - doc/ cleaned up
519 - enhancements in doc on filters 
520 - bootcd-aware GetBootMedium merged from onelab
521
522 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
523 - checkpoint while the new myplc-docs package is underway
524 - bugfix: GetSlivers & conf files
525 - doc: removed target files 
526
527 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
528 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
529 - the non-deleted fields were index, resulting in massivly slow queries.
530
531
532 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
533 - plcsh: better handling of options when running as a shell script
534 - getbootmedium exports compute_key
535 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
536
537 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
538 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
539 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
540
541 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
542 - refresh peer script to use a month-dependent logfile
543 - tracking the starting point for UniPi integration of the dummynet boxes
544
545 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
546 - plcsh adds its own path to sys.path
547 - fix so GetNodes can be called from a Node
548
549 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
550 - Initial build.
551
552 %define module_current_branch 4.3