Setting tag plcapi-5.3-10
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.3
3 %define taglevel 10
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Provides: PLCAPI
22 Obsoletes: PLCAPI
23
24 # requirement to mod_python or mod_wsgi: deferred to myplc
25 Requires: httpd mod_ssl
26 Requires: Django
27 Requires: postgresql >= 8.2, postgresql-server >= 8.2
28 # We use set everywhere
29 Requires: python >= 2.7
30 Requires: postgresql-python
31 Requires: python-psycopg2
32 Requires: python-pycurl
33 # used in GPG.py as a replacement to PyXML's Canonicalize
34 Requires: python-lxml
35 # Fedora had support for SOAPpy up to fedora20
36 # https://lists.fedoraproject.org/pipermail/devel/2014-June/199730.html
37 # https://lists.fedoraproject.org/pipermail/devel/2014-June/200379.html
38 %if ("%{distro}" == "Fedora" && %{distrorelease} <= 20) || ("%{distro}" != "Fedora")
39 Requires: SOAPpy
40 %endif
41 Requires: python-simplejson
42 # for the RebootNodeWithPCU method
43 Requires: pcucontrol >= 1.0-6
44 # for OMF integration
45 Requires: pyaspects >= 0.4
46 Requires: python-twisted-words
47 Requires: python-twisted-web
48 # ldap
49 Requires: python-ldap
50 # for memcache
51 Requires: memcached python-memcached
52 ### avoid having yum complain about updates, as stuff is moving around
53 # plc.d/api
54 Conflicts: MyPLC <= 4.3
55
56 # We use psycopg2
57 #
58 # but we don't need to rebuild it as we depend on distro's packages - baris
59 # BuildRequires: postgresql-devel
60
61 # Standard xmlrpc.so that ships with PHP does not marshal NULL
62 # for building the wsdl interface we used to require PyXML
63 # but this has gone with f20 so turning this off for now
64 BuildRequires: php-devel python-simplejson
65 Obsoletes: php-xmlrpc
66 Provides: php-xmlrpc
67
68 # PostgreSQL and SOAPpy are necessary to run the API server, but not
69 # plcsh. Since the only supported method of running the server is via
70 # MyPLC anyway, don't be so stringent about binary requirements, in
71 # case people want to install this package just for plcsh.
72 # Requires: postgresql-server, SOAPpy
73 AutoReqProv: no
74
75 %description
76 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
77 PlanetLab Central (PLC) database. The API may be accessed directly via
78 the Python shell program plcsh, through a toy standalone server, or
79 through Apache mod_python.
80
81 %prep
82 %setup -q
83
84 %build
85 # python-pycurl and python-psycopg2 avail. from fedora 5
86 # we used to ship our own version of psycopg2 and pycurl, for fedora4
87 # starting with 4.3, support for these two modules is taken out
88
89 # Build __init__.py metafiles and PHP API. 
90 %{__make} %{?_smp_mflags}
91 %{__make} -C wsdl
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
96
97 # Install shell symlink
98 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
99 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
100
101 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
102 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
103 ; Enable xmlrpc extension module
104 extension=xmlrpc.so
105 EOF
106
107 # Install initscripts
108 echo "* Installing initscripts"
109 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
110 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
111
112 # Install db-config.d files
113 echo "* Installing db-config.d files"
114 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
115 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
116 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
117
118 # Install wsdl
119 echo "* Installing wsdl"
120 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
121
122 ## Thierry - June 2013 - omfv6 does not require xmpp pubsub nodes management any more
123 ## Install omf_slicemgr.py
124 #install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
125 #install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
126 #mkdir -p $RPM_BUILD_ROOT/var/log/omf
127
128 # Install ratelimit log
129 mkdir -p $RPM_BUILD_ROOT/var/log
130 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
131 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %define php_extension_dir %(php-config --extension-dir)
137
138 %files
139 %defattr(-,root,root,-)
140 %dir %{_datadir}/plc_api
141 #%dir /var/log/omf/
142 %{_datadir}/plc_api/*
143 %{_bindir}/plcsh
144 %{php_extension_dir}/xmlrpc.so
145 %{_sysconfdir}/php.d/xmlrpc.ini
146 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
147 /etc/plc.d
148 /etc/planetlab/db-config.d
149 /var/www/html/wsdl/plcapi.wsdl
150 #/usr/bin/omf_slicemgr.py*
151 #/usr/bin/reset_xmpp_pubsub_nodes.py*
152 /var/log/plc_api_ratelimit.log
153
154
155 %changelog
156 * Sun Jul 10 2016 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-10
157 - GetBootMedium with systemd-debug option : add kernel arg systemd.log_target=console
158
159 * Fri Jun 26 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-9
160 - new bootstate 'upgrade' is like reinstall but leaves slices intact
161
162 * Fri Apr 24 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-8
163 - GetBootMedium now keeps logs of created bootCD's in /var/tmp/bootmedium
164
165 * Fri Apr 03 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-7
166 - reviewed logging strategy, no more direct print but use log instead
167
168 * Wed Feb 18 2015 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-6
169 - extensions for the ipv6 feature
170 - DeleteSliceTag can be run with the 'node' auth
171 - xmlrpc-epi-php.c has has a tweak for f21/php-5.6
172 - also SOAPpy is not present in f21 anymore, so drop that dep. with f>=21
173
174 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-5
175 - allow GetSlices to filter on tags as well
176
177 * Tue Aug 19 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-4
178 - enable filtering on tags (like hrn) with GetPersons and GetSites
179
180 * Mon Jun 02 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-3
181 - provide more context in messages from AddPersonToSlice and DeletePersonFromSlice
182
183 * Fri Mar 21 2014 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-2
184 - don't use PyXML that is deprecated in f20, use lxml instead
185 - higher max size for login_base (32 vs 20) and slice name (64 vs 32)
186
187 * Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.3-1
188 - create accessor 'hrn' for site as well
189 - create accessors 'sfa_created' for site/slice/person
190 - AddSite() and AddSlice() set respectively Site HRN and Slice HRN.
191 - UpdatePerson() updates Person HRN according to updated email.
192 - UpdateSite() updates Site HRN according to updated login_base.
193 - Fix AddPersonToSite().
194 - GetPeerData() ignores Sites/Slices/Persons that have tag sfa_created=='True'
195 - RefreshPeer() manages Site*Person and Person*Role relationships.
196
197 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-10
198 - provide a slicename_to_hrn function
199
200 * Fri Sep 20 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-9
201 - add an hrn accessor for slice so the SFA code can keep track of the federation-wide name of the slice
202
203 * Wed Aug 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-8
204 - fix for wsgi-based deployments, each thread has its own api()
205
206 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-7
207 - also cleanup omf-slicemgr initscript
208
209 * Fri Jun 28 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-6
210 - tear down omf-related aspects as this is no longer needed with omfv6
211
212 * Thu Jun 27 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-5
213 - also expose 'expires' in ResolveSlices
214
215 * Wed Jun 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-4
216 - drop GetSliceSshKeys, new RetrieveSlicePersonKeys and RetrieveSliceSliverKeys
217
218 * Wed May 29 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-3
219 - enable netconfig aspects if PLC_NETCONFIG_ENABLED
220
221 * Wed Apr 24 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-2
222 - use SFA code for computing hrn's when available
223
224 * Fri Mar 08 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.2-1
225 - new slice tag 'interface' for configuring a virtual interface
226 - new builtin 030-interface_tags
227 - new node accessor and tag 'virt' for mixing lxc & vs nodes
228 - also exposed in GetNodeFlavour based on fcdistro and PLC_FLAVOUR_VIRT_MAP
229 - moved ModPypthon and plc.wsgi in the apache/ subdir
230 - renamed PLCAPI.spec into plcapi.spec
231 - removed old and unused tag 'type' on slices(!) - original intention seemed like virt
232 - support for php-5.4
233
234 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
235 - implement PLC_VSYS_DEFAULTS in AddSlice
236
237 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
238 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
239 - AddPerson and UpdatePerson are now tag-aware
240 - as a side-effect AddPerson is more picky and rejects invalid fields
241 - which results in a requirement to use sfa-2.1-22 with this tag
242 - marginal improvement on the xml doc on tags
243
244 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
245 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
246 - reset_xmpp_pubsub_nodes now hos options and usage
247 - new Accessors for vicci
248
249 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
250 - fixed imports for tags management with sites and persons
251 - add predefined 'cpu_freezable' tag
252
253 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
254 - tweaks in interface initialization
255 - has 'vsys_vnet' as a predefined tagtype
256 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
257 - bugfix: GetSlivers & nodegroups
258 - bugfix: in jabber groups management
259
260 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
261 - fix gpg-authentication for Persons (thanks Jordan)
262 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
263 - ip address/network check: v4 or v6
264 - customized DB Message survive upgrade
265 - make sync works in lxc-hosted tests
266 - no svn keywords anymore
267
268 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
269 - fix sorting for methods list in docs
270 - untested but needed tweak for postgres startup in f16
271
272 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
273 - tweaks in postgresql setup - in line with sfa
274
275 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
276 - slight tweaks in Persons.py
277
278 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
279 - GetSession has support for more than one day sessions
280 - reset_xmpp_pubsub_nodes is much more efficient
281 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
282 - bugfix - deleting a person in the middle of the signup process
283
284 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
285 - ratelimit aspects
286 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
287 - requires Django for cache_utils
288 - attempt to expose 'pldistro' to sfa
289 - last_time_spent_online, last_time_spent_offline: new fields in Node
290 - new slice tags 'isolate_loopback' and 'cpu_cores'
291 - refresh-peer federation logs dump exceptions
292 - modpython logs have a timestamp
293 - more verbose/accurate php error reporting
294 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
295 - AddNode, UpdateNode: manage tags directly rather than through another method
296 - BootUpdateNode: only update once
297 - GetPersons: techs can access the list of persons on their site
298 - GetSlices and GetSliceTags: techs can see slices on their nodes
299 - GetSlivers: isrootonsite tag; cacheable
300
301 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
302 - rename initscript_body into initscript_code
303
304 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
305 - new initscript_body tag
306
307 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
308 - working draft for GetSliceSshKeys
309
310 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
311 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
312 - (this is for people who cancel their download)
313
314 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
315 - fix db-config sequence : accessors step now merged in, and occurs at the right time
316 - db-config also more robust
317 - no more explicit 'accessors' step in plc.d
318
319 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
320 - session auth: do *not* delete session when node runs a method that does not have 'node' role
321 - session auth: remove support for bootonce in old boot CDs
322 - give a reason when caller_may_write_slice_tag fails
323 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
324
325 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
326 - SetSliceVref needed the node role
327 - protect GetSliceFamily
328 - Fix bugs in tag authorizations
329
330 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
331 - altered checking of optional fields in Interfaces
332 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
333 - has pyxml and python-simplejson as new deps
334
335 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
336 - tweak doc extraction for fedora14
337
338 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
339 - builtin accessors for the myslice page
340 - Get{Node,Interface}Tags allowed to techs
341 - tweak in ratelimitaspect.py
342
343 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
344 - add admin role to accessor-related tags (arch, {fc,pl}distro)
345
346 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
347 - bugfix in {Update,Delete}PersonTag
348 - updated xml doc for filters, accessors and tagtypes
349 - more explicit msg in case of missing roles
350 - improvements in ratelimitaspects.py
351
352 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
353 - fix the roles for ssh_key and hmac tags
354
355 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
356 - tag permissions system based on roles and not min_role_ids
357 - accessors simplified accordingly (no more min_role_id)
358 - new methods AddRoleToTagType and DeleteRoleFromTagType
359 - accessor-related tagtypes are created sooner, and enforced
360 - cleaned up redundancy between db-config.d and accessors
361
362 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
363 - fix RefreshPeer that was not working in 5.0-17
364
365 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
366 - RefreshPeer is able to cope with 2 peers running different releases of the api
367 - DeletePerson can be used on duplicates
368 - first appearance of ModPythonJson.py
369
370 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
371 - set accessors return the new value
372 - tweaks in the pubsub groups management
373
374 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
375 - convert hostnames to lower case and use ILIKE instead of LIKE
376
377 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
378 - use hrn in pubsub groups
379
380 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
381 - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
382 - OMF fixes
383
384 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
385 - automatically set vsys tag for omf controlled slices
386
387 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
388 - addition of the 'ssh_key' slice tag
389 - first draft of the LDAP interface
390
391 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
392 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
393 - and readable through GetLeaseGranularity
394 - GetSlivers to expose reservation_policy and lease_granularity
395 - GetBootMedium fixed for reservable nodes
396 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
397 - new Apache mod_wsgi python interface
398
399 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
400 - the leases system
401
402 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
403 - previous tag had gone wrong
404
405 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
406 - fix pubsub hostname
407
408 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
409 - tweaks for the omf support (xmpp groups and RC-controlled slices)
410 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
411 - GetNodeFlavour exposes fcdistro
412
413 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
414 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
415
416 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
417 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
418 - pyaspect hooks allow to  maintain the namespace xmpp groups
419 - new omf_slicemgr is a proxy to xmpp, used by these hooks
420 - nodes have their hrn exposed in the 'hrn' tag
421 - node hrn exposed in GetSlivers, as well as the overall xmpp config
422 - system slice 'drl' gets created by db-config
423 - daniel's changes to Filter for supporting wildcards in lists
424 - AddSliceTag consistency check tweaked
425
426 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
427 - major cleanup
428 - get rid of all 4.2-related legacy code
429 - reset the migrations code, planetlab5.sql somes with (5,100)
430 - uses hashlib module when available
431
432 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
433 - first working version of 5.0:
434 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
435 - nodefamily is 3-fold with pldistro-fcdistro-arch
436 - site and person tags
437 - new methods GetSliceFamily and GetNodeFlavour
438 - deprecated the dummynet stuff that were for the external dummyboxes
439 - tags definition : more consistency between db-config scripts and accessors
440 - (get accessor to create the tag type too if absent)
441 - logging an event for AddSliceToNodes
442
443 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
444 - support for fedora 12
445 - fix subtle bug in filtering with ] and quotes
446
447 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
448 - * patch for php-5.3 (the one in f12)
449 - * validate email addresses with regex
450 - * add PersonTags and SiteTags
451 - * add additional accessors for node tags (kvariant, serial, ..)
452
453 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
454 - Redacting password, session, and authstring values from the event log.
455
456 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
457 - let AddSite set ext_consortium_id - required for the poorman registration pages
458 - drop version constraint on Requires: postgresql-python
459 - don't log system calls nor ReportRunLevel
460
461 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
462 - Fix requires for CentOS.
463
464 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
465 - Require postgresql 8.2 (for array operators && and @>)
466
467 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
468 - Filter now supports the | and & features to match in sequence values
469 - bugfix in the postgresql wrapper for sequence filter values
470 - reviewed GetSlivers to export admin keys more efficiently
471 - fix checking roles in UpdateSliceTag
472
473 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
474 - - Some typos in the documentation were fixed.
475 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
476 - to the tag's min_role_id.
477
478 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
479
480 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
481 - Ongoing work to add upcalls, using new SFA class
482 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
483 - reviewed type-checking for the 3 taggable classes node-interface-slice
484 - cleanup ald dummynet stuff
485 - expose the 'extensions' accessors to the API
486 - tweaked checks in AddSliceTag
487 - GetPersons exposes roles by default
488 - bugfix in ReportRunLevel for non-string levels
489 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
490
491 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
492 - new BindObjectToPeer method for sfa
493 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
494
495 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
496 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
497 - reportrunlevel logs its calls only when run_level changes
498 - pycurl more robust wrt to xmlrpclib.Transport
499
500 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
501 - produce a wsdl interface
502 - bugfix in getbootmedium for nodes with interface tags
503
504 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
505 - bugfix for some rare pattern-based filters
506
507 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
508 - improvements in the 4.2 legacy layer
509
510 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
511 - bugfix required for slice tags set on nodegroups
512
513 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
514 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
515
516 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
517 - more powerful legacy layer with 4.2
518
519 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
520 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
521 - migration script has an option for running interactively
522
523 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
524 - skips already added entries
525
526 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
527 - yet another set of fixes for external dummynet boxes
528
529 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
530 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
531 - and tmp file is cleaned up
532
533 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
534 - restore missing ResolveSlices
535
536 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
537 - new method GetDummyBoxMedium
538
539 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
540 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
541
542 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
543 - support for external dummynet boxes back in 4.3 - first draft
544
545 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
546 - fixes for smooth federation between 4.2 and 4.3
547 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
548
549 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
550 - support for BootCD variants (GetBootMedium ['variant:centos5'])
551 - fix corner case with filters like {'~slice_id':[]}
552 - fix transaction leak that caused the db connections pool to exhaust
553 - properly expose all methods, including Legacy/, and not only Methods/
554
555 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
556 - renumbered as 4.3
557 - nodes have new fields run_level (in addition to boot_state) and verified
558 - tweaked migration from 4.2
559 - tuned rpm dependencies
560 - doc generation more explicit about errors like missing python modules
561 - removed obsolete method GetSlicesMD5
562
563 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
564 - unified all tags
565 - renamed interface settings into interface tags and slice attributes into slice tags
566 - nodes have a node_type
567 - various changes on the way to 4.3
568
569 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
570 - Checkpointing : this version still has interface settings and slice attributes
571
572 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
573 - first iteration with taggable nodes/interfaces/slices
574 - embryo for ilinks
575 - cleaned up boot states
576 - migration script moslty complete
577
578 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
579 - fixed doc build by locating locally installed DTDs at build-time
580
581 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
582 - no more doc packaged outside of myplc-docs - doc/ cleaned up
583 - enhancements in doc on filters 
584 - bootcd-aware GetBootMedium merged from onelab
585
586 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
587 - checkpoint while the new myplc-docs package is underway
588 - bugfix: GetSlivers & conf files
589 - doc: removed target files 
590
591 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
592 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
593 - the non-deleted fields were index, resulting in massivly slow queries.
594
595
596 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
597 - plcsh: better handling of options when running as a shell script
598 - getbootmedium exports compute_key
599 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
600
601 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
602 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
603 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
604
605 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
606 - refresh peer script to use a month-dependent logfile
607 - tracking the starting point for UniPi integration of the dummynet boxes
608
609 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
610 - plcsh adds its own path to sys.path
611 - fix so GetNodes can be called from a Node
612
613 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
614 - Initial build.
615
616 %define module_current_branch 4.3