review packaging: usable with both mod_wsgi and mod_python
[plcapi.git] / plcapi.spec
1 %define name plcapi
2 %define version 5.1
3 %define taglevel 6
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 Summary: PlanetLab Central API
8 Name: %{name}
9 Version: %{version}
10 Release: %{release}
11 License: PlanetLab
12 Group: System Environment/Daemons
13 Source0: %{name}-%{version}.tar.gz
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16 Vendor: PlanetLab
17 Packager: PlanetLab Central <support@planet-lab.org>
18 Distribution: PlanetLab %{plrelease}
19 URL: %{SCMURL}
20
21 Obsoletes: plcapilib, PLCAPI
22
23 # We use set everywhere
24 Requires: python >= 2.4
25 Requires: postgresql >= 8.2, postgresql-server >= 8.2
26 Requires: postgresql-python
27 Requires: python-psycopg2
28 Requires: python-pycurl
29 Requires: httpd
30 # requirement to mod_python or mod_wsgi: deferred to myplc
31 Requires: mod_ssl
32 Requires: SOAPpy
33 Requires: python-simplejson
34 # for the RebootNodeWithPCU method
35 Requires: pcucontrol >= 1.0-6
36 # for OMF integration
37 Requires: pyaspects >= 0.4
38 Requires: python-twisted-words
39 Requires: python-twisted-web
40 # ldap
41 Requires: python-ldap
42 # for memcache
43 Requires: python-memcached
44 Requires: memcached
45 Requires: Django
46 ### avoid having yum complain about updates, as stuff is moving around
47 # plc.d/api
48 Conflicts: MyPLC <= 4.3
49
50 # We use psycopg2
51 #
52 # but we don't need to rebuild it as we depend on distro's packages - baris
53 # BuildRequires: postgresql-devel
54
55 # Standard xmlrpc.so that ships with PHP does not marshal NULL
56 BuildRequires: php-devel PyXML python-simplejson
57 Obsoletes: php-xmlrpc
58 Provides: php-xmlrpc
59
60 # PostgreSQL and SOAPpy are necessary to run the API server, but not
61 # plcsh. Since the only supported method of running the server is via
62 # MyPLC anyway, don't be so stringent about binary requirements, in
63 # case people want to install this package just for plcsh.
64 # Requires: postgresql-server, SOAPpy
65 AutoReqProv: no
66
67 %description
68 The PLCAPI package provides an XML-RPC and SOAP API for accessing the
69 PlanetLab Central (PLC) database. The API may be accessed directly via
70 the Python shell program plcsh, through a toy standalone server, or
71 through Apache mod_python.
72
73 %prep
74 %setup -q
75
76 %build
77 # python-pycurl and python-psycopg2 avail. from fedora 5
78 # we used to ship our own version of psycopg2 and pycurl, for fedora4
79 # starting with 4.3, support for these two modules is taken out
80
81 # Build __init__.py metafiles and PHP API. 
82 %{__make} %{?_smp_mflags}
83 %{__make} -C wsdl
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 %{__make} %{?_smp_mflags} install DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}"
88
89 # Install shell symlink
90 mkdir -p $RPM_BUILD_ROOT/%{_bindir}
91 ln -s %{_datadir}/plc_api/plcsh $RPM_BUILD_ROOT/%{_bindir}/plcsh
92
93 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/php.d
94 cat > $RPM_BUILD_ROOT/%{_sysconfdir}/php.d/xmlrpc.ini <<EOF
95 ; Enable xmlrpc extension module
96 extension=xmlrpc.so
97 EOF
98
99 # Install initscripts
100 echo "* Installing initscripts"
101 find plc.d | cpio -p -d -u ${RPM_BUILD_ROOT}/etc/
102 chmod 755 ${RPM_BUILD_ROOT}/etc/plc.d/*
103
104 # Install db-config.d files
105 echo "* Installing db-config.d files"
106 mkdir -p ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
107 cp db-config.d/* ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d
108 chmod 444 ${RPM_BUILD_ROOT}/etc/planetlab/db-config.d/*
109
110 # Install wsdl
111 echo "* Installing wsdl"
112 install -D -m 644 wsdl/plcapi.wsdl $RPM_BUILD_ROOT/var/www/html/wsdl/plcapi.wsdl
113
114 # Install omf_slicemgr.py
115 install -D -m 755 omf/omf_slicemgr.py $RPM_BUILD_ROOT/usr/bin/omf_slicemgr.py
116 install -D -m 755 omf/reset_xmpp_pubsub_nodes.py $RPM_BUILD_ROOT/usr/bin/reset_xmpp_pubsub_nodes.py
117 mkdir -p $RPM_BUILD_ROOT/var/log/omf
118
119 # Install ratelimit log
120 touch $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
121 chown apache:apache $RPM_BUILD_ROOT/var/log/plc_api_ratelimit.log
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %define php_extension_dir %(php-config --extension-dir)
127
128 %files
129 %defattr(-,root,root,-)
130 %dir %{_datadir}/plc_api
131 %dir /var/log/omf/
132 %{_datadir}/plc_api/*
133 %{_bindir}/plcsh
134 %{php_extension_dir}/xmlrpc.so
135 %{_sysconfdir}/php.d/xmlrpc.ini
136 %config (noreplace) %{_datadir}/plc_api/PLC/Accessors/Accessors_site.py
137 /etc/plc.d
138 /etc/planetlab/db-config.d
139 /var/www/html/wsdl/plcapi.wsdl
140 /usr/bin/omf_slicemgr.py*
141 /usr/bin/reset_xmpp_pubsub_nodes.py*
142 /var/log/plc_api_ratelimit.log
143
144
145 %changelog
146 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-6
147 - implement PLC_VSYS_DEFAULTS in AddSlice
148
149 * Wed Dec 12 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-5
150 - add hrn tag to persons, managed by AddPerson and AddPersonToSite
151 - AddPerson and UpdatePerson are now tag-aware
152 - as a side-effect AddPerson is more picky and rejects invalid fields
153 - which results in a requirement to use sfa-2.1-22 with this tag
154 - marginal improvement on the xml doc on tags
155
156 * Fri Nov 23 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-4
157 - tweak omf_slicemgr for smaller logs, split per month for easier cleaning
158 - reset_xmpp_pubsub_nodes now hos options and usage
159 - new Accessors for vicci
160
161 * Fri Aug 31 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-3
162 - fixed imports for tags management with sites and persons
163 - add predefined 'cpu_freezable' tag
164
165 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-2
166 - tweaks in interface initialization
167 - has 'vsys_vnet' as a predefined tagtype
168 - bugfix: prevent DeleteSliceFromNodes from messing with foreign slices
169 - bugfix: GetSlivers & nodegroups
170 - bugfix: in jabber groups management
171
172 * Mon Apr 16 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.1-1
173 - fix gpg-authentication for Persons (thanks Jordan)
174 - PostgreSQL.quote reviewed for f16/postgresql9 (used deprecated internal helper)
175 - ip address/network check: v4 or v6
176 - customized DB Message survive upgrade
177 - make sync works in lxc-hosted tests
178 - no svn keywords anymore
179
180 * Fri Feb 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-37
181 - fix sorting for methods list in docs
182 - untested but needed tweak for postgres startup in f16
183
184 * Mon Nov 28 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-36
185 - tweaks in postgresql setup - in line with sfa
186
187 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-35
188 - slight tweaks in Persons.py
189
190 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-34
191 - GetSession has support for more than one day sessions
192 - reset_xmpp_pubsub_nodes is much more efficient
193 - reset_xmpp_pubsub_nodes uses the config instead of localhost:5053
194 - bugfix - deleting a person in the middle of the signup process
195
196 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-33
197 - ratelimit aspects
198 - cache getslivers per node if PLC_GET_SIVERS_CACHE is enabled
199 - requires Django for cache_utils
200 - attempt to expose 'pldistro' to sfa
201 - last_time_spent_online, last_time_spent_offline: new fields in Node
202 - new slice tags 'isolate_loopback' and 'cpu_cores'
203 - refresh-peer federation logs dump exceptions
204 - modpython logs have a timestamp
205 - more verbose/accurate php error reporting
206 - postgresql listens on PLC_DB_HOST+localhost instead of 0.0.0.0
207 - AddNode, UpdateNode: manage tags directly rather than through another method
208 - BootUpdateNode: only update once
209 - GetPersons: techs can access the list of persons on their site
210 - GetSlices and GetSliceTags: techs can see slices on their nodes
211 - GetSlivers: isrootonsite tag; cacheable
212
213 * Tue Mar 22 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-32
214 - rename initscript_body into initscript_code
215
216 * Mon Mar 21 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-31
217 - new initscript_body tag
218
219 * Wed Mar 09 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-30
220 - working draft for GetSliceSshKeys
221
222 * Thu Feb 17 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-29
223 - trash getbootmedium tmp file if already exists but is longer than 5 minutes old
224 - (this is for people who cancel their download)
225
226 * Fri Feb 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-28
227 - fix db-config sequence : accessors step now merged in, and occurs at the right time
228 - db-config also more robust
229 - no more explicit 'accessors' step in plc.d
230
231 * Thu Feb 03 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-27
232 - session auth: do *not* delete session when node runs a method that does not have 'node' role
233 - session auth: remove support for bootonce in old boot CDs
234 - give a reason when caller_may_write_slice_tag fails
235 - remove ugly hack that was setting 'vref' to 'omf' - need to set both tags now
236
237 * Tue Feb 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-26
238 - SetSliceVref needed the node role
239 - protect GetSliceFamily
240 - Fix bugs in tag authorizations
241
242 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-25
243 - altered checking of optional fields in Interfaces
244 - UpdateTagType more picky on inputs - msg when trying to set roles, which is not supported
245 - has pyxml and python-simplejson as new deps
246
247 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-24
248 - tweak doc extraction for fedora14
249
250 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-23
251 - builtin accessors for the myslice page
252 - Get{Node,Interface}Tags allowed to techs
253 - tweak in ratelimitaspect.py
254
255 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-22
256 - add admin role to accessor-related tags (arch, {fc,pl}distro)
257
258 * Mon Dec 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-21
259 - bugfix in {Update,Delete}PersonTag
260 - updated xml doc for filters, accessors and tagtypes
261 - more explicit msg in case of missing roles
262 - improvements in ratelimitaspects.py
263
264 * Fri Dec 03 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-20
265 - fix the roles for ssh_key and hmac tags
266
267 * Wed Dec 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-19
268 - tag permissions system based on roles and not min_role_ids
269 - accessors simplified accordingly (no more min_role_id)
270 - new methods AddRoleToTagType and DeleteRoleFromTagType
271 - accessor-related tagtypes are created sooner, and enforced
272 - cleaned up redundancy between db-config.d and accessors
273
274 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-18
275 - fix RefreshPeer that was not working in 5.0-17
276
277 * Thu Sep 16 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-17
278 - RefreshPeer is able to cope with 2 peers running different releases of the api
279 - DeletePerson can be used on duplicates
280 - first appearance of ModPythonJson.py
281
282 * Wed Sep 01 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - plcapi-5.0-16
283 - set accessors return the new value
284 - tweaks in the pubsub groups management
285
286 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - plcapi-5.0-15
287 - convert hostnames to lower case and use ILIKE instead of LIKE
288
289 * Fri Jul 16 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-14
290 - use hrn in pubsub groups
291
292 * Tue Jul 13 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - plcapi-5.0-13
293 - - Add timestamps to Nodes, PCUs and Interfaces to make concrete statements about a node's configuration state.
294 - - OMF fixes
295
296 * Mon Jun 28 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-12
297 - automatically set vsys tag for omf controlled slices
298
299 * Sat Jun 26 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-11
300 - addition of the 'ssh_key' slice tag
301 - first draft of the LDAP interface
302
303 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-10
304 - reservation granularity defined in plc-config-tty (requires myplc 5.0.5)
305 - and readable through GetLeaseGranularity
306 - GetSlivers to expose reservation_policy and lease_granularity
307 - GetBootMedium fixed for reservable nodes
308 - tweaks in pcucontrol (requires pcucontrol-1.0-6)
309 - new Apache mod_wsgi python interface
310
311 * Fri May 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-9
312 - the leases system
313
314 * Wed Apr 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-8
315 - previous tag had gone wrong
316
317 * Wed Apr 14 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-5.0-6
318 - fix pubsub hostname
319
320 * Fri Apr 02 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-5
321 - tweaks for the omf support (xmpp groups and RC-controlled slices)
322 - BootNodeUpdate supports also ssh_rsa_key (and logs only changes)
323 - GetNodeFlavour exposes fcdistro
324
325 * Sun Mar 14 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-4
326 - do not use UpdateNode for handling the 'hrn' tag - should fix refresh peer & foreign nodes more generally
327
328 * Fri Mar 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-3
329 - slice tag 'omf_control' supported for getting OMF's resource controller shipped to slivers
330 - pyaspect hooks allow to  maintain the namespace xmpp groups
331 - new omf_slicemgr is a proxy to xmpp, used by these hooks
332 - nodes have their hrn exposed in the 'hrn' tag
333 - node hrn exposed in GetSlivers, as well as the overall xmpp config
334 - system slice 'drl' gets created by db-config
335 - daniel's changes to Filter for supporting wildcards in lists
336 - AddSliceTag consistency check tweaked
337
338 * Thu Feb 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-2
339 - major cleanup
340 - get rid of all 4.2-related legacy code
341 - reset the migrations code, planetlab5.sql somes with (5,100)
342 - uses hashlib module when available
343
344 * Fri Jan 29 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-5.0-1
345 - first working version of 5.0:
346 - pld.c/, db-config.d/ and nodeconfig/ scripts should now sit in the module they belong to
347 - nodefamily is 3-fold with pldistro-fcdistro-arch
348 - site and person tags
349 - new methods GetSliceFamily and GetNodeFlavour
350 - deprecated the dummynet stuff that were for the external dummyboxes
351 - tags definition : more consistency between db-config scripts and accessors
352 - (get accessor to create the tag type too if absent)
353 - logging an event for AddSliceToNodes
354
355 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-32
356 - support for fedora 12
357 - fix subtle bug in filtering with ] and quotes
358
359 * Fri Dec 18 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-31
360 - * patch for php-5.3 (the one in f12)
361 - * validate email addresses with regex
362 - * add PersonTags and SiteTags
363 - * add additional accessors for node tags (kvariant, serial, ..)
364
365 * Tue Nov 03 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-30
366 - Redacting password, session, and authstring values from the event log.
367
368 * Mon Oct 19 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-29
369 - let AddSite set ext_consortium_id - required for the poorman registration pages
370 - drop version constraint on Requires: postgresql-python
371 - don't log system calls nor ReportRunLevel
372
373 * Thu Oct 15 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - PLCAPI-4.3-28
374 - Fix requires for CentOS.
375
376 * Fri Oct 09 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - PLCAPI-4.3-27
377 - Require postgresql 8.2 (for array operators && and @>)
378
379 * Thu Oct 08 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-26
380 - Filter now supports the | and & features to match in sequence values
381 - bugfix in the postgresql wrapper for sequence filter values
382 - reviewed GetSlivers to export admin keys more efficiently
383 - fix checking roles in UpdateSliceTag
384
385 * Sat Sep 26 2009 Marc Fiuczynski <mef@cs.princeton.edu> - PLCAPI-4.3-25
386 - - Some typos in the documentation were fixed.
387 - - UpdateSliceTag check if a node's min_role_id is >= (rather than >)
388 - to the tag's min_role_id.
389
390 * Fri Sep 18 2009 anil vengalil <avengali@sophia.inria.fr> - PLCAPI-4.3-24
391
392 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-23
393 - Ongoing work to add upcalls, using new SFA class
394 - new methods BindObjectToPeer, UnBindObjectFromPeer, still for SFA
395 - reviewed type-checking for the 3 taggable classes node-interface-slice
396 - cleanup ald dummynet stuff
397 - expose the 'extensions' accessors to the API
398 - tweaked checks in AddSliceTag
399 - GetPersons exposes roles by default
400 - bugfix in ReportRunLevel for non-string levels
401 - tweaks in GetSlivers ( seems that it now exposes the keys for the root context )
402
403 * Fri Jul 10 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-22
404 - new BindObjectToPeer method for sfa
405 - AddSliceTag and UpdateSliceTag open to the 'node' auth method with restrictions
406
407 * Wed Jul 01 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-21
408 - getbootmedium supports options as tags (serial, cramfs, kvariant, kargs, no-hangcheck )
409 - reportrunlevel logs its calls only when run_level changes
410 - pycurl more robust wrt to xmlrpclib.Transport
411
412 * Tue Jun 16 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-20
413 - produce a wsdl interface
414 - bugfix in getbootmedium for nodes with interface tags
415
416 * Sun Jun 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-19
417 - bugfix for some rare pattern-based filters
418
419 * Wed Jun 03 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-18
420 - improvements in the 4.2 legacy layer
421
422 * Sat May 30 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-17
423 - bugfix required for slice tags set on nodegroups
424
425 * Thu May 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-16
426 - more complete compatibility layer - second iteration, with legacy code isolated in Legacy/
427
428 * Tue May 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-15
429 - more powerful legacy layer with 4.2
430
431 * Fri May 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-14
432 - RefreshPeer sets lock per-peer to avoid multiple concurent instances
433 - migration script has an option for running interactively
434
435 * Wed May 06 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-13
436 - skips already added entries
437
438 * Tue Apr 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-12
439 - yet another set of fixes for external dummynet boxes
440
441 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-11
442 - GetDummyBoxMedium returns a base64-encoded boot image, doc is updated
443 - and tmp file is cleaned up
444
445 * Wed Apr 22 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-10
446 - restore missing ResolveSlices
447
448 * Mon Apr 20 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-9
449 - new method GetDummyBoxMedium
450
451 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-8
452 - remove duplicate in Methods/__init__ that was breaking build of myplc-docs
453
454 * Fri Apr 17 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-7
455 - support for external dummynet boxes back in 4.3 - first draft
456
457 * Thu Apr 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-6
458 - fixes for smooth federation between 4.2 and 4.3
459 - peername is not UNIQUE in schema anymore, was preventing delete/recreate
460
461 * Tue Apr 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-5
462 - support for BootCD variants (GetBootMedium ['variant:centos5'])
463 - fix corner case with filters like {'~slice_id':[]}
464 - fix transaction leak that caused the db connections pool to exhaust
465 - properly expose all methods, including Legacy/, and not only Methods/
466
467 * Tue Mar 24 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-4
468 - renumbered as 4.3
469 - nodes have new fields run_level (in addition to boot_state) and verified
470 - tweaked migration from 4.2
471 - tuned rpm dependencies
472 - doc generation more explicit about errors like missing python modules
473 - removed obsolete method GetSlicesMD5
474
475 * Wed Jan 28 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-3
476 - unified all tags
477 - renamed interface settings into interface tags and slice attributes into slice tags
478 - nodes have a node_type
479 - various changes on the way to 4.3
480
481 * Thu Nov 27 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-2
482 - Checkpointing : this version still has interface settings and slice attributes
483
484 * Wed Sep 10 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.3-1
485 - first iteration with taggable nodes/interfaces/slices
486 - embryo for ilinks
487 - cleaned up boot states
488 - migration script moslty complete
489
490 * Wed May 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-8
491 - fixed doc build by locating locally installed DTDs at build-time
492
493 * Fri May 09 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-7
494 - no more doc packaged outside of myplc-docs - doc/ cleaned up
495 - enhancements in doc on filters 
496 - bootcd-aware GetBootMedium merged from onelab
497
498 * Thu May 08 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-6
499 - checkpoint while the new myplc-docs package is underway
500 - bugfix: GetSlivers & conf files
501 - doc: removed target files 
502
503 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - PLCAPI-4.2-5
504 - Removed conditions on the persons, site, and nodes indexes.  previsouly only
505 - the non-deleted fields were index, resulting in massivly slow queries.
506
507
508 * Wed Mar 26 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-3 PLCAPI-4.2-4
509 - plcsh: better handling of options when running as a shell script
510 - getbootmedium exports compute_key
511 - tweaks for accepted args in GetPCUTypes and BootNotifyOwners
512
513 * Thu Feb 14 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-2 PLCAPI-4.2-3
514 - GetBootMedium support for build.sh full options, incl. serial & console_spec 
515 - GetBootMedium simpler, cleaner and safer use of tmpdirs in (dated from bootcustom.sh)
516
517 * Fri Feb 01 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-1 PLCAPI-4.2-2
518 - refresh peer script to use a month-dependent logfile
519 - tracking the starting point for UniPi integration of the dummynet boxes
520
521 * Thu Jan 31 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - PLCAPI-4.2-0 PLCAPI-4.2-1
522 - plcsh adds its own path to sys.path
523 - fix so GetNodes can be called from a Node
524
525 * Fri Oct 27 2006 Mark Huang <mlhuang@CS.Princeton.EDU> - 
526 - Initial build.
527
528 %define module_current_branch 4.3